Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Reply
 
Thread Tools Search this Thread Display Modes
Old 5th April 2017, 06:10   #61  |  Link
tcope
Digital Artifact
 
tcope's Avatar
 
Join Date: Sep 2015
Location: Houston Texas
Posts: 37
Any chance on some usage doc's for
your version of FineDehalo ?

The default version has been providing
promising results at removing extreme
ringing in odd areas, while retaining detail
on HD footage. Though I am only working
in yv12 space, am eager to see how your
version may do.
tcope is offline   Reply With Quote
Old 5th April 2017, 06:15   #62  |  Link
magiblot
Eurobeat Fan
 
Join Date: Sep 2014
Posts: 97
Quote:
Originally Posted by hello_hello View Post
magiblot appears to be using SMDegrain 3.1.2.90s which appears to be quite broken. Would that be causing the problem?
No, I already updated it, but I haven't edited my old post.

Quote:
Originally Posted by real.finder View Post
maybe you have two .avsi for animeivtc in autoload folder, one old and one notand you say 2.00 and it 2.20anyway, I will see the sample now
Don't worry, that was just a mistake. What I do have is an "AnimeIVTC_helper" avsi, but maybe it is no loger necessary.

Last edited by magiblot; 5th April 2017 at 07:51.
magiblot is offline   Reply With Quote
Old 5th April 2017, 17:46   #63  |  Link
real.finder
Registered User
 
Join Date: Jan 2012
Location: Mesopotamia
Posts: 1,290
Quote:
Originally Posted by tcope View Post
Any chance on some usage doc's for
your version of FineDehalo ?

The default version has been providing
promising results at removing extreme
ringing in odd areas, while retaining detail
on HD footage. Though I am only working
in yv12 space, am eager to see how your
version may do.
the original FineDehalo don't has doc too

anyway, my edit to make more control of it, made mask function to use the mask for another things or using external Dehalo or mask in FineDehalo or whatever, and support HBD in avs+

and other functions included for masking
__________________
My Avisynth Stuff
real.finder is offline   Reply With Quote
Old 5th April 2017, 18:31   #64  |  Link
tcope
Digital Artifact
 
tcope's Avatar
 
Join Date: Sep 2015
Location: Houston Texas
Posts: 37
I am guessing the default legacy options still
apply.
FineDehalo

I look forward to exploring the added features.
Cheers
tcope is offline   Reply With Quote
Old 5th April 2017, 18:59   #65  |  Link
real.finder
Registered User
 
Join Date: Jan 2012
Location: Mesopotamia
Posts: 1,290
Quote:
Originally Posted by tcope View Post
I am guessing the default legacy options still
apply.
FineDehalo

I look forward to exploring the added features.
Cheers
yes, but that doc not by Author

maybe later I will explain the new things

and btw even if you work with yv12 source, you can convert it to more than 8 bit and filter it and then back to 8 bit, with this you will get getter result, Especially if you use many filters
__________________
My Avisynth Stuff
real.finder is offline   Reply With Quote
Old 5th April 2017, 23:33   #66  |  Link
tcope
Digital Artifact
 
tcope's Avatar
 
Join Date: Sep 2015
Location: Houston Texas
Posts: 37
Quote:
Originally Posted by real.finder View Post
and btw even if you work with yv12 source, you can convert it to more than 8 bit and filter it and then back to 8 bit, with this you will get getter result, Especially if you use many filters

Very good to know. May give colour space conversion
a try as well.

Thank You
tcope is offline   Reply With Quote
Old 5th May 2017, 00:03   #67  |  Link
real.finder
Registered User
 
Join Date: Jan 2012
Location: Mesopotamia
Posts: 1,290
new SMDegrain edit to use last KNLMeansCL (v1.1.0) https://forum.doom9.org/showthread.p...02#post1790702
__________________
My Avisynth Stuff
real.finder is offline   Reply With Quote
Old 5th May 2017, 17:12   #68  |  Link
Dreamland
Registered User
 
Join Date: Sep 2013
Location: Central Italy
Posts: 46
Thx..works perfectly!
Dreamland is offline   Reply With Quote
Old 8th May 2017, 00:36   #69  |  Link
Heaud
Registered User
 
Join Date: Apr 2008
Posts: 55
Using dfttestmc with mdg=true gives an error stating that there is no function named DarkPreserve_function. Am I missing something? Using Avisynth 2.6 with dither tools, dfttest, and MVTools.
Heaud is offline   Reply With Quote
Old 9th May 2017, 02:08   #70  |  Link
real.finder
Registered User
 
Join Date: Jan 2012
Location: Mesopotamia
Posts: 1,290
Quote:
Originally Posted by Heaud View Post
Using dfttestmc with mdg=true gives an error stating that there is no function named DarkPreserve_function. Am I missing something? Using Avisynth 2.6 with dither tools, dfttest, and MVTools.
yes, Advanced Denoising (the one that has sanimebob and smam)

or you can set mdg_domask=false
__________________
My Avisynth Stuff

Last edited by real.finder; 9th May 2017 at 02:11.
real.finder is offline   Reply With Quote
Old 9th May 2017, 04:09   #71  |  Link
Heaud
Registered User
 
Join Date: Apr 2008
Posts: 55
Ported the function found here into dfttestmc and the setting now works! Thank you for letting me know where to get a copy.
Heaud is offline   Reply With Quote
Old 22nd May 2017, 06:52   #72  |  Link
hello_hello
Registered User
 
Join Date: Mar 2011
Posts: 3,981
real.finder,

Unless I'm going blind, your mod of SRestore appears to be missing from your collection of Avisynth stuff. I eventually found a link to it here, so I guess that's where I got it originally, but I just thought I'd let you know in case you want to add it to the collection.

Cheers.
hello_hello is offline   Reply With Quote
Old 22nd May 2017, 10:21   #73  |  Link
real.finder
Registered User
 
Join Date: Jan 2012
Location: Mesopotamia
Posts: 1,290
Quote:
Originally Posted by hello_hello View Post
real.finder,

Unless I'm going blind, your mod of SRestore appears to be missing from your collection of Avisynth stuff. I eventually found a link to it here, so I guess that's where I got it originally, but I just thought I'd let you know in case you want to add it to the collection.

Cheers.
yes, I didn't add it since it in wiki

and speaking of SRestore, there still need some edit for HBD

in srestore_inside() function specifically, I find this flaw (in HBD) from a long time but too lazy to did edit it, as srestore is complex too
__________________
My Avisynth Stuff
real.finder is offline   Reply With Quote
Old 22nd May 2017, 10:39   #74  |  Link
hello_hello
Registered User
 
Join Date: Mar 2011
Posts: 3,981
The link in the wiki seems to lead to an older version than this one. (2.7h vs 2.76)?

Also, I don't know if anyone looks after the wiki, but there's a typo under the explanation of the omode option (the last example):

source #progressive
srestore(dmode=-4,omode="pp0")
decimate(cycle=5,quality=0) #recommed decimating

Last edited by hello_hello; 22nd May 2017 at 10:43.
hello_hello is offline   Reply With Quote
Old 22nd May 2017, 18:19   #75  |  Link
hello_hello
Registered User
 
Join Date: Mar 2011
Posts: 3,981
An SMDegrain question.....

Should contrasharp=50 (or some other value for sharpening with LSFMod) work for HD (720p) sources as contrasharp=true does? (although the latter is usually so subtle I wonder if it's working and I'm seeing placebo sharpening much of the time)
I ask, because contrasharp=50 (or some other value) appears not to work, although it does produce artefacts around the edges if you crank the sharpening up too much, even though it doesn't sharpen. For example (small section of the frame):

SMDegrain(thSAD=150)
LSFMod(strength=100)
Probably over-sharpened a bit, but to illustrate the difference.



SMDegrain(thSAD=150, contrasharp=500)
Note the bottom scan line.



Thanks.
hello_hello is offline   Reply With Quote
Old 22nd May 2017, 22:46   #76  |  Link
real.finder
Registered User
 
Join Date: Jan 2012
Location: Mesopotamia
Posts: 1,290
Quote:
Originally Posted by hello_hello View Post
An SMDegrain question.....

Should contrasharp=50 (or some other value for sharpening with LSFMod) work for HD (720p) sources as contrasharp=true does? (although the latter is usually so subtle I wonder if it's working and I'm seeing placebo sharpening much of the time)
I ask, because contrasharp=50 (or some other value) appears not to work, although it does produce artefacts around the edges if you crank the sharpening up too much, even though it doesn't sharpen. For example (small section of the frame):

SMDegrain(thSAD=150)
LSFMod(strength=100)
Probably over-sharpened a bit, but to illustrate the difference.



SMDegrain(thSAD=150, contrasharp=500)
Note the bottom scan line.



Thanks.
it use this setting

Code:
LSFmod(OutTO8,source=CClip,defaults="slow",strength=Contrasharp,soothe=false,Lmode=0,soft=-2,keep=0)
__________________
My Avisynth Stuff
real.finder is offline   Reply With Quote
Old 22nd May 2017, 23:29   #77  |  Link
hello_hello
Registered User
 
Join Date: Mar 2011
Posts: 3,981
I tried the same thing with v3.1.2d after downscaling to SD, to make sure it wasn't SMDegrain trying to be clever according to the resolution, and while the LSFMod version is oversharpened, to illustrate the difference:

SMDegrain(thSAD=150)


SMDegrain(thSAD=150, contrasharp=500)
Note the bottom row of pixels again.


SMDegrain(thSAD=150)
LSFMod(strength=500)


Edit: Looking at those screenshots again (upscaled to 1080p on my TV), the Contrasharp=500 version has been sharpened/altered compared to the original, so maybe the contrasharp function is meant to be so subtle it's almost impossible to see the effect at normal settings, even when LSFMod is used??

I'll confess I assumed it'd have the same effect as LSFMod on it's own, but maybe that's not how it works. From the help file:

Contrasharp.
In the other hand if your parameter input is an integer, LSFmod() will be used instead. It will be much slower, but maybe better for certain sources. Its value will serve as a contrasharpening multiplier, use one around 50 for similar strength as Contrasharpening().


I assume a "contrasharpening multiplier" is not the same thing?

Last edited by hello_hello; 23rd May 2017 at 00:08.
hello_hello is offline   Reply With Quote
Old 22nd May 2017, 23:47   #78  |  Link
real.finder
Registered User
 
Join Date: Jan 2012
Location: Mesopotamia
Posts: 1,290
the artefacts in bottom scan line and the top one seems bug in LSFMod with these settings defaults="slow",strength=100,soothe=false,Lmode=0,soft=-2,keep=0
__________________
My Avisynth Stuff
real.finder is offline   Reply With Quote
Old 23rd May 2017, 01:47   #79  |  Link
hello_hello
Registered User
 
Join Date: Mar 2011
Posts: 3,981
Quote:
Originally Posted by real.finder View Post
the artefacts in bottom scan line and the top one seems bug in LSFMod with these settings defaults="slow",strength=100,soothe=false,Lmode=0,soft=-2,keep=0
Those settings are fine for me when using LSFMod on it's own.

When I crank LSFMod up to a stupid level though, and overlay the result on the SMDegrain version, it looks as though the edge line/row of pixels is being sharpened by the same amount each time, while the rest of the image is being "contrasharpened" in the usual way, or however that works.

Place these two images on top of each other and switch between them and hopefully you'll see what I mean. It looks like the first column of pixels from the first image has been placed over the second image. Same with the last column on the right. That's possibly not what's actually happening....

LSFMod(defaults="slow",strength=500,soothe=false,Lmode=0,soft=-2,keep=0)


SMDegrain(thSAD=150, contrasharp=500)


It doesn't matter anyway. Normally you wouldn't crank the contrasharp setting so high, and I don't think using LSFMod for SMDegrain's contrasharpening is intended to sharpen in the usual way, so I'll continue to use LSFMod on it's own.

Thanks.

Last edited by hello_hello; 23rd May 2017 at 01:52.
hello_hello is offline   Reply With Quote
Old 23rd May 2017, 01:55   #80  |  Link
real.finder
Registered User
 
Join Date: Jan 2012
Location: Mesopotamia
Posts: 1,290
Quote:
Originally Posted by hello_hello View Post
Those settings are fine for me when using LSFMod on it's own.

When I crank LSFMod up to a stupid level though, and overlay the result on the SMDegrain version, it looks as though the edge line/row of pixels is being sharpened by the same amount each time, while the rest of the image is being "contrasharpened" in the usual way, or however that works.

Place these two images on top of each other and switch between them and hopefully you'll see what I mean. It looks like the first column of pixels from the first image has been placed over the second image. Same with the last column on the right. That's possibly not what's actually happening....

LSFMod(defaults="slow",strength=500,soothe=false,Lmode=0,soft=-2,keep=0)


SMDegrain(thSAD=150, contrasharp=500)


It doesn't matter anyway. Normally you wouldn't crank the contrasharp setting so high, and I don't think using LSFMod for SMDegrain's contrasharpening is intended to sharpen in the usual way, so I'll continue to use LSFMod on it's own.

Thanks.
interesting, I will check the SMDegrain code again
__________________
My Avisynth Stuff
real.finder is offline   Reply With Quote
Reply

Tags
avisynth, avs script, avs+, banding, generator, hbd, mod

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 07:34.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.