Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Reply
 
Thread Tools Search this Thread Display Modes
Old 23rd May 2019, 22:23   #61  |  Link
MasterNobody
Registered User
 
Join Date: Jul 2007
Posts: 537
Quote:
Originally Posted by kolak View Post
This is where Cinemacraft outperforms x264- quality balance between different frame types.
This problem has noting to do with balance between different frame types. It is problem with VBV.

mp3dom
To fix (debug) this problem developers (me) need at minimum short source sample which reproduce this problem and full x264 command line.

P.S. VBV algorithm is not ideal and sometimes its prediction fails.
MasterNobody is offline   Reply With Quote
Old 23rd May 2019, 22:27   #62  |  Link
mp3dom
Registered User
 
Join Date: Jul 2003
Location: Italy
Posts: 1,084
This is a bug or a problem somewhere that needs to be fixed, and not a result "by design".
The old Cinema Craft engine now tends to be inferior with the current sources. Animation has improved in resolutions compared to previous years, and now the old engine shows some "suffering" signs in keeping the quality on complex scenes without strong lowpass filtering and similar preprocessing, that visually lowers the definition.

Quote:
Originally Posted by MasterNobody View Post
To fix (debug) this problem developers (me) need at minimum short source sample which reproduce this problem and full x264 command line.
Sent by PM.

Last edited by mp3dom; 23rd May 2019 at 22:50.
mp3dom is offline   Reply With Quote
Old 24th May 2019, 21:03   #63  |  Link
kolak
Registered User
 
Join Date: Nov 2004
Location: Poland
Posts: 2,526
Quote:
Originally Posted by MasterNobody View Post
This problem has noting to do with balance between different frame types. It is problem with VBV.

mp3dom
To fix (debug) this problem developers (me) need at minimum short source sample which reproduce this problem and full x264 command line.

P.S. VBV algorithm is not ideal and sometimes its prediction fails.
Regardless if this is a bug in x264, Cinemacraft strong part was always good quality balance between frames (even in their MPEG2 encoder).

Quote:
Originally Posted by mp3dom View Post
The old Cinema Craft engine now tends to be inferior with the current sources. Animation has improved in resolutions compared to previous years, and now the old engine shows some "suffering" signs in keeping the quality on complex scenes without strong lowpass filtering and similar preprocessing, that visually lowers the definition
It's not actively developed product anymore, which is a shame, but there is no money in BD business anyway, so it's not worth to invest.

Last edited by kolak; 24th May 2019 at 21:06.
kolak is offline   Reply With Quote
Old 15th February 2021, 20:01   #64  |  Link
jpsdr
Registered User
 
Join Date: Oct 2002
Location: France
Posts: 1,888
I wanted to put the information on the issue i've open on gitlab/videolan, but i can't !
I don't have a smartphone neither a webcam, so on Gitlab i'm stuck on validating two step for my account, and it seems that there is no solution, and there is no link/contact support either to ask them how to do.

I don't know if the information was said, but disabling mbtree seems to reduce the effects of the issue. So it's not only VBV, but a mix also with mbtree.
__________________
My github.
jpsdr is offline   Reply With Quote
Old 15th February 2021, 22:08   #65  |  Link
MasterNobody
Registered User
 
Join Date: Jul 2007
Posts: 537
Quote:
Originally Posted by jpsdr View Post
I wanted to put the information on the issue i've open on gitlab/videolan, but i can't !
I don't have a smartphone neither a webcam, so on Gitlab i'm stuck on validating two step for my account, and it seems that there is no solution, and there is no link/contact support either to ask them how to do.

I don't know if the information was said, but disabling mbtree seems to reduce the effects of the issue. So it's not only VBV, but a mix also with mbtree.
Hi. If you have problems with login to code.videolan.org then you probably can try contact j-b at #x264dev@freenode.

And here is link to gitlab two-factor authentication (2FA) help.

Last edited by MasterNobody; 15th February 2021 at 22:16.
MasterNobody is offline   Reply With Quote
Old 23rd February 2021, 02:57   #66  |  Link
iAvoe
Registered User
 
Join Date: Sep 2017
Posts: 12
Try deadzone-inter=8 deadzone-intra=5 or --deadzone-inter 8 --deadzone-intra 5
iAvoe is offline   Reply With Quote
Old 24th February 2021, 12:47   #67  |  Link
mp3dom
Registered User
 
Join Date: Jul 2003
Location: Italy
Posts: 1,084
Mhmm, I don't think this could resolve, otherwise changing to tune grain (which lowers deadzone up to 6) would've fixed it
mp3dom is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 21:57.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.