Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Development

Reply
 
Thread Tools Search this Thread Display Modes
Old 20th February 2013, 08:52   #621  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 5,784
Quote:
Originally Posted by SEt View Post
... but here we go updated version.


I will immediately get you a bunch of german-speaking testers!
__________________

New German Gleitz board
MediaFire: x264 | x265 | VPx | AOM | Xvid
LigH is offline   Reply With Quote
Old 20th February 2013, 09:46   #622  |  Link
ryrynz
Registered User
 
ryrynz's Avatar
 
Join Date: Mar 2009
Posts: 3,018
Latest build is stable for me, cheers SEt.
ryrynz is offline   Reply With Quote
Old 20th February 2013, 15:03   #623  |  Link
SEt
Registered User
 
Join Date: Aug 2007
Posts: 374
rean, that you personally have problems is valid statement. But
Quote:
Originally Posted by rean View Post
On i7 you will always get crashes. Do not use SetMTMode(3). Use SetMTMode(3,4)!
is nonsense.
SEt is offline   Reply With Quote
Old 20th February 2013, 18:55   #624  |  Link
forclip
Registered User
 
Join Date: Dec 2009
Posts: 63
Do we need to recompile something again or is it a bug:

Quote:
Cache: Filter returned invalid response to CACHE_GETCHILD_CACHE_MODE. 198139200
And so on (with different digits at the end). But only with this build, not with the build by IanB (14.01.2013).

I know I must provide more info, but it's quite hard to do as I'm not an expert in all those plugins, just noticed that in my application all (or mostly all) filtering presets is broken with this build. Deinterlacing with QTGMC() for example:

Quote:
Cache: Filter returned invalid response to CACHE_GETCHILD_CACHE_MODE. 129064256
(D:\Program Files\Winnydows\XviD4PSP5\dlls\AviSynth\plugins\QTGMC.avs, line 776)
(D:\Program Files\Winnydows\XviD4PSP5\dlls\AviSynth\plugins\QTGMC.avs, line 386)
line 776:
Code:
diff = mt_makediff( Ref, Input, U=3,V=3 )
line 386
Code:
repair0 = (IsClip(srchClip) || Rep0 == 0) ? binomial0 : binomial0.QTGMC_KeepOnlyBobShimmerFixes( bobbed, Rep0, (RepChroma && ChromaMotion) )
forclip is offline   Reply With Quote
Old 21st February 2013, 08:07   #625  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 5,784
QTGMC is certainly a useful monster of testing script...

Are these already "fatal" error messages, or may it be useful to have DebugView running while testing?
__________________

New German Gleitz board
MediaFire: x264 | x265 | VPx | AOM | Xvid
LigH is offline   Reply With Quote
Old 21st February 2013, 11:12   #626  |  Link
forclip
Registered User
 
Join Date: Dec 2009
Posts: 63
Seems like false alarm

mt_masktools-26.dll 2.0.48.0 944Kb (966 656 bytes) - was the problem. It is something old that claims to be compatible with AviSynth 2.6, but in reality it uses AvisynthPluginInit2. Works fine after replacing it with another build that uses AvisynthPluginInit3 and avisynth.h somewhere from the summer of 2012 (i.e. after the "new-new" interface was introduced).

But another part of my question is still valid: do we need to recompile everything again using recent avisynth.h or not? I see that avisynth.h in DirectShowSource isn't updated, so may I guess that all this new caching features currently not used in existing plugins and it is not neccessary to recompile them?
forclip is offline   Reply With Quote
Old 21st February 2013, 12:24   #627  |  Link
invy
Registered User
 
Join Date: Jun 2007
Posts: 75
! C:\Users\v\AppData\Local\Temp\avisynth_20130220.7z: Unknown method in avisynth.dll
! C:\Users\v\AppData\Local\Temp\avisynth_20130220.7z: Error - operation failed


Winrar message ^^
invy is offline   Reply With Quote
Old 21st February 2013, 12:43   #628  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 5,784
Your 7-zip DLL used in WinRAR may be outdated (the file is compressed with LZMA2, available since v9.04); use a current 7-zip:

http://www.7-zip.org
http://sourceforge.net/projects/sevenzip
__________________

New German Gleitz board
MediaFire: x264 | x265 | VPx | AOM | Xvid

Last edited by LigH; 21st February 2013 at 12:46.
LigH is offline   Reply With Quote
Old 21st February 2013, 12:58   #629  |  Link
invy
Registered User
 
Join Date: Jun 2007
Posts: 75
Yeah I googled it pretty easily right after posting. Problem solved after updating to latest version.

Just a heads up to anyone dumb/lazy like me that still was using a Winrar version from 2007! (3.71)
invy is offline   Reply With Quote
Old 21st February 2013, 20:29   #630  |  Link
forclip
Registered User
 
Join Date: Dec 2009
Posts: 63
Quote:
Originally Posted by rean View Post
Do you mean mt masktool is not compatible with this Avisynth build?
I'm talking only about mt_masktools-26.dll. And yes, it isn't compatible with current AviSynth MT, but not with the latest official non-MT (aka Alpha4). I don't know why. The code can be simplified to something like this:

Code:
LoadPlugin("......\mt_masktools-26.dll")

ColorBars(pixel_type="YV12")
mt_average(last)
=
Quote:
Cache: Filter returned invalid response to CACHE_GETCHILD_CACHE_MODE. 136600896
forclip is offline   Reply With Quote
Old 21st February 2013, 23:07   #631  |  Link
Overdrive80
Anime addict
 
Overdrive80's Avatar
 
Join Date: Feb 2009
Location: Spain
Posts: 638
Quote:
Originally Posted by rean View Post
Just checked - yes. I got this error, too. Previous stable version works.
Its issue known, its necessary that should be fixed in mt_masktools_26.dll.

http://forum.doom9.org/showthread.ph...04#post1589904

http://forum.doom9.org/showthread.ph...60#post1589960

http://forum.doom9.org/showthread.ph...27#post1610927
__________________
Intel i7-6700K + Noctua NH-D15 + Z170A XPower G. Titanium + Kingston HyperX Savage DDR4 2x8GB + Nvidia GTX750 2GB DDR5 + SSD Vertex 4 256 GB + Antec EDG750 80 Plus Gold Mod + Corsair 780T Graphite

Last edited by Overdrive80; 22nd February 2013 at 21:40.
Overdrive80 is offline   Reply With Quote
Old 22nd February 2013, 10:36   #632  |  Link
SEt
Registered User
 
Join Date: Aug 2007
Posts: 374
forclip, I get exactly the same error from official Alpha4. Actually, without MTMode my build should behave exactly like official. MTMode changes several things, so there can be problems (but here turning on MTMode actually makes it work with no error).

About recompiling: I suggest using 2.5 interfaces (unless you need something 2.6-specific) – this way you don't need to recompile each time. But if you are using 2.6 interfaces – be ready to recompile as official interfaces are changing.
SEt is offline   Reply With Quote
Old 23rd February 2013, 01:52   #633  |  Link
blindbox
Registered User
 
Join Date: Jun 2010
Posts: 15
The download links are down. Mediafire should no longer be used, apparently. Anyone has a mirror?
blindbox is offline   Reply With Quote
Old 23rd February 2013, 02:43   #634  |  Link
SEt
Registered User
 
Join Date: Aug 2007
Posts: 374
I never thought Mediafire became this bad. Written them all I think about their quality, but don't expect any improvements. I'm open for suggestions of stable public (not personal) hosting (in PM).

Uploaded the archive as attachments to first post.

Well, I can say attachment rules here are also awful: not only attachments require approval, but also extremely limited in variants. Why the archive must be <= 200k? Oh and useless zips are somehow at premium and allowed 300k. More than that: it refuses 'multivolume' 7z in form name.7z.001 . These limits make absolutely no sense as all they do is prevent me from using the most compact format.
SEt is offline   Reply With Quote
Old 23rd February 2013, 11:29   #635  |  Link
tormento
Acid fr0g
 
tormento's Avatar
 
Join Date: May 2002
Location: Italy
Posts: 1,010
SEt: dropbox or skydrive? You can make a public link.
__________________
@turment on Telegram
tormento is offline   Reply With Quote
Old 23rd February 2013, 13:38   #636  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 5,784
Here is a little backup of mine; just repacked with optimal compression.
__________________

New German Gleitz board
MediaFire: x264 | x265 | VPx | AOM | Xvid
LigH is offline   Reply With Quote
Old 23rd February 2013, 22:42   #637  |  Link
SEt
Registered User
 
Join Date: Aug 2007
Posts: 374
Updated first post to Dropbox links. Report if you have any problems with it.
SEt is offline   Reply With Quote
Old 25th February 2013, 22:10   #638  |  Link
IanB
Avisynth Developer
 
Join Date: Jan 2003
Location: Melbourne, Australia
Posts: 3,168
@rean,

Every thread that interacts with COM must initialise COM, you have rogue threads using the COM environment.

Try COINIT_APARTMENTTHREADED, it adds an protection apartment that may get you around the problem.
IanB is offline   Reply With Quote
Old 26th February 2013, 21:27   #639  |  Link
SEt
Registered User
 
Join Date: Aug 2007
Posts: 374
First of all you are using MTMode wrong: the line
Code:
GetMTMode(false)>0 ? Distributor() : last
is special hack for FFDShow and must not be used when you use Avisynth the regular way by opening avs script.

If you'd still get crashes without that line, my initial guess is that Ut Video codec does something wrong as I see no crashes with FFV1 also. Try to test with different codecs.
SEt is offline   Reply With Quote
Old 9th March 2013, 10:51   #640  |  Link
SEt
Registered User
 
Join Date: Aug 2007
Posts: 374
New build – updated to cvs.
SEt is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 05:28.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.