Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Reply
 
Thread Tools Search this Thread Display Modes
Old 22nd October 2010, 16:48   #1  |  Link
OvejaNegra
ekTOMBE STUDIOS
 
OvejaNegra's Avatar
 
Join Date: Dec 2005
Location: Cuba
Posts: 253
Problem with tivtc (two pass script, first time i see this)

normally i use a script like this for the first pass:

#source
MPEG2Source ("dgp.d2v",info=3)
#for the dot crwal (it helps with the decimation and matching)
checkmate(tthr2=4,thr=2)
tcomb(mode=1,fthreshL=6,othreshL=6,fthreshC=30,othreshC=30)
#some times i get better results using both filters this way


#credits cutting
trim (0,46913)

#matching
#mcroma false because the video has too much chroma noise

tfm (micout=0,display=false,mode=0,pp=1,slow=2,mChroma=false,chroma=false,hint=true,cthresh=1,blockx=16,blocky=16,MI=80,metric=0,d2v="dgp.d2v",trimIn="trim.txt",output="TFM_matches.txt")

Crop(12, 0, -8, -0) #noise on borders

#decimate
tdecimate(display=false,chroma=false,nt=1,mode=4,output="TDecimate_metrics.txt",denoise=true,blockx=32,blocky=32,hint=true)


i run this script with megui (analysis pass)

now the second pass script:


#source
MPEG2Source ("dgp.d2v",info=3)

#color correction
#colormatrix (interlaced=true,hints=true,threads=0)
#
#dot crawling (this time is for removing the noise forever)
checkmate(tthr2=4,thr=2)
tcomb(mode=1,fthreshL=6,othreshL=6,fthreshC=30,othreshC=30)

#
#credits cutting
trim (0,46913)
#
#
#clip 2 for external deinterlecer
interp = last.nnedi(field=-2)
dt=last.tdeint(type=2,edeint=interp,mode=2,full=true)

#
#
TFM (micout=0,display=false,mode=0,pp=2,slow=2,clip2=dt,hint=true,d2v="dgp.d2v",trimIn="trim.txt",ovr="TFM_ovr.txt",input="TFM_matches.txt",batch=true)



tdecimate (display=false,mode=5,hybrid=2,vfrDec=0,chroma=false,input="TDecimate_metrics.txt",tfmIn="TFM_matches.txt",mkvOut="tiempos.txt",ovr="TDecimate_overrides.txt",batch=true)

Well, most of the time i use something like thie for my animes.
Now, using this precise script i made the first chapter of Bible Black (everything OK)

But the second chapter, well after running the first pass, the second one has interlaced frames randomly, bat matches and is a total mess.

By deleting filters, i was a ble to determine the culpirit :TFM
Is behaving very wierd, if i enable the display stats on the first pass and on the second pass to compare results, for example the frame 486 matches with C on the first pass detection.
BUT on the second pass it shows 486 matches P (OVR).

simply deleting input="TFM_matches.txt" on the second pass TFM line fixes the problem.

What's wrong?
The frames are changed from one pass to another?

Thanks
__________________
So, it works or not???
OvejaNegra is offline   Reply With Quote
Old 23rd October 2010, 03:10   #2  |  Link
mastrboy
Registered User
 
Join Date: Sep 2008
Posts: 303
have you tried to specify 'order' in TFM? i encoded a anime awhile ago that TFM detected order as bottom field and the encode resulted in random combed frames, setting the order manually to top field solved the problem, basically TFM's default setting for order "-1/autodetect" does not always work with anime...
mastrboy is offline   Reply With Quote
Old 23rd October 2010, 05:55   #3  |  Link
OvejaNegra
ekTOMBE STUDIOS
 
OvejaNegra's Avatar
 
Join Date: Dec 2005
Location: Cuba
Posts: 253
the order is correctly detected on the first pass (TFF) and the first pass has correct matching, the second pass uses the stats created on the first one, but it seems the stats are incorrectly writen or the video from the second pass has the frames changed in time position.
__________________
So, it works or not???
OvejaNegra is offline   Reply With Quote
Old 24th October 2010, 00:42   #4  |  Link
Nightshiver
Quality Freak
 
Join Date: Jun 2007
Location: Area 52
Posts: 597
Give a sample please.
Nightshiver is offline   Reply With Quote
Old 24th October 2010, 07:38   #5  |  Link
OvejaNegra
ekTOMBE STUDIOS
 
OvejaNegra's Avatar
 
Join Date: Dec 2005
Location: Cuba
Posts: 253
a sample of what?
part of the vob or pictures of the output of the second pass script?

The input vob is ok (a normal hibrid anime encoded as interlaced).
I can post pictures of the same frame on the first and second pass with debug output for comparing the work of tivtc.
Please specify what you want and i'll get it.

thanks
__________________
So, it works or not???
OvejaNegra is offline   Reply With Quote
Old 25th October 2010, 16:17   #6  |  Link
Nightshiver
Quality Freak
 
Join Date: Jun 2007
Location: Area 52
Posts: 597
The vob of course.....
Nightshiver is offline   Reply With Quote
Old 3rd November 2010, 19:39   #7  |  Link
OvejaNegra
ekTOMBE STUDIOS
 
OvejaNegra's Avatar
 
Join Date: Dec 2005
Location: Cuba
Posts: 253
Well, sorry for the delay, too much work.
I can confir right now that the problem "maybe"is solved.
I deleted and remake the dgindex project and the mismatchesa are gone and the video plays ok.
Plus, part of the problem was on the encoder (stutering), an update to x264 and Megui solved the problem.
Bu if anyone is interested on the vob sample i can post it. Please sugest where (rapidshare?).
Thanks
__________________
So, it works or not???
OvejaNegra is offline   Reply With Quote
Reply

Tags
tivtc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 10:55.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.