Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > VapourSynth

Reply
 
Thread Tools Search this Thread Display Modes
Old 16th September 2022, 03:01   #441  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
R60 installer is now up.
__________________
Github | AviSynth 101 | VapourSynth 101
l33tmeatwad is offline   Reply With Quote
Old 16th September 2022, 19:57   #442  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 7,347
Thanks!
__________________
Hybrid here in the forum, homepage
Selur is offline   Reply With Quote
Old 11th November 2022, 16:11   #443  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 7,347
Could you also add akarins vapoursynth plugin? (https://github.com/AkarinVS/vapoursynth-plugin)

Cu Selur
__________________
Hybrid here in the forum, homepage
Selur is offline   Reply With Quote
Old 2nd December 2022, 02:21   #444  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
R61 installer is now up.
__________________
Github | AviSynth 101 | VapourSynth 101
l33tmeatwad is offline   Reply With Quote
Old 2nd December 2022, 12:18   #445  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 7,347
Thanks, any plans for further updates?
__________________
Hybrid here in the forum, homepage
Selur is offline   Reply With Quote
Old 2nd December 2022, 21:41   #446  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
I'll do a yearly roundup of plugin updates closer to the end of the year, but I don't have plans to add much new, I'm trying to get ahold of a ARM Mac so I can start building that out as that's going to be more helpful for the future, although I'll continue to support the Intel machines for the base installer and common plugins until they are updated in a way where they won't compile.
__________________
Github | AviSynth 101 | VapourSynth 101
l33tmeatwad is offline   Reply With Quote
Old 15th April 2023, 15:41   #447  |  Link
groucho86
Registered User
 
Join Date: Apr 2016
Posts: 85
Quote:
Originally Posted by l33tmeatwad View Post
I'll do a yearly roundup of plugin updates closer to the end of the year, but I don't have plans to add much new, I'm trying to get ahold of a ARM Mac so I can start building that out as that's going to be more helpful for the future, although I'll continue to support the Intel machines for the base installer and common plugins until they are updated in a way where they won't compile.
Hi l33tmeatwad, first off, a big thank you for all your hard work simplifying the life of Mac users!!

The M1/M2 systems are working really well for the most part, but as soon as there is asm code, the builds obviously break.

For mvtools and and nnedi3, I found this:
https://github.com/Stefan-Olt

But currently have not found anyone solve the asm code for eedi3 (and I don't have the skill set to figure it out either). Hoping you might have some idea?
groucho86 is offline   Reply With Quote
Old 17th April 2023, 15:29   #448  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
Unfortunately I do not have a solution for that, as soon as I'm able to get my hands on an ARM based Mac I'll start building for that. Compiling things isn't too hard, I've got some detailed instructions in the early posts of this thread if you wanna try out compiling. Since these builds are separated from the typical install path you don't have to worry about breaking anything, I would just rename your current VapourSynth.framework folder so you have a backup of that. If you can get through setting up the framework it shouldn't be too hard to get plugins compiled too.
__________________
Github | AviSynth 101 | VapourSynth 101
l33tmeatwad is offline   Reply With Quote
Old 26th May 2023, 02:03   #449  |  Link
sevenrats
Registered User
 
Join Date: May 2023
Posts: 1
Quote:
Originally Posted by l33tmeatwad View Post
Unfortunately I do not have a solution for that, as soon as I'm able to get my hands on an ARM based Mac I'll start building for that. Compiling things isn't too hard, I've got some detailed instructions in the early posts of this thread if you wanna try out compiling. Since these builds are separated from the typical install path you don't have to worry about breaking anything, I would just rename your current VapourSynth.framework folder so you have a backup of that. If you can get through setting up the framework it shouldn't be too hard to get plugins compiled too.
I have an M2 we could use for this purpose. Would you be willing to collaborate on matrix or discord? Alternatively, we could just go back and forth with error messages here, but it would be easier to DM or just give you shell access.
sevenrats is offline   Reply With Quote
Old 24th June 2023, 15:48   #450  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
I apologize for the delay on R63, there were some changes that will require a higher minimum OS version. This means I'll have to do some testing and build a new base, which I haven't had time to deal with. I'll try to get to it ASAP.
__________________
Github | AviSynth 101 | VapourSynth 101
l33tmeatwad is offline   Reply With Quote
Old 1st August 2023, 15:59   #451  |  Link
anton_foy
Registered User
 
Join Date: Dec 2005
Location: Sweden
Posts: 705
My first day with VapourSynth so apologies for the newbie question.
Im on macos monterey 12.6 (MacBook Air) using the installer of mac and I want to try out waifu2x.

error message:
Code:
Warning: Failed to load /Library/Frameworks/VapourSynth.framework/lib/vapoursynth/libwaifu2x-w2xc.dylib. Error given: dlopen(/Library/Frameworks/VapourSynth.framework/lib/vapoursynth/libwaifu2x-w2xc.dylib, 0x0001): Library not loaded: '@loader_path/../libw2xc.dylib'
  Referenced from: '/Library/Frameworks/VapourSynth.framework/lib/vapoursynth/libwaifu2x-w2xc.dylib'
  Reason: tried: '/Library/Frameworks/VapourSynth.framework/lib/vapoursynth/../libw2xc.dylib' (no such file), '/usr/local/lib/libw2xc.dylib' (no such file), '/usr/lib/libw2xc.dylib' (no such file)
It does not complain about any other plugins like ttempsmooth or removegrain that are in the same folder.

Script .vpy:
Code:
import vapoursynth as vs
import havsfunc as haf

core = vs.get_core()
#core.max_cache_size = 2048

video = core.lsmas.LWLibavSource(source=/Users/comp/Movies/1.mp4)

#video = haf.QTGMC(video, Preset="Slower", TFF=True)

video = core.fmtc.matrix (clp, mat="709",col_fam=vs.RGB)
video = core.fmtc.bitdepth (clp,bits=32,dmode=0)

video = w2xc.Waifu2x(video[, int noise=1, int scale=2, int block=512, bint photo=True, int gpu=1, int processor=-1, bint list_proc=False, bint log=False])

video = core.fmtc.resample(video, css="420")
video = core.fmtc.bitdepth(video, bits=8)
video = core.std.Trim(3600, 3700)
In Terminal:
Code:
vspipe -c y4m first.vpy - | ffmpeg -f yuv4mpegpipe -colorspace bt709 -i - -vcodec rawvideo -pix_fmt yuv420 -y vp_output.mov
Thanks!
anton_foy is offline   Reply With Quote
Old 1st August 2023, 16:13   #452  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
So that plugin requires the Vulkan SDK to be installed. Is your MacBook one of the newer ARM based ones? If so I'm not sure you're going to be able to get that working with the Intel compiles for VapourSynth.
__________________
Github | AviSynth 101 | VapourSynth 101
l33tmeatwad is offline   Reply With Quote
Old 1st August 2023, 16:21   #453  |  Link
anton_foy
Registered User
 
Join Date: Dec 2005
Location: Sweden
Posts: 705
Quote:
Originally Posted by l33tmeatwad View Post
So that plugin requires the Vulkan SDK to be installed. Is your MacBook one of the newer ARM based ones? If so I'm not sure you're going to be able to get that working with the Intel compiles for VapourSynth.
Ah probably missing the Vulkan SDK then I will try, thanks! Edit: Its the M1 2020

Last edited by anton_foy; 1st August 2023 at 17:03.
anton_foy is offline   Reply With Quote
Old 19th August 2023, 10:27   #454  |  Link
anton_foy
Registered User
 
Join Date: Dec 2005
Location: Sweden
Posts: 705
I did not get Waifu2x to work but thats ok, I got qtgmc to work properly and very fast aswell. Great so far but none of the others except nnedi3 is working for me, when calling for example video = core.focus.temporalsoften(video) I get an error telling me 'Attribute error: No attribute with the name focus exists.' does not exist even though the plugins along with all of those needed for qtgmc script is in the same folder. I mean qtgmc in Havsfunc depend on those plugins in the plugs folder so I don't understand it.
anton_foy is offline   Reply With Quote
Old 19th August 2023, 10:50   #455  |  Link
ChaosKing
Registered User
 
Join Date: Dec 2005
Location: Germany
Posts: 1,796
Searching for focus or temporalsoften in havsfunc leads to 0 results :-)
__________________
AVSRepoGUI // VSRepoGUI - Package Manager for AviSynth // VapourSynth
VapourSynth Portable FATPACK || VapourSynth Database
ChaosKing is offline   Reply With Quote
Old 19th August 2023, 11:32   #456  |  Link
anton_foy
Registered User
 
Join Date: Dec 2005
Location: Sweden
Posts: 705
Quote:
Originally Posted by ChaosKing View Post
Searching for focus or temporalsoften in havsfunc leads to 0 results :-)
Yes I meant any other core filters, temporalsoften for example
Just copied the lines from others here who used ts and other core filters. Was thinking this is some kind of macos issue with those but most probably Im the issue (vs n00b)
anton_foy is offline   Reply With Quote
Old 24th August 2023, 15:20   #457  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 7,347
Quote:
Searching for focus or temporalsoften in havsfunc leads to 0 results :-)
as aside note: iirc. older havsfunc.QTGMC versions required TemporalSoften
__________________
Hybrid here in the forum, homepage
Selur is offline   Reply With Quote
Old 29th November 2023, 19:56   #458  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 415
I apologize for the delay, but I finally got around to setting up a fresh development environment for everything. Based on various factors the new minimum OS version is 10.15. Additionally, since macOS compilation is known to be broken for R63, I will not be patching that version just to compile it so that will not be made available as an installer. VapourSynth R62 and older plugins will remain available for anyone that needs support on 10.13 or 10.14.

Installers for VapourSynth R64 & 65 are now available, the minimum OS version is now 10.15 and Python has been upgraded to 3.11, so make sure to backup any scripts in site-packages before installing as it will remove the Python 3.10 site-packages folder.
__________________
Github | AviSynth 101 | VapourSynth 101
l33tmeatwad is offline   Reply With Quote
Old 30th November 2023, 05:20   #459  |  Link
groucho86
Registered User
 
Join Date: Apr 2016
Posts: 85
Are these new for Intel only still? Meaning any asm code will not work on M1/M2/M3?
groucho86 is offline   Reply With Quote
Old 30th November 2023, 10:54   #460  |  Link
kedautinh12
Registered User
 
Join Date: Jan 2018
Posts: 2,161
Hi are you have other account Groucho2004?
kedautinh12 is offline   Reply With Quote
Reply

Tags
meatwadismagical, meatwadthegreat

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 14:02.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.