Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 16th April 2007, 14:12   #221  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
@J-Wo

What was the length of the entire pathname?
Guest is offline  
Old 22nd April 2007, 13:06   #222  |  Link
CruNcher
Registered User
 
CruNcher's Avatar
 
Join Date: Apr 2002
Location: Germany
Posts: 4,949
Quote:
Originally Posted by neuron2 View Post
I have created an Avisynth source filter for AVC/H.264 streams. I would appreciate feedback and suggestions for the most important features to add. At this point it is fast and reliable but limited in functionality. I need your guidance to prioritize future work. I also ask to be notified about any streams that are problematic with DGAVCDec.
Blue-Ray .m2ts with AVC doesn't work (feature request)
__________________
all my compares are riddles so please try to decipher them yourselves :)

It is about Time

Join the Revolution NOW before it is to Late !

http://forum.doom9.org/showthread.php?t=168004
CruNcher is offline  
Old 22nd April 2007, 16:05   #223  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Quote:
Originally Posted by CruNcher View Post
Blue-Ray .m2ts with AVC doesn't work (feature request)
Do you mean the demuxed elementary stream or the m2ts file itself? Obviously the latter doesn't work because I haven't added container support yet. I will be adding transport stream support first, followed by MP4.

If the elementary stream is not working, please post a link to the stream if you want support.
Guest is offline  
Old 22nd April 2007, 17:43   #224  |  Link
CruNcher
Registered User
 
CruNcher's Avatar
 
Join Date: Apr 2002
Location: Germany
Posts: 4,949
no no everything fine with the elementary stream (except that the slider seems to sometimes flip back/forth @ when seeking with the mouse hard todo fine seeks that way with the mouse useing the arrow buttons is precise and works fine hmm) i meant container support
huh and it crashed after bringing the main window into the back and then onto the front again boom dgavcindex terminated itself, only happens with a Stream loaded. Jep happens allways with every kind of elementary loaded in the preview window
__________________
all my compares are riddles so please try to decipher them yourselves :)

It is about Time

Join the Revolution NOW before it is to Late !

http://forum.doom9.org/showthread.php?t=168004

Last edited by CruNcher; 22nd April 2007 at 17:50.
CruNcher is offline  
Old 22nd April 2007, 17:53   #225  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Quote:
Originally Posted by CruNcher View Post
huh and it crashed after bringing the main window into the back and then onto the front again boom dgavcindex terminated itself, only happens with a Stream loaded. Jep happens allways with every kind of elementary loaded in the preview window
Oops. I'll fix that.
Guest is offline  
Old 22nd April 2007, 19:27   #226  |  Link
bob0r
Pain and suffering
 
bob0r's Avatar
 
Join Date: Jul 2002
Posts: 1,337
Blu-Ray

BLU-RAY

REPEAT AFTER ME:
BLU-RAY BLU-RAY is without an E!
BLU-RAY BLU-RAY is without an E!
BLU-RAY BLU-RAY is without an E!
BLU-RAY BLU-RAY is without an E!

(in dutch it rhymes, but oh well )
bob0r is offline  
Old 22nd April 2007, 19:35   #227  |  Link
CruNcher
Registered User
 
CruNcher's Avatar
 
Join Date: Apr 2002
Location: Germany
Posts: 4,949
okay BLU-RAY (will forget it in 2 secs anyway yeah dementia is something bad)
__________________
all my compares are riddles so please try to decipher them yourselves :)

It is about Time

Join the Revolution NOW before it is to Late !

http://forum.doom9.org/showthread.php?t=168004
CruNcher is offline  
Old 23rd April 2007, 14:42   #228  |  Link
tomos
Registered User
 
Join Date: Feb 2002
Location: UK
Posts: 534
not sure if this has been mentioned previously, but i found that dgavc doesnt like AVC files named *.mpv.

it scans fine but just times out loading. renaming the video to .h264 and editing the filename in the dga file so it ends with .h264 works fine. no re-scanning needed
tomos is offline  
Old 24th April 2007, 00:41   #229  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Quote:
Originally Posted by tomos View Post
it scans fine but just times out loading. renaming the video to .h264 and editing the filename in the dga file so it ends with .h264 works fine. no re-scanning needed
I'm not able to duplicate this. What do you mean by "times out loading"?
Guest is offline  
Old 24th April 2007, 01:16   #230  |  Link
tomos
Registered User
 
Join Date: Feb 2002
Location: UK
Posts: 534
at the moment i am messing with the hd-dvd movie 'babel'.

i am doing this now.

i run the file babel.mpv through dgavcindex. runs fine. no probs. then the probs start.

I drag and drop the AVS file onto vdub and it sits there for aaaages. task manager shows the cpu use going from 5-25%.

after a while (takes longer depending on the length/size of the source file i think) i get this error from vdub (for the trailer. took about 5 mins. would take 20+ for the actual movie)

Quote:
---------------------------
VirtualDub Error
---------------------------
Avisynth open failure:
AVCSource: Could not open one of the input files.
(L:\Babel\extra\Trailer.avs, line 2)
---------------------------
OK
---------------------------
After this i change the extension of the file from movie.mpv to movie.h264. i change the extension in the dga file as well. then drag and drop onto vdub and bingo. works fine.

if you still have probs replicating it, i suppose it could be this particular clip maybe?
tomos is offline  
Old 24th April 2007, 01:41   #231  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Please give me the AVS script and a fragment of the source stream that causes the problem. Thank you.
Guest is offline  
Old 24th April 2007, 02:01   #232  |  Link
tomos
Registered User
 
Join Date: Feb 2002
Location: UK
Posts: 534
Hi,

took 5 megs worth of the video and included the files in a rar file here

http://www.mytempdir.com/1306335

replicated the same issue with this sample

thanks
tomos is offline  
Old 24th April 2007, 05:07   #233  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Still works fine for me.

Can anyone else duplicate it with the files supplied?
Guest is offline  
Old 24th April 2007, 06:47   #234  |  Link
Trahald
Wewkiee
 
Trahald's Avatar
 
Join Date: Feb 2002
Location: kashyyyk
Posts: 2,270
if i use his files i get the same, 'avcsource:could not open one of the input files' errors.

i tried to drop the file directly into dgavcindex and i get '
---------------------------
Warning
---------------------------
slice_qp_delta makes slice_qp_y out of range

Hit Yes to continue with further popups, hit No to disable them.
---------------------------
Yes No
---------------------------
warnings..
renaming the extension made no difference... dunno if it has to do with where he cut the file? the warnings pop up pretty much immediately
__________________
...yeah...but...why on earth would I compare apples with apples?
Trahald is offline  
Old 24th April 2007, 13:47   #235  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Quote:
Originally Posted by Trahald View Post
renaming the extension made no difference
Do you mean just to the warnings? Did it make it possible to open the AVS in VirtualDub.

I cannot duplicate this, everything works fine for opening the AVS. Yes, I have the warning popup but it is harmless.

There is nothing in the code that even looks at the filename extension!

Last edited by Guest; 24th April 2007 at 13:51.
Guest is offline  
Old 24th April 2007, 20:59   #236  |  Link
Deinorius
Najarenthur
 
Deinorius's Avatar
 
Join Date: Jan 2006
Location: Austria (Vienna)
Posts: 202
I get an error with DGAVCIncx a4. By indexing it shows this warning (attachment). For a second it works, then it stops. But it uses still 50 % CPU, which is much with mine.

Indexing with a3 und decoding with a4 .dlls works fine.
Attached Images
 
Deinorius is offline  
Old 25th April 2007, 00:30   #237  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
For the hundred millionth time, if you want support give me the unprocessed input stream, or a fragment thereof.
Guest is offline  
Old 25th April 2007, 00:41   #238  |  Link
tomos
Registered User
 
Join Date: Feb 2002
Location: UK
Posts: 534
Quote:
Originally Posted by neuron2 View Post
Do you mean just to the warnings? Did it make it possible to open the AVS in VirtualDub.

I cannot duplicate this, everything works fine for opening the AVS. Yes, I have the warning popup but it is harmless.

There is nothing in the code that even looks at the filename extension!
i'll give it a go at some point on some other systems and retry. it does seem a little weird.
tomos is offline  
Old 25th April 2007, 01:25   #239  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Only thing I can think of is that you are inadvertently using DGAVCDecode.dll from alpha 3. You did update both DGAVCIndex and DGAVCDecode, yes?
Guest is offline  
Old 25th April 2007, 02:31   #240  |  Link
tomos
Registered User
 
Join Date: Feb 2002
Location: UK
Posts: 534
crap. sorry, i missed the update.

sorry about wasting your time
tomos is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 07:18.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.