Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 2nd December 2007, 23:16   #201  |  Link
SeeMoreDigital
Life looks better in UHD
 
SeeMoreDigital's Avatar
 
Join Date: Jun 2003
Location: Notts, UK
Posts: 11,302
Quote:
Originally Posted by vlada View Post

Anyway I have another problem. I'm not sure if MediaInfo is supposed to handle elemantary streams, but I think it usually does. I have a h.264 stream demuxed from AVCHD camcorder. MediaInfo 0.7.5.5 reports it as an AC3 audio. A sample can be downloaded here (7 MB).
Yes it can handle "elementary" streams...

MediaInfo v0.7.5.3 reports your sample as being: -
Code:
General #0
Complete name        : C:\Documents and Settings\SeeMoreDigital\Desktop\video5.264
Format               : AVC
Format/Info          : Advanced Video Codec
Format/Family        : AVC
File size            : 7.27 MiB

Video #0
Codec                : AVC
Codec/Info           : MPEG-4 AVC
Codec profile        : High@L4.0
Width                : 1440 pixels
Height               : 1088 pixels
Aspect ratio         : 4/3
PixelAspectRatio     : 1.000
DisplayAspectRatio   : 1.324
....and yes, MediaInfo v0.7.5.5 reports this: -
Code:
General #0
Complete name        : C:\Documents and Settings\SeeMoreDigital\Desktop\video5.264
Format               : AC3
Format/Info          : Audio Coding 3
File size            : 7.27 MiB
PlayTime             : 1mn 59s
Bit rate             : 512 Kbps

Audio #0
Codec                : AC3
Bit rate             : 512 Kbps
Bit rate mode        : CBR
Channel(s)           : 3 channels
Channel positions    : L C R
Cheers
__________________
| I've been testing hardware media playback devices and software A/V encoders and decoders since 2001 | My Network Layout & A/V Gear |
SeeMoreDigital is offline   Reply With Quote
Old 3rd December 2007, 01:08   #202  |  Link
foxyshadis
ангел смерти
 
foxyshadis's Avatar
 
Join Date: Nov 2004
Location: Lost
Posts: 9,356
Quote:
Originally Posted by vlada View Post
A friend of mine wrote a Python wrapper for the .dll so it is solved. I didn't have the time to dive into the code yet, I just verified it works. If anyone's interested in it, let me know.
Sure!
__________________
There are four boxes to be used in defense of liberty: soap, ballot, jury, and ammo. Please use in that order. ~ Ed Howdershelt
foxyshadis is offline   Reply With Quote
Old 8th December 2007, 12:50   #203  |  Link
vlada
Registered User
 
Join Date: Apr 2003
Location: Czech Republic
Posts: 752
So here it is: http://www.sendspace.com/file/ks1hei

As my friend told me it might not be fully functional, because he's never programmed anything in Python before. I'll also post it as an attachment, I hope somebody will approve it. It's only 4kB.

From what I tested so far everything seems to work correctly. I removed some comments he wrote me in Czech and translated some of them to English.
Attached Files
File Type: zip python.zip (3.9 KB, 791 views)
vlada is offline   Reply With Quote
Old 9th December 2007, 22:20   #204  |  Link
vlada
Registered User
 
Join Date: Apr 2003
Location: Czech Republic
Posts: 752
Zenitram> I have a TS sample, where MediaInfo can't detect any streams. It has one h.264 video track and 4 AC3 audio tracks. Are you interested in that file?
vlada is offline   Reply With Quote
Old 18th December 2007, 21:12   #205  |  Link
Atak_Snajpera
RipBot264 author
 
Atak_Snajpera's Avatar
 
Join Date: May 2006
Location: Poland
Posts: 6,530
Does anybody know why I get always that kind of garbage with every file on Vista?

Atak_Snajpera is offline   Reply With Quote
Old 21st December 2007, 01:40   #206  |  Link
vlada
Registered User
 
Join Date: Apr 2003
Location: Czech Republic
Posts: 752
Atak_Snajpera
I can confirm this too with 0.7.5.6. Version 0.7.5.0 works correctly. (I use Czech WinXP)
vlada is offline   Reply With Quote
Old 21st December 2007, 16:40   #207  |  Link
Kurtnoise
Swallowed in the Sea
 
Kurtnoise's Avatar
 
Join Date: Oct 2002
Location: Aix-en-Provence, France
Posts: 5,183
try this build...
Kurtnoise is offline   Reply With Quote
Old 21st December 2007, 16:44   #208  |  Link
Kurtnoise
Swallowed in the Sea
 
Kurtnoise's Avatar
 
Join Date: Oct 2002
Location: Aix-en-Provence, France
Posts: 5,183
Quote:
Originally Posted by vlada View Post
Zenitram> I have a TS sample, where MediaInfo can't detect any streams. It has one h.264 video track and 4 AC3 audio tracks. Are you interested in that file?
sure...upload a sample please. Same thing for the raw AVC (the link to download the file is dead).
Kurtnoise is offline   Reply With Quote
Old 23rd December 2007, 20:55   #209  |  Link
Atak_Snajpera
RipBot264 author
 
Atak_Snajpera's Avatar
 
Join Date: May 2006
Location: Poland
Posts: 6,530
Thanks Kurtnoise13 for fixed version
Atak_Snajpera is offline   Reply With Quote
Old 1st January 2008, 20:09   #210  |  Link
vlada
Registered User
 
Join Date: Apr 2003
Location: Czech Republic
Posts: 752
Quote:
Originally Posted by Kurtnoise13 View Post
sure...upload a sample please. Same thing for the raw AVC (the link to download the file is dead).
The problematic .TS file is uploaded at http://www.sendspace.com/file/xjfw21. I think the problem with AVC stream is general, because it happend to me with more files. But if you can't reproduce it I will reupload the sample again.

Also I have some features requests for MediaInfo. I'm now working on a program, which uses MediaInfo library to get information about media files and then displays the needed modification to transcode it to DVD-Video. I also plan to add more output formats and maybe some day even make it a simple to use transcoding tool.

Here is the problem I currently have:
I need to know video compression. I need to know if it is MPEG-1/2/4 ASP or AVC. Or any other compression format. I use the "codec/family" information to get the compression, but it only works for AVI. In other containers the video compression is found under "codec". I could workaround it, but I think this inconsistency should be fixed in MediaInfo.

Second problem is, that for Matroska files the DLL only displays Mk. Again I could workaround it very simply, but I think I should mention it.

Also I'd like to ask you if it is possible to indicate some more informations about H.264. For example B-frames, CABAC etc. Is it possible at all?

Also I get much more information from a RAW AVC stream then from the same video muxed in MKV. Why?
vlada is offline   Reply With Quote
Old 2nd January 2008, 06:20   #211  |  Link
Kurtnoise
Swallowed in the Sea
 
Kurtnoise's Avatar
 
Join Date: Oct 2002
Location: Aix-en-Provence, France
Posts: 5,183
Quote:
Originally Posted by vlada View Post
The problematic .TS file is uploaded at http://www.sendspace.com/file/xjfw21. I think the problem with AVC stream is general, because it happend to me with more files. But if you can't reproduce it I will reupload the sample again.
thanks...I'll try.

Quote:
Originally Posted by vlada View Post
Here is the problem I currently have:
I need to know video compression. I need to know if it is MPEG-1/2/4 ASP or AVC. Or any other compression format. I use the "codec/family" information to get the compression, but it only works for AVI. In other containers the video compression is found under "codec". I could workaround it, but I think this inconsistency should be fixed in MediaInfo.

Second problem is, that for Matroska files the DLL only displays Mk. Again I could workaround it very simply, but I think I should mention it.
Should be easy to tweak this...

Quote:
Originally Posted by vlada View Post
Also I'd like to ask you if it is possible to indicate some more informations about H.264. For example B-frames, CABAC etc. Is it possible at all?
It's possible and it's planned afaik...but I've no deadline on that.

Quote:
Originally Posted by vlada View Post
Also I get much more information from a RAW AVC stream then from the same video muxed in MKV. Why?
such as ? mkv parsing has been rewritten recently. So, several things are missing.
Kurtnoise is offline   Reply With Quote
Old 2nd January 2008, 16:48   #212  |  Link
vlada
Registered User
 
Join Date: Apr 2003
Location: Czech Republic
Posts: 752
Quote:
Originally Posted by Kurtnoise13 View Post
such as ? mkv parsing has been rewritten recently. So, several things are missing.
For example used profile (Baseline, Main, High etc.)
vlada is offline   Reply With Quote
Old 2nd January 2008, 20:37   #213  |  Link
Kurtnoise
Swallowed in the Sea
 
Kurtnoise's Avatar
 
Join Date: Oct 2002
Location: Aix-en-Provence, France
Posts: 5,183
with which matroska writer tools ? (x264/xvid_encraw-mkvtoolnix-gdsmux-gstreamer-handrake-avidemux-avimux_gui)
Kurtnoise is offline   Reply With Quote
Old 3rd January 2008, 01:25   #214  |  Link
vlada
Registered User
 
Join Date: Apr 2003
Location: Czech Republic
Posts: 752
O.K., so I'll be more specific. This what I get from an MKV:

Code:
Hlavní #0
Celý název a cesta   : C:\_avchd\video4.mkv
Formát               : Mk
Velikost souboru     : 16.2 MiB
Hrací čas            : 22s 880ms
Bit rate             : 5957 Kbps
Encoded date         : UTC 2007-08-11 16:43:56
Použitý software     : mkvmerge v2.0.2 ('You're My Flame') built on Feb 21 2007 23:40:55
Enkódoval            : libebml v0.7.7 + libmatroska v0.8.1

Video #0
Codec                : MPEG-4 AVC
Codec/Info           : MPEG4 ISO advanced profile
Hrací čas            : 22s 880ms
Bit rate             : 5833 Kbps
Šířka                : 1440pixely
Výška                : 1080pixely
Poměr stran          : 16/9
Frame rate           : 25.000 fps
The SW used to create the video is clear. Sorry for the Czech description, but even if I switch MediaInfo to English, the text remains in Czech. But it should be clear what the parameters are.

Now the same file after demuxing in MediaInfo 0.7.5.6:
Code:
Hlavní #0
Celý název a cesta   : C:\_avchd\video4.264
Velikost souboru     : 16.2 MiB
And now the same file in 0.7.5.0 (CLI, but it would be the same with GUI version):
Code:
General #0

Complete name        : C:\_avchd\video4.264
Format               : AVC
Format/Info          : Advanced Video Codec
Format/Family        : AVC
File size            : 16.2 MiB

Video #0
Codec                : AVC
Codec/Info           : MPEG-4 AVC
Codec profile        : High@L4.0
Width                : 1440 pixels
Height               : 1088 pixels
Aspect ratio         : 4/3
PixelAspectRatio     : 1.000
DisplayAspectRatio   : 1.324
So first of all there is a bug in newer versions of MediaInfo that they don't read RAW AVC streams. With the older version 0.7.5.0 there are no problems. Also as you can see, I get different information about the video stream when it is demuxed. From a RAW AVC stream I get the information about profile, but not bitrate, framerate and time. Neuron2 says it should be possible to read framerate information from an AVC stream.

Also aspect ratio doesn't match. Any idea why?

If you can't reproduce it and want to see this sample video, let me know and I'll upload it.

Last edited by vlada; 3rd January 2008 at 18:30. Reason: Finished uncomplete sentence
vlada is offline   Reply With Quote
Old 4th January 2008, 20:32   #215  |  Link
Kurtnoise
Swallowed in the Sea
 
Kurtnoise's Avatar
 
Join Date: Oct 2002
Location: Aix-en-Provence, France
Posts: 5,183
mmh, I just tried to parse a raw AVC stream on my side with the last library and I got all infos...could you upload a sample of your video4.mkv file.

Thanks.
Kurtnoise is offline   Reply With Quote
Old 4th January 2008, 23:37   #216  |  Link
vlada
Registered User
 
Join Date: Apr 2003
Location: Czech Republic
Posts: 752
The sample is at http://www.sendspace.com/file/gpb5ul. It is a 17MB clip from Panasonic AVCHD camcorder muxed into MKV (only video).
vlada is offline   Reply With Quote
Old 5th January 2008, 21:28   #217  |  Link
Kurtnoise
Swallowed in the Sea
 
Kurtnoise's Avatar
 
Join Date: Oct 2002
Location: Aix-en-Provence, France
Posts: 5,183
I've no idea why the parsing fails...I'll ask to Zenitram to look at this more carefully.



btw, I've made a fix for your 2nd problem from the post #211.
Kurtnoise is offline   Reply With Quote
Old 6th January 2008, 12:00   #218  |  Link
vlada
Registered User
 
Join Date: Apr 2003
Location: Czech Republic
Posts: 752
Thanks a lot for your great feedback.
vlada is offline   Reply With Quote
Old 23rd January 2008, 21:22   #219  |  Link
Kurtnoise
Swallowed in the Sea
 
Kurtnoise's Avatar
 
Join Date: Oct 2002
Location: Aix-en-Provence, France
Posts: 5,183
@vlada: some new stuff in the incoming release...

Quote:
General #0
Complete name : D:\Tor_\Script ED new_h264.mkv
Format : Matroska
File size : 5.11 MiB
PlayTime : 36s 959ms
Bit rate : 1160 Kbps
Encoded date : UTC 2008-01-23 20:13:57
Writing application : mkvmerge v2.1.0 ('Another Place To Fall') built on Aug 19 2007 13:40:07
Writing library : libebml v0.7.7 + libmatroska v0.8.1

Video #0
Codec : MPEG-4 AVC
Codec/Family : AVC
Codec/Info : Advanced Video Codec
Codec profile : High@L5.1
PlayTime : 36s 920ms
Bit rate : 1107 Kbps
Width : 640 pixels
Height : 336 pixels
Display Aspect ratio : 1.905
Frame rate : 25.000 fps
Chroma : 4:2:0
Interlacement : Progressive
Writing library : x264 - core 57 svn-699C
Kurtnoise is offline   Reply With Quote
Old 23rd January 2008, 21:31   #220  |  Link
vlada
Registered User
 
Join Date: Apr 2003
Location: Czech Republic
Posts: 752
That's great thanks a lot. I hope to get back to coding my application after a 2-weeks break. It is great news that I'll be able to get more detailed info.
vlada is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 20:27.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.