Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 31st July 2017, 10:39   #44501  |  Link
dbcooper
Registered User
 
Join Date: Jul 2009
Posts: 43
Hmm, the new AMD Vega GPUs have new instructions for video processing:

dbcooper is offline   Reply With Quote
Old 2nd August 2017, 08:52   #44502  |  Link
Goeggel
Registered User
 
Join Date: Jul 2017
Posts: 14
Only D3D9, no D3D11

I have been looking through the forum, but haven't found any solution yet: when using madVR, I always only get D3D9, not D3D11.

Zoom Player 13 with madVR 0.91.11
LAV 0.70.2
Windows 7 64bit
Nvidia GTX980 with driver 384.76

Windowed, I get: D3D9 old path
With FSE, I get: D3D9 new path

I think I have chosen all relevant configurations for D3D11, but I am not 100% sure. Anything I should test/check/change?
Goeggel is offline   Reply With Quote
Old 2nd August 2017, 09:08   #44503  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 5,655
go to rendering -> general settings -> "use direct3D 11 for..."
you changed some other settings too but you should now that better than me.
huhn is offline   Reply With Quote
Old 2nd August 2017, 17:36   #44504  |  Link
Goeggel
Registered User
 
Join Date: Jul 2017
Posts: 14
Quote:
Originally Posted by huhn View Post
go to rendering -> general settings -> "use direct3D 11 for..."
you changed some other settings too but you should now that better than me.
Many thanks for your prompt reply!
I had already enabled this setting. Somehow it doesn't work. Is there a debug log or any other way to check why D3D11 doesn't kick in?
Goeggel is offline   Reply With Quote
Old 2nd August 2017, 17:48   #44505  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 3,534
Do any of madVR's settings work?
__________________
madVR options explained
Asmodian is offline   Reply With Quote
Old 2nd August 2017, 18:39   #44506  |  Link
Goeggel
Registered User
 
Join Date: Jul 2017
Posts: 14
Yes, to me it looks like other settings work just fine. For example "switch to matching display mode" works on my TV. Or changing brightness under "color & gamma" works, too.
Goeggel is offline   Reply With Quote
Old 2nd August 2017, 19:35   #44507  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 5,655
there is a debug log but it is not really readable for us.

and you change other settings too which may make trouble like present frames in advanced.

i recommend to use the default settings and try d3d11 again.
huhn is offline   Reply With Quote
Old 2nd August 2017, 23:52   #44508  |  Link
MS-DOS
Registered User
 
Join Date: Sep 2012
Posts: 74
Quote:
Originally Posted by Goeggel View Post
Anything I should test/check/change?
Seems like you have desktop composition disabled. D3D11 presentation doesn't work without it.
MS-DOS is offline   Reply With Quote
Old 3rd August 2017, 03:21   #44509  |  Link
JayeDog
Registered User
 
Join Date: Mar 2017
Posts: 7
i just updated to windows 10 creators update but can't see the "HDR and advanced color" option under display properties.

I have a gtx 950. Do I need a hdr compatible display for the option to show up?
JayeDog is offline   Reply With Quote
Old 3rd August 2017, 03:46   #44510  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 3,534
Quote:
Originally Posted by JayeDog View Post
Do I need a hdr compatible display for the option to show up?
Yes.
__________________
madVR options explained
Asmodian is offline   Reply With Quote
Old 3rd August 2017, 06:35   #44511  |  Link
oddball
Registered User
 
Join Date: Jan 2002
Posts: 1,262
I've not heard much from Madshi lately. Hope he's OK.
oddball is offline   Reply With Quote
Old 3rd August 2017, 09:45   #44512  |  Link
pirlouy
_
 
Join Date: May 2008
Location: France
Posts: 628
So sweet of you. If you're that much a fanboy, you can spy his account, and you'll be reassured.
But maybe you meant you haven't heard much from a new version from Madshi lately. xD
__________________
Windows 10 x64; 1080p 60" TV, GTX 750; mpv or madVR+LAV Filters+MPC-BE
pirlouy is offline   Reply With Quote
Old 3rd August 2017, 16:25   #44513  |  Link
Goeggel
Registered User
 
Join Date: Jul 2017
Posts: 14
Quote:
Originally Posted by MS-DOS View Post
Seems like you have desktop composition disabled. D3D11 presentation doesn't work without it.
This gives me a headache. Still no D3D11. Here's what I have tried so far:
- no difference when disabling or enabling "present several frames in advance"
- no difference when disabling or enabling "disable desktop composition"
- removed madVR including all registry entries and settings.bin. Reinstalled it and enabled "use direct3D 11 for..." -> no luck
- Problem also occurs with Media Player Classic. So it doesn't seem to be related to Zoom Player.

Are there any settings in Windows 7 or Nvidia display driver which could interfere?
Goeggel is offline   Reply With Quote
Old 3rd August 2017, 16:28   #44514  |  Link
sneaker_ger
Registered User
 
Join Date: Dec 2002
Posts: 5,384
Do you have the Windows 7 Platform Update?
sneaker_ger is offline   Reply With Quote
Old 3rd August 2017, 17:31   #44515  |  Link
Goeggel
Registered User
 
Join Date: Jul 2017
Posts: 14
Yes, I guess so. I have Windows 7 64bit SP1 with all updates since. When I try to manually install Windows6.1-KB2670838-x64.msu (I think that's the platform update) it tells me that it is already installed.
Goeggel is offline   Reply With Quote
Old 3rd August 2017, 19:21   #44516  |  Link
sneaker_ger
Registered User
 
Join Date: Dec 2002
Posts: 5,384
Aero/DWM is enabled?
https://superuser.com/questions/4795...dwm-is-enabled
sneaker_ger is offline   Reply With Quote
Old 3rd August 2017, 19:56   #44517  |  Link
Goeggel
Registered User
 
Join Date: Jul 2017
Posts: 14
Quote:
Originally Posted by sneaker_ger View Post
Yes yes yes that's it! The corresponding DWM service was deactivated. With the service running I now have D3D11.

Many thanks for all your help here! A great community! Much appreciated.

Goeggel is offline   Reply With Quote
Old 4th August 2017, 00:24   #44518  |  Link
cokeefe
Registered User
 
Join Date: Aug 2011
Posts: 5
Quote:
Originally Posted by sneaker_ger View Post
Thank you, thank you! I have been trying to figure this out for the last two hours. I had switched to non-Aero Classic desktop, and switching back to Aero allowed D3D11 again in MadVR.

Naturally, I had also done a bunch of updates so the red herrings were running wild.
cokeefe is offline   Reply With Quote
Old 4th August 2017, 16:05   #44519  |  Link
Helios61
Registered User
 
Join Date: Aug 2011
Posts: 15
Hi madshi, Hi community,
unfortunately i've noticed some issues with madVR (?). I hope, sombody can help and give me some support.

Global Settings:
Windows 10 PRO / 1703
Intel HD-Grafik 630 / current driver
madVR v0.91.11
LAV Filters 0.70.2
HTPC -> Yamaha RX-V681 -> LG49UB856V (HDMI Connection)

1. In MPC-HC HD (LAV) Audio Bitstreaming doesn't work with refreshrate changer (madVR) enabled. This issue i've already reported in Mediaportal Forum and sebastiii could fix it in MediaPortal ->Link<-. With refreshrate changer disabled or EVR all is working fine.

2. With MediaPortal / madVR my 4K movies seems to be downscaled, ->

although display resolution is reported by TV as 4K. Playback of the same movie with MPC-HC and the same madVR settings isn't downscaled. Is it a wrong setting or am i doing something wrong?

3. Playback of frame packed 3D movies (MVC) unfortunately is completely broken in MPC-HC and Mediaportal (LAV 3D Plugin installed). If i start a 3D mkv, i get heavy flickering and stuttering. I have uploaded a 1 minute video (very bad, but you can see, what i mean) to dropbox ->Link<-. Playback with my "old" HD 4600 and similar driver settings is working fine.

As i said before, it would be great, if somebody could help me to find a solution.

Thanks in advance
Helios

Last edited by Helios61; 4th August 2017 at 16:19.
Helios61 is offline   Reply With Quote
Old 4th August 2017, 16:08   #44520  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 9,736
Quote:
Originally Posted by Helios61 View Post
2. With MediaPortal / madVR my 4K movies seems to be downscaled, ->

although display resolution is reported by TV as 4K. Playback of the same movie with MPC-HC and the same madVR settings isn't downscaled. Is it a wrong setting or am i doing something wrong?
This is usually a result of the player not being High-DPI-aware, so Windows pretends its running on a lower resolution and upscales it afterwards.
Basically, this needs to be fixed in your player. It needs to handle High-DPI scenarios.
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Reply

Tags
direct compute, dithering, error diffusion, madvr, ngu, nnedi3, quality, renderer, scaling, uhd upscaling, upsampling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 23:45.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.