Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Reply
 
Thread Tools Search this Thread Display Modes
Old 17th December 2018, 08:06   #81  |  Link
asarian
Registered User
 
Join Date: May 2005
Posts: 1,372
Quote:
Originally Posted by LigH View Post
It's just what the media-autobuild_suite produces, no additional changes. Look here for download link and version details.
Cool. Thx. I took the one from the start-post link (the one I'm encoding with now). It is dated Dec 13, 2018, so it looked pretty recent to me.

P.S. Yours -- apart from being compiled with a later compiler -- also appears to be a lot smaller (~14 MB vs. ~22 MB).
__________________
Gorgeous, delicious, deculture!
asarian is offline   Reply With Quote
Old 17th December 2018, 08:12   #82  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 5,829
Maybe the other one forgot stripping compiler symbols.
__________________

New German Gleitz board
MediaFire: x264 | x265 | VPx | AOM | Xvid
LigH is offline   Reply With Quote
Old 18th December 2018, 10:09   #83  |  Link
jpsdr
Registered User
 
Join Date: Oct 2002
Location: France
Posts: 1,702
Quote:
Originally Posted by LoRd_MuldeR View Post
Well, the person maintaining "tMod" build obviously did not bother to port all of the "custom" patches to latest x264 after the "8/10 bits unification" (Dec 2017), which was quite a big change in x264 codebase.

Instead "tMod" build seems now to be based on an old version of x264, just before the big "8/10 bits unification" happened with a some fixes cherry-picked from x264 master...
Yes, toooooooo much work to port all the custom patches.
Instead, i manualy put all the fixes from the master, except things which are specific to CPU not Intel.
__________________
My github.
jpsdr is offline   Reply With Quote
Old 18th December 2018, 16:02   #84  |  Link
Dogway
Registered User
 
Join Date: Nov 2009
Posts: 1,008
Quote:
Originally Posted by LoRd_MuldeR View Post
..."8/10 bits unification" (Dec 2017), which was quite a big change in x264 codebase.

Instead "tMod" build seems now to be based on an old version of x264, just before the big "8/10 bits unification" happened with a some fixes cherry-picked from x264 master...
Not sure if that unification is the reason but tMod build comes as the fastest for which I tested. Hopefully I don't miss much of the latest master builds.
Dogway is offline   Reply With Quote
Old 18th December 2018, 22:41   #85  |  Link
LoRd_MuldeR
Software Developer
 
LoRd_MuldeR's Avatar
 
Join Date: Jun 2005
Location: Last House on Slunk Street
Posts: 13,011
Quote:
Originally Posted by Dogway View Post
Not sure if that unification is the reason but tMod build comes as the fastest for which I tested. Hopefully I don't miss much of the latest master builds.
Comparing the speed of x264 builds that have not been built from the same revision (Git commit), or even comparing "vanilla" builds to builds that contain "custom" patches, won't yield much meaningful results.

(It would pretty much be a comparison of apples and oranges, because a whole lot of things may have changed between the builds you are comparing)
__________________
There was of course no way of knowing whether you were being watched at any given moment.
How often, or on what system, the Thought Police plugged in on any individual wire was guesswork.



Last edited by LoRd_MuldeR; 19th December 2018 at 03:18.
LoRd_MuldeR is offline   Reply With Quote
Old 19th December 2018, 21:14   #86  |  Link
Dogway
Registered User
 
Join Date: Nov 2009
Posts: 1,008
Just comparing them seems like none of them are compiled with opencl support? Was this deprecated at some point? I was reading about it not speeding up encoding much (~3%) but that translates to hours if your plan is to encode a library.
Dogway is offline   Reply With Quote
Old 19th December 2018, 21:23   #87  |  Link
Groucho2004
 
Groucho2004's Avatar
 
Join Date: Mar 2006
Location: A wretched hive of scum and villainy
Posts: 4,209
Quote:
Originally Posted by Dogway View Post
I was reading about it not speeding up encoding much (~3%)
I did some tests with "--OpenCL" a while ago and the speedup was ~1% at best (GTX750).
__________________
Groucho's Avisynth Stuff
Groucho2004 is offline   Reply With Quote
Old 19th December 2018, 21:27   #88  |  Link
Dogway
Registered User
 
Join Date: Nov 2009
Posts: 1,008
Is there a build to test? I just bought a GTX1070 and maybe it can be faster with current opencl enabled builds.
Dogway is offline   Reply With Quote
Old 19th December 2018, 21:41   #89  |  Link
Groucho2004
 
Groucho2004's Avatar
 
Join Date: Mar 2006
Location: A wretched hive of scum and villainy
Posts: 4,209
Quote:
Originally Posted by Dogway View Post
Is there a build to test? I just bought a GTX1070 and maybe it can be faster with current opencl enabled builds.
Most builds should have it enabled since it's the default. You have to disable it in ./configure (--disable-opencl) if you don't want it included.
__________________
Groucho's Avisynth Stuff
Groucho2004 is offline   Reply With Quote
Old 19th December 2018, 21:44   #90  |  Link
Dogway
Registered User
 
Join Date: Nov 2009
Posts: 1,008
(compiled) builds
Dogway is offline   Reply With Quote
Old 19th December 2018, 21:52   #91  |  Link
Groucho2004
 
Groucho2004's Avatar
 
Join Date: Mar 2006
Location: A wretched hive of scum and villainy
Posts: 4,209
Quote:
Originally Posted by Dogway View Post
(compiled) builds
Huh?

Have you tried this or the builds from VideoHelp?
__________________
Groucho's Avisynth Stuff

Last edited by Groucho2004; 19th December 2018 at 21:54.
Groucho2004 is offline   Reply With Quote
Old 19th December 2018, 21:53   #92  |  Link
asarian
Registered User
 
Join Date: May 2005
Posts: 1,372
Quote:
Originally Posted by Dogway View Post
(compiled) builds
Both LigH's x264, and the videolan one, are compiled with OpenCL support. So, it's just a matter of running your x264 flavor command-line with --opencl or not, for the test.
__________________
Gorgeous, delicious, deculture!
asarian is offline   Reply With Quote
Old 19th December 2018, 21:58   #93  |  Link
Dogway
Registered User
 
Join Date: Nov 2009
Posts: 1,008
I tested with videolan's, Ligh's and tmod. So not sure why it doesn't work, it warns me with a:
Code:
x264 [warning]: OpenCL: not compiled with OpenCL support, disabling
Using x64 builds in 10bit mode.

edit: yes confirmed, not working in 10-bit mode, only in 8-bit.

Last edited by Dogway; 19th December 2018 at 22:02.
Dogway is offline   Reply With Quote
Old 19th December 2018, 22:14   #94  |  Link
asarian
Registered User
 
Join Date: May 2005
Posts: 1,372
Quote:
Originally Posted by Dogway View Post
I tested with videolan's, Ligh's and tmod. So not sure why it doesn't work, it warns me with a:
Code:
x264 [warning]: OpenCL: not compiled with OpenCL support, disabling
Using x64 builds in 10bit mode.

edit: yes confirmed, not working in 10-bit mode, only in 8-bit.

It just so happened Lord_Mulder explained the 10-bit thing to me this very day. See: no OpenCL for 10-bit
__________________
Gorgeous, delicious, deculture!
asarian is offline   Reply With Quote
Old 19th December 2018, 22:23   #95  |  Link
Dogway
Registered User
 
Join Date: Nov 2009
Posts: 1,008
lol the very same question, I guess I clicked on the wrong thread. 8-bit encoding then it seems (with banding
Dogway is offline   Reply With Quote
Old 20th December 2018, 08:47   #96  |  Link
jpsdr
Registered User
 
Join Date: Oct 2002
Location: France
Posts: 1,702
I'm not 100% sure so this may have to be verified, but i vaguely remember reading once (it was now a long time ago), also that opencl doesn't produce exactly the same result than pure software (a little less good).
Considering that, the fact that to compile with opencl you need to install others third-party "things", the fact that speedup is not realy significant, i personnaly don't compile with opencl in the releases i made, and don't intend to bother with.
__________________
My github.
jpsdr is offline   Reply With Quote
Old 20th December 2018, 09:17   #97  |  Link
asarian
Registered User
 
Join Date: May 2005
Posts: 1,372
Quote:
Originally Posted by jpsdr View Post
I'm not 100% sure so this may have to be verified, but i vaguely remember reading once (it was now a long time ago), also that opencl doesn't produce exactly the same result than pure software (a little less good).
That would suck. Especially if the gain is allegedly only like 1%.

Quote:
Considering that, the fact that to compile with opencl you need to install others third-party "things", the fact that speedup is not realy significant, i personnaly don't compile with opencl in the releases i made, and don't intend to bother with.
A reasonable position. It's just that, in my quest for ever-more GPU-assisted tools, OpenCL just feels right; but it may just be a placebo.

As for having to 'install' third-party "things", I don't think that's a real issue: every Windows install will come with at least a default OpenCL.dll in its path.
__________________
Gorgeous, delicious, deculture!
asarian is offline   Reply With Quote
Old 20th December 2018, 09:44   #98  |  Link
Dogway
Registered User
 
Join Date: Nov 2009
Posts: 1,008
I made a test and at slower preset I get 109fps without opencl and 113 at most with it. That's about 3%, or an extra 1h and a half of rendering content for a 24fps film for 9h at night. tMod is already 3 or 4% faster than other builds I tested so if what you say is true I guess than at equal speed I would rather use one that doesn't degrade my content. Too bad we can't have both for a 7% gain haha.
Dogway is offline   Reply With Quote
Old 20th December 2018, 09:46   #99  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 5,829
An OpenCL driver is usually part of the graphic driver set (like OpenGL and maybe even OpenAL).
__________________

New German Gleitz board
MediaFire: x264 | x265 | VPx | AOM | Xvid
LigH is offline   Reply With Quote
Old 21st December 2018, 09:24   #100  |  Link
jpsdr
Registered User
 
Join Date: Oct 2002
Location: France
Posts: 1,702
Someone (not me... ) made tests with my releases (only on the x64 versions). It says that win32 version was around 1~2% faster than posix version, and Broadwell version was around also 1~2% faster than "normal" release. Both combined, you can indeed maybe achieve 3~4%. Different build configuration can explain differences in speed, but only that. Otherwise, code is the same. I'm not sure that only difference in gcc version could produce a such difference on speed.
Out of curiosity, when you said tMod is around 3~4%, which build ? Win32 or Posix ? Normal or Broadwell ?

Ah, and about opencl, i should have said : To build with it, it seems that i need to install in the build environement some others third party things i don't know about, so, too much bother for something from my point of view is not worth it.
__________________
My github.

Last edited by jpsdr; 21st December 2018 at 09:27.
jpsdr is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 03:17.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.