Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Linux, Mac OS X, & Co

Reply
 
Thread Tools Search this Thread Display Modes
Old 9th June 2013, 06:40   #1  |  Link
Tatsh
Enthusiast
 
Join Date: Jul 2005
Posts: 32
Encoding to MP4 DVD with shifting framerate

I have a DVD that seems to be consistent in shifting framerates from 29.970 to 24000/1001 over and over as the video plays.

It almost seems this is impossible to rip. With mencoder, I have tried filmdint, yadif, pullup+softskip. The video is seen as 29.970 by mplayer.

Code:
VIDEO:  MPEG2  720x480  (aspect 2)  29.970 fps  9800.0 kbps (1225.0 kbyte/s)
but then the really strange part is this:

Code:
demux_mpg: 24000/1001fps progressive NTSC content detected, switching framerate.
A:   1.9 V:   1.8 A-V:  0.015 ct:  0.056  42/ 39  7%  0%  0.3% 0 0 

demux_mpg: 30000/1001fps NTSC content detected, switching framerate.
A:   1.9 V:   1.9 A-V:  0.014 ct:  0.057  43/ 40  7%  0%  0.3% 0 0 
Warning! FPS changed 23.976 -> 29.970  (-5.994005) [4]  
A:   5.2 V:   5.2 A-V: -0.006 ct:  0.125 144/138  6%  0%  0.3% 0 0 

demux_mpg: 24000/1001fps progressive NTSC content detected, switching framerate.
A:   5.6 V:   5.6 A-V:  0.007 ct:  0.134 155/148  6%  0%  0.3% 0 0 

demux_mpg: 30000/1001fps NTSC content detected, switching framerate.
A:   5.7 V:   5.7 A-V:  0.006 ct:  0.135 156/149  6%  0%  0.3% 0 0 
Warning! FPS changed 23.976 -> 29.970  (-5.994005) [4]  
A:   7.1 V:   7.1 A-V:  0.001 ct:  0.198 200/188  6%  0%  0.3% 0 0 

demux_mpg: 24000/1001fps progressive NTSC content detected, switching framerate.
A:   7.8 V:   7.8 A-V:  0.058 ct:  0.224 218/206  6%  0%  0.3% 0 0 

demux_mpg: 30000/1001fps NTSC content detected, switching framerate.
A:   7.9 V:   7.8 A-V:  0.054 ct:  0.229 219/207  6%  0%  0.3% 0 0 
Warning! FPS changed 23.976 -> 29.970  (-5.994005) [4]  
A:  10.5 V:  10.5 A-V:  0.000 ct:  0.295 301/286  6%  0%  0.3% 0 0
Encoding to 30 FPS makes the video go too fast and encoding to 24 keeps the video in sync for about the first 30 seconds.

Is it simply not possible to get this back into a normal state? I do not care about whether it is 24000/1001 or 30000/1001. Either is fine, but I want to make sure the audio stays synced.

Any mencoder help appreciated. I am using this wrapper (written by me) to help https://gist.github.com/Tatsh/5737088 (see line 30 mainly). In the script that imports this, I just call encoder_do_all().
Tatsh is offline   Reply With Quote
Old 18th February 2014, 05:59   #2  |  Link
beandog
Registered User
 
beandog's Avatar
 
Join Date: Jun 2009
Location: /usa/utah/slc
Posts: 18
Yah I've had that problem a lot. The simple solution is to use Handbrake, either the GUI or the CLI app. It's always had great filters that take care of variable framerate like this.
__________________
If it ain't broke, tweak it.
beandog is offline   Reply With Quote
Reply

Tags
mencoder, ntsc, progressive

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 16:11.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.