Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 26th January 2009, 00:32   #901  |  Link
rica
Registered User
 
Join Date: Mar 2008
Posts: 2,021
Awaiting, thanks.
rica is offline  
Old 27th January 2009, 02:00   #902  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
OK, the MKV test version is back on the road:

http://neuron2.net/dgavcdecnv/dgavcdecnv1011test.zip

Please provide test streams with your problem reports.

I added some pop-up messages to notify you of possible problem conditions. Please let me know if you see any of them.
Guest is offline  
Old 27th January 2009, 02:53   #903  |  Link
xopowo
Registered User
 
Join Date: Aug 2008
Posts: 25
Quote:
Originally Posted by neuron2 View Post
What is it about the server that bugs you?

When I load my avs script into vdubmod (I have to have to server running). Say I make frame cuts, then close the file and then reopen it to have it open honoring the cuts. CUVIDServer will keep frames in memory.. So, if there was a video frame (non-black) in memory, than if I start to encode from there, that frame, even if not included with the cuts that I made; will be part of the final encode. Don't know why it does that, but it does it every time.

The only way around this that I know of is to make cuts in vdubmod, close the app, close cuvidserver, reopen the server, then vdubmod, load the avs and then it's good. I don't know if this is happening to anyone else, but it happens to me everytime.
xopowo is offline  
Old 27th January 2009, 03:17   #904  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Quote:
Originally Posted by xopowo View Post
Say I make frame cuts, then close the file and then reopen it to have it open honoring the cuts.
I don't use VirtualDubMod so I ask this: Why do you have to close and re-open the file? How do you close it?

When you exit VDM, the filter gets deinstantiated, which should clear the CUVID server. I don't know what happens if you just do File/Close video file. If VDM doesn't deinstantiate the source filter, then there can be trouble.

Last edited by Guest; 27th January 2009 at 03:20.
Guest is offline  
Old 27th January 2009, 05:30   #905  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Nvidia Development Dialog Updated

I've updated the Nvidia Development dialog to cover the period of the VC1 development and the ongoing MKV support.

http://neuron2.net/dgavcdecnv/cuda/cuda.html

The updated material starts here:

http://neuron2.net/dgavcdecnv/cuda/cuda.html#update
Guest is offline  
Old 27th January 2009, 07:44   #906  |  Link
xopowo
Registered User
 
Join Date: Aug 2008
Posts: 25
Quote:
Originally Posted by neuron2 View Post
I don't use VirtualDubMod so I ask this: Why do you have to close and re-open the file? How do you close it?

When you exit VDM, the filter gets deinstantiated, which should clear the CUVID server. I don't know what happens if you just do File/Close video file. If VDM doesn't deinstantiate the source filter, then there can be trouble.

Perhaps "cuts" wasn't the best way in which to describe it. When I make trims would be more appropriate. Then, when the trims are saved into the avs file, then I re-open the file so that the script will load with the applicable trims. When this happens, if there was a video frame that was viewed with the server running, then even though I load the script again with the appropriate trims, that video frame is stuck in memory somehow and it will actually encode into the video even if that particular frame is outside of the boundary of the trims that were specified.

Does that perhaps explain it better? It makes sense to me, but that obviously does nobody but myself any good.

**edit** If I hit file/close, or just re-open the avs with the trims in it, or if I physically close the application and re-launch it ... this particular anomoly happens each time. I 'have' to exit the cuvid server and relaunch it to clear any frames that it may have in memory.

Last edited by xopowo; 27th January 2009 at 07:46.
xopowo is offline  
Old 27th January 2009, 07:49   #907  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
I guess you are using the AVS script editor?

You should tell me exactly what menu items you select, etc., as I am not a user of that and when you say "I re-open the file" that means nothing to me because I don't know what you are actually doing in the program to make that happen.

I also don't know how VDM refreshed the AVS script and whether it deinstantiates the filter. If it isn't deinstantiating it to reload the script then it won't work. I'm willing to work to make third party apps work right with the server, but VDM is abandoned for a long time.

Last edited by Guest; 27th January 2009 at 07:56.
Guest is offline  
Old 27th January 2009, 07:51   #908  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Do you happen to have the CUVID deinterlacer enabled?
Guest is offline  
Old 27th January 2009, 20:29   #909  |  Link
Sharc
Registered User
 
Join Date: May 2006
Posts: 3,244
Quote:
Originally Posted by neuron2 View Post
...... I added some pop-up messages to notify you of possible problem conditions. Please let me know if you see any of them.
Spares cues in this Matroska file. Seeking may be slow.
Sharc is offline  
Old 27th January 2009, 21:36   #910  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
And is seeking slow?
Guest is offline  
Old 27th January 2009, 21:46   #911  |  Link
rica
Registered User
 
Join Date: Mar 2008
Posts: 2,021
I get this:



with this mkv:

http://www.sendspace.com/file/hsogkj

That is working with TMT and MPC-HC.

The method i used:

On the fly cut from original disc as is with head.exe.
Remux video to mkv with eac3to or GraphStudio. (both files don't work.)

_ _ _ _
Attached Images
 

Last edited by rica; 27th January 2009 at 22:10.
rica is offline  
Old 27th January 2009, 21:57   #912  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
"This" doesn't help me because I cannot see the image through my firewall. Can you give it to me in words?
Guest is offline  
Old 27th January 2009, 22:01   #913  |  Link
Eragon4ever
lost program in the net
 
Join Date: Jun 2006
Location: Germany
Posts: 106
"Timecode tracking failure."
Eragon4ever is offline  
Old 27th January 2009, 22:06   #914  |  Link
rica
Registered User
 
Join Date: Mar 2008
Posts: 2,021
I put an attachment to my previous post.

Last edited by rica; 27th January 2009 at 22:08.
rica is offline  
Old 27th January 2009, 22:13   #915  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Redownload the version. I updated it to fix that yesterday evening.
Guest is offline  
Old 27th January 2009, 22:27   #916  |  Link
Sharc
Registered User
 
Join Date: May 2006
Posts: 3,244
Quote:
Originally Posted by neuron2 View Post
And is seeking slow?
Yes, slow.
Sharc is offline  
Old 27th January 2009, 22:29   #917  |  Link
rica
Registered User
 
Join Date: Mar 2008
Posts: 2,021
Quote:
Originally Posted by neuron2 View Post
Redownload the version. I updated it to fix that yesterday evening.
OK, i've revized; thanks.
Attached Images
 

Last edited by rica; 27th January 2009 at 22:38.
rica is offline  
Old 27th January 2009, 22:44   #918  |  Link
rica
Registered User
 
Join Date: Mar 2008
Posts: 2,021
What is next; it is DGVC1NV's turn?
rica is offline  
Old 27th January 2009, 22:57   #919  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Patience, my friend. I have to solve a few issues and add audio support first.
Guest is offline  
Old 27th January 2009, 23:41   #920  |  Link
~bT~
н∂-αиαтι
 
Join Date: May 2006
Location: Bedfordshire, UK
Posts: 1,005
Quote:
Originally Posted by neuron2 View Post
And is seeking slow?
i cant seek at all. would u like a sample?

edit: after i saved the project, it let me seek.

i then tried to open another mkv and it crashed. had to restart cuvid server. loaded the mkv again, no seeking..saved the project, seeking works

Last edited by ~bT~; 27th January 2009 at 23:49.
~bT~ is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 23:07.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.