Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 30th March 2018, 23:01   #49961  |  Link
Warner306
Registered User
 
Join Date: Dec 2014
Posts: 1,124
Quote:
Originally Posted by maxkolonko123 View Post
So my question is why after matching tv refresh rate to movie such problem started to occur? and steps i should i do to try make this sorted.

btw. i have smooth option off if does matter or not in this situation, but from what i remember when i had on, there were issues with smooth playback

what i notice as well that :
- decoder, upload, render, present queue cant stabilize, i can see every few seconds changes there

cheers
It's called clock jitter and it's normal for all HTPCs. The clocks are often worse at 24p. Most won't notice these frame repeats/drops, but they can be improved.

Read this tutorial on how to combat it: http://madvr.com/crt/CustomResTutorial.html

Last edited by Warner306; 30th March 2018 at 23:10.
Warner306 is offline   Reply With Quote
Old 30th March 2018, 23:08   #49962  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 3,683
At 60Hz each refresh is less than half the frame time so you do not get repeated frames reported even if madVR needs to hold a frame for an extra refresh. The same with displaying a frame for one less refresh, every frame normally gets at least two refreshes so even if madVR needs to drop a refresh to resync the frame is still displayed, just for less time, so no dropped frames are reported.

With a matching refresh rate any need to resync the video to the audio will result in dropping or repeating entire frames. You need to use the custom refresh rate tab of madVR to optimize your refresh rate to match your audio clock. Do not pay attention to the clock deviation reported in the OSD to judge this, the reported dropped or repeated frames are more accurate indicators.

Small fluctuations in the queues are normal, as long as none of them have a 0 it should be fine.
__________________
madVR options explained
Asmodian is offline   Reply With Quote
Old 30th March 2018, 23:18   #49963  |  Link
maxkolonko123
Registered User
 
Join Date: Nov 2017
Posts: 56
Quote:
Originally Posted by Asmodian View Post
At 60Hz each refresh is less than half the frame time so you do not get repeated frames reported even if madVR needs to hold a frame for an extra refresh. The same with displaying a frame for one less refresh, every frame normally gets at least two refreshes so even if madVR needs to drop a refresh to resync the frame is still displayed, just for less time, so no dropped frames are reported.

With a matching refresh rate any need to resync the video to the audio will result in dropping or repeating entire frames. You need to use the custom refresh rate tab of madVR to optimize your refresh rate to match your audio clock. Do not pay attention to the clock deviation reported in the OSD to judge this, the reported dropped or repeated frames are more accurate indicators.

Small fluctuations in the queues are normal, as long as none of them have a 0 it should be fine.
Thought reclock will do all the magic for me, cause this sounds to me like blakc magic

all my refresh rates are standard mode with unknown timing details

Last edited by maxkolonko123; 30th March 2018 at 23:23.
maxkolonko123 is offline   Reply With Quote
Old 30th March 2018, 23:51   #49964  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 3,683
If you are using reclock and still getting dropped or repeated frames something is wrong somewhere.
__________________
madVR options explained
Asmodian is offline   Reply With Quote
Old 31st March 2018, 00:17   #49965  |  Link
maxkolonko123
Registered User
 
Join Date: Nov 2017
Posts: 56
Quote:
Originally Posted by Asmodian View Post
If you are using reclock and still getting dropped or repeated frames something is wrong somewhere.
It all started from adding 2160p23 and 24p and making nvidia refresh rate match movie rate. Like i said when i play movie on 59hz without matching to 23.97fps it was all good and 1 frame repeat was at 44min not 7min.

I didnt change any other settings in madvr just this refresh rate


So annoying, always something wrong god dammit

Last edited by maxkolonko123; 31st March 2018 at 00:19.
maxkolonko123 is offline   Reply With Quote
Old 31st March 2018, 00:21   #49966  |  Link
el Filou
Registered User
 
el Filou's Avatar
 
Join Date: Oct 2016
Posts: 537
Quote:
Originally Posted by DragonQ View Post
I'm confused. Increasing the "display's peak nits" setting in the HDR tab makes it more washed out for me.
Setting a high 'peak nits' value clips (Edit: compresses) the highlights less severely (so you get more dynamic range) but the picture will have lower overall brightness and contrast.
Setting a very low 'peak nits' value will make the picture brighter and with more contrast but with lower dynamic range as highlights will be clipped (Edit: compressed) more severely.

Do you know the real max brightness of your monitor in cd/mē (nits)? If yes then try setting the backlight of your monitor to its highest possible value (or better make a profile for madVR HDR if possible), and then set the 'peak nits' setting to your monitor's maximum light output value. Many PC LCD monitors can easily get to 300-350, which is blindingly bright for native SDR but useful for madVR's HDR downconversion.
__________________
HTPC: Windows 10 1809, MediaPortal 1, LAV Filters, ReClock, madVR. DVB-C TV, Panasonic GT60, 6.0 speakers Denon 2310, Core 2 Duo E7400, GeForce 1050 Ti

Last edited by el Filou; 1st April 2018 at 00:38.
el Filou is offline   Reply With Quote
Old 31st March 2018, 00:43   #49967  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 3,683
Quote:
Originally Posted by maxkolonko123 View Post
It all started from adding 2160p23 and 24p and making nvidia refresh rate match movie rate. Like i said when i play movie on 59hz without matching to 23.97fps it was all good and 1 frame repeat was at 44min not 7min.
Well, to be fair 23p or 24p on 60Hz is never "all good" without smooth motion. You are not getting told there are issues but there is a lot of judder in the playback. Frames are displayed for 2 or 3 refreshes, with rare frames displayed for 1 or 4 refreshes, but no reported frame drops or repeats. Reclock does not do anything in this situation either, it cannot sync the audio clock to the video rate to correctly display 23p at 60Hz because it is impossible to correctly display 23p at 60Hz (without smooth motion).

Stop using Reclock and use smooth motion with 60Hz (disable display modes) or keep Reclock and use a matching refresh rate. Check your Reclock settings if you are getting reported dropped or repeated frames watching 23p at 23 Hz. Ignore the "1 frame repeat/drop every X minutes" in the OSD when using Reclock, Reclock messes up madVR's predictions because it is constantly adjusting the audio speed to prevent dropped or repeated frames (edit: except when the video frame rate is too far away from the refresh rate, like 23p at 60Hz, in which case it does not do its adjustment).
__________________
madVR options explained

Last edited by Asmodian; 31st March 2018 at 00:49.
Asmodian is offline   Reply With Quote
Old 31st March 2018, 00:46   #49968  |  Link
brazen1
Registered User
 
Join Date: Oct 2017
Posts: 227
When you play at 59Hz, all is not good. You have judder and motion problems unless you use 'smooth motion' setting which helps.
If you have a native 60hz display, use that old setting with smooth motion on.
If you have a native 120Hz display, use how we are trying to explain to you for best results.
Is your display native 60Hz or 120Hz? Google 'refresh rate' for your model.
__________________
HOW TO-Kodi 2D-3D-UHD (4k) HDR Guide Internal & External Players
W10 1903 9604GB RGB 4:4:4 @Matched Refresh Rates 8,10,12bit
KODI MPC-HC/BE PDVD19 DVDFab 3 & 5
65JS8500 UHD HDR 3D

Last edited by brazen1; 31st March 2018 at 00:50.
brazen1 is offline   Reply With Quote
Old 31st March 2018, 00:57   #49969  |  Link
Statick
Registered User
 
Join Date: Aug 2016
Posts: 21
is there a way to enable upscaling refinements only when a certain level of upscaling has taken place? I like to have various enhancements enabled when upscaling SD DVD content to 1080, but when I watch stuff which is already in HD I get dropped frames unless I disable them, and I don't really need the enhancements enabled then anyway

I'm running MadVR on a HTPC so I don't really want to be fiddling with settings every time I watch something, ideally I want one setting that works all the time (which currently means I have to keep some of the enhancements disabled)

also, is there a way to choose a basic upscaling algorithm other than Jinc when a doubling algorithm is selected? I have xbr selected for doubling, with Lanczos3 for "if any (more) scaling is required", but when I watch 4:3 1080 content with black bars zoomed 50%, it scales the image using Jinc AR regardless
Statick is offline   Reply With Quote
Old 31st March 2018, 01:12   #49970  |  Link
maxkolonko123
Registered User
 
Join Date: Nov 2017
Posts: 56
Quote:
Originally Posted by brazen1 View Post
When you play at 59Hz, all is not good. You have judder and motion problems unless you use 'smooth motion' setting which helps.
If you have a native 60hz display, use that old setting with smooth motion on.
If you have a native 120Hz display, use how we are trying to explain to you for best results.
Is your display native 60Hz or 120Hz? Google 'refresh rate' for your model.
I have lg e6 so native is 60hz. That's why im trying to figure it out how to get it sorted so i can play movies at original refresh mode how u guys recommend, just dont know where to look for solution in my settings.

When i was using smooth motion with 59hz they i had really stuttering playback, that's why now is off.

Do you think that my issue might cause of

Display 23.97852hz
composition 23.976hz

Would this small difference matter?

Reclock showing : refresh rate 24.000hz DDR, while in nvidia planel is 23hz insted 24 like it says in reclock, but dont know if this matter

Last edited by maxkolonko123; 31st March 2018 at 01:26.
maxkolonko123 is offline   Reply With Quote
Old 31st March 2018, 01:17   #49971  |  Link
Warner306
Registered User
 
Join Date: Dec 2014
Posts: 1,124
Quote:
Originally Posted by Statick View Post
is there a way to enable upscaling refinements only when a certain level of upscaling has taken place? I like to have various enhancements enabled when upscaling SD DVD content to 1080, but when I watch stuff which is already in HD I get dropped frames unless I disable them, and I don't really need the enhancements enabled then anyway

I'm running MadVR on a HTPC so I don't really want to be fiddling with settings every time I watch something, ideally I want one setting that works all the time (which currently means I have to keep some of the enhancements disabled)

also, is there a way to choose a basic upscaling algorithm other than Jinc when a doubling algorithm is selected? I have xbr selected for doubling, with Lanczos3 for "if any (more) scaling is required", but when I watch 4:3 1080 content with black bars zoomed 50%, it scales the image using Jinc AR regardless
You need to create profile rules for different content. madVR was designed this way. The first page has an explanation on how to create these rules. I suggest using resolution for the rules covering the scaling category in the madVR control panel.
Warner306 is offline   Reply With Quote
Old 31st March 2018, 01:21   #49972  |  Link
Warner306
Registered User
 
Join Date: Dec 2014
Posts: 1,124
Quote:
Originally Posted by maxkolonko123 View Post
I have lg e6 so native is 60hz. That's why im trying to figure it out how to get it sorted so i can play movies at original refresh mode how u guys recommend, just dont know where to look for solution in my settings.

When i was using smooth motion with 59hz they i had really stuttering playback, that's why now is off.
I looked up your display previously and it supports 24p playback. If using ReClock, you must output the audio as PCM streams. That is the trade off. Using custom modes is necessary when bitstreaming. Or you could watch some content and see if you actually notice the frame drops/repeats.
Warner306 is offline   Reply With Quote
Old 31st March 2018, 02:11   #49973  |  Link
maxkolonko123
Registered User
 
Join Date: Nov 2017
Posts: 56
Quote:
Originally Posted by Warner306 View Post
I looked up your display previously and it supports 24p playback. If using ReClock, you must output the audio as PCM streams. That is the trade off. Using custom modes is necessary when bitstreaming. Or you could watch some content and see if you actually notice the frame drops/repeats.

Hmmm

So shall i accept bitstream or no in reclock ? when i untick it my AVR shows MUTICH when i tick accept bitstream then im getting right audio mode like dts hd etc.
maxkolonko123 is offline   Reply With Quote
Old 31st March 2018, 02:38   #49974  |  Link
Warner306
Registered User
 
Join Date: Dec 2014
Posts: 1,124
Quote:
Originally Posted by maxkolonko123 View Post
Hmmm

So shall i accept bitstream or no in reclock ? when i untick it my AVR shows MUTICH when i tick accept bitstream then im getting right audio mode like dts hd etc.
Media speed correction only works with PCM output. You lose Dolby Atmos and DTS:X if you need these. I would come to grips with custom modes. The tutorial posted earlier was written by the developer madshi.

Edit: I should say bitstreaming technically works with ReClock, but it drops/dupes packets of data to keep time. When I’ve tried this, madVR judders. It can also lead to audio dropouts.

Last edited by Warner306; 31st March 2018 at 02:41.
Warner306 is offline   Reply With Quote
Old 31st March 2018, 03:08   #49975  |  Link
maxkolonko123
Registered User
 
Join Date: Nov 2017
Posts: 56
Quote:
Originally Posted by Warner306 View Post
Media speed correction only works with PCM output. You lose Dolby Atmos and DTS:X if you need these. I would come to grips with custom modes. The tutorial posted earlier was written by the developer madshi.

Edit: I should say bitstreaming technically works with ReClock, but it drops/dupes packets of data to keep time. When I’ve tried this, madVR judders. It can also lead to audio dropouts.
For now i will try this guide https://sunmaiblog.wordpress.com/201...ming-hd-audio/ and stick to bitstream with wasapi exclusive and see how it goes, it showed me 2 dropped 1 repeated in reclock but didnt had any dropped frames in madvr, but i just watched few minutes on windowed mode in mpc-hc, will watch something as it should and see then.

If wasapi exclusive wont help or i will still have dropped frames, i will try stricte PCM mode and re watch same movie and compare dropped frames to bitstream mode.

When u mentioned the audio dropouts, sometimes i have clicks in avr, like sound mode change or so but its not, so maybe it's the bitstream case then.

The custom modes in madvr i would love to try this but it's hard for me to get my head around it even with this tutorial, main thing is i watched movie for over 10min and didnt get any timing details, so i dont know if i need to add again my 23hz mode or what, to make madvr measure my video playback

In custom modes the : delete and optimize is greyed out i can only do edit and reset gpu. So if someone would be so kind and help me out a lil bit more how to get this started, i would try to sort my issue trough custom display modes and then see if messing with custom mode and bitstream can work together without any issues

Last edited by maxkolonko123; 31st March 2018 at 03:20.
maxkolonko123 is offline   Reply With Quote
Old 31st March 2018, 08:01   #49976  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 3,683
Quote:
Originally Posted by maxkolonko123 View Post
In custom modes the : delete and optimize is greyed out i can only do edit and reset gpu. So if someone would be so kind and help me out a lil bit more how to get this started, i would try to sort my issue trough custom display modes and then see if messing with custom mode and bitstream can work together without any issues
Click on the refresh rate you want to customize (make sure it is not the active mode) and click edit. Choose "CVT Reduced Blanking v2" as a good starting point. Click Test Mode, and then click Yes when it asks if you want to save these custom timings. The status has to say "custom timings", not "standard mode", for madVR to measure and optimize a refresh rate.

Then watch something for at least 10 minutes, the longer the better. Do not seek, pause, look at menus, etc. while watching; ideally simply start a movie playing and then don't touch anything for the entire movie. After it is over go back into custom modes and click optimize.

Do not use Reclock while doing this.
__________________
madVR options explained
Asmodian is offline   Reply With Quote
Old 31st March 2018, 12:04   #49977  |  Link
maxkolonko123
Registered User
 
Join Date: Nov 2017
Posts: 56
Quote:
Originally Posted by Asmodian View Post
Click on the refresh rate you want to customize (make sure it is not the active mode) and click edit. Choose "CVT Reduced Blanking v2" as a good starting point. Click Test Mode, and then click Yes when it asks if you want to save these custom timings. The status has to say "custom timings", not "standard mode", for madVR to measure and optimize a refresh rate.

Then watch something for at least 10 minutes, the longer the better. Do not seek, pause, look at menus, etc. while watching; ideally simply start a movie playing and then don't touch anything for the entire movie. After it is over go back into custom modes and click optimize.

Do not use Reclock while doing this.

Ok so CVT v1 and v2 doesnt work, screen go blank then comes after while and there is no option to click yes etc.

CVT CRT after test mode showed me option to save settings, and now it says custom timing,optimization data avaible, so when did madvr measure data ? cause i didnt watch movie after doing test mode CVT CRT, either i cant apply any of the avaible timing paramters when in the customize , its shows only Test Mode and Cancel


Started everything from scratch got to the point custom settings not mesured yet -> watched movie for about 20min -> optimization data available and plenty to chose from but there is no Apply button only Test mode :/

Last edited by maxkolonko123; 31st March 2018 at 13:26.
maxkolonko123 is offline   Reply With Quote
Old 31st March 2018, 13:05   #49978  |  Link
Razoola
Registered User
 
Join Date: May 2007
Posts: 454
Reclock works fine with bitstreaming for me, I have always used it that way. You must of course be using custom refresh rates or youll get dropped/repeated audio packets. I never saw a situation where a dropped audio packet caused a video judder, only issue you can get is audio pops and crackles if your refessh rate is not close enough.
Razoola is offline   Reply With Quote
Old 31st March 2018, 13:28   #49979  |  Link
maxkolonko123
Registered User
 
Join Date: Nov 2017
Posts: 56
Quote:
Originally Posted by Razoola View Post
Reclock works fine with bitstreaming for me, I have always used it that way. You must of course be using custom refresh rates or youll get dropped/repeated audio packets. I never saw a situation where a dropped audio packet caused a video judder, only issue you can get is audio pops and crackles if your refessh rate is not close enough.
The main thing what i've notice sometimes when bitstream in reclock i've got clicks on avr every now and then, same click sound when changing audio mode/source but it never affected movie, but yeah clicks are consistent.
maxkolonko123 is offline   Reply With Quote
Old 31st March 2018, 18:56   #49980  |  Link
Warner306
Registered User
 
Join Date: Dec 2014
Posts: 1,124
Quote:
Originally Posted by maxkolonko123 View Post
The main thing what i've notice sometimes when bitstream in reclock i've got clicks on avr every now and then, same click sound when changing audio mode/source but it never affected movie, but yeah clicks are consistent.
The correct way to use ReClock is to output in PCM. This is because ReClock can resample the audio (it actually upsamples the audio like Dolby TrueHD 96K Upsampling) and then slows it down or speeds it up to keep time. The change in pitch is so minor as to be imperceptible. So this option should still be considered lossless or close to lossless.

ReClock can't touch a bitstream source because it needs to be unpacked into separate PCM channels first. So it uses another approach when bitstreaming that is not failsafe or lossless, to say the least.

Given the trouble you are having with custom modes, I would try using ReClock with PCM output. As stated previously, you lose Dolby Atmos and DTS:X if you need these. You can bitstream with ReClock, but it is not the recommended way to use this software. It even warns you about this in its configuration panel.

Or, you could just live with these dropped frames. I did for years and rarely, if ever, noticed them. It is one frame we are talking about, not several at a time. It all depends on how much of a perfectionist you are.

Last edited by Warner306; 31st March 2018 at 19:20.
Warner306 is offline   Reply With Quote
Reply

Tags
direct compute, dithering, error diffusion, madvr, ngu, nnedi3, quality, renderer, scaling, uhd upscaling, upsampling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 10:09.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.