Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Audio encoding

Reply
 
Thread Tools Search this Thread Display Modes
Old 22nd October 2008, 09:54   #61  |  Link
lobothefoots
Registered User
 
Join Date: Sep 2008
Posts: 6
I found two problems using this GUI

-when I extract an AC3 stream to WAVS using libvab (not nero) the log say it can't find the withe.noise file.

-I can't extract AC3 to DTS anymore.

the source is a Bluray directory

hope this helps
lobothefoots is offline   Reply With Quote
Old 22nd October 2008, 12:43   #62  |  Link
Greif
Registered User
 
Join Date: Dec 2006
Location: Ontario, Canada
Posts: 227
1) sounds like a bug with eac3to, do you get the same result when trying the same in a command window? If so, submit a bug on the eac3to thread

2) ahhhh.. due to the filtering of the audio extract types. I will remove this "feature" in the next version
Greif is offline   Reply With Quote
Old 22nd October 2008, 12:45   #63  |  Link
Greif
Registered User
 
Join Date: Dec 2006
Location: Ontario, Canada
Posts: 227
Quote:
Originally Posted by nwg View Post
It would be good to have a rebuild/remux feature like in evodemux. While that program is good. It is not possible to find out what the tick boxes are in terms of what languages and subtitles they are very easily. It would be good to be able to select what I want then click on rebuild to create a new evo or m2ts file.
I'm thinking of providing the ability to select single evo/m2ts files in addition to folders. It would bypass the feature grid and just show you the streams contained in your selection.

The goal of this tool is to strictly extract streams, nothing more.
Greif is offline   Reply With Quote
Old 22nd October 2008, 12:45   #64  |  Link
lobothefoots
Registered User
 
Join Date: Sep 2008
Posts: 6
no I don't have this problem with eac3to 2.69
lobothefoots is offline   Reply With Quote
Old 22nd October 2008, 15:35   #65  |  Link
Greif
Registered User
 
Join Date: Dec 2006
Location: Ontario, Canada
Posts: 227
Quote:
Originally Posted by lobothefoots
... the log say it can't find the withe.noise file.
Is that the exact wording from the log? (withe --> white)

I'll try it later today to see if I can reproduce.
Greif is offline   Reply With Quote
Old 22nd October 2008, 16:21   #66  |  Link
lobothefoots
Registered User
 
Join Date: Sep 2008
Posts: 6
Quote:
Originally Posted by Greif View Post
Is that the exact wording from the log? (withe --> white)

I'll try it later today to see if I can reproduce.
sorry , of course it is white and not withe (typo)

edit: try to check this screen capture at
http cps.tech.free.fr/temp/pb.JPG

Last edited by lobothefoots; 22nd October 2008 at 16:33.
lobothefoots is offline   Reply With Quote
Old 22nd October 2008, 17:24   #67  |  Link
Greif
Registered User
 
Join Date: Dec 2006
Location: Ontario, Canada
Posts: 227
can you provide the entire contents of the log? thanks.
Greif is offline   Reply With Quote
Old 25th October 2008, 07:35   #68  |  Link
TMC
Registered User
 
Join Date: Aug 2008
Posts: 2
Looks like it would be a nice GUI, but I can't get it to work. As someone else has said, it crashes on selecting an HDDVD feature as soon as "analysing" gets to 100%.

Tried with a BluRay and got an unhandled exception error.

OS = Vista Ultimate. AnyDVD.

Last edited by TMC; 25th October 2008 at 07:39.
TMC is offline   Reply With Quote
Old 25th October 2008, 12:27   #69  |  Link
Greif
Registered User
 
Join Date: Dec 2006
Location: Ontario, Canada
Posts: 227
Ok I am seriously getting Maybe it's my own discs but I have yet to have it crash on me.

I will release a version with verbose logging. Give it a try with that version on a couple of different discs that you've had issues with. It will be out later today...

That way, I can figure out what the problem is and fix it.

Greif is offline   Reply With Quote
Old 26th October 2008, 06:51   #70  |  Link
lobothefoots
Registered User
 
Join Date: Sep 2008
Posts: 6
Quote:
Originally Posted by Greif View Post
can you provide the entire contents of the log? thanks.
it appears only in your gui, there is nothing in the log;
I guess it is because there is no [a**] tag in front of the line.

I can report as well alot of crashes
With die hard bluray movie, it loads the content but if I try to demux it crashes.

I'll try the verbose version.
lobothefoots is offline   Reply With Quote
Old 26th October 2008, 07:48   #71  |  Link
Kurtnoise
Swallowed in the Sea
 
Kurtnoise's Avatar
 
Join Date: Oct 2002
Location: Aix-en-Provence, France
Posts: 5,183
Just copy the log from eac3to here using this command:

Code:
eac3to.exe "\Path where is my disc\"
Kurtnoise is offline   Reply With Quote
Old 26th October 2008, 14:30   #72  |  Link
nwg
Registered User
 
Join Date: Mar 2004
Posts: 819
It is working great for me for Blu Rays. However when I use it on a disc with DTS MA audio, I cannot select DTS as the stream type. Do I use RAW? Also what does +options do?
nwg is offline   Reply With Quote
Old 26th October 2008, 21:15   #73  |  Link
azad
Registered User
 
azad's Avatar
 
Join Date: May 2002
Location: Germany
Posts: 69
@nwg
I've the same problem.

@Greif
Great tool! Thanks!

One thing, for all my DTS-MA streams the file extension is ".dtshd". But since Stream Extractor uses ".dts" as file extension for DTS-MA streams, I've to rename all the audio streams manually. That's a lot of work and I'm quite lazy , so it would be nice to have an additional file extension for DTS-MA streams and not only ".dts".
__________________
Agent 47: "Eat your sandwich, I need to get some sleep."
azad is offline   Reply With Quote
Old 27th October 2008, 00:04   #74  |  Link
Greif
Registered User
 
Join Date: Dec 2006
Location: Ontario, Canada
Posts: 227
For those having problems with loading features, here is a debug version. This version has some extra logging and will create a log file named HdBrStreamExtractor.txt in the same directory.

If you are having issues, please run this version and upload the log file to http://pastebin.com/ so I can review. Thanks.

@azad: I need to clean up some of the audio extract types. It should be done soon.
Greif is offline   Reply With Quote
Old 27th October 2008, 00:12   #75  |  Link
Greif
Registered User
 
Join Date: Dec 2006
Location: Ontario, Canada
Posts: 227
@nwg/@azad: could either of you show me the output of the discs you are trying to extract from (with DTS HD MA)?

Show me the result of this:
Code:
eac3to.exe [disc location]
ex. eac3to.exe f:
And then show me the result of the stream listing for the selected feature:
Code:
eac3to.exe [disc location] [stream#]
ex. eac3to.exe f: 1)
Thanks.
Greif is offline   Reply With Quote
Old 27th October 2008, 14:37   #76  |  Link
Anacletus
Registered User
 
Anacletus's Avatar
 
Join Date: Mar 2005
Posts: 50
Hi Greif, i tried to use your app, but the result was this when trying to analize the godfather



caused this error:



Any toughts?

Anac
Anacletus is offline   Reply With Quote
Old 27th October 2008, 17:57   #77  |  Link
Greif
Registered User
 
Join Date: Dec 2006
Location: Ontario, Canada
Posts: 227
Quote:
Originally Posted by Anacletus View Post
Any toughts?
Show me the result of the stream listing for the selected feature:

Code:
eac3to.exe "c:\Moviez-HD\The Godfather" 1)
Greif is offline   Reply With Quote
Old 27th October 2008, 18:47   #78  |  Link
Anacletus
Registered User
 
Anacletus's Avatar
 
Join Date: Mar 2005
Posts: 50
Quote:
Originally Posted by Greif View Post
Show me the result of the stream listing for the selected feature:

Code:
eac3to.exe "c:\Moviez-HD\The Godfather" 1)
here it is:


Anacletus is offline   Reply With Quote
Old 27th October 2008, 21:26   #79  |  Link
Greif
Registered User
 
Join Date: Dec 2006
Location: Ontario, Canada
Posts: 227
@Anacletus: can you use the debug version posted above and show me the log file?

I'll look into it using your screenshot in the meantime.
Greif is offline   Reply With Quote
Old 28th October 2008, 11:22   #80  |  Link
Anacletus
Registered User
 
Anacletus's Avatar
 
Join Date: Mar 2005
Posts: 50
Quote:
Originally Posted by Greif View Post
@Anacletus: can you use the debug version posted above and show me the log file?

I'll look into it using your screenshot in the meantime.
here's the log produced by the debug version:

Code:
[12.19.55] Retrieving features
[12.19.55] Arguments: "C:\Moviez-HD\The Godfather"
[12.19.57] Feature Retrieval Completed
[12.19.57] Retrieving streams
[12.19.57] Arguments: "C:\Moviez-HD\The Godfather" 1) -progressnumbers
[12.20.22] M2TS, 1 video track, 6 audio tracks, 16 subtitle tracks, 2:57:09
Anacletus is offline   Reply With Quote
Reply

Tags
eac3to, hdbrstreamextractor

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 12:37.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.