Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > (HD) DVD & Blu-ray authoring

Reply
 
Thread Tools Search this Thread Display Modes
Old 1st February 2008, 03:12   #161  |  Link
jamos
Hey Now!
 
Join Date: Feb 2006
Posts: 812
Quote:
Originally Posted by VintageGuy View Post
Waiting on Jamos step by step to AVCHD.
http://forum.doom9.org/showthread.php?t=134348
jamos is offline   Reply With Quote
Old 1st February 2008, 03:14   #162  |  Link
jamos
Hey Now!
 
Join Date: Feb 2006
Posts: 812
Quote:
Originally Posted by SKAPiter View Post
Hi. First off, thanks for the good program! Especially m2ts option looks promising for AVCHD disk creation.

Problems I found...

1. Automatic level changing from 5.1 to 4.1 does not work for me. I had to demux to elementary streams and change to 4.1 by H264Info.

2. I successfuly muxed one h264 video stream and two AC3 audio streams. It plays both audio streams on the PC but PS3 does not see the second stream. Only first one.

Is it supposed to support only one audio stream or I am doing something wrong?

PS3 can only play the first stream for files. You would need AVCHD disk to have different audio streams. And yes the 4.1 option does not work currently with TSmuxer.
jamos is offline   Reply With Quote
Old 1st February 2008, 03:16   #163  |  Link
jamos
Hey Now!
 
Join Date: Feb 2006
Posts: 812
Quote:
Originally Posted by SKAPiter View Post
I just created an AVCHD disk via TsRemux 0.0.19 from the above mentioned m2ts file and burned it to DV+RW. The resulted disk is recongnized by PS3 as AVCHD. Video plays fine with all features, i.e. 5 min. chapters, ff/rw but here is NO AUDIO :-) None of the audio stream is present. Bumer. :-(
uncheck bypass audio alignment and it should work.
jamos is offline   Reply With Quote
Old 1st February 2008, 11:38   #164  |  Link
winnydows
Registered User
 
winnydows's Avatar
 
Join Date: Feb 2006
Location: Moscow
Posts: 190
Nice tool! I wait this tool creation .
How soon will be added demuxing functions ?
Now I use ffmpeg for demuxing, but ff can`t demux mpeg4aac.
winnydows is offline   Reply With Quote
Old 1st February 2008, 18:54   #165  |  Link
jamos
Hey Now!
 
Join Date: Feb 2006
Posts: 812
DTS does not work yet.
jamos is offline   Reply With Quote
Old 1st February 2008, 23:24   #166  |  Link
menlvd
Registered User
 
Join Date: May 2006
Location: Moscow
Posts: 97
http://www.smlabs.net/tsMuxer/tsMuxeR_1.2.10.zip
menlvd is offline   Reply With Quote
Old 1st February 2008, 23:29   #167  |  Link
d1g1ta7
Registered User
 
Join Date: Apr 2006
Posts: 19
would it be possible to rewrite the headers of 1920x1088 h.264 videos to 1920x1080? The PS3 seems to have issues playing back 1920x1088 h.264 videos, but 1920x1080 work fine.
d1g1ta7 is offline   Reply With Quote
Old 1st February 2008, 23:59   #168  |  Link
Zow
Registered User
 
Join Date: Sep 2007
Posts: 69
Quote:
Originally Posted by menlvd View Post
What's new? I can't try it until I get home. (I am still hoping for subtitles to MKV:-)
Zow is offline   Reply With Quote
Old 2nd February 2008, 00:16   #169  |  Link
lance79
Registered User
 
Join Date: Aug 2007
Posts: 64
I am trying to mux a vc1 es stream to m2ts with tsmuxer but having some problems.The vc1-es is accepted and converted but when playing back the first second play's right,after that the video go's full speed to the end.Also tsremux cant make a valid blu-ray structure from it.

I've tried with wmv 720p & 1088p.

I use VC-1 "ES" writer filter, v0.2 for getting the vc1 es from the wmv.

http://www.ftyps.com/unrelated/vc1_es.v0.2.zip

Here is a sample of the 1088p vc1 es, maby u can take a look at it?

http://www.zshare.net/download/7100918641ee95

greetz,

lance
lance79 is offline   Reply With Quote
Old 2nd February 2008, 00:26   #170  |  Link
menlvd
Registered User
 
Join Date: May 2006
Location: Moscow
Posts: 97
Quote:
Originally Posted by lance79 View Post
I am trying to mux a vc1 es stream to m2ts with tsmuxer but having some problems.The vc1-es is accepted and converted but when playing back the first second play's right,after that the video go's full speed to the end.Also tsremux cant make a valid blu-ray structure from it.

I've tried with wmv 720p & 1088p.

I use VC-1 "ES" writer filter, v0.2 for getting the vc1 es from the wmv.

http://www.ftyps.com/unrelated/vc1_es.v0.2.zip

Here is a sample of the 1088p vc1 es, maby u can take a look at it?

http://www.zshare.net/download/7100918641ee95

greetz,

lance
try new version 1.2.10 maybe that's help U
in new ver, have some bug fix for vc-1 streams?
but for me it's not worked
still have problem with playing resulting file

Last edited by menlvd; 2nd February 2008 at 00:32.
menlvd is offline   Reply With Quote
Old 3rd February 2008, 01:27   #171  |  Link
idbirch2
Registered User
 
Join Date: Oct 2002
Location: UK
Posts: 680
Is there any chance this app will ever be able to mux into an MPEG program stream i.e .mpg or .m2p? I'm trying to remux an MPEG2 BluRay with DTS audio for streaming to a 360 but Vista MCX does not allow .ts streaming any more.
idbirch2 is offline   Reply With Quote
Old 3rd February 2008, 01:35   #172  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
@roman76r

Can you release the source code?
Guest is offline   Reply With Quote
Old 3rd February 2008, 05:56   #173  |  Link
lchiu7
Registered User
 
Join Date: Apr 2002
Posts: 279
Alas I had high hopes for this but I can't get it to work.

Situation:

Some H.264 files and AC3 in a MKV container. I demultiplexed the audio and video and changed the level to 4.1

Using the latest version ran tsmuxer to put them back in a .ts container with aac and ac3 audio. File plays fine on my PC using vlc but put in on a DVD or USB stick and try to play on the PS3 and the PS3 says no data on either medium

Up till now this has worked for me

Demuxed the mkv file into the elemental streams
Change the level to 4.1
Reencode the audio from AC3 to aac 5.1 using eac2to and neroencode
Mux the two files back using mp4box

These play fine

But I really want AC3 audio since my PS3 is connected via Toslink (not HDMI) so 5.1 aac ends up as 2 channel PCM if I want to get any audio at all)

Any ideas what I could be doing wrong?
lchiu7 is offline   Reply With Quote
Old 3rd February 2008, 08:18   #174  |  Link
lance79
Registered User
 
Join Date: Aug 2007
Posts: 64
isn't fixed in this version...

Quote:
Originally Posted by menlvd View Post
try new version 1.2.10 maybe that's help U
in new ver, have some bug fix for vc-1 streams?
but for me it's not worked
still have problem with playing resulting file
lance79 is offline   Reply With Quote
Old 3rd February 2008, 11:32   #175  |  Link
Sparky101
Registered User
 
Join Date: Mar 2007
Posts: 23
Quote:
Originally Posted by lchiu7 View Post
Alas I had high hopes for this but I can't get it to work.

Situation:

Some H.264 files and AC3 in a MKV container. I demultiplexed the audio and video and changed the level to 4.1

Using the latest version ran tsmuxer to put them back in a .ts container with aac and ac3 audio. File plays fine on my PC using vlc but put in on a DVD or USB stick and try to play on the PS3 and the PS3 says no data on either medium

Up till now this has worked for me

Demuxed the mkv file into the elemental streams
Change the level to 4.1
Reencode the audio from AC3 to aac 5.1 using eac2to and neroencode
Mux the two files back using mp4box

These play fine

But I really want AC3 audio since my PS3 is connected via Toslink (not HDMI) so 5.1 aac ends up as 2 channel PCM if I want to get any audio at all)

Any ideas what I could be doing wrong?
Try remuxing your .ts to .m2ts with TSRemux.
Sparky101 is offline   Reply With Quote
Old 3rd February 2008, 11:33   #176  |  Link
Sparky101
Registered User
 
Join Date: Mar 2007
Posts: 23
Quote:
Originally Posted by idbirch2 View Post
Is there any chance this app will ever be able to mux into an MPEG program stream i.e .mpg or .m2p? I'm trying to remux an MPEG2 BluRay with DTS audio for streaming to a 360 but Vista MCX does not allow .ts streaming any more.
Can't you just rename the file to .mpg?
Sparky101 is offline   Reply With Quote
Old 3rd February 2008, 12:35   #177  |  Link
napalm-187
Registered User
 
Join Date: Jul 2006
Posts: 38
hi
i have an question

i have remuxed an m2ts with h264 with an sperate dts file

in direktshowplayers plays fine, but in powerdvd not
the info window of the file says mpeg4 with 346 mbit
and the file dont play

where is here the failure

thx
napalm-187 is offline   Reply With Quote
Old 3rd February 2008, 12:39   #178  |  Link
idbirch2
Registered User
 
Join Date: Oct 2002
Location: UK
Posts: 680
Quote:
Originally Posted by Sparky101 View Post
Can't you just rename the file to .mpg?
No, Vista no longer allows streaming of .TS packets to an extender so it doesn't matter what file extension you rename it to, it won't play.

I've found from a bit of searching though, that ReJig can mux DTS with M2V, and it has successfully created a VOB which plays fine in MPC with DTS intact. VOB is a program stream so renaming this to .MPG should work. I'll be testing this on the 360 shortly.

Last edited by idbirch2; 3rd February 2008 at 12:44.
idbirch2 is offline   Reply With Quote
Old 3rd February 2008, 13:04   #179  |  Link
mic64
Registered User
 
Join Date: Jun 2005
Posts: 42
Hi

anyone else have problems with importin ac3 files?
I get always the message "Can't detect Stream Type"
mic64 is offline   Reply With Quote
Old 3rd February 2008, 14:28   #180  |  Link
BillyBlue77
Registered User
 
Join Date: Apr 2005
Posts: 4
Hi,

I'm trying to play a self encoded mkv (megui, h264, ac3 english and german, subtitles english and german) on my PS3 (non linuxed). The only success I had was using "mkv2vob", of course losing the second ac3 audio and all subtitles, but ff/rw is possible. The aspect ratio is wrong with mkv2vob though.

When I try to remux this mkv with tsMuxeR, the resulting file is not shown on the PS3, neither as ts nor m2ts. It plays well on the PC using MediaPlayerClassic and the aspect ratio is correct. Am I doing something wrong or missing a step? Do I have to use TSRemux afterwards? I thought I read in this thread that this is not necessary?

Thx in advance,
Billy

Last edited by BillyBlue77; 3rd February 2008 at 14:33.
BillyBlue77 is offline   Reply With Quote
Reply

Tags
tsmuxer

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 21:01.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.