Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old Yesterday, 01:35   #1  |  Link
beto@endrix
Registered User
 
Join Date: Feb 2018
Posts: 5
Issue with MPC-BE + madVR + LAV + XySubFilter

So yesterday I found out just how much better this combo is compared to VLC, and spent my night configuring it (following this and this) and getting it ready to watch a BluRay 4K movie today.

However, I stumbled on a problem: the movie is in a matroska container and it has forced french .pgs subtitles coded in, although it has many others in the same file (forced and not). When I switch to another language, or when I set my preferred language to play at start, as soon as the first subtitle appears, the video loses all its quality, the image appears really dull and washed. I think that happens because the renderer swaps to internal, or madVR crashes. Maybe it's none of that, still new to this.

Can someone tell me what is happening and how can I fix it?

Windows 7
1070 on the latest drivers

Happy to provide more information if you need.

Last edited by beto@endrix; Yesterday at 02:42.
beto@endrix is offline   Reply With Quote
Old Yesterday, 02:19   #2  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 1,902
Try use internal filters + madVR.
__________________
I7 2600K@4.2 /Asrock P67 Extreme4 Gen 3 /Kingston HyperX 8Gb 1866 (4x2) Kit /OCZ Vertex 3 256Gb /Gigabyte GTX 960 /BenQ EW2430 /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old Yesterday, 02:42   #3  |  Link
beto@endrix
Registered User
 
Join Date: Feb 2018
Posts: 5
That works, but the trade-off is losing LAV, which I'd prefer not to...
Is that the only solution that comes to your mind or is there something else I could try?
beto@endrix is offline   Reply With Quote
Old Yesterday, 04:12   #4  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 1,902
Quote:
Originally Posted by beto@endrix View Post
That works, but the trade-off is losing LAV, which I'd prefer not to...
Is that the only solution that comes to your mind or is there something else I could try?
If no problem without LAV ...
__________________
I7 2600K@4.2 /Asrock P67 Extreme4 Gen 3 /Kingston HyperX 8Gb 1866 (4x2) Kit /OCZ Vertex 3 256Gb /Gigabyte GTX 960 /BenQ EW2430 /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline   Reply With Quote
Old Yesterday, 08:40   #5  |  Link
chros
Registered User
 
chros's Avatar
 
Join Date: Mar 2002
Posts: 1,074
I'm pretty sure it's xysubfilter (I also use lavfilters but with the internal subengine). You can try to drop xysubfilter first to see what will change.
__________________
MSI GE60-0NC(i73630QM,16GB,IntelHD4000(10.18.10.4653)+GeForceGT650m(2GB,v355.98)+muxless,1920x1080@60Hz,Plextor M5M 256GB SSD,Win8.1x64+MPC-BEx64+LAV+MadVR)+Yamaha RX-A830+LG 55LD650(1080p@24/25/60Hz)
chros is offline   Reply With Quote
Old Yesterday, 18:08   #6  |  Link
beto@endrix
Registered User
 
Join Date: Feb 2018
Posts: 5
Quote:
Originally Posted by chros View Post
I'm pretty sure it's xysubfilter (I also use lavfilters but with the internal subengine). You can try to drop xysubfilter first to see what will change.
Yeah, that's it. The thing is, it works fine on the usual 1080p H.264 stuff. Maybe a conflict with HEVC?
I guess I have to drop that to watch 4K...

Another thing, is using Direct3D 11 for presentation on the rendering settings of madVR supposed to give you a better performance? Every time I turn that on and reset, the player freezes all over the place..
beto@endrix is offline   Reply With Quote
Old Yesterday, 18:19   #7  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 9,093
If its HDR content, xysubfilter will probably "lose" the HDR metadata in the process.
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old Yesterday, 20:45   #8  |  Link
beto@endrix
Registered User
 
Join Date: Feb 2018
Posts: 5
It's Dunkirk, pretty sure it has HDR, so that should be the problem. Damn shame, the subtitles look way better with xysub, but I guess I have to live with it..

Nothing on the D3D 11 thingy?

Also, thank you so much for the help thus far, really appreciate it!
beto@endrix is offline   Reply With Quote
Old Yesterday, 21:44   #9  |  Link
sneaker_ger
Registered User
 
Join Date: Dec 2002
Posts: 4,850
Quote:
Originally Posted by nevcairiel View Post
If its HDR content, xysubfilter will probably "lose" the HDR metadata in the process.
But XySubFilter sits between splitter and renderer, not between video decoder and renderer? And has its own input into madvr that's independent?
sneaker_ger is offline   Reply With Quote
Old Today, 02:16   #10  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 2,882
Use whatever works better, D3D11 or D3D9. There aren't any major performance improvements in D3D11, just that it might interact with new OSes a little better.
__________________
madVR options explained
Asmodian is offline   Reply With Quote
Old Today, 05:31   #11  |  Link
beto@endrix
Registered User
 
Join Date: Feb 2018
Posts: 5
Quote:
Originally Posted by Asmodian View Post
Use whatever works better, D3D11 or D3D9. There aren't any major performance improvements in D3D11, just that it might interact with new OSes a little better.
That's exactly what I wanted to know, thanks a lot.
beto@endrix is offline   Reply With Quote
Reply

Tags
4k movie, bluray, madvr, matroska, mpc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 07:45.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.