Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 17th May 2009, 14:24   #1061  |  Link
kostik
Registered User
 
Join Date: Jul 2007
Posts: 128
great build. Works smooth for me...1080p24 , even with spline 64 and lancroz 8.

Thank you very much, expecting for your next builds , great job
kostik is offline   Reply With Quote
Old 17th May 2009, 14:42   #1062  |  Link
noee
Registered User
 
Join Date: Jan 2007
Posts: 530
Just a couple of issues so far:

- Changing monitor rez during playback no longer handled gracefully (black screen, but playback continues, MPC becomes non-responsive)
- Playback of 1080/30P (1:1) with many dropped/delayed frames. Counters increment as playback continues

720 24/30P are stable, good numbers, very smooth. SD material upscaled, excellent as well, butter-smoove.

HD2600XT, CoreAVC 1.9.5
chroma resampler=SoftCubic100
luma upsampler=Lanczos4
luma downsampler=Lanczos4
noee is offline   Reply With Quote
Old 17th May 2009, 15:59   #1063  |  Link
wayland
Registered User
 
Join Date: May 2009
Posts: 23
cant show it in screenshots but black is gray when using madvr or HR and having the nvidia control panel set to RGB, must be a problem with my either my tv (Panasonic Viera TH-42PZ80) or how nvidia does RGB as the ati3450 i used to use was fine
wayland is offline   Reply With Quote
Old 17th May 2009, 16:02   #1064  |  Link
flanger216
Registered User
 
Join Date: Mar 2004
Posts: 140
Fantastic update. Refresh rate is reported perfectly for me now. CPU usage is down. More surprisingly, my GPU usage is considerably down. Previously my HD3600 could only handle Catmull-Rom luma upscaling; now it can do Spline36 with no dropped frames, an upload queue of 4/8 and a render queue of 8/8 (!). Awesome stuff as always.
flanger216 is offline   Reply With Quote
Old 17th May 2009, 16:03   #1065  |  Link
aydc
Registered User
 
Join Date: Jul 2003
Posts: 43
Thank you for this fantastic renderer madshi! I haven't seen anything this exciting on this scene since the early days of Haali Renderer. I'm using the 0.9 version and I love it.

I have two improvement ideas:

1. Could you include a brightness or gamma slider on the settings screen? Some movies are too dark, so I want to change the brightness while watching the movie. Yes, most decoders have this, but it would be great if we could adjust it for all the formats in the same place, which is the renderer.

2. When using MPC, if I go from windowed mode to fullscreen, the image gets blocky for 1/3 of a second, then it corrects itself. Not a big deal, but a smoothed transition from windowed mode to fullscreen would be preferable.

Cheers!
aydc is offline   Reply With Quote
Old 17th May 2009, 16:14   #1066  |  Link
TinTime
Registered User
 
Join Date: Jan 2009
Location: UK
Posts: 403
Quote:
Originally Posted by wayland View Post
cant show it in screenshots but black is gray when using madvr or HR and having the nvidia control panel set to RGB, must be a problem with my either my tv (Panasonic Viera TH-42PZ80) or how nvidia does RGB as the ati3450 i used to use was fine
Set nvidia control panel to RGB output, madVR to TV levels, and your TV brightness to halfway. How is that?
TinTime is offline   Reply With Quote
Old 17th May 2009, 17:13   #1067  |  Link
TinTime
Registered User
 
Join Date: Jan 2009
Location: UK
Posts: 403
I'm afraid version 0.10 now gives me permanent tearing with 24fps material at a reported refresh rate of 24.001Hz, with or without ReClock. The vsync interval is 41.66ms, the movie frame interval is 40.67ms. This is with both SD and HD video on a 1080p screen using an 8600GT. Previous versions of madVR were fine.

The decoder queue is always 16/16. The upload and render queues both fluctuate slightly but remain above 4/8. I don't seem to get dropped or delayed frames beyond the initial flurry when starting up the video and going to full screen.

25fps video at 50Hz refresh rate works fine, as does playing the 24fps video at 50Hz or 60Hz (from a tearing point of view).
TinTime is offline   Reply With Quote
Old 17th May 2009, 17:42   #1068  |  Link
cyberbeing
Broadband Junkie
 
Join Date: Oct 2005
Posts: 1,859
Quote:
Originally Posted by madshi View Post
The render queue fluctuating between 7/8 and 8/8 is perfectly fine. It may go down to 4/8 without having to worry. Lower values than 4/8 might be dangerous for smooth motion, though. And of course the "delayed frames" number in the OSD increasing throughout the whole movie is bad.
It's more like the render queue occasionally goes to 7/8 for like 2-3 seconds and then I get a delayed frame. After about 5-10 delayed frames, I would usually get a dropped frame. These increasing delayed/dropped frames during downscaling is what I'm concerned about. It happens no matter what scaling method I choose, yet, when upscaling 1920x1080 (or any other resolution), there is no problem and when playing at 1:1, no problem.

Was something changed with downscaling in 0.10 which could be causing the render queue to not keep up with the video. In earlier versions of madVR, downscaling seemed less intensive then upscaling since a smaller image had to be rendered. In any case, I'm suspecting this is a bug in 0.10.
cyberbeing is offline   Reply With Quote
Old 17th May 2009, 17:43   #1069  |  Link
KoD
Registered User
 
Join Date: Mar 2006
Posts: 552
Quote:
Originally Posted by Egh View Post
MPC sub renderer is the best Especially if you upscale video on playback.

As for internal subtitle mechanics, I'm not sure. Renderers (such as Haali's one) have a subtitle pin. As MPC renders in some user selected resolution (I personally use 1280x1024), I guess it is renderer's job to up/down scale the subtitle texture and blend it with the video. Using some filter in-between is a flexible but not optimal approach, imo.
I'm sorry to inform you, but the external vsfilter is more advanced in the features it supports than the internal MPC one. As for Haali's renderer, subtitle rendering happens with MPC by using vsfilter callbacks, so Haali's renderer doesn't magically use any other subtitling code, it's still vsfilter that does the job.

Similar advice to Mark_A_W, who also somehow believes Haali's renderer has a subtitler incorporated. Just use the vsfilter.dll I've linked to in a previous post, and be done with it. No more "madVR doesn't support subtitles" nonsense, please. This is the fourth time I write about this, but some people seem to have selective blindness.

Last edited by KoD; 17th May 2009 at 17:48.
KoD is offline   Reply With Quote
Old 17th May 2009, 18:11   #1070  |  Link
Peekstra
Registered User
 
Join Date: Sep 2006
Posts: 31
Did anyone get Zoomplayer 6.0 to work without any Macrovision failure when trying to play a DVD and using Madvr 0.10?

I tried dscaler, ffdshow and powerdvd.
Peekstra is offline   Reply With Quote
Old 17th May 2009, 18:14   #1071  |  Link
Jong
Registered User
 
Join Date: Mar 2007
Location: London, UK
Posts: 576
Quote:
Originally Posted by madshi View Post
AFAIK, these problems should go away in fullscreen exclusive mode, fortunately.
Madshi, in fullscreen exclusive mode you can do your own OSD right? At least equivalent to the MPC one and hopefully a lot less gross!?

I think a good OSD (and stability) will go a long way to get round most people's problem with exclusive mode.

MPC-HC's VMR9 exclusive mode is good and stable but the OSD is ugly.

Zoomplayer has no OSD at all AND seems rather unstable.

Exclusive mode has got a bad name unreasonably, just because it has been an afterthought in most players. TheaterTek did it right, but then gave up the game 2 years ago
Jong is offline   Reply With Quote
Old 17th May 2009, 18:16   #1072  |  Link
wayland
Registered User
 
Join Date: May 2009
Posts: 23
i feel foolish now, it was a problem with the tv's settings. i had set it up using the dve bluray (and powerdvd) , loading the patterns from the blurray in evr and madvr evr was more or less the same as powerdvd while madvr needs a much lower brightness setting
wayland is offline   Reply With Quote
Old 17th May 2009, 18:19   #1073  |  Link
KoD
Registered User
 
Join Date: Mar 2006
Posts: 552
madshi, please, do a quick re-release of 0.10 with the renderer reading the settings for luma upscaling and downscaling, because right now it's unusable. I wonder if people realize each time they start playing a file, the settings were reset to Soft 50 and Lanczos4.

Another issue: when I try opening a file in ZoomPlayer, I have to wait about 10 seconds till playback starts. I'm not using any 3dlut, so it's not a 3dlut file being generated. Anyone else experiencing this ? I don't know what exactly happens, but it looks like either madVR is collecting data for a while before playback starts, or simply a thread synchronization issue, with a thread waiting too much for another one (it's not a deadlock I guess, since playback eventually starts)
KoD is offline   Reply With Quote
Old 17th May 2009, 18:19   #1074  |  Link
allak
Registered User
 
Join Date: Feb 2009
Posts: 47
Quote:
Originally Posted by cyberbeing View Post
Why don't you use VSFilter? It works perfectly with every madVR revision.
Hello, I've tried to use the external VSFilter, but as soon as I load it (by listing it under "external filters") MPC-HC does not use madVR anymore and seems to switch to the overlay mixer renderer.

I think that is because, with VSFilter loaded, the PIN out of the MPC Video Decoder filter change from YV12 to YUY2, which is not supported by madVR.

I've checked the Properties of VSFilter and under the "Colors" tab I have YV12 listed before YUY2, so I do not understand why the Video Decoder wants to output YUY2 .

Is there any other setting I could try to set ? TIA
allak is offline   Reply With Quote
Old 17th May 2009, 18:19   #1075  |  Link
Matching_Mole
Registered User
 
Join Date: Feb 2009
Posts: 99
Quote:
Originally Posted by KoD View Post
I'm sorry to inform you, but the external vsfilter is more advanced in the features it supports than the internal MPC one.
You're right, vsfilter can work with madVR and have all this features. But it still remains a bad option for me because you have to force it in a graph (for example when I want to add subtitles to an DVD - or a blu-ray - without a subtitle in my language). This is not easy with some graph configurations, I have experienced this before to use the features of MPC. More than the easiness of MPC, the quality is also better because the subtitles are rendered at the final step and are not affected by the sizing operations.

And overall (for me at least), the override placement do not work with vsfilter (this is logical because it add the subtitles to the decoded frames without the black borders... this is the render which add them) except if you make resize in ffdshow in orders to have the black borders... but I think this is not the best solution with madVR

So for me the very best solution is to add the subtitles pins to madVr. But it is to Madshi to make this decision to implement it.
Matching_Mole is offline   Reply With Quote
Old 17th May 2009, 18:58   #1076  |  Link
Blight
Software Developer
 
Blight's Avatar
 
Join Date: Oct 2001
Location: Israel
Posts: 995
v0.10 Bug Report using Zoom Player:

1. When pausing the video, the image is not updated (pause the video then drag the window off-screen and the window will be wiped black).
2. Switching the playback window between monitors doesn't update the OSD data (which may indicate that it's not being updated with the new monitor data).
3. Initial video load drops a lot of frames (even with tear-fix disabled), about 9-15 dropped.
4. Pressing Stop and then seeking, doesn't update the image (and pressing Stop doesn't show the first video frame either).
5. Pressing Pause doesn't pause the image instantly, at least 3-4 more frames are displayed.
6. I still get the occasional full on freeze (no image, GUI stops responding).
7. It takes 2-3 seconds longer than other renderers for the first video frame to show.

WinVista 32bit, NV 7600GT
__________________
Yaron Gur
Zoom Player . Lead Developer
Blight is offline   Reply With Quote
Old 17th May 2009, 19:19   #1077  |  Link
cyberbeing
Broadband Junkie
 
Join Date: Oct 2005
Posts: 1,859
Quote:
Originally Posted by allak View Post
I think that is because, with VSFilter loaded, the PIN out of the MPC Video Decoder filter change from YV12 to YUY2, which is not supported by madVR.

I've checked the Properties of VSFilter and under the "Colors" tab I have YV12 listed before YUY2, so I do not understand why the Video Decoder wants to output YUY2 .
You would have to ask in the MPC-HC thread for someone to fix that. I just checked and MPC Video decoder does seem to always output YUY2 when connecting to VSFilter. This is something outside of madshi's control.

A workaround would be to use a different decoder like FFDshow and disable MPC's decoder.
cyberbeing is offline   Reply With Quote
Old 17th May 2009, 20:59   #1078  |  Link
nuhi
Registered User
 
Join Date: Aug 2007
Posts: 22
hey madshi, how about RGB32 output support?
Currently I am watching some movie with a lot of red light and only ffdshow with RGB32 output can decode it without the blocking artifacts but then I would need to go to EVR output since madvr doesn't accept that format.
Anyway just wondering, if it's a problem don't worry about it.
Thanks.
nuhi is offline   Reply With Quote
Old 17th May 2009, 21:02   #1079  |  Link
KoD
Registered User
 
Join Date: Mar 2006
Posts: 552
Quote:
Originally Posted by Matching_Mole View Post
You're right, vsfilter can work with madVR and have all this features. But it still remains a bad option for me because you have to force it in a graph (for example when I want to add subtitles to an DVD - or a blu-ray - without a subtitle in my language). This is not easy with some graph configurations, I have experienced this before to use the features of MPC. More than the easiness of MPC, the quality is also better because the subtitles are rendered at the final step and are not affected by the sizing operations.

And overall (for me at least), the override placement do not work with vsfilter (this is logical because it add the subtitles to the decoded frames without the black borders... this is the render which add them) except if you make resize in ffdshow in orders to have the black borders... but I think this is not the best solution with madVR

So for me the very best solution is to add the subtitles pins to madVr. But it is to Madshi to make this decision to implement it.
Actually, the subtitles being placed only on top of the image is how things are supposed to be. That's how subtitles are designed to work in the first place by the one creating them. If you ever get to watch subtitles which are placed over specific elements in an image, you'll notice they're no longer where they should be if you force positioning overriding.

All of this is because vsfilter (the external version) is the renderer that defines the standards for advanced subtitle formats like ssa and ass, and every subtitle file that is being created is being created to work the way vsfilter works.
KoD is offline   Reply With Quote
Old 17th May 2009, 21:21   #1080  |  Link
cyberbeing
Broadband Junkie
 
Join Date: Oct 2005
Posts: 1,859
Quote:
Originally Posted by nuhi View Post
Currently I am watching some movie with a lot of red light and only ffdshow with RGB32 output can decode it without the blocking artifacts but then I would need to go to EVR output since madvr doesn't accept that format.
Having ffdshow output YV12 and madVR using 'softcubic100' chroma upsampling should have smoother reds then ffdshow using RGB32. Are you claiming this is not the case?

If so, maybe you should post a sample along with your configuration and hardware details.

Last edited by cyberbeing; 17th May 2009 at 21:28.
cyberbeing is offline   Reply With Quote
Reply

Tags
direct compute, dithering, error diffusion, madvr, ngu, nnedi3, quality, renderer, scaling, uhd upscaling, upsampling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:06.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.