Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 5th March 2019, 17:41   #41  |  Link
Zetti
Registered User
 
Join Date: Dec 2015
Location: Denmark
Posts: 212
419.35 is released.

https://us.download.nvidia.com/Windo...ease-notes.pdf
Zetti is offline   Reply With Quote
Old 5th March 2019, 18:36   #42  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 4,293
They need to fix the HDR metadata issue one of these days. Those of us that do other things besides watch movies really could use a fixed updated driver. And those poor (after spending the kind of money they did ) RTX 20x0 owners can't really use older drivers anyway. I have not checked the latest driver to see if the metadata has been fixed. Anyone have time to do so?
__________________
HTPC: Windows 10, I9 9900k, RTX 2070 Founder's Edition, Pioneer Elite VSX-LX303, LG C8 65" OLED
SamuriHL is offline   Reply With Quote
Old 5th March 2019, 18:57   #43  |  Link
VBB
Registered User
 
VBB's Avatar
 
Join Date: May 2016
Location: Long Beach, CA
Posts: 78
I think Manni is the only one with the means to test it. Too bad Nvidia doesn't care about HTPC users whatsoever...
__________________
Henry

LG OLED65C7P | VIZIO M70-C3 | Denon AVR-X3500H | Elac Uni-Fi | Elac Debut 2.0 SUB3030
NVIDIA GeForce GTX 960 | LAV Filters | madVR | MPC-HC | Plex | X-Rite i1Display Pro | DisplayCAL | HCFR
VBB is offline   Reply With Quote
Old 5th March 2019, 19:12   #44  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 4,293
We're certainly not a priority for them, no. Hopefully Manni will get a minute to check. I'm not super hopeful given that it's been broken for quite some time now.
__________________
HTPC: Windows 10, I9 9900k, RTX 2070 Founder's Edition, Pioneer Elite VSX-LX303, LG C8 65" OLED
SamuriHL is offline   Reply With Quote
Old 5th March 2019, 19:19   #45  |  Link
Manni
Registered User
 
Join Date: Jul 2014
Posts: 732
Quote:
Originally Posted by SamuriHL View Post
We're certainly not a priority for them, no. Hopefully Manni will get a minute to check. I'm not super hopeful given that it's been broken for quite some time now.
Madshi has reported the issue to his contact at nVidia, so I'm hoping it will get fixed at some point. I'll try to test the latest version later today and I'll report back. I had recently reverted to 385.28 because of this, as I needed to run some tests in passthrough and the recent drivers are not usable for this. It should be a priority for them!
__________________
Win10 Pro x64 b1903 MCE
i7 3770K@4.0Ghz 16Gb@2.18Ghz EVGA GTX 1080 Ti SC2 11Gb@2GHz 436.48 RGB Full 8bits
MPC-BE/LAV/MadVR/jRiver/MyMovies V5.25
Denon X8500H>HD Fury Maestro>JVC RS2000
Manni is offline   Reply With Quote
Old 5th March 2019, 19:20   #46  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 9,817
Chances for non-criticial things like that to get fixed are higher in a new major driver branch then a point release. But who knows.
I still think it could help to actually tell the OS about the metadata instead of hoping the driver just ignores the OS.

If I had a device to test this, I would try to proof my idea with some code, but alas I do not, so..
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 5th March 2019, 19:24   #47  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 4,293
Tell Jim to expense you one. LMAO I would be very curious what the results of such a test show cause I have a feeling you could be right. I think nVidia changed this back when Windows added support for HDR. Things haven't been quite right since.
__________________
HTPC: Windows 10, I9 9900k, RTX 2070 Founder's Edition, Pioneer Elite VSX-LX303, LG C8 65" OLED
SamuriHL is offline   Reply With Quote
Old 5th March 2019, 20:57   #48  |  Link
Manni
Registered User
 
Join Date: Jul 2014
Posts: 732
Quote:
Originally Posted by nevcairiel View Post
Chances for non-criticial things like that to get fixed are higher in a new major driver branch then a point release. But who knows.
I still think it could help to actually tell the OS about the metadata instead of hoping the driver just ignores the OS.

If I had a device to test this, I would try to proof my idea with some code, but alas I do not, so..
Please contact me by PM/email if you wish, I can send you a HD Fury Vertex
__________________
Win10 Pro x64 b1903 MCE
i7 3770K@4.0Ghz 16Gb@2.18Ghz EVGA GTX 1080 Ti SC2 11Gb@2GHz 436.48 RGB Full 8bits
MPC-BE/LAV/MadVR/jRiver/MyMovies V5.25
Denon X8500H>HD Fury Maestro>JVC RS2000

Last edited by Manni; 5th March 2019 at 21:00.
Manni is offline   Reply With Quote
Old 5th March 2019, 22:36   #49  |  Link
Manni
Registered User
 
Join Date: Jul 2014
Posts: 732
Quote:
Originally Posted by SamuriHL View Post
We're certainly not a priority for them, no. Hopefully Manni will get a minute to check. I'm not super hopeful given that it's been broken for quite some time now.
Okay I tested 419.35, and either there is a bug in the latest madVR build, or the new driver is even worse. It's not that it passes bogus metadata, it doesn't switch to HDR anymore

The OSD reports NV HDR and HDR passthrough, but the GPU isn't sending HDR, so no HDR metadata reported at all...

Back to 385.28, though I might try 397.31 to see one more time if I can get better 3D and most of everything else, but last time I tried I had to go back to 385.28 anyway.
__________________
Win10 Pro x64 b1903 MCE
i7 3770K@4.0Ghz 16Gb@2.18Ghz EVGA GTX 1080 Ti SC2 11Gb@2GHz 436.48 RGB Full 8bits
MPC-BE/LAV/MadVR/jRiver/MyMovies V5.25
Denon X8500H>HD Fury Maestro>JVC RS2000
Manni is offline   Reply With Quote
Old 5th March 2019, 22:39   #50  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 4,293
FFS they broke THAT again? I give up...thanks for testing.
__________________
HTPC: Windows 10, I9 9900k, RTX 2070 Founder's Edition, Pioneer Elite VSX-LX303, LG C8 65" OLED
SamuriHL is offline   Reply With Quote
Old 5th March 2019, 22:54   #51  |  Link
VBB
Registered User
 
VBB's Avatar
 
Join Date: May 2016
Location: Long Beach, CA
Posts: 78
@Manni Did you have madVR set to 8-bit or 10-bit/auto? With 8-bit it doesn't switch using newer drivers.
__________________
Henry

LG OLED65C7P | VIZIO M70-C3 | Denon AVR-X3500H | Elac Uni-Fi | Elac Debut 2.0 SUB3030
NVIDIA GeForce GTX 960 | LAV Filters | madVR | MPC-HC | Plex | X-Rite i1Display Pro | DisplayCAL | HCFR
VBB is offline   Reply With Quote
Old 5th March 2019, 23:12   #52  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 3,683
I had to restart after installing the new drivers but HDR passthrough works the same in 419.35 for me. madVR needs to send 10 bit to the driver (on startup, if I change to 8 bit while playing HDR stays active) but I don't need FSE to activate HDR on my LG C7 OLED. I cannot see what metadata is actually being sent to the TV but HDR does activate.

Edit: This is using standard v0.92.17, not any of the new HDR test builds.
__________________
madVR options explained

Last edited by Asmodian; 5th March 2019 at 23:15.
Asmodian is offline   Reply With Quote
Old 5th March 2019, 23:51   #53  |  Link
Manni
Registered User
 
Join Date: Jul 2014
Posts: 732
Quote:
Originally Posted by VBB View Post
@Manni Did you have madVR set to 8-bit or 10-bit/auto? With 8-bit it doesn't switch using newer drivers.
Ah OK, yes I was using 8bits because there is a bug in RGB 12bits with my JVC rs2000, it forces YCC422 internally and messes up levels...

I'll try again with 12bits and will report back.
__________________
Win10 Pro x64 b1903 MCE
i7 3770K@4.0Ghz 16Gb@2.18Ghz EVGA GTX 1080 Ti SC2 11Gb@2GHz 436.48 RGB Full 8bits
MPC-BE/LAV/MadVR/jRiver/MyMovies V5.25
Denon X8500H>HD Fury Maestro>JVC RS2000
Manni is offline   Reply With Quote
Old 6th March 2019, 00:00   #54  |  Link
Manni
Registered User
 
Join Date: Jul 2014
Posts: 732
Quote:
Originally Posted by Asmodian View Post
I had to restart after installing the new drivers but HDR passthrough works the same in 419.35 for me. madVR needs to send 10 bit to the driver (on startup, if I change to 8 bit while playing HDR stays active) but I don't need FSE to activate HDR on my LG C7 OLED. I cannot see what metadata is actually being sent to the TV but HDR does activate.

Edit: This is using standard v0.92.17, not any of the new HDR test builds.
Here I do need FSE to enable HDR (with nVidia CP set to 12bits and madVR set to 10bits or +), which I didn't need with former drivers (even recent), so that's a step back.

And sadly the metadata is still bogus
__________________
Win10 Pro x64 b1903 MCE
i7 3770K@4.0Ghz 16Gb@2.18Ghz EVGA GTX 1080 Ti SC2 11Gb@2GHz 436.48 RGB Full 8bits
MPC-BE/LAV/MadVR/jRiver/MyMovies V5.25
Denon X8500H>HD Fury Maestro>JVC RS2000
Manni is offline   Reply With Quote
Old 6th March 2019, 00:11   #55  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 4,293
Quote:
Originally Posted by Manni View Post
And sadly the metadata is still bogus
Of course it is. I suspect nev is correct in that 1) we won't see this fixed until another major branch and/or 2) the way it is supposed to work has changed and the code needs to be updated to reflect that.
__________________
HTPC: Windows 10, I9 9900k, RTX 2070 Founder's Edition, Pioneer Elite VSX-LX303, LG C8 65" OLED
SamuriHL is offline   Reply With Quote
Old 6th March 2019, 00:18   #56  |  Link
Manni
Registered User
 
Join Date: Jul 2014
Posts: 732
Quote:
Originally Posted by SamuriHL View Post
Of course it is. I suspect nev is correct in that 1) we won't see this fixed until another major branch and/or 2) the way it is supposed to work has changed and the code needs to be updated to reflect that.
I was not expecting it to be fixed.

I was not expecting it to be worse than in 419.17 though, as that version didn't need FSE. That was a disappointment.

Anyway, back to an older driver.

I'll test again at the next major branch change.
__________________
Win10 Pro x64 b1903 MCE
i7 3770K@4.0Ghz 16Gb@2.18Ghz EVGA GTX 1080 Ti SC2 11Gb@2GHz 436.48 RGB Full 8bits
MPC-BE/LAV/MadVR/jRiver/MyMovies V5.25
Denon X8500H>HD Fury Maestro>JVC RS2000
Manni is offline   Reply With Quote
Old 6th March 2019, 01:00   #57  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 9,817
Quote:
Originally Posted by Manni View Post
I'll test again at the next major branch change.
As far as I can tell, that should be the 421 branch ready for Windows 10 19H1 (presumably in April)
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 6th March 2019, 01:52   #58  |  Link
Manni
Registered User
 
Join Date: Jul 2014
Posts: 732
Quote:
Originally Posted by nevcairiel View Post
As far as I can tell, that should be the 421 branch ready for Windows 10 19H1 (presumably in April)
OK thanks, I'll try that then. I'm back to 397.31 for now, as that's the first release with better 3D that doesn't need CRU to get custom refresh rates working in 12bits. Fingers crossed I won't have to go back to 385.28 and lose the better 3D...
__________________
Win10 Pro x64 b1903 MCE
i7 3770K@4.0Ghz 16Gb@2.18Ghz EVGA GTX 1080 Ti SC2 11Gb@2GHz 436.48 RGB Full 8bits
MPC-BE/LAV/MadVR/jRiver/MyMovies V5.25
Denon X8500H>HD Fury Maestro>JVC RS2000
Manni is offline   Reply With Quote
Old 6th March 2019, 02:27   #59  |  Link
Manni
Registered User
 
Join Date: Jul 2014
Posts: 732
Sadly no custom refresh rates in 12bits with 397.31, so back to 385.28, at least while I need to do tests with HDR passthrough.

Unfortunately I can't transpose my madVR custom refresh rates into CRU with the RS2000, for some reason they don't work, I think because the front porch parameter is limited to 1023 in CRU and madVR comes up with 1276, so CRU isn't an option. It used to work fine with the rs500.
__________________
Win10 Pro x64 b1903 MCE
i7 3770K@4.0Ghz 16Gb@2.18Ghz EVGA GTX 1080 Ti SC2 11Gb@2GHz 436.48 RGB Full 8bits
MPC-BE/LAV/MadVR/jRiver/MyMovies V5.25
Denon X8500H>HD Fury Maestro>JVC RS2000

Last edited by Manni; 6th March 2019 at 03:11.
Manni is offline   Reply With Quote
Old 8th March 2019, 13:21   #60  |  Link
Manni
Registered User
 
Join Date: Jul 2014
Posts: 732
Quote:
Originally Posted by VBB View Post
@Manni Did you have madVR set to 8-bit or 10-bit/auto? With 8-bit it doesn't switch using newer drivers.
Updating my excel nVidia bug tracking Excel spreadsheet, does anyone know with which driver version (even roughly) this started?

Thanks!
__________________
Win10 Pro x64 b1903 MCE
i7 3770K@4.0Ghz 16Gb@2.18Ghz EVGA GTX 1080 Ti SC2 11Gb@2GHz 436.48 RGB Full 8bits
MPC-BE/LAV/MadVR/jRiver/MyMovies V5.25
Denon X8500H>HD Fury Maestro>JVC RS2000

Last edited by Manni; 8th March 2019 at 13:42.
Manni is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 21:40.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.