Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > DVD & BD Rebuilder

Reply
 
Thread Tools Search this Thread Display Modes
Old 14th January 2020, 13:47   #29161  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,456
Quote:
Originally Posted by jdobbs View Post
Quote:
Originally Posted by LowDead View Post
Also found this in EXTRACT.META:

Code:
MUXOPT --no-pcr-on-video-pid --new-audio-pes --demux --vbr  --vbv-len=500
  - Scanning for Variable Frame Rate...
Hmmm... that's not good. Actually that file never gets used except when I set a test flag... but the fact that the text " - Scanning for Variable Frame Rate..." is being written to it makes be wonder how that could even happen.

This may help me put a finger on the problem. Thanks.
I found what was causing this. It was a stupid mistake on my part. I've fixed it for the next release.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 14th January 2020, 15:09   #29162  |  Link
LowDead
Registered User
 
Join Date: Feb 2005
Location: Sweden
Posts: 184
Quote:
Originally Posted by jdobbs View Post
I found what was causing this. It was a stupid mistake on my part. I've fixed it for the next release.
Great, thanks!

//LD
LowDead is offline   Reply With Quote
Old 14th January 2020, 16:09   #29163  |  Link
Michi
Registered User
 
Join Date: Aug 2019
Posts: 52
Quote:
Originally Posted by jdobbs View Post
Still a little confused. So... if I understand correctly, the reencoded files that BD-RB created work fine when you remux it manually, but not when BD-RB performs the remux?
Yes, this is correct. I manually remuxed the reencoded files by BD-RB an overwrite it.

Quote:
Originally Posted by jdobbs View Post
you try using the the version I linked in the post above?
Yes , I used this version yesterday and it's the same.

Quote:
Originally Posted by jdobbs View Post
you post the META file that is used by BD-RB and the one used when you do it manually so I can see the difference? If you are using the GUI, just cut and paste from the area in the GUI.
META file of the main movie by BD-RB:

Code:
MUXOPT --no-pcr-on-video-pid --new-audio-pes --blu-ray-v3 --vbr --auto-chapters=5 --vbv-len=500 --start-time=27000000
V_MPEGH/ISO/HEVC, "Q:\4K\WORKFILES\VID_00008.AVS.hevc", fps=24, insertSEI, contSPS
V_MPEGH/ISO/HEVC, "Q:\4K\WORKFILES\00008.track_4117.hevc", fps=24, secondary, contSPS
A_AC3, "Q:\4K\WORKFILES\00008.track_4356.AC3", lang=deu
S_HDMV/PGS, "Q:\4K\WORKFILES\00008.track_4771.sup",lang=deu
META file by manually remuxing with tsmuxergui:

Code:
MUXOPT --no-pcr-on-video-pid --new-audio-pes --vbr  --vbv-len=500
V_MPEGH/ISO/HEVC, "Q:\4K\COLD_PURSUIT\BDMV\STREAM\00008.m2ts", track=6912
V_MPEGH/ISO/HEVC, "Q:\4K\COLD_PURSUIT\BDMV\STREAM\00008.m2ts", fps=24, ar=As source, track=4113
A_AC3, "Q:\4K\COLD_PURSUIT\BDMV\STREAM\00008.m2ts", track=4352, lang=deu
S_HDMV/PGS, "Q:\4K\COLD_PURSUIT\BDMV\STREAM\00008.m2ts", fps=24, track=4608, lang=deu
Attached Images
 
Michi is offline   Reply With Quote
Old 14th January 2020, 17:23   #29164  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,456
Quote:
Originally Posted by Michi
Yes, this is correct. I manually remuxed the reencoded files by BD-RB an overwrite it.
Looking at the what you posted, it doesn't look like you used the files reencoded by BD-RB when you did it manually?

In BD-RB you used "Q:\4K\WORKFILES\VID_00008.AVS.hevc"

In the manual remux you used "Q:\4K\COLD_PURSUIT\BDMV\STREAM\00008.m2ts"

Am I missing something?
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 14th January 2020, 17:30   #29165  |  Link
Michi
Registered User
 
Join Date: Aug 2019
Posts: 52
Quote:
Originally Posted by jdobbs View Post

In the manual remux you used "Q:\4K\COLD_PURSUIT\BDMV\STREAM\00008.m2ts"
This is the m2ts-file created by BD-RB.
Michi is offline   Reply With Quote
Old 14th January 2020, 17:53   #29166  |  Link
thekiller
Registered User
 
Join Date: Mar 2010
Posts: 24
Quote:
Originally Posted by thekiller View Post
I just did a test directly with the disk directly, same problem, is this file you want?


#Created by BD Rebuilder - v0.61.01
DirectshowSource("G:\BDMV\STREAM\00000.m2ts", fps=23.976, framecount=198868, audio=false)
LoadPlugin("C:\Users\Sebastien\Desktop\Videos\BD_Rebuilder\tools\autocrop.dll")
Autocrop(mode=0, hMultOf=4)
ConvertToYV12().AssumeFPS(24000,1001)
you have forgotten me??
thekiller is offline   Reply With Quote
Old 15th January 2020, 13:09   #29167  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,456
Quote:
Originally Posted by Michi View Post
This is the m2ts-file created by BD-RB.
Ok. I see.

So you read it from the file BD-RB created and is sees "track=6912"? That's interesting -- and probably the source of the issue!

Thanks!
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net

Last edited by jdobbs; 15th January 2020 at 18:16.
jdobbs is offline   Reply With Quote
Old 15th January 2020, 13:11   #29168  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,456
Quote:
Originally Posted by thekiller View Post
you have forgotten me??
From the first post of this thread:
Code:
Don't push bug resolution or keep asking for a fix. I will get to the reported bugs, but only when I can find the time.
It has nothing to do with "forgotten" -- but with priorities. Right now I've prioritized "getting Dolby Vision working" as the thing I need to complete next.

It appears that AUTOCROP is having issues finding the borders on your source. Since AUTOCROP is an external filter (developed by someone else) there's not a lot I can do about it. I'd suggest you just just set autocropping off in the ALTERNATE output dialog.

Alternatively you could read info about autocrop at this link and possibly add it as a filter (using the SETUP dialog). That way you could experiment with some of its settings (like maybe the "threshold" or "sample" parameters) when you find sources that resize oddly. Remember, though, to disable the filter when you are trying to output to something other than ALTERNATE
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net

Last edited by jdobbs; 15th January 2020 at 13:54.
jdobbs is offline   Reply With Quote
Old 15th January 2020, 15:32   #29169  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,456
BD Rebuilder v0.61.04

I have updated the first post of this thread with a link to the most recent version of BD-RB (v0.61.04). Changes for this release:
Code:
- Corrected an error in which IMPORT_PAL_TO_FILM
  was not working for UHD sources.
- Fixed "Error 52" and failure when attempting
  to import a source that needed to be scanned
  for variable frame rate. Introduced in the
  v0.61.xx series.
- Fixed an error in which the wrong PID was
  being assigned to Dolby Vision substreams
  on full backups, causing it to not playback 
  correctly on machines supporting it when 
  enabled.
- Other minor corrections and cosmetic fixes.
@michi -- Let me know if this fixes your Dolby Vision issues.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net

Last edited by jdobbs; 15th January 2020 at 18:17.
jdobbs is offline   Reply With Quote
Old 15th January 2020, 22:20   #29170  |  Link
thekiller
Registered User
 
Join Date: Mar 2010
Posts: 24
Quote:
Originally Posted by jdobbs View Post
From the first post of this thread:
Code:
Don't push bug resolution or keep asking for a fix. I will get to the reported bugs, but only when I can find the time.
It has nothing to do with "forgotten" -- but with priorities. Right now I've prioritized "getting Dolby Vision working" as the thing I need to complete next.

It appears that AUTOCROP is having issues finding the borders on your source. Since AUTOCROP is an external filter (developed by someone else) there's not a lot I can do about it. I'd suggest you just just set autocropping off in the ALTERNATE output dialog.

Alternatively you could read info about autocrop at this link and possibly add it as a filter (using the SETUP dialog). That way you could experiment with some of its settings (like maybe the "threshold" or "sample" parameters) when you find sources that resize oddly. Remember, though, to disable the filter when you are trying to output to something other than ALTERNATE
ok I understand, for the moment I am doing this to force the correct resolution:

1. You go to the SETUP dialog (from the Settings menu).
2. Then click on "Use AVS Filters during encoding".
3. Within the editor dialog, just at the text: Crop(0,140,1920,800)
4. Save it.

it happens on old movies, if recent movies I don't have the problem

thank
thekiller is offline   Reply With Quote
Old 15th January 2020, 23:29   #29171  |  Link
Michi
Registered User
 
Join Date: Aug 2019
Posts: 52
This version is a major release! DV works great on my Sony X800M2.

Great job jdobbs!
Michi is offline   Reply With Quote
Old 16th January 2020, 00:14   #29172  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,456
Quote:
Originally Posted by Michi View Post
This version is a major release! DV works great on my Sony X800M2.

Great job jdobbs!
Good news. Thanks for helping me put my finger on where the problem was.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 16th January 2020, 00:17   #29173  |  Link
zamengo
Registered User
 
Join Date: Mar 2018
Posts: 28
Quote:
Originally Posted by jdobbs View Post
Good news. Thanks for helping me put my finger on where the problem was.
Jcdr428 tsmuxer help with this or you still using justdan version ?
zamengo is offline   Reply With Quote
Old 16th January 2020, 02:11   #29174  |  Link
MrVideo
Registered User
 
MrVideo's Avatar
 
Join Date: May 2007
Location: Wisconsin
Posts: 1,620
Quote:
Originally Posted by jdobbs View Post
Code:
- Corrected an error in which IMPORT_PAL_TO_FILM
  was not working for UHD sources.
Huh? PAL sources are 625 analog converted to 576i (which is technically no longer PAL). There is no such thing as PAL 4K sources. So, I am confused.
__________________
My Total Eclipse 2017 Photos
MrVideo is offline   Reply With Quote
Old 16th January 2020, 10:35   #29175  |  Link
FilipeAmadeuO
Registered User
 
Join Date: Aug 2002
Location: Portugal
Posts: 321
Quote:
Originally Posted by FilipeAmadeuO View Post
@jdobbs
Can you please add the possibility to replace the subtitles/audio and change language of subtitles/audio diretly on BDRebuilder GUI ?
Something like right click on subtitle/audio and select file to use for replace…
That would be a nice improvement...
@jdobbs
Before you finish this improvement is there any option on bdrebuilder.ini file that stops processing after all m2ts demux so i can replace subtitles manually and then continue with the remux ?

Also another question. Why is Dolby Vision HEVC file extracted on a 2nd run ? Why canīt it be extracted together with the other video/audio files ?
TsMuxer limitation ?

Last edited by FilipeAmadeuO; 16th January 2020 at 12:31.
FilipeAmadeuO is offline   Reply With Quote
Old 16th January 2020, 13:23   #29176  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,456
Quote:
Originally Posted by zamengo View Post
Jcdr428 tsmuxer help with this or you still using justdan version ?
Still using the justdan version. (same as last release).
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 16th January 2020, 13:30   #29177  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,456
Quote:
Originally Posted by FilipeAmadeuO View Post
@jdobbs
Before you finish this improvement is there any option on bdrebuilder.ini file that stops processing after all m2ts demux so i can replace subtitles manually and then continue with the remux ?

Also another question. Why is Dolby Vision HEVC file extracted on a 2nd run ? Why canīt it be extracted together with the other video/audio files ?
TsMuxer limitation ?
BD-RB works with one CLPI/M2TS at a time when doing full backups, so you'd have to stop/replace subtitles one at a time. That could get to be a real challenge on multi-part sources.

Normally the Dolby HEVC file isn't extracted individually. The only time BD-RB extracts streams individually is if it encounters an error when trying to extract all tracks at once.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 16th January 2020, 13:44   #29178  |  Link
FilipeAmadeuO
Registered User
 
Join Date: Aug 2002
Location: Portugal
Posts: 321
Quote:
Originally Posted by jdobbs View Post
BD-RB works with one CLPI/M2TS at a time when doing full backups, so you'd have to stop/replace subtitles one at a time. That could get to be a real challenge on multi-part sources.
I know that
Any chance to demux all m2ts at once -> stop -> i replace subtitles manually -> remux all m2ts ?
Or even better implement subtitle/dudio replacement directly on GUI

Quote:
Originally Posted by jdobbs View Post
Normally the Dolby HEVC file isn't extracted individually. The only time BD-RB extracts streams individually is if it encounters an error when trying to extract all tracks at once.
Any way to check extraction errors ? On the log there is no error reported

Last edited by FilipeAmadeuO; 16th January 2020 at 15:31.
FilipeAmadeuO is offline   Reply With Quote
Old 16th January 2020, 14:26   #29179  |  Link
ROB271
Registered User
 
Join Date: Nov 2019
Posts: 4
Hdr10

Hello,

test with 61.04, gemini man full backup this time

dolby vision seems to be working fine but hdr10 (when dolby vision is turned off) plays in black & white but when I switch to sdr it plays in colour

just for testing purposes to eliminate any player problem I did a full backup with dvdfab from the same rip & dolby vision, hdr10 & sdr all play ok

maybe a flag in the hdr10 metadata is not being set ?

Thanks

----------------------
[01/15/20] BD Rebuilder v0.61.04
[15:09:28] Source: GEMINI_MAN
- Input BD size: 83.91 GB
- Approximate total content: [02:18:54.406]
- Target BD size: 22.95 GB
- Windows Version: 6.2 [9200]
- Quality: Good (Fastest, BD-25+), ABR
- Decoding/Frame serving: FFMPEG
- Audio Settings: AC3=0 DTS=0 HD=1 Kbs=640
[15:09:28] PHASE ONE, Encoding
- [15:09:28] Processing: VID_00000 (1 of 3)
- [15:09:28] Extracting A/V streams [VID_00000]
- [15:09:35] Reencoding video [VID_00000]
- Source Video: HEVC, 3840x2160
- Rate/Length: 23.976fps, 528 frames
- Bitrate: 7,699 Kbs
- [15:09:35] Reencoding: VID_00000, Pass 1 of 1
- [15:10:32] Video Encode complete
- [15:10:32] Processing audio tracks
- Track 4352 (eng): Keeping original audio
- [15:10:32] Multiplexing M2TS
- [15:10:37] Processing: VID_00003 (2 of 3)
- [15:10:37] Extracting A/V streams [VID_00003]
- [15:42:02] Reencoding video [VID_00003]
- Source Video: HEVC, 3840x2160
- Rate/Length: 59.940fps, 420,962 frames
- Bitrate: 14,359 Kbs
- [15:42:02] Reencoding: VID_00003, Pass 1 of 1
- [03:30:38] Video Encode complete
- [03:30:38] Processing audio tracks
- Track 4352 (eng): Keeping original audio
- [03:30:38] Multiplexing M2TS
- Error in attempt to multiplex: MUX_00003.meta
- Mux successful complete
[03:46:51] - Failed to build structure, aborted
----------------------
[01/16/20] BD Rebuilder v0.61.04
[11:01:26] Source: GEMINI_MAN
- Input BD size: 83.91 GB
- Approximate total content: [02:18:54.406]
- Target BD size: 22.95 GB
- Windows Version: 6.2 [9200]
- Quality: Good (Fastest, BD-25+), ABR
- Decoding/Frame serving: FFMPEG
- Audio Settings: AC3=0 DTS=0 HD=1 Kbs=640
- Resuming from previously started job.
[11:01:29] PHASE ONE, Encoding
- [11:01:29] Processing: VID_00003 (2 of 3)
- [11:02:51] Multiplexing M2TS
- [11:19:35] Processing: VID_00579 (3 of 3)
- [11:19:35] Extracting A/V streams [VID_00579]
- [11:20:15] Reencoding video [VID_00579]
- Source Video: HEVC, 3840x2160
- Rate/Length: 59.940fps, 10,940 frames
- Bitrate: 13,347 Kbs
- [11:20:15] Reencoding: VID_00579, Pass 1 of 1
- [11:37:02] Video Encode complete
- [11:37:02] Processing audio tracks
- Track 4352 (eng): Keeping original audio
- [11:37:02] Multiplexing M2TS
[11:37:25]PHASE ONE complete
[11:37:25]PHASE TWO - Rebuild Started
- [11:37:25] Rebuilding BD file Structure
[11:38:11] - Encode and Rebuild complete
[11:38:11] JOB: GEMINI_MAN finished.
[Status]
LABEL=GEMINI_MAN
VERSION=v0.61.04
SOURCE_SIZE=90095341075
SOURCE_VIDEO_SIZE=88809314304
TARGET_SIZE=24641536000
REDUCTION=.262984906617481
RESIZE_1080=0
RESIZE_1440=0
AUDIO_TO_KEEP=eng;
KEEP_HD_AUDIO=-1
SUBS_TO_KEEP=eng;
BACKUP_MODE=0
MOVIEONLY_TYPE=0
USE_LAVF=0
INSTANCES=1
DGDECNV=0
DGDECIM=0
FRIMSOURCE=0
FFMS2=0
SSIF_MODE=0
HEVC_MODE=0
QUICK=0
ENCODE_STEP=0
COMPLETED=3
REBUILD_COMPLETE=1
[00000]
AUDIO=1
PGS=
VIDEO2=5633354.34782609
V2MBRATE=0
M2TS_TARGET=43585646
RATE=7699
NSTART=27000000
NEND=27990989
NSIZE=40765440
FLINK=0
MLINK=0
[00003]
AUDIO=10000000
PGS=10000000000000
VIDEO2=2559780314.13043
V2MBRATE=0
M2TS_TARGET=22902965004
RATE=14359
NSTART=27000000
NEND=343037221
NSIZE=21128626176
FLINK=0
MLINK=0
[00579]
AUDIO=1
PGS=00000000000
VIDEO2=66427404.3478261
V2MBRATE=0
M2TS_TARGET=408958580
RATE=13347
NSTART=27000000
NEND=35213204
NSIZE=375988224
FLINK=0
MLINK=0

Last edited by ROB271; 17th January 2020 at 18:04.
ROB271 is offline   Reply With Quote
Old 16th January 2020, 18:33   #29180  |  Link
Michi
Registered User
 
Join Date: Aug 2019
Posts: 52
Quote:
Originally Posted by ROB271 View Post
Hello,

test with 61.04, gemini man full backup this time

dolby vision seems to be working fine but hdr10 (when dolby vision is turned off) plays in black & white but when I switch to sdr it plays in colour

just for testing purposes to eliminate any player problem I did a full backup with dvdfab from the same rip & dolby vision, hdr10 & sdr all play ok
HDR10 or HDR10+?

My Sony X800M2 have no problem with HDR10 on UHD-discs made by BD-RB. The Sony can't play HDR10+.

Which player can play HDR10+ discs?
Michi is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 10:28.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.