Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 6th February 2008, 08:34   #821  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 6,292
Big Hooray, Donald. With TS support and CLI interface, you made a few milestones towards integration into some automating GUIs.

P.S.: Please check the CLI table in your manual, regarding the description of the pcrPID parameter. I assume it's not another "video stream"?

Last edited by LigH; 6th February 2008 at 08:39.
LigH is offline  
Old 6th February 2008, 13:13   #822  |  Link
Deinorius
Najarenthur
 
Deinorius's Avatar
 
Join Date: Jan 2006
Location: Austria (Vienna)
Posts: 202
Quote:
Originally Posted by neuron2 View Post
OK, here's your primitive CLI:
Yippieh, thank you very much!
Deinorius is offline  
Old 6th February 2008, 23:06   #823  |  Link
7oby
Registered User
 
Join Date: Sep 2007
Posts: 27
Quote:
Originally Posted by neuron2 View Post
OK, here's your primitive CLI:
That is awesome!

Finally I got rid of all this nasty DirectShowFilter stuff and have a fully automatic DVB-S2 HDTV -> PS3 conversion running:


(german only):
http://forum.gleitz.info/showpost.ph...&postcount=221

bg,
7oby
7oby is offline  
Old 13th February 2008, 14:46   #824  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 6,292
I tried to open the "wedding shot". Unfortunately, DGAVCDec 1.00a15 could not index it:

Quote:
---------------------------
Error
---------------------------
reserved picture_structure used (can't determine NumClockTs)
---------------------------
Just for testing, similar issues with a transmuxed *.ts using "tsremux":

Quote:
---------------------------
Warning
---------------------------
Found NALU w/ forbidden_bit set, bit error? Let's try...

Hit Yes to continue with further DGAVCIndex error/warning popups, hit No to disable them.
---------------------------
Hitting "No" here makes DGAVCIndex crash (with "Send report to MS?"). With "Yes" there are lots of more errors, you can try yourself (didn't want to bloat this reply; if you need, ask me for them).

Opening the raw stream demuxed using "tsremux" works well.
LigH is offline  
Old 13th February 2008, 15:25   #825  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
M2TS support is broken. I'll fix it in the next version, which will also have audio demux. Thank you for providing this test stream.
Guest is offline  
Old 13th February 2008, 15:46   #826  |  Link
Atak_Snajpera
RipBot264 author
 
Atak_Snajpera's Avatar
 
Join Date: May 2006
Location: Poland
Posts: 7,474
Quote:
which will also have audio demux
Don't forget about audio delay Thanks!
Atak_Snajpera is offline  
Old 13th February 2008, 18:40   #827  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Quote:
Originally Posted by Atak_Snajpera View Post
Don't forget about audio delay Thanks!
What do you mean by that? Is there some particular design that you are hoping for?

As it happens, I am experimenting in this area. At first I will release a version with no solution just to get feedback on my demuxing code. Meanwhile I'll continue my experiments and follow up with another version with some solution.

BTW, the M2TS bug is fixed and I'm just regression testing and testing all the transport streams with audio that I can find before giving you a new version.
Guest is offline  
Old 13th February 2008, 19:53   #828  |  Link
Atak_Snajpera
RipBot264 author
 
Atak_Snajpera's Avatar
 
Join Date: May 2006
Location: Poland
Posts: 7,474
Quote:
What do you mean by that? Is there some particular design that you are hoping for?
Let's say some noob didn't cut TS files on Keyframes. Then he tries to encode file but after that he realizes that audio is out of sync. Some badly cut samples should be still available on x264.nl In Dgindex you store audio delay in file name so you could use the same method or cut audio according to keyframe. It's up to you.

Last edited by Atak_Snajpera; 13th February 2008 at 19:57.
Atak_Snajpera is offline  
Old 14th February 2008, 21:26   #829  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Need some sample transport streams with DTS and LPCM audio

I'm about to release a version with audio demuxing. I have the following supported:

MPEG audio
AAC ADTS (not LATM/LOAS yet)
AC3

I can add DTS and LPCM if needed, but I need test streams for that. So does anybody have any transport streams with AVC video and audio in a format not listed above? If so, please make the streams available so I can add support for them. Thank you.
Guest is offline  
Old 14th February 2008, 22:46   #830  |  Link
Atak_Snajpera
RipBot264 author
 
Atak_Snajpera's Avatar
 
Join Date: May 2006
Location: Poland
Posts: 7,474
http://www.mediafire.com/?ezyxmgmioss - m2ts with DTS

http://www.mediafire.com/?bzojtnioymt - ts with DTS , and 3 AC3

Last edited by Atak_Snajpera; 14th February 2008 at 23:18.
Atak_Snajpera is offline  
Old 15th February 2008, 02:03   #831  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Thanks.

But are you sure about the first one? Everything I have says there is no audio in that stream.
Guest is offline  
Old 15th February 2008, 02:53   #832  |  Link
check
phjbdpcrjlj2sb3h
 
check's Avatar
 
Join Date: Sep 2005
Location: Western Australia
Posts: 1,692
does AC3 include EAC3?
check is offline  
Old 15th February 2008, 03:21   #833  |  Link
ChronoCross
Does it really matter?
 
ChronoCross's Avatar
 
Join Date: Jun 2004
Location: Chicago, IL
Posts: 1,542
Quote:
Originally Posted by neuron2 View Post
Thanks.

But are you sure about the first one? Everything I have says there is no audio in that stream.
I can hear it when I playback in nero.
ChronoCross is offline  
Old 15th February 2008, 03:47   #834  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Quote:
Originally Posted by check View Post
does AC3 include EAC3?
Maybe. Do you have a test stream for me?
Guest is offline  
Old 15th February 2008, 10:46   #835  |  Link
Flaarn
Registered User
 
Join Date: Jan 2003
Location: UK
Posts: 23
I think neuron2 may have some "fun" with the audio delay if he decides to implement it, my own experience with broadcast streams that have demuxed so far has always required some manual syncing as none of the demuxers seem to give identical output and what something like pts calc gives as the offset, and what the output is from the demuxer dont always marry up, what I mean here is a lot dont seem to output from what many folks would regard as a valid startpoint hence the need for some manual intervention.
Something I would like clarified if possible the switches between 2.0/5.1 do they throw a spanner in the works or not, some of the information I've come across suggests it's a change in bitrate ie 192/384 etc, that can cause an issue rather than the amount of channels but i've also come across information that suggests different, in any case I've found one size does not fit all so far.
Something that actually gets it right would be great.

Last edited by Flaarn; 15th February 2008 at 11:30.
Flaarn is offline  
Old 15th February 2008, 23:55   #836  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Quote:
Originally Posted by ChronoCross View Post
I can hear it when I playback in nero.
It's using another "undocumented" stream type: 0x82. So I added code to interpret that as DTS and it is working now.

This is the last call for TS streams before the first release with demuxing. I now support MPA, AAC, AC3, and DTS. I can try to add EAC3 (which may work already; I've no test stream) and LPCM. If you want something supported, send me a link to a stream.

BTW, the new design allows for demuxing all audio streams at once, instead of having to demux each PID separately (as in DGIndex).

Last edited by Guest; 15th February 2008 at 23:58.
Guest is offline  
Old 16th February 2008, 00:20   #837  |  Link
Atak_Snajpera
RipBot264 author
 
Atak_Snajpera's Avatar
 
Join Date: May 2006
Location: Poland
Posts: 7,474
Quote:
It's using another "undocumented" stream type: 0x82. So I added code to interpret that as DTS and it is working now.
File was muxed with TSMuxer I just wanted to make sure that your app will also support files muxed with this tool.


How did you solve problem with correct audio delay? For example xport cuts audio stream according to first key frame , DGindex stores delay value in filename...

Last edited by Atak_Snajpera; 16th February 2008 at 00:28.
Atak_Snajpera is offline  
Old 16th February 2008, 00:41   #838  |  Link
Unearthly
Encoder in Training
 
Unearthly's Avatar
 
Join Date: Mar 2007
Location: Massachusetts
Posts: 37
http://www.mediafire.com/?5n0czjmvxtg - m2ts with stereo LPCM.
Unearthly is offline  
Old 16th February 2008, 01:02   #839  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Quote:
Originally Posted by Atak_Snajpera View Post
File was muxed with TSMuxer I just wanted to make sure that your app will also support files muxed with this tool.
I hope the author is following the appropriate specifications.

Quote:
How did you solve problem with correct audio delay? For example xport cuts audio stream according to first key frame , DGindex stores delay value in filename...
I haven't decided yet. The first version just starts outputing audio at the first audio frame header following the first decodable frame. Video starts at the first decodable frame. So they're likely to be close. Let me know how it works.

@Unearthly

Thank you for the test stream.
Guest is offline  
Old 17th February 2008, 01:58   #840  |  Link
Southstorm
20yr Videographer
 
Join Date: Jan 2008
Location: The Great Northwest
Posts: 272
@neuron2

Just wanted to say thankyou for some excellent programs.
They make life that much simpler!
Southstorm is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 23:06.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.