Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 24th January 2006, 00:48   #261  |  Link
berrinam
Registered User
 
berrinam's Avatar
 
Join Date: Apr 2005
Posts: 1,740
Quote:
Originally Posted by Richard Berg
3) Have some jobs going. Dragdrop a d2v file and queue the index job. The d2v creator dialog will sit there, and the rest of MeGUI will be unresponsive, until you kill it. Waiting for the index job would probably work too, but that might be days away...
I can't reproduce this. You do realise that you have to close the d2v creator after you have created the job, right? (For some reason, the close checkbox isn't displayed there).
berrinam is offline  
Old 24th January 2006, 00:59   #262  |  Link
Richard Berg
developer wannabe
 
Richard Berg's Avatar
 
Join Date: Nov 2001
Location: Brooklyn, NY
Posts: 1,211
I've never worked with d2v files before, and all of my MeGUI instances are running long jobs so I can't test in a state w/ empty queue. Is the Queue button never supposed to dismiss the dialog? If so, what's the intended scenario? Queuing the same idx job several times?
Richard Berg is offline  
Old 24th January 2006, 01:23   #263  |  Link
berrinam
Registered User
 
berrinam's Avatar
 
Join Date: Apr 2005
Posts: 1,740
Quote:
Originally Posted by Richard Berg
I've never worked with d2v files before, and all of my MeGUI instances are running long jobs so I can't test in a state w/ empty queue. Is the Queue button never supposed to dismiss the dialog? If so, what's the intended scenario? Queuing the same idx job several times?
Opening the D2V creator through the menu gives you a checkbox which says 'and close', next to the Queue. When in dialog mode, this doesn't exist, which seems ot be the wrong behaviour. The reason there are all these variations is that there are 4 ways of opening the D2V creator window:
1. Menu (has the 'and close' checkbox)
2. Load an index job (closes when you press update. Has no 'and close' checkbox)
3. Select an mpeg2 file in the AviSynth Script Creator (I think this closes when you press queue)
4. Drag-n-drop (doesn't close and doesn't have the 'and close' checkbox. This is the bug)
berrinam is offline  
Old 24th January 2006, 03:34   #264  |  Link
berrinam
Registered User
 
berrinam's Avatar
 
Join Date: Apr 2005
Posts: 1,740
Quote:
Originally Posted by Doom9
I think so to. I think the breaking change has been introduced in 1.4.6 beta 3 (http://forum.doom9.org/showthread.ph...522#post764522) so if you could try to create your project again using an older beta (or just the latest stable version) and verify that it works there, that would be much appreciated.
I would imagine this would also cause problems with auto force film, as the fps is indicated slightly differently in the d2v file. Time to change the auto force film code, and boost the required DGMPGDec version to 1.4.6 beta 3 or later, then. What do you think?
berrinam is offline  
Old 24th January 2006, 03:54   #265  |  Link
berrinam
Registered User
 
berrinam's Avatar
 
Join Date: Apr 2005
Posts: 1,740
Quote:
Originally Posted by puffpio
Using megui 0.2.3.2033

When loading an avs file into the program, then going into the bitrate calculator, the video length, framerate, and framecount is incorrect

This occurs both when I loaded an avs script taht was @ 29.97fps and also at 23.97fps. In both cases the framerate the bitrate calculator displayed was 25fps, and the video length was short by a couple minutes.

It used to work correctly a couple versions ago...maybe I need to delete some configuration files?
Can you test this in 0.2.3.2041 when it is released? I _think_ I fixed it there, but your testing again would be appreciated.
berrinam is offline  
Old 24th January 2006, 06:30   #266  |  Link
ChronoCross
Does it really matter?
 
ChronoCross's Avatar
 
Join Date: Jun 2004
Location: Chicago, IL
Posts: 1,542
Quote:
Originally Posted by berrinam
I would imagine this would also cause problems with auto force film, as the fps is indicated slightly differently in the d2v file. Time to change the auto force film code, and boost the required DGMPGDec version to 1.4.6 beta 3 or later, then. What do you think?
I only use the official finals. I don't want to encounter double the bugs lol. but if you up it I guess I'll have no choice.
ChronoCross is offline  
Old 24th January 2006, 07:05   #267  |  Link
foxyshadis
ангел смерти
 
foxyshadis's Avatar
 
Join Date: Nov 2004
Location: Lost
Posts: 9,532
DG has stated that he doesn't believe in differentiating between a beta and final version, he just increments the number when he feels enough features have gone in to warrant it. Thus some of his are permanent betas.

Just to make sure it didn't get overlooked:
The current --filter syntax is incorrect. MeGUI outputs something like -2,3, but the proper syntax is -2:3, and given -2,3 x264 will always reuse the first argument, thus -2,3, -2,-6, and -2,0 are all equivalent to -2:-2.
__________________
There are four boxes to be used in defense of liberty: soap, ballot, jury, and ammo. Please use in that order.
foxyshadis is offline  
Old 24th January 2006, 11:42   #268  |  Link
L4z4rus
Registered User
 
L4z4rus's Avatar
 
Join Date: Jul 2005
Location: UK
Posts: 7
Hi, I've just done a CVS update, but I get the following error when trying to compile? (I haven't had any problems in the past) Last working version I compiled was 0.2.3.2037 yesterday:

Code:
Microsoft (R) Visual C# 2005 Compiler version 8.00.50727.42
for Microsoft (R) Windows (R) 2005 Framework version 2.0.50727
Copyright (C) Microsoft Corporation 2001-2005. All rights reserved.

AviSynthAudioEncoder.cs(635,7): error CS1024: Preprocessor directive expected
AviSynthAudioEncoder.cs(647,7): error CS1024: Preprocessor directive expected
Microsoft (R) Visual C# 2005 Compiler version 8.00.50727.42
for Microsoft (R) Windows (R) 2005 Framework version 2.0.50727
Copyright (C) Microsoft Corporation 2001-2005. All rights reserved.

AviSynthAudioEncoder.cs(635,7): error CS1024: Preprocessor directive expected
AviSynthAudioEncoder.cs(647,7): error CS1024: Preprocessor directive expected
Microsoft (R) Visual C# 2005 Compiler version 8.00.50727.42
for Microsoft (R) Windows (R) 2005 Framework version 2.0.50727
Copyright (C) Microsoft Corporation 2001-2005. All rights reserved.

Form1.cs(3282,10): warning CS1030: #warning: 'dimzon'
neroraw\neroraw.cs(60,27): error CS0017: Program
        'c:\meGUI\MeGUI-src.CVS\megui.exe' has more than one entry point
        defined: 'MeGUI.NeroRawAacEncoder.Main(string[])'
Form1.cs(2702,15): error CS0017: Program 'c:\meGUI\MeGUI-src.CVS\megui.exe' has
        more than one entry point defined: 'MeGUI.MeGUI.Main()'
Press any key to continue . . .
L4z4rus is offline  
Old 24th January 2006, 12:04   #269  |  Link
The Link
Registered User
 
The Link's Avatar
 
Join Date: Nov 2001
Location: Germany
Posts: 189
@L4z4rus: Just remove the neroraw folder and try again or make a new cvs checkout since Dimzon seems to have fixed this compilation bug.
__________________
When birds burp, it must taste like bugs! (Calvin&Hobbes)

The Link is offline  
Old 24th January 2006, 12:26   #270  |  Link
L4z4rus
Registered User
 
L4z4rus's Avatar
 
Join Date: Jul 2005
Location: UK
Posts: 7
@The Link:
Thanks, still no luck - tried removing neroraw, no success, & made a new cvs checkout, still getting the same error log....

Update: worked out the problem, I'd checked all the files in the error had updated except for compile.bat, I'll try & update again in a bit as its still currently giving me an older version.

Last edited by L4z4rus; 24th January 2006 at 12:31.
L4z4rus is offline  
Old 24th January 2006, 12:28   #271  |  Link
The Link
Registered User
 
The Link's Avatar
 
Join Date: Nov 2001
Location: Germany
Posts: 189
Strange ... when I removed the neroraw folder compiling worked here. Dimzon said that he commited the fix (http://forum.doom9.org/showthread.ph...118#post774118) but probably it takes some time till all servers are synchronized (or whatever).
__________________
When birds burp, it must taste like bugs! (Calvin&Hobbes)

The Link is offline  
Old 24th January 2006, 12:39   #272  |  Link
dimzon
BeHappy/MeGUI developer
 
dimzon's Avatar
 
Join Date: Oct 2003
Location: Moscow, Russia
Posts: 1,727
Quote:
Originally Posted by The Link
Strange ... when I removed the neroraw folder compiling worked here. Dimzon said that he commited the fix (http://forum.doom9.org/showthread.ph...118#post774118) but probably it takes some time till all servers are synchronized (or whatever).
anonimous cvs has up to 6hrs lag
dimzon is offline  
Old 24th January 2006, 13:27   #273  |  Link
L4z4rus
Registered User
 
L4z4rus's Avatar
 
Join Date: Jul 2005
Location: UK
Posts: 7
I'll remember to allow for the CVS delay in the future...

...Bugger....now i've managed to update to latest CVS changes I get a new error (compile.bat rev1.5; AviSynthAudioEncoder.cs rev1.3; AvisynthWrapper.cs rev1.1):

Code:
Microsoft (R) Visual C# 2005 Compiler version 8.00.50727.42
for Microsoft (R) Windows (R) 2005 Framework version 2.0.50727
Copyright (C) Microsoft Corporation 2001-2005. All rights reserved.

AvisynthWrapper.cs(360,7): warning CS0162: Unreachable code detected
AvisynthWrapper.cs(363,7): warning CS0162: Unreachable code detected
AvisynthWrapper.cs(366,7): warning CS0162: Unreachable code detected
AvisynthWrapper.cs(369,7): warning CS0162: Unreachable code detected
AvisynthWrapper.cs(372,7): warning CS0162: Unreachable code detected
AvisynthWrapper.cs(375,7): warning CS0162: Unreachable code detected
Microsoft (R) Visual C# 2005 Compiler version 8.00.50727.42
for Microsoft (R) Windows (R) 2005 Framework version 2.0.50727
Copyright (C) Microsoft Corporation 2001-2005. All rights reserved.

AvisynthWrapper.cs(360,7): warning CS0162: Unreachable code detected
AvisynthWrapper.cs(363,7): warning CS0162: Unreachable code detected
AvisynthWrapper.cs(366,7): warning CS0162: Unreachable code detected
AvisynthWrapper.cs(369,7): warning CS0162: Unreachable code detected
AvisynthWrapper.cs(372,7): warning CS0162: Unreachable code detected
AvisynthWrapper.cs(375,7): warning CS0162: Unreachable code detected
Microsoft (R) Visual C# 2005 Compiler version 8.00.50727.42
for Microsoft (R) Windows (R) 2005 Framework version 2.0.50727
Copyright (C) Microsoft Corporation 2001-2005. All rights reserved.

Form1.cs(3282,10): warning CS1030: #warning: 'dimzon'
AviSynthAudioEncoder.cs(695,13): warning CS0618:
        'System.Threading.Thread.Suspend()' is obsolete: 'Thread.Suspend has
        been deprecated.  Please use other classes in System.Threading, such as
        Monitor, Mutex, Event, and Semaphore, to synchronize Threads or protect
        resources.  http://go.microsoft.com/fwlink/?linkid=14202'
AviSynthAudioEncoder.cs(702,13): warning CS0618:
        'System.Threading.Thread.Resume()' is obsolete: 'Thread.Resume has been
        deprecated.  Please use other classes in System.Threading, such as
        Monitor, Mutex, Event, and Semaphore, to synchronize Threads or protect
        resources.  http://go.microsoft.com/fwlink/?linkid=14202'
AvisynthWrapper.cs(360,7): warning CS0162: Unreachable code detected
AvisynthWrapper.cs(363,7): warning CS0162: Unreachable code detected
AvisynthWrapper.cs(366,7): warning CS0162: Unreachable code detected
AvisynthWrapper.cs(369,7): warning CS0162: Unreachable code detected
AvisynthWrapper.cs(372,7): warning CS0162: Unreachable code detected
AvisynthWrapper.cs(375,7): warning CS0162: Unreachable code detected
Microsoft (R) Visual C# 2005 Compiler version 8.00.50727.42
for Microsoft (R) Windows (R) 2005 Framework version 2.0.50727
Copyright (C) Microsoft Corporation 2001-2005. All rights reserved.

warning CS1607: Assembly generation -- The version '0.0.1.*' specified for the
        'file version' is not in the normal 'major.minor.build.revision' format
L4z4rus is offline  
Old 24th January 2006, 13:31   #274  |  Link
dimzon
BeHappy/MeGUI developer
 
dimzon's Avatar
 
Join Date: Oct 2003
Location: Moscow, Russia
Posts: 1,727
Quote:
Originally Posted by L4z4rus
I'll remember to allow for the CVS delay in the future...

...Bugger....now i've managed to update to latest CVS changes I get a new error (compile.bat rev1.5; AviSynthAudioEncoder.cs rev1.3; AvisynthWrapper.cs rev1.1)
there are no error word @ output, there are only warning isn't it So don't worry about this warnings.
dimzon is offline  
Old 24th January 2006, 13:52   #275  |  Link
L4z4rus
Registered User
 
L4z4rus's Avatar
 
Join Date: Jul 2005
Location: UK
Posts: 7
@Dimzon

Thanks - I'm having an idiot day today , i've just spotted the binaries in my CVS folder
L4z4rus is offline  
Old 24th January 2006, 18:45   #276  |  Link
dumbas..
Its all in the name....
 
Join Date: Oct 2005
Location: Northern Hemishere, I think..
Posts: 33
Megui mp4 output error

1. Checked for thread reports non found so forgive if repeated or in wrong thread.

Objective:

Test Megui and staxrip for most suitable gui for EPISODE DVD use.
Player Media Player classic 6.4.8.7
Fdshow ver 29 November
x264 set to use libravic
Both gui's using same vob sample

Stax rip:

output > playable >all ok

Megui
created aac audio frorm vob clip in mp4 container > playable
created video from vob to mp4 >playable

BUT when I mux above > error reported See END OF LOG

log:
Starting job job2 at 17:14:35
Job is a dgindex job. dgindex commandline:
"C:\MY PROGRAMS\VIDEO\StaxRip\Applications\DGIndex\DGIndex.exe" -AIF=[C:\Documents and Settings\Brian\My Documents\DVD\VTS_07_1.VOB] -OF=[C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\dgindex] -exit -OM=2
successfully set up dgindex
Processing ended at 17:14:36
----------------------------------------------------------------------------------------------------------

Log for job job2


----------------------------------------------------------------------------------------------------------
Starting job job1 at 17:18:35
Job is an audio job. Commandline:
-core( -input "C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\dgindex T01 3_2ch 448Kbps DELAY 0ms.ac3" -output "C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\megui audio.mp4" -logfile "C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\megui audio.besweet.log" ) -azid( -s stereo -c normal -L -3db ) -dimzon( -dllname bse_FAAC.dll -q 100 ) -ota( -g max )
successfully started encoding
Processing ended at 17:18:40
----------------------------------------------------------------------------------------------------------

Log for job job1

BeSweet v1.5b30 by DSPguru.
--------------------------

[00:00:00:000] Initializing...
[00:00:00:000] -- Initializing...

[00:00:34:016] |

[00:00:34:016] Finalizing...
[00:00:34:016] Conversion Completed !

Visit DSPguru's Homepage at :
http://DSPguru.doom9.net/

----------------------------------------------------------------------------------------------------------
Starting job job2-1 at 17:18:40
Job is a video job. encoder commandline:
--pass 1 --bitrate 1161 --stats "C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\avisynth.stats" --bframes 2 --b-pyramid --nf --subme 1 --analyse none --me dia --progress --no-psnr --output NUL "C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\avisynth.avs"
successfully started encoding
Processing ended at 17:19:03
----------------------------------------------------------------------------------------------------------

Log for job job2-1

avis [info]: 640x272 @ 25.00 fps (851 frames)
x264 [info]: using cpu capabilities MMX MMXEXT SSE SSE2 3DNow!
x264 [info]: slice I:6 Avg QP:17.33 size: 10569
x264 [info]: slice P:552 Avg QP:19.08 size: 6761
x264 [info]: slice B:293 Avg QP:23.26 size: 2729
x264 [info]: mb I I16..4: 66.0% 0.0% 34.0%
x264 [info]: mb P I16..4: 41.6% 0.0% 0.0% P16..4: 43.7% 0.0% 0.0% 0.0% 0.0% skip:14.7%
x264 [info]: mb B I16..4: 2.3% 0.0% 0.0% B16..8: 29.8% 0.0% 0.0% direct:14.3% skip:53.5%
x264 [info]: final ratefactor: 20.68
x264 [info]: kb/s:1079.9

Actual bitrate after encoding without container overhead: 1080.13

----------------------------------------------------------------------------------------------------------
job job2-1 has been processed. This job is linked to the next job: job2-2
Starting job job2-2 at 17:19:03
Job is a video job. encoder commandline:
--pass 2 --bitrate 1161 --stats "C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\avisynth.stats" --bframes 2 --b-pyramid --bime --weightb --nf --trellis 1 --analyse p8x8,b8x8,i4x4,p4x4 --progress --no-psnr --output "C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\megui video.mp4" "C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\avisynth.avs"
successfully started encoding
Processing ended at 17:19:56
----------------------------------------------------------------------------------------------------------

Log for job job2-2

avis [info]: 640x272 @ 25.00 fps (851 frames)
x264 [info]: using cpu capabilities MMX MMXEXT SSE SSE2 3DNow!
mp4 [info]: initial delay 2 (scale 25)
x264 [info]: slice I:6 Avg QP:17.17 size: 7830
x264 [info]: slice P:552 Avg QP:18.73 size: 6778
x264 [info]: slice B:293 Avg QP:22.40 size: 3842
x264 [info]: mb I I16..4: 68.5% 0.0% 31.5%
x264 [info]: mb P I16..4: 30.3% 0.0% 15.8% P16..4: 20.4% 10.0% 5.3% 1.3% 0.9% skip:15.9%
x264 [info]: mb B I16..4: 2.6% 0.0% 2.0% B16..8: 31.4% 2.9% 7.1% direct: 9.0% skip:45.0%
x264 [info]: kb/s:1155.0

Actual bitrate after encoding without container overhead: 1155.16
desired video bitrate of this job: 1161 kbit/s - obtained video bitrate: 1157.18942420682 kbit/s
----------------------------------------------------------------------------------------------------------
Starting job job3 at 17:21:19
Job is a mux job. Commandline:
-add "C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\megui video.mp4" -add "C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\megui audio.mp4":lang=eng -new "C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\megui video and audio muxed.mp4"
successfully set up muxer
Processing ended at 17:21:19
----------------------------------------------------------------------------------------------------------

Log for job job3

IsoMedia import - track ID 1 - Video (size 640 x 272)
Unknown input file type
Error importing C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\megui audio.mp4:lang=eng: Feature Not Supported
(Feature Not Supported)

----------------------------------------------------------------------------------------------------------

As a test I muxed the .264 and aac output from staxrip through the Megui muxer to MP4 Result >PLAYABLE

THEREFORE megui muxing works (but with Staxrip output files)

Confused NEW user needs tea and sympathy
I MUST be doing something daft here so be gentle!

I would like to use Megui 'cause it will queue episodic DVD conversion.
dumbas.. is offline  
Old 24th January 2006, 19:23   #277  |  Link
Richard Berg
developer wannabe
 
Richard Berg's Avatar
 
Join Date: Nov 2001
Location: Brooklyn, NY
Posts: 1,211
Do you have the latest version of mp4box?
Richard Berg is offline  
Old 25th January 2006, 00:01   #278  |  Link
ChronoCross
Does it really matter?
 
ChronoCross's Avatar
 
Join Date: Jun 2004
Location: Chicago, IL
Posts: 1,542
CVS works great. Thanks guys.
ChronoCross is offline  
Old 25th January 2006, 00:25   #279  |  Link
dumbas..
Its all in the name....
 
Join Date: Oct 2005
Location: Northern Hemishere, I think..
Posts: 33
@Richard Berg

Thanks

Well I have the version dated 8/11/2005
Not sure how to acertain the version number
I tried the latest release from
http://www.aziendeassociate.it/cd//gpac/dev/MP4Box.7z

dated 03 January 2006

It crashes out with a windows error

AppName: mp4box.exe AppVer: 0.0.0.0 ModName: mp4box.exe
ModVer: 0.0.0.0 Offset: 0005c867


The MeGui log is none the wiser:
Muxjob ended and deletion of intermediate files is activated
Starting job job2 at 23:16:29
Job is a mux job. Commandline:
-add "C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\megui video.mp4" -add "C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\megui audio.mp4":lang=eng -new "C:\Documents and Settings\Brian\My Documents\DVD\MEgui Output\megui Mux.mp4"
successfully set up muxer
Processing ended at 23:16:40
----------------------------------------------------------------------------------------------------------

Log for job job2


----------------------------------------------------------------------------------------------------------


So I'm a bit stuck. Neither want to work!
dumbas.. is offline  
Old 25th January 2006, 01:03   #280  |  Link
ChronoCross
Does it really matter?
 
ChronoCross's Avatar
 
Join Date: Jun 2004
Location: Chicago, IL
Posts: 1,542
Well I can confirm that there is a problem with the latest cvs in terms of mp4box. it doesn't seem to be a meGUI problem but rather with the compiling itself. I just compiled it and it gives the same crash error.

I'm going to try and troubleshoot it.

I still can't compile it to correctly work but here's a working version dated 1/19/06 from kurtnoise.

http://kurtnoise.free.fr/mp4tools/

Last edited by ChronoCross; 25th January 2006 at 01:18.
ChronoCross is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 08:32.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.