Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 19th April 2010, 18:08   #12541  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Quote:
Originally Posted by Polcius View Post
Anyone can shed some light? Or some documentation page about MPC-HC?

I just want to know what ticking the "Dynamic Range Control" exactly does, and how does it interfere with soundcard settings.
Sorry, most team members do not believe in post-processing and cannot answer your questions.
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline  
Old 20th April 2010, 06:20   #12542  |  Link
iron2000
Questioning User
 
Join Date: Jan 2005
Posts: 163
Will there be a fix soon for QT and Real compatibility with EVR Sync?
__________________
8 Pro x64 | i5-3470 | 8GB ram | GT430 | Xonar DX | MPC-HC x86
iron2000 is offline  
Old 20th April 2010, 11:43   #12543  |  Link
hoborg
Registered User
 
Join Date: Nov 2008
Posts: 454
Quote:
Originally Posted by hoborg View Post
Hi.
Is there plan to update MP4 splitter to support this sample ?

It is working with Haali, but only black screen using "MP4Splitter.ax".
Please alow me return to this problem.
This is little mystery to me, i am not sure where the problems can be.

If you play this sample in latest builds on MPC-HC, it will play normaly, but only if DXVA is off - you will have only black screen when using DXVA, but audio is OK and play.

some tests:
MP4Splitter.ax + MPC video decoder/FFDshow DXVA decoder (DXVA on) - Black screen
MP4Splitter.ax + MPC video decoder/FFDshow decoder (DXVA off) - working fine
Haali splitter + MPC video decoder/FFDshow DXVA decoder (DXVA on) - working fine
Haali splitter + MPC video decoder/FFDshow decoder (DXVA off) - working fine

Few MPC-HC version ago, it doesnot work even with DXVA off.

So, where the problem have roots, it is splitter or decoder problem?
__________________
Working machine: Win10x64 + Intel Skull Canyon
My HTPC.

How to start with Bitcoin
hoborg is offline  
Old 20th April 2010, 12:13   #12544  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Quote:
Originally Posted by iron2000 View Post
Will there be a fix soon for QT and Real compatibility with EVR Sync?
We have some ideas here but nothing concrete.

Quote:
Originally Posted by hoborg View Post
Please alow me return to this problem.
This is little mystery to me, i am not sure where the problems can be.

If you play this sample in latest builds on MPC-HC, it will play normaly, but only if DXVA is off - you will have only black screen when using DXVA, but audio is OK and play.

some tests:
MP4Splitter.ax + MPC video decoder/FFDshow DXVA decoder (DXVA on) - Black screen
MP4Splitter.ax + MPC video decoder/FFDshow decoder (DXVA off) - working fine
Haali splitter + MPC video decoder/FFDshow DXVA decoder (DXVA on) - working fine
Haali splitter + MPC video decoder/FFDshow decoder (DXVA off) - working fine

Few MPC-HC version ago, it doesnot work even with DXVA off.

So, where the problem have roots, it is splitter or decoder problem?
Does it also have a black screen if you mux it to mkv? If not then you can report the bug to bento4 http://bento4.sourceforge.net/
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline  
Old 20th April 2010, 12:18   #12545  |  Link
hoborg
Registered User
 
Join Date: Nov 2008
Posts: 454
Quote:
Originally Posted by tetsuo55 View Post

Does it also have a black screen if you mux it to mkv? If not then you can report the bug to bento4 http://bento4.sourceforge.net/
Yes, MKV works, and i already report that to bento4.
But i am not sure this is really splitter bug, becouse it woks if DXVA is off.
__________________
Working machine: Win10x64 + Intel Skull Canyon
My HTPC.

How to start with Bitcoin
hoborg is offline  
Old 20th April 2010, 12:22   #12546  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
You can open a ticket on the mpc-hc tracker, and mention that you reported it upstream but that it only affects dxva so it might be a problem in mpc-hc's dxva decoder.
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline  
Old 20th April 2010, 12:31   #12547  |  Link
hoborg
Registered User
 
Join Date: Nov 2008
Posts: 454
Quote:
Originally Posted by tetsuo55 View Post
You can open a ticket on the mpc-hc tracker, and mention that you reported it upstream but that it only affects dxva so it might be a problem in mpc-hc's dxva decoder.
I think it already exist here:
http://sourceforge.net/apps/trac/mpc-hc/ticket/24
__________________
Working machine: Win10x64 + Intel Skull Canyon
My HTPC.

How to start with Bitcoin
hoborg is offline  
Old 20th April 2010, 12:33   #12548  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Add the information from and link to the bento4 ticket then.
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline  
Old 20th April 2010, 12:39   #12549  |  Link
hoborg
Registered User
 
Join Date: Nov 2008
Posts: 454
Quote:
Originally Posted by tetsuo55 View Post
Add the information from and link to the bento4 ticket then.
Already done:
http://zebulon.bok.net/trac/Bento4/ticket/9
__________________
Working machine: Win10x64 + Intel Skull Canyon
My HTPC.

How to start with Bitcoin
hoborg is offline  
Old 20th April 2010, 13:05   #12550  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Add the link to that ticket to http://sourceforge.net/apps/trac/mpc-hc/ticket/24
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline  
Old 20th April 2010, 13:17   #12551  |  Link
hoborg
Registered User
 
Join Date: Nov 2008
Posts: 454
Quote:
Originally Posted by tetsuo55 View Post
Done...
__________________
Working machine: Win10x64 + Intel Skull Canyon
My HTPC.

How to start with Bitcoin
hoborg is offline  
Old 20th April 2010, 15:54   #12552  |  Link
XhmikosR
Registered User
 
Join Date: Mar 2007
Location: Hellas (Greece)
Posts: 543
Quote:
Originally Posted by Aleksoid1978 View Post
I can compile MPC-HC with VS2010, but ... it's not stable and has bug in GUI(like without themes support).
Even after yesterday's commits I still cannot compile mpc-hc with MSVC 2010 successfully. I'm getting the following errors when linking mpc-hc:

Quote:
Error 62 error LNK2019: unresolved external symbol __imp____lc_codepage referenced in function _wcsrtombs C:\Users\USER\Desktop\mpc-hc\src\apps\mplayerc\MPCVideoDecRU.lib(wcrtomb.o) mpc-hc
Error 63 error LNK2001: unresolved external symbol __imp____lc_codepage C:\Users\USER\Desktop\mpc-hc\src\apps\mplayerc\MPCVideoDecRU.lib(mbrtowc.o) mpc-hc
https://sourceforge.net/apps/trac/mp.../153#comment:9

Can you describe how exactly you solved these errors?
__________________
My Specs

Last edited by XhmikosR; 20th April 2010 at 15:58. Reason: typo
XhmikosR is offline  
Old 20th April 2010, 19:47   #12553  |  Link
gngn
the hedgehog
 
gngn's Avatar
 
Join Date: Apr 2008
Posts: 163
rev1802 of MPC-HC introduced some seeking-problems with DXVA on and H264 files that have b_pyramid=2 (and "b-pyramid=normal" is now default in x264 since r1455 Feb 21 2010)
when seeking the image freezes (but sound continues, even the video-playback time goes on). after a few seconds showing that frozen frame playback will start, first very jerky, until it becomes normal.

problem is more pregnant with HaaliSplitter then with the internal matroska splitter.
__________________
Athlonx2@2,9Ghz,2G DDRAM2@800Mhz,WinXPSP3 x86,GF8600GTS-256M,Nvidiadrivers 295.73
latest MPC-HC (MVS2010 SP1, GCC 4.7.1)
VMR9renderless+VMR9MixerMode+YUVMixing,VSync+AccurateVSync,all GPUflushes on

Last edited by gngn; 20th April 2010 at 20:01. Reason: added details
gngn is offline  
Old 21st April 2010, 01:05   #12554  |  Link
torpedo
Registered User
 
Join Date: Aug 2009
Posts: 18
@clsid:
The SSE optimization of ffMpeg compilation has been deprecated since svn 1792. The current optimization option is MMX. Why the optimization option was reverted to MMX?
torpedo is offline  
Old 21st April 2010, 01:32   #12555  |  Link
Superb
Registered User
 
Join Date: Feb 2010
Posts: 364
Quote:
Originally Posted by XhmikosR View Post
Even after yesterday's commits I still cannot compile mpc-hc with MSVC 2010 successfully. I'm getting the following errors when linking mpc-hc:


https://sourceforge.net/apps/trac/mp.../153#comment:9

Can you describe how exactly you solved these errors?
http://forum.doom9.org/showthread.ph...08#post1339108
http://forum.doom9.org/showthread.ph...54#post1339154

mingwex points to a removed variable (Microsoft removed it in VS2010).
Superb is offline  
Old 21st April 2010, 05:21   #12556  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 1,873
Quote:
Originally Posted by XhmikosR View Post
Even after yesterday's commits I still cannot compile mpc-hc with MSVC 2010 successfully. I'm getting the following errors when linking mpc-hc:


https://sourceforge.net/apps/trac/mp.../153#comment:9

Can you describe how exactly you solved these errors?
Try this libmingwex.a - http://aleksoid.tosei.ru/Dist/lib/libmingwex.7z
__________________
I7 2600K@4.2 /Asrock P67 Extreme4 Gen 3 /Kingston HyperX 8Gb 1866 (4x2) Kit /OCZ Vertex 3 256Gb /Gigabyte GTX 960 /BenQ EW2430 /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline  
Old 21st April 2010, 05:40   #12557  |  Link
Superb
Registered User
 
Join Date: Feb 2010
Posts: 364
@Aleksoid1978: did you simply remove this symbol from the lib itself? or did you compile a new, fixed mingwex lib (which doesn't import this deprecated/removed variable)?
Superb is offline  
Old 21st April 2010, 06:02   #12558  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 1,873
Quote:
Originally Posted by Superb View Post
@Aleksoid1978: did you simply remove this symbol from the lib itself? or did you compile a new, fixed mingwex lib (which doesn't import this deprecated/removed variable)?
Just remove ... as here - http://ffmpeg.arrozcru.org/forum/vie....php?f=1&t=891
__________________
I7 2600K@4.2 /Asrock P67 Extreme4 Gen 3 /Kingston HyperX 8Gb 1866 (4x2) Kit /OCZ Vertex 3 256Gb /Gigabyte GTX 960 /BenQ EW2430 /LG 47LM620T /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline  
Old 21st April 2010, 06:37   #12559  |  Link
_xxl
ffdshow user
 
_xxl's Avatar
 
Join Date: Oct 2005
Location: Romania
Posts: 818
Quote:
The SSE optimization of ffMpeg compilation has been deprecated since svn 1792. The current optimization option is MMX. Why the optimization option was reverted to MMX?
FFmpeg has hand written optimizations and doesn't need any forced SSE optimizations, will just make ffmpeg slower, that was proven years ago.
_xxl is offline  
Old 21st April 2010, 07:41   #12560  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Quote:
Originally Posted by _xxl View Post
FFmpeg has hand written optimizations and doesn't need any forced SSE optimizations, will just make ffmpeg slower, that was proven years ago.
that proof is no longer valid and will have to be re-tested.
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline  
Closed Thread

Tags
dxva, h264, home cinema, media player classic, mpc-hc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:13.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.