Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 18th November 2009, 14:47   #10521  |  Link
snyders6dogrecipe
Registered User
 
Join Date: Nov 2009
Posts: 25
Quote:
Originally Posted by nurbs View Post
Those pictures are also identical.
I tried it one more time, and the 2 indeed had the exact same filesize. I guess it's something that can only be noticed in motion.
snyders6dogrecipe is offline  
Old 18th November 2009, 15:57   #10522  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Quote:
Originally Posted by snyders6dogrecipe View Post
I tried it one more time, and the 2 indeed had the exact same filesize. I guess it's something that can only be noticed in motion.
see this: http://sourceforge.net/apps/trac/mpc-hc/ticket/110
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline  
Old 18th November 2009, 16:01   #10523  |  Link
hdboy
Registered User
 
Join Date: Jan 2007
Posts: 130
Quote:
Originally Posted by tetsuo55 View Post
lock-back buffer was replaced with the GPU flush options that you can find in the rightclick menu > renderer settings
so what would be the equivalent of enabling lock back buffer in the new version? I think that may help snyders6dogrecipe.

otherwise, snyders6dogrecipe, maybe you can just try all different combinations of the GPU control options.
hdboy is offline  
Old 18th November 2009, 18:54   #10524  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Quote:
Originally Posted by hdboy View Post
so what would be the equivalent of enabling lock back buffer in the new version? I think that may help snyders6dogrecipe.

otherwise, snyders6dogrecipe, maybe you can just try all different combinations of the GPU control options.
i have no idea
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline  
Old 18th November 2009, 21:23   #10525  |  Link
73ChargerFan
Registered User
 
73ChargerFan's Avatar
 
Join Date: Dec 2006
Posts: 506
Quote:
Originally Posted by snyders6dogrecipe View Post
I wish I could be more helpful with this.
Then describe your system, and what you're watching on? Perhaps you are seeing flickering, like on CRT monitors at 60Hz under fluorescent lights?
73ChargerFan is offline  
Old 18th November 2009, 21:23   #10526  |  Link
hoborg
Registered User
 
Join Date: Nov 2008
Posts: 454
Is there a plan to add support for BlueRay S_HDMV/PGS subtitles?

MKV sample
__________________
Working machine: Win10x64 + Intel Skull Canyon
My HTPC.

How to start with Bitcoin

Last edited by hoborg; 18th November 2009 at 21:27.
hoborg is offline  
Old 18th November 2009, 21:25   #10527  |  Link
73ChargerFan
Registered User
 
73ChargerFan's Avatar
 
Join Date: Dec 2006
Posts: 506
RE Identical Images - Hurting eyes sounds like flashing or frequency, not one image looking better. That is, the display logic, not decoding.
73ChargerFan is offline  
Old 18th November 2009, 21:26   #10528  |  Link
hoborg
Registered User
 
Join Date: Nov 2008
Posts: 454
Double post...
__________________
Working machine: Win10x64 + Intel Skull Canyon
My HTPC.

How to start with Bitcoin
hoborg is offline  
Old 18th November 2009, 22:59   #10529  |  Link
hdboy
Registered User
 
Join Date: Jan 2007
Posts: 130
Quote:
Originally Posted by sharangad View Post
There're two different 8400 GSs. One is the original G86 based version and the other is the G98 based version which is identical in performance to the desktop 9400 mobo GPU (except for lack of audio).

G98 based 8400 GS supports VC-1 and MPEG-2 bitstream ( and iDCT ) modes as well as H.264 FGT and non-FGT modes.

G86 only supports iDCT and earlier modes for VC-1 and WMV as well as bitstream for H.264.

You can tell them apart from the clock speeds.
I'm looking at either a 9600gt or 9800gt. does either of those support bitstream for all vc1/avc/wmv? this info is surprisingly hard to find.
hdboy is offline  
Old 19th November 2009, 02:19   #10530  |  Link
Snowknight26
Registered User
 
Join Date: Aug 2007
Posts: 1,381
Quote:
Originally Posted by hdboy View Post
this info is surprisingly hard to find.
Not really. A Wikipedia search for PureVideo does the job.

I'm pretty sure that VP2 GPUs can only do H.264 in MPC-HC, while VP3+ can do all VC-1 and H.264. MPEG-2 doesn't get hardware acceleration with MPC-HC's internal filters, so I can't comment on how other decoders such as the CyberLink ones handle MPEG-2 on VP1-4.
Snowknight26 is online now  
Old 19th November 2009, 02:40   #10531  |  Link
cc979
Curious BetaTester
 
Join Date: Oct 2005
Posts: 430
@snyders6dogrecipe them images are md5 identical, your eye-strain maybe due to refresh-rates, monitor or lcd ?
__________________
Asrock N68-S AMD Athlon(tm) II X4 620 Processor (2.6GHz) - Crucial 2GB PC6400 800MHz DDR2 - Nvidia 9600GT

Tools: ProcessExplorer & ProcessMonitor - BatchCompressor

Guide: MinGW Compiling GCC
cc979 is offline  
Old 19th November 2009, 03:35   #10532  |  Link
snyders6dogrecipe
Registered User
 
Join Date: Nov 2009
Posts: 25
I have an Alienware m9750 laptop, with dual 2.0 gz processor and nvidia 8700m gt. I also use a 1080p projector in the dark, and the effect is the same while using v1.3.1249. Any combination of the right-click->renderer settings doesn't fix the problem without introducing tearing. Any chance the "lock backbuffer" option could be made available again in the future?
snyders6dogrecipe is offline  
Old 19th November 2009, 08:37   #10533  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Quote:
Originally Posted by snyders6dogrecipe View Post
I have an Alienware m9750 laptop, with dual 2.0 gz processor and nvidia 8700m gt. I also use a 1080p projector in the dark, and the effect is the same while using v1.3.1249. Any combination of the right-click->renderer settings doesn't fix the problem without introducing tearing. Any chance the "lock backbuffer" option could be made available again in the future?
i have asked you 2 times to confirm if the description in bug 110 matches your issue.
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline  
Old 19th November 2009, 09:19   #10534  |  Link
snyders6dogrecipe
Registered User
 
Join Date: Nov 2009
Posts: 25
Here it is:
Quote:
Originally Posted by snyders6dogrecipe View Post
Unfortunately, my issue doesn't match that bug report because it doesn't change anything when I turn off VMR mixer mode. I think my issue is just related to the new syncing methods introduced in this build.

Could you please tell me what it means to "wait for flushes"?
snyders6dogrecipe is offline  
Old 19th November 2009, 09:32   #10535  |  Link
Darkvater
Registered User
 
Join Date: Nov 2001
Posts: 17
Quote:
Originally Posted by clsid View Post
The build made by alexins require v42 of the DLL.
Since v42 the DLL has been split into two files, so you need an additional file as well, D3DCompiler_42.dll if I remember correctly.
I just downloaded version 1.3.1249 for Windows7 final and using the "System Default" renderer I get horribly blocky scaled video (on fullscreen). I tried setting it to WMR9 renderless, but MPC complains about d3dx9.dll missing, no matter if I use the x86 or x64 version. I did not have this problem in Windows7 RC1 which I used so far.

What is the proper way to solve this? I downloaded the Directx SDK and copied d3dx9_41.dll to the MPC directory, that enabled WMR9 renderless but seemingly half the picture is cut off (see attachment)?? EVR Custom Pres is okay, but searching is slow.

Currently I set output to EVR (Vista/.NET3), doesn't need d3d9x.dll, don't know if this has any issues? However, the default setting is wrong.
Attached Images
  
Darkvater is offline  
Old 19th November 2009, 10:09   #10536  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Quote:
Originally Posted by snyders6dogrecipe View Post
Here it is:
sorry i missed that.

Flush GPU before VSync
forces the GPU to render the frame as soon as possible so the frame will be ready to be presented at the VSync

Flush GPU after Present
forces the driver to actualize the Present as soon as possible

Wait for flushes
This will cause the renderer to spin, waiting for the GPU flushes

Can you try using 2d surfaces instead of 3d ones.
Also can you confirm that you have the latest DX installed?(did you update everything as instructed?)
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline  
Old 19th November 2009, 10:37   #10537  |  Link
snyders6dogrecipe
Registered User
 
Join Date: Nov 2009
Posts: 25
Is there a page that guides people on how to compile MPC-HC? I downloaded the GNU sourcecode tarball, and I'm trying to compile mpc-hc_vs2005.sln in the \mpc-hc\tags\release_v1_2_908_0 folder (after I overwrote the dxva-related files with the ones from the release_v1_3_1249_0 folder), but I get 239 errors when I try to build it :P

Last edited by snyders6dogrecipe; 19th November 2009 at 10:40.
snyders6dogrecipe is offline  
Old 19th November 2009, 10:49   #10538  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Quote:
Originally Posted by snyders6dogrecipe View Post
Is there a page that guides people on how to compile MPC-HC? I downloaded the GNU sourcecode tarball, and I'm trying to compile mpc-hc_vs2005.sln in the \mpc-hc\tags\release_v1_2_908_0 folder (after I overwrote the dxva-related files with the ones from the release_v1_3_1249_0 folder), but I get 239 errors when I try to build it :P
The correct solution would be finding and fixing the problem you encounter, as you are probably not the only one suffering from this issue.

Compiling instructions can be found here:
http://sourceforge.net/apps/trac/mpc...ompile_the_MPC

Can you tell us which combination of settings causes the problem to disappear? (but introduces tearing)

Dit you try to reset the renderer settings to defaults
and then reset to optimal settings?
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC

Last edited by tetsuo55; 19th November 2009 at 10:52.
tetsuo55 is offline  
Old 19th November 2009, 10:54   #10539  |  Link
Leak
ffdshow/AviSynth wrangler
 
Leak's Avatar
 
Join Date: Feb 2003
Location: Austria
Posts: 2,441
Quote:
Originally Posted by Darkvater View Post
What is the proper way to solve this? I downloaded the Directx SDK and copied d3dx9_41.dll to the MPC directory, that enabled WMR9 renderless but seemingly half the picture is cut off (see attachment)?? EVR Custom Pres is okay, but searching is slow.
The proper way to fix this is once and for all is to install the DirectX runtime - yes, even under Windows 7, since it doesn't come with any recent version of DirectX 9 either.
__________________
now playing: [artist] - [track] ([album])
Leak is offline  
Old 19th November 2009, 11:16   #10540  |  Link
snyders6dogrecipe
Registered User
 
Join Date: Nov 2009
Posts: 25
Thank you. I did install the latest DX, and with 2D on it is still the same.
snyders6dogrecipe is offline  
Closed Thread

Tags
dxva, h264, home cinema, media player classic, mpc-hc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 22:18.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.