Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 10th July 2009, 16:04   #8541  |  Link
Jong
Registered User
 
Join Date: Mar 2007
Location: London, UK
Posts: 574
I'm using DXVA with the Cyberlink decoder
Jong is offline  
Old 10th July 2009, 17:59   #8542  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
Jong - can you post the filters that MPC-HC is using to decode the DVD? Thus far, subs and menu highlighting only work for me with the Cyberlink decoder if I explicitly disable DXVA. With DXVA enabled, I can use the menus but there is no highlighting and subs don't show up. I'm beginning to think this might be some sort of version incompatibility, because so far no combination of external MPEG-2 filter and renderer works to get both DXVA and subs. Are you using the decoder from PowerDVD 9?
Inspector.Gadget is offline  
Old 10th July 2009, 19:18   #8543  |  Link
Jong
Registered User
 
Join Date: Mar 2007
Location: London, UK
Posts: 574
I have used both 7 & 8 in my time (don't have 9). Currently using 7. I definitely have no issue with menus & VMR9 (on XP SP3). EVR however does not show menu highlighting. I thought that had nothing to do with MPEG2 decoder, but now you have me thinking!

I will try to publish the filter list by tomorrow.
Jong is offline  
Old 10th July 2009, 19:27   #8544  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
Thank you for your help. I'd love to get this all working now that I'm renting a lot of foreign-language DVDs where I need the subs.
Inspector.Gadget is offline  
Old 10th July 2009, 19:36   #8545  |  Link
Jong
Registered User
 
Join Date: Mar 2007
Location: London, UK
Posts: 574
Are you using XP or Vista? If XP you are using VMR9 renderless, aren't you?
Jong is offline  
Old 10th July 2009, 19:43   #8546  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
I'm on Vista SP2 x64. I use EVR Custom by default, but I've tried various combinations of decoders and renderers including VMR9 Renderless and I still can't get both DXVA and subtitles working at the same time.
Inspector.Gadget is offline  
Old 10th July 2009, 19:48   #8547  |  Link
Jong
Registered User
 
Join Date: Mar 2007
Location: London, UK
Posts: 574
Ah well my info may not be much use then.

As you probably know from the DXVA Support page, on Vista you have to use EVR CP. With EVR CP I get no menu highlighting, which may or may not be related to Cyberlink (I will test tomorrow). I do have a Vista 32 system, not a Vista 64 system, but I have not got Cyberlink on that system. I wil try to install the Cyberlink codec on Vista over the weekend and see how it goes!
Jong is offline  
Old 10th July 2009, 23:24   #8548  |  Link
Jong
Registered User
 
Join Date: Mar 2007
Location: London, UK
Posts: 574
Here are my fillters, but as I say this is XP SP3.



Jong is offline  
Old 11th July 2009, 00:00   #8549  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
Thank you, Jong. I'll see if any online retailers are still selling PDVD7 and see if I can use that decoder within Directshow. Since I have the same problem with Microsoft's MPEG-2 decoder and the Arcsoft one, I doubt that will help. Thank you for the info though.
Inspector.Gadget is offline  
Old 11th July 2009, 01:02   #8550  |  Link
ar-jar
Registered User
 
Join Date: Mar 2009
Location: Vreta kloster, Sweden
Posts: 332
Building MPC with the latest DirectX SDK?

Is it possible to build the latest svn revision of MPC with the latest DirectX SDK? I get a lot of errors indicating missing include files (and perhaps missing libraries as well when I come that far). Any hints anybody? Thanks! -A
ar-jar is offline  
Old 11th July 2009, 01:07   #8551  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
Quote:
Originally Posted by Sina™ View Post
what do you think about this?:
As near as I can tell you aren't using any subs
Inspector.Gadget is offline  
Old 11th July 2009, 02:16   #8552  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
But you're not using DXVA in that shot, as far as I can tell. That's what I'm trying to do: get both DXVA and subtitles from MPC-HC's internal subtitle renderer when playing a DVD using any of the Microsoft/Cyberlink/Arcsoft decoders.
Inspector.Gadget is offline  
Old 11th July 2009, 03:05   #8553  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
Thanks, but KMPlayer isn't going to do me any good if it can't do subs and DXVA simultaneously. I can already do one-or-the-other as it is.
Inspector.Gadget is offline  
Old 11th July 2009, 03:46   #8554  |  Link
kumi
Straight to video
 
kumi's Avatar
 
Join Date: Jun 2005
Posts: 637
Quote:
Originally Posted by Inspector.Gadget View Post
it can't do subs and DXVA simultaneously.
Do you want DXVA decoding, or deinterlacing, or what? The MPC-HC internal subtitle engine works fine for me with DXVA deinterlacing (using the ffdshow Video Decoder). Using EVR Custom on Windows XP.
__________________
.
kumi is offline  
Old 11th July 2009, 04:10   #8555  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
ffdshow doesn't do DXVA. I want DXVA decoding with any external decoder (Microsoft, Cyberlink, Arcsoft) plus the display of DVD subs using MPC-HC's internal subtitle renderer. Maybe it can't be done, but I'd like to get a definitive answer.
Inspector.Gadget is offline  
Old 11th July 2009, 04:37   #8556  |  Link
73ChargerFan
Registered User
 
73ChargerFan's Avatar
 
Join Date: Dec 2006
Posts: 506
Quote:
Originally Posted by 73ChargerFan View Post
Can someone tell me the registry key to activate D3D Fullscreen GUI support ???

I can't find a way to activate it, because the popup menu item is disabled unless you are playing a video in D3D fullscreen, but then you can't see the popup menu!
Quote:
Originally Posted by Leak View Post
Errr... at least for VMR9 it's selectable as long as a video is opened. No need for the player to be in Direct3D fullscreen...
Thanks Leak... you were right.

It turns out that somehow I had "2d surfaces" selected. Changing to "3d Surfaces" fixed everything, and it now behaves as expected.
73ChargerFan is offline  
Old 11th July 2009, 06:01   #8557  |  Link
boyumeow
Registered User
 
boyumeow's Avatar
 
Join Date: Aug 2007
Posts: 141
Quote:
Originally Posted by ar-jar View Post
Is it possible to build the latest svn revision of MPC with the latest DirectX SDK? I get a lot of errors indicating missing include files (and perhaps missing libraries as well when I come that far). Any hints anybody? Thanks! -A
Would it helps if U install all the directx sdk in the same root folder, like overlapping each one. Thanks.
boyumeow is offline  
Old 11th July 2009, 06:27   #8558  |  Link
ADude
Registered User
 
Join Date: Nov 2007
Posts: 340
Gosh, go away for a couple of days, and people are reinventing the wheel !

The Cyberlink MPEG2 + DXVA + DVD bug is well known and is already in the bug database. It is known for menu highlighting, I am not sure that subtitle aspect was previously known or not, so that may be an additional bit of information.
__________________
s/w: Vista Home Basic 32bit (no Aero), MPC-HC, EVR Custom Presenter, CoreAVC Pro, ffdshow, SPDIFer
h/w: Antec 2480 case, Gigabyte GA-MA69GM-S2H, 4200+, 2.5gb+512mb, ATI x1250 IGP, MS MCE remote
ADude is offline  
Old 11th July 2009, 07:53   #8559  |  Link
ar-jar
Registered User
 
Join Date: Mar 2009
Location: Vreta kloster, Sweden
Posts: 332
Quote:
Originally Posted by boyumeow View Post
Would it helps if U install all the directx sdk in the same root folder, like overlapping each one. Thanks.
Not sure what would happen then. At least it would be an "unclean" build as it would be based on two versions of the SDK that wouldn't necessarily be compatible and could indeed be in conflict. Hopefully some experienced MPC dev makes the effort to bring everything up to date (if there isn't a magic trick that I haven't discovered). -A
ar-jar is offline  
Old 11th July 2009, 08:26   #8560  |  Link
Jong
Registered User
 
Join Date: Mar 2007
Location: London, UK
Posts: 574
Quote:
Originally Posted by ADude View Post
Gosh, go away for a couple of days, and people are reinventing the wheel !

The Cyberlink MPEG2 + DXVA + DVD bug is well known and is already in the bug database. It is known for menu highlighting, I am not sure that subtitle aspect was previously known or not, so that may be an additional bit of information.
It did not mention the subtitle problem I have added it.

It was unclear if it affected just Cyberlink or all MPEG2 decoders in DXVA mode. I can confirm IG's comment it also affects the MS decoder.

It also suggested it affects all Windows versions, but XP SP3 definitely works fine here (with VMR9 renderless).

Quote:
Originally Posted by Inspector.Gadget View Post
Thank you, Jong. I'll see if any online retailers are still selling PDVD7 and see if I can use that decoder within Directshow. Since I have the same problem with Microsoft's MPEG-2 decoder and the Arcsoft one, I doubt that will help. Thank you for the info though.
I don't think PDVD7 will help, although I have not tested it. It does seem to affect all DXVA MPEG2 decoders on Vista (EVR CP).

if you look in the bug tracker though you will see you can get it to work by regressing to an earlier version. Maybe you can use one version for DVDs and one for other things?

Also, unless you are right up against it on CPU (and your PC would have to be very old) Kumi's suggestion of DXVA deinterlacing and ffdshow decoding sounds pretty good. DXVA deinterlacing is why I use the Cyberlink decoder.

Last edited by Jong; 11th July 2009 at 10:38.
Jong is offline  
Closed Thread

Tags
dxva, h264, home cinema, media player classic, mpc-hc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 10:42.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.