Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-2 Encoding

Reply
 
Thread Tools Search this Thread Display Modes
Old 17th November 2004, 11:38   #81  |  Link
Peter Cheat
Just a Member
 
Join Date: Aug 2004
Location: Australia
Posts: 225
Yeah, that was a paranoid check. I removed "bEncodeDlg->EnableWindow()" now. And your fix wasn't "quick and dirty". It sets the control back to default. Nothing dirty about that . I tried to make it "smooth", but that really doesn't matter...

I've updated here. If someone can confirm that this one now works when 0.01a didn't that would be good. CQ mode is now vbv compliant (report buffer underflows if they occur).
__________________
If you want it done properly, do it yourself!
Modified Libavcodec Site

Last edited by Peter Cheat; 17th November 2004 at 11:52.
Peter Cheat is offline   Reply With Quote
Old 17th November 2004, 12:19   #82  |  Link
freelock7
High beam
 
freelock7's Avatar
 
Join Date: Apr 2004
Location: Belgium
Posts: 290
First (quick) results (from Dragongodz link):
-the average don't work in 1Pass.
-In 2Pass, it's ok but quality could be better(low bitrate).
-very slow

(from Peter link):
Same results

Last edited by freelock7; 17th November 2004 at 12:32.
freelock7 is offline   Reply With Quote
Old 17th November 2004, 12:34   #83  |  Link
Peter Cheat
Just a Member
 
Join Date: Aug 2004
Location: Australia
Posts: 225
1 pass VBR is broken. I intend to replace it with CQ, targetting a bitrate doesn't work well.

What settings are you using (thats probably what is making it slow).

At least it works, so I can make the release official.
__________________
If you want it done properly, do it yourself!
Modified Libavcodec Site
Peter Cheat is offline   Reply With Quote
Old 17th November 2004, 12:42   #84  |  Link
freelock7
High beam
 
freelock7's Avatar
 
Join Date: Apr 2004
Location: Belgium
Posts: 290
VBR:2600(2Pass)_KVCD Notch
Turbo:on
interlaced
scene detection
treillis:on
LeastBits
SATD
DIAMOND3(1)
first pass:7.5fps-SecondPass:3.5fps
(1)Not tested other <motion search> options.
Follow up Tomorrow.
freelock7 is offline   Reply With Quote
Old 17th November 2004, 12:51   #85  |  Link
Peter Cheat
Just a Member
 
Join Date: Aug 2004
Location: Australia
Posts: 225
They are slow settings try:

VBR:2600(2Pass)_KVCD Notch
Turbo on
interlaced
scene detection
trellis off
Comp. Fn.
SAD
Adaptive6

I use this and get ~25fps for SVCD and ~15fps for DVD. Depends on your AviSynth script though. I find that trellis is no good for low bitrate, and that Adaptive search is better (because it is so much faster).
__________________
If you want it done properly, do it yourself!
Modified Libavcodec Site
Peter Cheat is offline   Reply With Quote
Old 17th November 2004, 17:15   #86  |  Link
Peter1234
Registered User
 
Join Date: Aug 2004
Posts: 130
Peter Cheat,
Version 0.01a did not work for me, but your version 0.01b and dragongodz version do work. With only Mpeg2Source as script I am getting about 30 fps indicated for pass 1 and 2 in 2 pass VBR for 2000 kbps. I have not done any testing other than to check that it works. I am using XP SP1 on 3 GHz P4 with SSE2.
Peter1234 is offline   Reply With Quote
Old 17th November 2004, 21:33   #87  |  Link
Fl0ppy
Registered User
 
Join Date: May 2002
Posts: 26
I'm trying to download the last file but host.sk send me: error 404 file not found.
And other thing, if i try to add a matrix in external file, the quality it's worst.
But if i edit the ini file and i add it, the quality it's superb.
Fl0ppy is offline   Reply With Quote
Old 18th November 2004, 09:38   #88  |  Link
Peter Cheat
Just a Member
 
Join Date: Aug 2004
Location: Australia
Posts: 225
@Fl0ppy
Make sure the file is in XviD format. A simple text file doesn't work, which is why I also added the ini file for easy usage (for n00bs like me who can't be bothered converting to some format, copy&paste is much easier ). Btw, the link does work, host.sk sometimes gets a bit bogged down.

@Peter1234
Thanks for confirming. Hopefully there will be less problems/complaints now .
__________________
If you want it done properly, do it yourself!
Modified Libavcodec Site
Peter Cheat is offline   Reply With Quote
Old 18th November 2004, 11:02   #89  |  Link
lanius
Registered User
 
Join Date: Dec 2003
Posts: 5
The download from this file doesn't work
NuEnc 0.01b based on QuEnc

all other files works
lanius is offline   Reply With Quote
Old 18th November 2004, 11:14   #90  |  Link
Peter1234
Registered User
 
Join Date: Aug 2004
Posts: 130
Peter Cheat,
I have been experimenting with version 0.01b and everything seemed to be working until I tried an xvid matrix. I was able to load the matrix and the program seemed to use it and generated a good output file. I closed the program while testing the output file and now the program will not open. I have reloaded the registry settings you posted but it still will not open. I would like to clean the registry entries but I do not know where to find them. Can you tell me where they are located (and if possible, what changes I should make). Thanks.

EDIT 1: I found the registry entry and deleted the data for m_csCustom. Program will now open but I do not think I will try an xvid matrix again.

EDIT 2: Program is running, but I noticed that selecting an ini matrix from the pull down box does not enter a value in REG_SZ. It still says (value not set) from when I erased the entry. Shouldn't it enter a value for the selected matrix?

Last edited by Peter1234; 18th November 2004 at 11:56.
Peter1234 is offline   Reply With Quote
Old 18th November 2004, 11:47   #91  |  Link
Peter Cheat
Just a Member
 
Join Date: Aug 2004
Location: Australia
Posts: 225
Here is a mirror. You'll have to go to http://members.lycos.co.uk/petercheat/ first, then add nuenc0.01b.zip to the url. I'm still looking for free reliable webspace.

@Peter1234
This is odd. I've use XviD matrices without any problems. I followed this procedure.
- Opened NuEnc
- Clicked on advanced button and selected matrix from file, then found an xvid matrix
- Encoded a trailer 2-pass VBR
- Closed NuEnc
- Reopened NuEnc (no problem opening it)

Are you doing anthing different?

The Xvid matrix code was taken from Nic. I hope its not another problem with the controls I used .
__________________
If you want it done properly, do it yourself!
Modified Libavcodec Site
Peter Cheat is offline   Reply With Quote
Old 18th November 2004, 11:57   #92  |  Link
Peter1234
Registered User
 
Join Date: Aug 2004
Posts: 130
We were typing at same time. Please see my above edit.
Peter1234 is offline   Reply With Quote
Old 18th November 2004, 12:13   #93  |  Link
Peter Cheat
Just a Member
 
Join Date: Aug 2004
Location: Australia
Posts: 225
m_nMatNum <- stores matrix selected from ini.
m_csCustomMatrixFile <- stores a custom matrix from file

m_csCustomMatrixFile is chosen if m_nMatNum points to the last entry (From File...)
__________________
If you want it done properly, do it yourself!
Modified Libavcodec Site
Peter Cheat is offline   Reply With Quote
Old 18th November 2004, 12:17   #94  |  Link
Peter1234
Registered User
 
Join Date: Aug 2004
Posts: 130
Peter Cheat,
I am using a matrix that worked in QuEnc 0.56. I tried again. I selected the xvid matrix and ran the program and I got an output file. I am using CQ mode. I closed program and it will not re-open. But, there may be a regristry problem now because the address for the xvid matrix did not get entered in m_csCustom this time and program will still not open.
Peter1234 is offline   Reply With Quote
Old 18th November 2004, 12:24   #95  |  Link
Peter1234
Registered User
 
Join Date: Aug 2004
Posts: 130
Peter Cheat,
m_nMatNum is 0x0000000(0) and m_csCustom is empty. Should I remove and reinstall NuEnc 0.01b?
Peter1234 is offline   Reply With Quote
Old 18th November 2004, 12:40   #96  |  Link
Peter Cheat
Just a Member
 
Join Date: Aug 2004
Location: Australia
Posts: 225
Initially there are no keys when NuEnc isrun for the first time. You can't really uninstall it, you could try deleting ALL the keys relating to NuEnc. But I doubt this will solve the problem.

m_nMatNum is 0 and m_csCustomMatrixFile is empty, NuEnc should load without problems, selecting the default matrix (I've tried it and no problems opening it).

If m_csCustomMatrixFile and m_nMatNum are not being written to registry, then NuEnc might not be closing properly (crashing). Is the output file ok (not blocky)?
__________________
If you want it done properly, do it yourself!
Modified Libavcodec Site
Peter Cheat is offline   Reply With Quote
Old 18th November 2004, 12:48   #97  |  Link
Peter1234
Registered User
 
Join Date: Aug 2004
Posts: 130
Peter Cheat,
Output video looked good. I will reinstall backup and wait to see if anyone else has a problem. Before I tried the xvid matrix I did select different ini matrix files and that seemed to worked OK.
Peter1234 is offline   Reply With Quote
Old 18th November 2004, 13:41   #98  |  Link
lanius
Registered User
 
Join Date: Dec 2003
Posts: 5
Thanks !!!!
lanius is offline   Reply With Quote
Old 18th November 2004, 23:17   #99  |  Link
freelock7
High beam
 
freelock7's Avatar
 
Join Date: Apr 2004
Location: Belgium
Posts: 290
Final results of my first test on PC (not read on DVD player yet)
-----------------------------------------------------------------
In VBR-2Pass, at low bitrate, I did not see any real improvement in picture quality compared to the preceding versions even if the choice of the advanced options is much vaster and more pointed.
QuEnc0.54 from Amnon's EasyCD/DVD 0.61 with custom matrix produced the best picture.
But, in CQ (30) NuEnc0.01b produces a great quality with a fast response in high bitrate. Very good surprise and it is very fast!
Disadvantage: one does not know the final size of the video.
Undoubtedly NuEnc 0.1b has a great potential with this new CQ setting.
Great job Peter! You must continue to still make it more powerful!
------------
PS: VBR-1Pass not tested with NuEnc0.01b (cause known).
NuEnc0.00a is the best >4000kbs.

Last edited by freelock7; 19th November 2004 at 08:14.
freelock7 is offline   Reply With Quote
Old 19th November 2004, 02:44   #100  |  Link
evade
Registered User
 
Join Date: Nov 2003
Posts: 97
@Peter Cheat

mencoder is my encoding application of choice on my linux system. would you be so kind as to provide the source for your changed version?

Last edited by evade; 19th November 2004 at 02:57.
evade is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 01:43.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.