Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Development

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 28th June 2020, 17:59   #1  |  Link
hello_hello
Registered User
 
Join Date: Mar 2011
Posts: 4,311
Avisynth+ audio problem. Not a thread for XP-haters

Based on some very quick testing on Win7, this appears to be an XP-only problem. I'm using Avisynth+ 3.5.1 and MPC-HC 1.7.13.

When the script contains audio, opening it with MPC-HC results in the error message below. I'd put it down to running an OS Microsoft doesn't support, and one that was released 4000 years ago etc etc etc etc, but I also get the same error when MPC-HC is auto-loading an external audio file (ie when there's an audio file with the same name as the script in the folder). If I disable MPC-HCs auto-loading of audio files, the problem goes away, so it's not the end of the world, aside from the fact I'm used to extracting the audio and having it play with the script in MPC-HC much of the time, and I have to avoid scripts with audio.

Other formats are fine. ie I can open an MKV with MPC-HC while it's auto-loading external audio without any error.

I haven't done much further investigating but it seems SMPlayer can no longer open the video in scripts, and the AVS input component for foobar2000 no longer works. It's fine with Avisynth 2.6. I haven't had a chance to check SMPlayer with Avisynth 2.6 again.

I've just been replacing Avisynth.dll in the system32 folder, but the other Avisynth+ dlls are loaded via a script when Avisynth+ is running.

Cheers.

Code:
LAV Splitter Source (internal)::Audio
LAV Audio Decoder (internal)::Output
Audio Switcher::Out

Media Type 0:
--------------------------
Audio: PCM 48000Hz stereo 2304kbps

AM_MEDIA_TYPE: 
majortype: MEDIATYPE_Audio {73647561-0000-0010-8000-00AA00389B71}
subtype: MEDIASUBTYPE_PCM {00000001-0000-0010-8000-00AA00389B71}
formattype: FORMAT_WaveFormatEx {05589F81-C356-11CE-BF01-00AA0055595A}
bFixedSizeSamples: 1
bTemporalCompression: 0
lSampleSize: 6
cbFormat: 40

WAVEFORMATEX:
wFormatTag: 0xfffe
nChannels: 2
nSamplesPerSec: 48000
nAvgBytesPerSec: 288000
nBlockAlign: 6
wBitsPerSample: 24
cbSize: 22 (extra bytes)

WAVEFORMATEXTENSIBLE:
wValidBitsPerSample: 24
dwChannelMask: 0x00000003
SubFormat: {00000001-0000-0010-8000-00AA00389B71}

pbFormat:
0000: fe ff 02 00 80 bb 00 00 00 65 04 00 06 00 18 00 ..?...e......
0010: 16 00 18 00 03 00 00 00 01 00 00 00 00 00 10 00 ................
0020: 80 00 00 aa 00 38 9b 71                         ?...8?q


Media Type 1:
--------------------------
Audio: PCM 48000Hz stereo 1536kbps

AM_MEDIA_TYPE: 
majortype: MEDIATYPE_Audio {73647561-0000-0010-8000-00AA00389B71}
subtype: MEDIASUBTYPE_PCM {00000001-0000-0010-8000-00AA00389B71}
formattype: FORMAT_WaveFormatEx {05589F81-C356-11CE-BF01-00AA0055595A}
bFixedSizeSamples: 1
bTemporalCompression: 0
lSampleSize: 4
cbFormat: 18

WAVEFORMATEX:
wFormatTag: 0x0001
nChannels: 2
nSamplesPerSec: 48000
nAvgBytesPerSec: 192000
nBlockAlign: 4
wBitsPerSample: 16
cbSize: 0 (extra bytes)

pbFormat:
0000: 01 00 02 00 80 bb 00 00 00 ee 02 00 04 00 10 00 ....?.........
0010: 00 00                                           ..

Last edited by hello_hello; 28th June 2020 at 18:38.
hello_hello is offline   Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 07:26.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.