Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > IFO/VOB Editors

Reply
 
Thread Tools Search this Thread Display Modes
Old 13th October 2004, 03:49   #1  |  Link
2COOL
PGC Navigator in Training
 
2COOL's Avatar
 
Join Date: Oct 2002
Location: NTSC Land
Posts: 3,552
Turning Subtitles ON by Default v2.0 using PgcEdit

HTML guide hosted by r0lZ.

Disclaimer (not included in guide): Once proposed default subtitle is set to display, you cannot change to another subtitle using the subtitle menu , before or during. The only way to change subtitles during Title play is to use your remote's Subtitle button. This method would work great for movie-only backups though!

Note: You must also set your default subtitle language on your standalone DVD Player.

10/10/2004: This is my 2nd version of my 1st half of my first guide. PgcEdit v.0.3.5 used at this time.
__________________
2COOL

Last edited by 2COOL; 13th October 2004 at 08:04.
2COOL is offline   Reply With Quote
Old 5th January 2005, 13:27   #2  |  Link
CoNS
reMember
 
Join Date: Oct 2004
Location: Under your bed
Posts: 729
Hiya 2COOL,

I have a disc where I wanted to force subpic stream 0 on. I followed your guide v2.0 with PgcEdit, and it works in my software player (Media Player Classic), but it does not work in my standalone SONY?

It's a quite clean-cut case:

The disc is authored in IfoEdit 0.971, it has 1 video stream (NTSC), 1 audio stream and 2 custom made subtitle streams (created with Srt2Sup). After authoring I've used SupRemap to edit the IFO file for the main movie in order to change the first four subtitle colours.

I then wanted to turn the first subtitle stream on by default and followed your guide. As the disc was authored in IfoEdit with the movie only, I didn't have any pre, post or cell commands in the VTST containing the movie. I added the SetSTN command as you described. As I wanted to turn stream 0 on, I followed step 14 a and d in your guide.

In my standalone Sony player, the disc starts playing, but no subtitles are shown. When I press the subtitle button on my remote, it selects stream 1 (the next stream) and displays the subtitles. If I press the button once more the subtitles are turned off (has reached the last stream) and if I press the button once more, stream 0 is displayed and shown correctly.

Weird, huh?
CoNS is offline   Reply With Quote
Old 5th January 2005, 18:50   #3  |  Link
2COOL
PGC Navigator in Training
 
2COOL's Avatar
 
Join Date: Oct 2002
Location: NTSC Land
Posts: 3,552
Quote:
Originally posted by CoNS
I have a disc where I wanted to force subpic stream 0 on. I followed your guide v2.0 with PgcEdit, and it works in my software player (Media Player Classic), but it does not work in my standalone SONY?
Just to confirm...play it in IfoEdit and see that the first subpicture is selected in DVD Play Panel.

I'm not an expert with subtitles but maybe their size don't match your aspect ratio to your movie?
__________________
2COOL
2COOL is offline   Reply With Quote
Old 5th January 2005, 19:56   #4  |  Link
CoNS
reMember
 
Join Date: Oct 2004
Location: Under your bed
Posts: 729
Ok, I've played it in IfoEdit 0.971. The first subtitle IS selected and is also turned on and shows correctly. Just like in Media Player Classic.

As for the sub size/aspect ratio: Well, that's not the problem. The video is NTSC and the subs are created for NTSC video in Srt2Sup. They're vertically aligned at the bottom of the video, but still in the picture.

As I wrote, they show fine and are turned on as they should in the software player. Also, in my standalone Sony, they show fine BUT they're not turned on by default, that's the problem. I have to trigger them with the subtitle button on my remote.
CoNS is offline   Reply With Quote
Old 6th January 2005, 01:13   #5  |  Link
blutach
Country Member
 
blutach's Avatar
 
Join Date: Sep 2004
Location: is everything!
Posts: 6,499
@cons - can you post your IFO PGC commands please (the ones in the title and where the SetSTN is encountered)?

However, my guess is that it's a player thing. Another case of "relucant subtitles", which many Pioneer DV player owners complain about.

Regards
__________________
Les

Only use genuine Verbatim or Taiyo Yuden media.
blutach is offline   Reply With Quote
Old 6th January 2005, 15:21   #6  |  Link
CoNS
reMember
 
Join Date: Oct 2004
Location: Under your bed
Posts: 729
Yep, when I get home from work today I'll post the exact pre command for that PGC. As I write in my initial post, there were no pre, post or cell commands before I added the SetSTN command according to 2COOL's guide.

I think it's a player problem, too. But it's weird that on other DVDs that I play on my Sony, I can go into a subtitle menu (part of the main menu of the disc) and select a subtitle and then press play movie, and the movie starts playing fine with the subtitles right away.

Maybe another command is used in these cases? Could it be that my Sony doesn't recognize or accept this command (stream 0 with 2COOL's guide):



Whereas this one is accepted (stream 1 with 2COOL's guide):



What do you think?
CoNS is offline   Reply With Quote
Old 6th January 2005, 16:15   #7  |  Link
r0lZ
PgcEdit daemon
 
r0lZ's Avatar
 
Join Date: Jul 2003
Posts: 7,070
Well, in your first example, you set the forced subpic. This is a verry special case, using a special stream that must have been defined as forced.
You should use stream 0, ON:
Code:
[51 00 00 00 C0 00 00 00] 1 (SetSTN) Set Sub-picture stream = 0, on
__________________
r0lZ
PgcEdit homepage (hosted by VideoHelp)
BD3D2MK3D A tool to convert 3D blu-rays to SBS, T&B or FS MKV
r0lZ is offline   Reply With Quote
Old 6th January 2005, 17:39   #8  |  Link
CoNS
reMember
 
Join Date: Oct 2004
Location: Under your bed
Posts: 729
Hmm, then 2COOL's guide is wrong (or I am reading it wrong?)

If you have a normal subtitle stream as stream # 0 and want to turn this stream on by default, you shouldn't do step 14 a in the guide as it says, but instead step 14 b and c and select stream 0?

I'll try and change the SetSTN pre command to the setting you suggested, r0lZ, and burn the disc later tonight to see if that works better...
CoNS is offline   Reply With Quote
Old 6th January 2005, 20:43   #9  |  Link
CoNS
reMember
 
Join Date: Oct 2004
Location: Under your bed
Posts: 729
Yep, the "(SetSTN) Set Sub-picture stream = 0, on" pre command worked. The first subtitle stream is now turned on by default on my Sony standalone... Thx, r0lZ (and to 2COOL for the guide in the first place).

2COOL, unless I'm reading your guide wrong, you should consider changing it, so that step 14 b and c are always used, no matter which stream number it is?

I'm wondering what PgcEdit's function "force subpic 0" is for, then? If it's about selecting a stream with forced subtitles, why is it only for stream no. 0?
CoNS is offline   Reply With Quote
Old 6th January 2005, 21:08   #10  |  Link
2COOL
PGC Navigator in Training
 
2COOL's Avatar
 
Join Date: Oct 2002
Location: NTSC Land
Posts: 3,552
@CoNS

When I did the guide I tested it on my Sony and it worked then. There is a possibility that yours might have a problem with the forced sub-picture command. Have you tried your backup on another standalone?
__________________
2COOL
2COOL is offline   Reply With Quote
Old 6th January 2005, 22:42   #11  |  Link
r0lZ
PgcEdit daemon
 
r0lZ's Avatar
 
Join Date: Jul 2003
Posts: 7,070
@2COOL: It doesn't work with my Sony neither.
Anyway, I wonder why you use a different technique to set subpic 0. Why not use the standard syntax?
__________________
r0lZ
PgcEdit homepage (hosted by VideoHelp)
BD3D2MK3D A tool to convert 3D blu-rays to SBS, T&B or FS MKV
r0lZ is offline   Reply With Quote
Old 7th January 2005, 16:27   #12  |  Link
CoNS
reMember
 
Join Date: Oct 2004
Location: Under your bed
Posts: 729
Hmmm, sounds a bit like that the special "force subpic 0" command is for that very special case where the first sub stream is marked as "forced" (in PgcEdit in the domain stream attributes) and you want to turn that one by default.

Can anyone confirm that this is correct? If yes, I don't understand why this option is available for stream 0 only? But then it makes sence why 2COOL's guide doesn't work for me regarding stream 0.
CoNS is offline   Reply With Quote
Old 7th January 2005, 16:46   #13  |  Link
r0lZ
PgcEdit daemon
 
r0lZ's Avatar
 
Join Date: Jul 2003
Posts: 7,070
Unfortunately, I have made the test of using the command to set the forced subpic 0, and changed the subpic 0 stream attribute to forced. But it doesn't work on my Sony.
I have also tested with "normal" and "normal caption", without any result.
Seems that the Sony DVD-S725D cannot handle the "forced" subpic.
Or is it something more to do? Or a flag in the VOB?
__________________
r0lZ
PgcEdit homepage (hosted by VideoHelp)
BD3D2MK3D A tool to convert 3D blu-rays to SBS, T&B or FS MKV
r0lZ is offline   Reply With Quote
Old 7th January 2005, 20:02   #14  |  Link
CoNS
reMember
 
Join Date: Oct 2004
Location: Under your bed
Posts: 729
Why have you made the function for stream 0 only in PfcEdit?
CoNS is offline   Reply With Quote
Old 7th January 2005, 20:29   #15  |  Link
2COOL
PGC Navigator in Training
 
2COOL's Avatar
 
Join Date: Oct 2002
Location: NTSC Land
Posts: 3,552
Quote:
Originally posted by CoNS
Why have you made the function for stream 0 only in PfcEdit?
r0lZ was scratching his head in this post. Unless, he's a little more knowledgable on this subject now. Who knows? Anyways, even mpucoder quoted the values below a few times around here.

00-7f will do nothing, bit 7 must be set to cause any change
80-9f stream 0 to 31 selected, but off
a0-bd meaningless
be no subpicture
bf stream 0 forced, but off - ie, invalid
c0-df stream 0 to 31 selected and displayed
e0-fe meaningless
ff stream 0 forced and displayed.
__________________
2COOL
2COOL is offline   Reply With Quote
Old 7th January 2005, 20:47   #16  |  Link
CoNS
reMember
 
Join Date: Oct 2004
Location: Under your bed
Posts: 729
Whaddayathink, 2COOL. R U gonna change your guide and go with the "Set Sub-picture stream = 0, on" for stream 0, i.e. delete step 14 a in your guide?
CoNS is offline   Reply With Quote
Old 7th January 2005, 20:51   #17  |  Link
2COOL
PGC Navigator in Training
 
2COOL's Avatar
 
Join Date: Oct 2002
Location: NTSC Land
Posts: 3,552
Quote:
Originally posted by CoNS
Whaddayathink, 2COOL. R U gonna change your guide and go with the "Set Sub-picture stream = 0, on" for stream 0, i.e. delete step 14 a in your guide?
I did an edited version yesterday but then gave up to do other personal priorities. I'm mentally tapped out at the moment and will work on it again. I have to update the images to reflect PgcEdit's current version.
__________________
2COOL
2COOL is offline   Reply With Quote
Old 7th January 2005, 20:53   #18  |  Link
CoNS
reMember
 
Join Date: Oct 2004
Location: Under your bed
Posts: 729
mentally tapped out is not good! but it's friday...! try some red wine like me! it helps!
CoNS is offline   Reply With Quote
Old 7th January 2005, 20:57   #19  |  Link
2COOL
PGC Navigator in Training
 
2COOL's Avatar
 
Join Date: Oct 2002
Location: NTSC Land
Posts: 3,552
Friends don't let friends drive...ummm...edit drunk! Anyways, I have to work this whole weekend so that makes it my 10 days of work in a row. Stop the insanity!
__________________
2COOL
2COOL is offline   Reply With Quote
Old 7th January 2005, 20:59   #20  |  Link
CoNS
reMember
 
Join Date: Oct 2004
Location: Under your bed
Posts: 729
hehe, weekend for me now! Oh well, I better go watch a movie with the missus! After all it is Friday night now here in Scandinavia!
CoNS is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 04:00.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.