Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 30th July 2003, 06:39   #1  |  Link
wata
Registered User
 
Join Date: Jul 2002
Posts: 166
Anamorphic encode rv9 convert mkv doesn't play

Anamorphic encode rv9 convert mkv doesn't play
both latest realmedia & Matroska splitter install
no video, sound play fine

popup from mpc:

Stream 0

Media Type 0:
--------------------------
AM_MEDIA_TYPE:
majortype: MEDIATYPE_Video {73646976-0000-0010-8000-00AA00389B71}
subtype: FOURCC GUID {30345652-0000-0010-8000-00AA00389B71}
formattype: FORMAT_VideoInfo {05589F80-C356-11CE-BF01-00AA0055595A}
bFixedSizeSamples: 0
bTemporalCompression: 0
lSampleSize: 1
cbFormat: 146

VIDEOINFOHEADER:
rcSource: (0,0)-(0,0)
rcTarget: (0,0)-(0,0)
dwBitRate: 0
dwBitErrorRate: 0
AvgTimePerFrame: 333332

BITMAPINFOHEADER:
biSize: 40
biWidth: 0
biHeight: 864
biPlanes: 0
biBitCount: 0
biCompression: RV40
biSizeImage: 0
biXPelsPerMeter: 0
biYPelsPerMeter: 0
biYPelsPerMeter: 0
biClrUsed: 0
biClrImportant: 0
wata is offline   Reply With Quote
Old 30th July 2003, 08:33   #2  |  Link
nah
RV9 Convaincu !
 
Join Date: Apr 2002
Location: Toulouse
Posts: 31
yes, I have the 'same' pb.

posted :
-----------------------------
I've tested RealMediaSplitter 1.0.0.4 and MatroskaMuxer 1.0.0.6 and MPC doesn't play the mkv.
It worked well with the RealMediaSplitter 1.0.0.3
-----------------------------
__________________
UteamVision
nah is offline   Reply With Quote
Old 30th July 2003, 11:18   #3  |  Link
wata
Registered User
 
Join Date: Jul 2002
Posts: 166
RealMediaSplitter 1.0.0.3 doesn't work for me as well
wata is offline   Reply With Quote
Old 30th July 2003, 12:11   #4  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
what if you use RealMedia instead of DirectShow in MPC for RealVideo?
__________________
Detritus Software
Sirber is offline   Reply With Quote
Old 30th July 2003, 12:58   #5  |  Link
wata
Registered User
 
Join Date: Jul 2002
Posts: 166
i would like to use mkv so that it can display dvobsub subs

the special renderer for subtitling does work for me cause using it cause 100% cpu load.
wata is offline   Reply With Quote
Old 30th July 2003, 13:58   #6  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
I mean in Format selection, "RealMedia" or "DirectShow" for RealVideo and RealAudio.
__________________
Detritus Software
Sirber is offline   Reply With Quote
Old 30th July 2003, 18:07   #7  |  Link
karl_lillevold
Moderator
 
karl_lillevold's Avatar
 
Join Date: Oct 2002
Location: Seattle
Posts: 1,584
Why anamorphic RV9 in mkv does not show video is problably something Gabest can answer. Perhaps you should try to ping him over in this thread.
__________________
This information is provided "AS IS" with no warranties, grants no rights, and reflects my personal opinion.
karl_lillevold is offline   Reply With Quote
Old 31st July 2003, 04:59   #8  |  Link
dillee1
Registered User
 
Join Date: Feb 2003
Posts: 28
I dun have problem with anamorphic RV9 in mkv .

Audio is not rendered, however.... wtf
dillee1 is offline   Reply With Quote
Old 3rd August 2003, 18:26   #9  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
Same problem:

Stream 0

Media Type 0:
--------------------------
AM_MEDIA_TYPE:
majortype: MEDIATYPE_Video {73646976-0000-0010-8000-00AA00389B71}
subtype: FOURCC GUID {30345652-0000-0010-8000-00AA00389B71}
formattype: FORMAT_VideoInfo {05589F80-C356-11CE-BF01-00AA0055595A}
bFixedSizeSamples: 0
bTemporalCompression: 0
lSampleSize: 1
cbFormat: 146

VIDEOINFOHEADER:
rcSource: (0,0)-(0,0)
rcTarget: (0,0)-(0,0)
dwBitRate: 0
dwBitErrorRate: 0
AvgTimePerFrame: 333332

BITMAPINFOHEADER:
biSize: 40
biWidth: 0
biHeight: 848
biPlanes: 0
biBitCount: 0
biCompression: RV40
biSizeImage: 0
biXPelsPerMeter: 0
biYPelsPerMeter: 0
biYPelsPerMeter: 0
biClrUsed: 0
biClrImportant: 0

using internal MPC splitters
__________________
Detritus Software
Sirber is offline   Reply With Quote
Old 4th August 2003, 15:48   #10  |  Link
dillee1
Registered User
 
Join Date: Feb 2003
Posts: 28
tested a few more old clips.
Some got video no audio
Some got audio no video
some got none
some got both.

interesting.....
dillee1 is offline   Reply With Quote
Old 4th August 2003, 16:43   #11  |  Link
gabest
Registered User
 
gabest's Avatar
 
Join Date: Oct 2001
Posts: 1,459
Could you check their fourcc or waveformat tag when mpc reports them? (and for that you have to change the rendering of real media files to be done through dshow at options/formats)
__________________
gabest.org
gabest is offline   Reply With Quote
Old 4th August 2003, 23:05   #12  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
Some more informations...

+ EBML head
+ Segment
|+ Seek head (subentries will be skipped)
|+ EbmlVoid
|+ Segment information
| + Timecode scale: 1000000
| + Duration: 5914.470s
| + Date: Sun Aug 03 13:15:57 2003 UTC
| + Muxing application: DirectShow Matroska Muxer
|+ Segment tracks
| + A track
| + Track number: 1
| + Track UID: 38
| + Track type: video
| + MinCache: 1
| + MaxCache: 1
| + Codec ID: V_REAL/RV40
| + CodecPrivate, length 58
| + Default duration: 33.333ms (30.000 fps for a video track)
| + Video track
| + Pixel width: 0
| + Pixel height: 848
| + Frame rate: 30.000031
| + A track
| + Track number: 2
| + Track UID: 7719
| + Track type: audio
| + MinCache: 1
| + MaxCache: 1
| + Codec ID: A_REAL/COOK
| + CodecPrivate, length 94
| + Audio track
| + Sampling frequency: 44100.000000
| + Channels: 2
| + Bit depth: 16
| + A track
| + Track number: 3
| + Track UID: 21238
| + Track type: subtitles
| + MinCache: 1
| + MaxCache: 1
| + Codec ID: S_TEXT/ASCII
|+ Cluster

When trying to extract:

C:\Documents and Settings\sirber\Bureau\Helix Factory\bin\mkv>mkvextract.exe tra
cks Solaris.mkv 1:vid.rmvb
Warning: Track ID 1 is missing some critical information. Skipping track.
Nothing to do. Exiting.

C:\Documents and Settings\sirber\Bureau\Helix Factory\bin\mkv>mkvextract.exe tra
cks Solaris.mkv 2:aud.rm
Warning: Unsupported CodecID 'A_REAL/COOK' for ID 2. Skipping track.
Nothing to do. Exiting.

C:\Documents and Settings\sirber\Bureau\Helix Factory\bin\mkv>mkvextract.exe tra
cks Solaris.mkv 3:sub.srt
Warning: Unsupported CodecID 'S_TEXT/ASCII' for ID 3. Skipping track.
Nothing to do. Exiting.

*********************
This infos is from a "normal" working anamorphic MKV file:

+ EBML head
+ Segment
|+ Seek head (subentries will be skipped)
|+ EbmlVoid
|+ Segment information
| + Muxing application: libebml v0.5.0 + libmatroska v0.5.0
| + Writing application: mkvmerge v0.6.0
| + Duration: 20.547s
| + Date: Mon Aug 04 22:10:29 2003 UTC
| + Segment UID: 0x83 0xd3 0x9b 0x0f 0xfc 0xde 0x24 0x43 0x88 0x05 0x8f 0xb8 0xf
6 0x4f 0xce 0x04
|+ Segment tracks
| + A track
| + Track number: 1
| + Track UID: 2574048674
| + Track type: audio
| + Codec ID: A_REAL/COOK
| + CodecPrivate, length 94
| + Audio track
| + Sampling frequency: 44100.000000
| + Channels: 2
| + Bit depth: 16
| + A track
| + Track number: 2
| + Track UID: 237765970
| + Track type: video
| + MinCache: 1
| + Codec ID: V_REAL/RV40
| + CodecPrivate, length 34
| + MaxCache: 1
| + Default duration: 41.708ms (23.976 fps for a video track)
| + Video track
| + Pixel width: 856
| + Pixel height: 364
| + Display height: 364
| + Display width: 856
| + Lacing flag: 0
|+ Cluster
__________________
Detritus Software

Last edited by Sirber; 4th August 2003 at 23:27.
Sirber is offline   Reply With Quote
Old 4th August 2003, 23:26   #13  |  Link
gabest
Registered User
 
gabest's Avatar
 
Join Date: Oct 2001
Posts: 1,459
What did you use to create this file? S_TEXT/ASCII isn't supposed to be used anymore. I could only think you connected ogm's subtitle parser or used a very old build of matroskamuxer.
__________________
gabest.org
gabest is offline   Reply With Quote
Old 4th August 2003, 23:26   #14  |  Link
karl_lillevold
Moderator
 
karl_lillevold's Avatar
 
Join Date: Oct 2002
Location: Seattle
Posts: 1,584
i just tried the latest mkvmerge tool instead of Dark-Cracker's
directshow wrapper, and it seems to create a 'good' anamorphic RV9
file.

the atest.mkv file, as created by DC's dshow wrapper:
| + Video track
| + Pixel width: 0
| + Pixel height: 856

[mkvinfo]

with mkvmerge:
| + Video track
| + Pixel width: 856
| + Pixel height: 364
| + Display height: 364
| + Display width: 856

So it seems the directshow wrapper method does not work for anamorphic
files. The mkvmerge'd file plays video, but stutters and freezes a few times.
__________________
This information is provided "AS IS" with no warranties, grants no rights, and reflects my personal opinion.
karl_lillevold is offline   Reply With Quote
Old 4th August 2003, 23:28   #15  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
Quote:
Originally posted by gabest
What did you use to create this file? S_TEXT/ASCII isn't supposed to be used anymore. I could only think you connected ogm's subtitle parser or used a very old build of matroskamuxer.
It's SRT format, and IIRC I used your subtitle renderer...
__________________
Detritus Software
Sirber is offline   Reply With Quote
Old 4th August 2003, 23:42   #16  |  Link
gabest
Registered User
 
gabest's Avatar
 
Join Date: Oct 2001
Posts: 1,459
Sirber: Are you sure you are using the latest muxer? Could you check the version number at the file properies in explorer?

karl_lillevold: mkvmerge's demuxer may not recognize those double packed frame types, try to compare the frame listing of rmeditor with what you get in the codec through the dshow filter.
__________________
gabest.org
gabest is offline   Reply With Quote
Old 4th August 2003, 23:49   #17  |  Link
Sirber
retired developer
 
Sirber's Avatar
 
Join Date: Oct 2002
Location: Canada
Posts: 8,978
MatroskaMuxer.ax: 1.0.0.6
subtitlesource.ax: 1.0.0.1
__________________
Detritus Software
Sirber is offline   Reply With Quote
Old 4th August 2003, 23:53   #18  |  Link
karl_lillevold
Moderator
 
karl_lillevold's Avatar
 
Join Date: Oct 2002
Location: Seattle
Posts: 1,584
Quote:
Originally posted by gabest
karl_lillevold: mkvmerge's demuxer may not recognize those double packed frame types, try to compare the frame listing of rmeditor with what you get in the codec through the dshow filter.
Without actually checking, that sounds very likely, since the freezes are 100% deterministic and probably a result of such an error in mkvmerge's demuxer.
__________________
This information is provided "AS IS" with no warranties, grants no rights, and reflects my personal opinion.
karl_lillevold is offline   Reply With Quote
Old 5th August 2003, 00:08   #19  |  Link
karl_lillevold
Moderator
 
karl_lillevold's Avatar
 
Join Date: Oct 2002
Location: Seattle
Posts: 1,584
so I did check, and the mkvmerge'd file has a large number of missing frames, most likely as a result of the demuxer problem Gabest mentioned. This means most files converted from rmvb to mkv using mkvmerge will have missing frames, so this is not a recommended method until this problem is fixed in mkvmerge's demuxer.
__________________
This information is provided "AS IS" with no warranties, grants no rights, and reflects my personal opinion.
karl_lillevold is offline   Reply With Quote
Old 5th August 2003, 08:15   #20  |  Link
Mosu
MKVToolNix author
 
Mosu's Avatar
 
Join Date: Sep 2002
Location: Braunschweig, Germany
Posts: 4,084
Quote:
Originally posted by karl_lillevold
so I did check, and the mkvmerge'd file has a large number of missing frames, most likely as a result of the demuxer problem Gabest mentioned. This means most files converted from rmvb to mkv using mkvmerge will have missing frames, so this is not a recommended method until this problem is fixed in mkvmerge's demuxer.
Definitely likely that mkvmerge does not handle some streams correctly. Can someone please provide me with (preferably small) sample files which show this behaviour?

I'll ask Gabest how to handle those thingies.
__________________
Latest MKVToolNix is v63.0.0

If I ever ask you to upload something, please use my file server.
Mosu is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 21:06.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.