Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Audio encoding

Reply
 
Thread Tools Search this Thread Display Modes
Old 2nd June 2003, 23:54   #1  |  Link
Dark-Cracker
Registered User
 
Dark-Cracker's Avatar
 
Join Date: Feb 2002
Posts: 1,195
Besweet bugs : ABR/Preset MP3 & ogg -6ch ( 3 bugs )

Besweet : ABR/presets MP3 bugs & OGG -6ch bug.
hi,

@Dspguru
there is still some bugs (already reported a few mounth ago) i hope u can find the time to fix them :

(tested with the latest lame_enc.dll and libvorbis.dll on rarewares)

- ogg and -ch6 at a bitrate upper than 192 :

working for a bitrate=191 kbps with an Actual Avg. Bitrate : 213kbps
but not working for 192 kbps, it encode at 128 kbps (without -6ch switch no problem).

logfile :
.....................................
BeSweet v1.5b18 by DSPguru.
--------------------------
Using azid.dll v1.8 (b825) by Midas (midas@egon.gyaloglo.hu).
Using libVorbis.dll v1.0 ( Apr 16 2003 ) by John33 (www.inf.ufpr.br/~rja00).

Logging start : 06/02/03 , 19:24:56.

C:\WINDOWS\BUREAU\BESWEE~1.5B1\BESWEET.EXE -core( -input H:\testvob\out.ac3 -output H:\raspoutine\toto.ogg -logfile besweet.log ) -ogg( -b 192 -6ch ) -split( -start 0 -end 10)

[00:00:00:000] +------- BeSweet -----
[00:00:00:000] | Input : H:\testvob\out.ac3
[00:00:00:000] | Output: H:\raspoutine\toto.ogg
[00:00:00:000] | Floating-Point Process: Yes
[00:00:00:000] +-------- AZID -------
[00:00:00:000] | Input Channels Mode: 2/0, Bitrate: 192kbps
[00:00:00:000] | Total Gain: 0.000dB, Compression: None
[00:00:00:000] | LFE levels: To LR -INF, To LFE 0.0dB
[00:00:00:000] | Center mix level: BSI
[00:00:00:000] | Surround mix level: BSI
[00:00:00:000] | Dialog normalization: No
[00:00:00:000] | Rear channels filtering: No
[00:00:00:000] | Source Sample-Rate: 48.0KHz
[00:00:00:000] +-------- OGG --------
[00:00:00:000] | Avarege Bitrate : 192
[00:00:00:000] +---------------------
[00:00:10:048] Conversion Completed !
[00:00:10:048] Actual Avg. Bitrate : 128kbps
[00:00:20:000] <-- Transcoding Duration

Logging ends : 06/02/03 , 19:25:16.
.....................................

there is an another problem with the lame_enc.dll file and the --abr switch.

if u use a bitrate under 77 kbps the encode failed "with a lame_enc.dll failed msg".

working for --arb 77 :

log file :
................................
BeSweet v1.5b18 by DSPguru.
--------------------------
Using azid.dll v1.8 (b825) by Midas (midas@egon.gyaloglo.hu).
Using lame_enc.dll v1.32 (11/5/2003), Engine 3.94 <http://www.mp3dev.org/>.

Logging start : 06/02/03 , 19:31:31.

C:\WINDOWS\BUREAU\BESWEE~1.5B1\BESWEET.EXE -core( -input H:\testvob\out.ac3 -output H:\raspoutine\toto.mp3 -logfile besweet.log ) -lame( --abr 77 )

[00:00:00:000] +------- BeSweet -----
[00:00:00:000] | Input : H:\testvob\out.ac3
[00:00:00:000] | Output: H:\raspoutine\toto.mp3
[00:00:00:000] | Floating-Point Process: Yes
[00:00:00:000] +-------- AZID -------
[00:00:00:000] | Input Channels Mode: 2/0, Bitrate: 192kbps
[00:00:00:000] | Output Stereo mode: Dolby surround compatible
[00:00:00:000] | Total Gain: 0.000dB, Compression: None
[00:00:00:000] | LFE levels: To LR -INF, To LFE 0.0dB
[00:00:00:000] | Center mix level: BSI
[00:00:00:000] | Surround mix level: BSI
[00:00:00:000] | Dialog normalization: No
[00:00:00:000] | Rear channels filtering: No
[00:00:00:000] | Source Sample-Rate: 48.0KHz
[00:00:00:000] +-------- LAME -------
[00:00:00:000] | Bitrate method : ABR
[00:00:00:000] | Avarege Bitrate : 77
[00:00:00:000] | MP3 Min bitrate : 32
[00:00:00:000] | MP3 Max bitrate : 320
[00:00:00:000] | Channels Mode : Joint Stereo
[00:00:00:000] | Error Protection: No
[00:00:00:000] +---------------------
[00:01:00:032] Conversion Completed !
[00:01:00:032] Actual Avg. Bitrate : 71kbps
[00:00:21:000] <-- Transcoding Duration

Logging ends : 06/02/03 , 19:31:52.

................................

and crashed for a bitrate < 77 (tested with 76,80,64,32..)

Logfile :
.................................
BeSweet v1.5b18 by DSPguru.
--------------------------
Using azid.dll v1.8 (b825) by Midas (midas@egon.gyaloglo.hu).
Using lame_enc.dll v1.32 (11/5/2003), Engine 3.94 <http://www.mp3dev.org/>.

Logging start : 06/02/03 , 19:34:34.

C:\WINDOWS\BUREAU\BESWEE~1.5B1\BESWEET.EXE -core( -input H:\testvob\out.ac3 -output H:\raspoutine\toto.mp3 -logfile besweet.log ) -lame( --abr 76 )

[00:00:00:000] +------- BeSweet -----
[00:00:00:000] | Input : H:\testvob\out.ac3
[00:00:00:000] | Output: H:\raspoutine\toto.mp3
[00:00:00:000] | Floating-Point Process: Yes
Error 47: Error with LAME dll!
Quiting...
[00:00:00:000] Conversion Completed !

Logging ends : 06/02/03 , 19:34:34.
.................................

and another problem is with the bitrate limitation and the preset :
if u try to use the max bitrate limitation in a preset it automaticly encode in cbr 128 kbps

exemple , if u use : --alt-preset standard -B 96 it does work and i finaly have a cbr 128 kbps while normaly it's possible to use the max bitrate limitation with presets.

logfile :
..................................
BeSweet v1.5b18 by DSPguru.
--------------------------
Using azid.dll v1.8 (b825) by Midas (midas@egon.gyaloglo.hu).
Using lame_enc.dll v1.32 (11/5/2003), Engine 3.94 <http://www.mp3dev.org/>.

Logging start : 06/02/03 , 19:35:50.

C:\WINDOWS\BUREAU\BESWEE~1.5B1\BESWEET.EXE -core( -input H:\testvob\out.ac3 -output H:\raspoutine\toto.mp3 -logfile besweet.log ) -lame( --alt-preset standard -B 96 ) -split( -start 0 -end 10)

[00:00:00:000] +------- BeSweet -----
[00:00:00:000] | Input : H:\testvob\out.ac3
[00:00:00:000] | Output: H:\raspoutine\toto.mp3
[00:00:00:000] | Floating-Point Process: Yes
[00:00:00:000] +-------- AZID -------
[00:00:00:000] | Input Channels Mode: 2/0, Bitrate: 192kbps
[00:00:00:000] | Output Stereo mode: Dolby surround compatible
[00:00:00:000] | Total Gain: 0.000dB, Compression: None
[00:00:00:000] | LFE levels: To LR -INF, To LFE 0.0dB
[00:00:00:000] | Center mix level: BSI
[00:00:00:000] | Surround mix level: BSI
[00:00:00:000] | Dialog normalization: No
[00:00:00:000] | Rear channels filtering: No
[00:00:00:000] | Source Sample-Rate: 48.0KHz
[00:00:00:000] +-------- LAME -------
[00:00:00:000] | 'alt standard' preset is used
[00:00:00:000] +---------------------
[00:00:10:048] Conversion Completed !
[00:00:10:048] Actual Avg. Bitrate : 128kbps
[00:00:06:000] <-- Transcoding Duration

Logging ends : 06/02/03 , 19:35:56.
.........................................

PS: a little mistake in the word "average" written "avarage" in the ogg ouput msg.

Ps2: problem with path name and space seems to be fixed.

i hope u could find time to finish to fix these bugs.

Bye.
keep up good work.
__________________

AutoDub v1.8 : Divx3/4/5 & Xvid Video codec and .OGG/.MP3/.AC3/.WMA audio codec.
AutoRV10 v1.0 : Use RealVideo 10 Codec and support 2 Audio Streams and Subtitles.


Last edited by Dark-Cracker; 2nd June 2003 at 23:57.
Dark-Cracker is offline   Reply With Quote
Old 3rd June 2003, 01:29   #2  |  Link
DSPguru
BeSweet Author
 
DSPguru's Avatar
 
Join Date: Oct 2001
Location: On top of a supercompact cardinal
Posts: 3,506
10x. i didn't forget. you might have noticed that the links to your bug-reports are already a part of the openned issues list.
DSPguru is offline   Reply With Quote
Old 3rd June 2003, 02:49   #3  |  Link
Dark-Cracker
Registered User
 
Dark-Cracker's Avatar
 
Join Date: Feb 2002
Posts: 1,195
damn sorry
i have post this thread in the end of another thread it for that i have post again these bugs
i only want to be sure there were always in your eradiquate bugs list
happy to see u are come back.

PS: don't kick my ass it's my birthday.

Bye.
__________________

AutoDub v1.8 : Divx3/4/5 & Xvid Video codec and .OGG/.MP3/.AC3/.WMA audio codec.
AutoRV10 v1.0 : Use RealVideo 10 Codec and support 2 Audio Streams and Subtitles.

Dark-Cracker is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:02.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.