Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Subtitles

Reply
 
Thread Tools Search this Thread Display Modes
Old 8th March 2003, 19:56   #41  |  Link
gabest
Registered User
 
gabest's Avatar
 
Join Date: Oct 2001
Posts: 1,459
New build here.
- fps as the third textsub parameter is back
- textsubswapuv(bool) function (guess what it does )
- fixed a nasty color overflow bug with yv12

Though there is textsubswapuv now, I still don't have any prob without it. Those who have please try to load other files encoded differently to check if it's not only because of one badly working codec.

kitsaros2000: Try to sync the subs before using them, there are a few good program to do it.
__________________
gabest.org
gabest is offline   Reply With Quote
Old 9th March 2003, 15:05   #42  |  Link
Balm
DVDtoOgm & DVDtoMKV
 
Join Date: Feb 2003
Posts: 26
Thanks a lot

Cu Balm
Balm is offline   Reply With Quote
Old 10th March 2003, 04:30   #43  |  Link
Kyo
Anime Team!
 
Kyo's Avatar
 
Join Date: Jan 2002
Location: JulyCity
Posts: 280
Thanks Gabest for your hard work on the subtitler filters!
__________________
Old time lurker
Kyo is offline   Reply With Quote
Old 12th March 2003, 16:34   #44  |  Link
kitsaros2000
Registered User
 
Join Date: Apr 2002
Posts: 61
thx Gabest !
kitsaros2000 is offline   Reply With Quote
Old 14th March 2003, 19:15   #45  |  Link
frank
Registered User
 
Join Date: Oct 2001
Location: Germany
Posts: 763
The UV swapping bug is fixed in AVS 2.51!
frank is offline   Reply With Quote
Old 16th March 2003, 04:06   #46  |  Link
dblmask
Registered User
 
Join Date: Mar 2002
Posts: 23
kudos 2 gabest

the vsfilter.dll work incredible ok with AviSynth 2.08 and AviSynth 2.51,

Excellent work!!!

I've been having problems using this script with avisynth 2.08
Code:
LoadPlugin("C:\avisynth\plugins\textsub.vdf")
AviSource("G:\video.avi")
TextSub("G:\subs.srt")
and I was getting only the video without subs, the I decided to try the new vsfilter, and all works excellent
Code:
LoadPlugin("C:\avisynth\plugins\vsfilter.dll") 
AviSource("G:\video.avi")
TextSub("G:\subs.srt")
Thanks Gabest, this toy has no price.
dblmask is offline   Reply With Quote
Old 24th March 2003, 01:09   #47  |  Link
Prettz
easily bamboozled user
 
Prettz's Avatar
 
Join Date: Sep 2002
Location: Atlanta
Posts: 373
Hi, I'm having a problem using VobSub with Avisynth 2.5. When using VobSub filter from an avs script, VobSub displays the subtitles in the wrong color, even though the VobSub config dialog shows the correct colors when I go to configure it (I have it set to remember the last color settings and everything). I'm using version 2.13 of VobSub.
Specifically it displays all of the colors correctly except for the subtitles' main color. It displays that color as a pale teal-blue instead of the normal pale yellow color. The other 3 subtitle colors (the border colors) are done correctly.

I can give more info if anyone thinks they might be able to help.
Prettz is offline   Reply With Quote
Old 24th March 2003, 01:17   #48  |  Link
gabest
Registered User
 
gabest's Avatar
 
Join Date: Oct 2001
Posts: 1,459
Are the ok-looking colors grayscale? Then you might want to try the u/v swapping function.
__________________
gabest.org
gabest is offline   Reply With Quote
Old 24th March 2003, 14:46   #49  |  Link
OtherSide
Registered User
 
Join Date: Mar 2003
Posts: 4
Thanks for all your hard work, gabest! But...

I'm having two problems with the latest build of VSFilter - subtitles shifting up and to the right, and the old UV mixup problem. I'm not sure if I should be posting this here or perhaps in the Avisynth forum so I'll try here first.

The following script was used:

#LoadPlugin("D:\Avisynth 2.5\MPEG2Dec\MPEG2Dec3.dll")
LoadPlugin("D:\Avisynth 2.5\MPEG2Dec\MPEG2Dec.dll")
LoadPlugin("D:\Avisynth 2.5\Decomb\Decomb.dll")
LoadPlugin("D:\Avisynth 2.5\VSFilter\Release\VSFilter.dll")
mpeg2source("E:\DVDRip\NADESICO_01\nadesico_01.d2v")
Telecide()
Decimate(5)
crop(8,0,698,478)
VobSub("E:\DVDRip\NADESICO_01\VTS_01_0")
LanczosResize(640,480)

Both MPEG2Decs are compatible with Avisynth 2.51 which I am using (MPEG2Dec.dll obtained here).
Images captured through VirtualDubMod 1.4.13.
Decomb version is 4.06 beta 7.

The following "shifting" problem occurs on multiple frames, I just decided to use this one as an example.
When using MPEG2Dec
When using MPEG2Dec3
*** However, when the crop and LanczosResize are commented out, the problem disappears.

UV problem:
When using MPEG2Dec
When using MPEG2Dec3
*** However, when Decomb and its associated commands are commented out, the problem disappears - hence my point about whether to post this in Subtitle or Avisynth Usage forum.
Also, the UV problem does not occur on all frames.
Putting SwapUV() above and below the VobSub command does not fix this issue, but inserting ConvertToYUY2 above VobSub("...") does fix it.

Knowing my luck, it's probably something simple which I've missed
OtherSide is offline   Reply With Quote
Old 24th March 2003, 18:54   #50  |  Link
Prettz
easily bamboozled user
 
Prettz's Avatar
 
Join Date: Sep 2002
Location: Atlanta
Posts: 373
Quote:
Originally posted by gabest
Are the ok-looking colors grayscale? Then you might want to try the u/v swapping function.
Wow that fixed the problem perfectly, thanks. I would never have guessed that that was the cause of the color problem.
Prettz is offline   Reply With Quote
Old 26th March 2003, 07:38   #51  |  Link
gabest
Registered User
 
gabest's Avatar
 
Join Date: Oct 2001
Posts: 1,459
OtherSide: I found the bug causing the color shift, a new build will be posted soon.
__________________
gabest.org
gabest is offline   Reply With Quote
Old 26th March 2003, 14:58   #52  |  Link
OtherSide
Registered User
 
Join Date: Mar 2003
Posts: 4
Woohoo! Thanks gabest Do you know the cause of the "up and to the right" subtitle problem?
OtherSide is offline   Reply With Quote
Old 27th March 2003, 08:59   #53  |  Link
ZaP37
Registered User
 
Join Date: Nov 2002
Posts: 8
I can't get TextSub to work, is it working in the latest build? With this script it's as if vsfilter isn't loaded at all (no subs).

LoadPlugin("P:\AV\Divx Encoding Tools\AviSynth 2.5.1\plugins\mpeg2dec3.dll")
LoadPlugin("P:\AV\Divx Encoding Tools\AviSynth 2.5.1\plugins\decomb.dll")
LoadPlugin("P:\AV\Divx Encoding Tools\AviSynth 2.5.1\plugins\vsfilter.dll")
mpeg2source("P:\divx\bolly\bhb.d2v")
FieldDeinterlace()
crop(14,100,684,278)
TextSub("P:\divx\bolly\bhb.srt")
BicubicResize(576,256,0,0.75)
ZaP37 is offline   Reply With Quote
Old 27th March 2003, 09:26   #54  |  Link
gabest
Registered User
 
gabest's Avatar
 
Join Date: Oct 2001
Posts: 1,459
Check the srt for errors, if it opens in mpc then it should open in vsfilter too.

New build at:
http://vobsub.edensrising.com/vsfilter.rar
__________________
gabest.org
gabest is offline   Reply With Quote
Old 27th March 2003, 13:48   #55  |  Link
OtherSide
Registered User
 
Join Date: Mar 2003
Posts: 4
Great stuff gabest, looks like both problems have been fixed! Thanks again
OtherSide is offline   Reply With Quote
Old 28th March 2003, 01:20   #56  |  Link
ZaP37
Registered User
 
Join Date: Nov 2002
Posts: 8
The problem was my own fault! Somehow the srt got skewed by 2 hours, so the first sub didn't appear until the end of the movie! How I didn't notice this when I first opened the srt I'm not sure...

Thanks infinitely for this invaluable tool gabest!!
ZaP37 is offline   Reply With Quote
Old 8th April 2003, 00:31   #57  |  Link
gabest
Registered User
 
gabest's Avatar
 
Join Date: Oct 2001
Posts: 1,459
It works, try another browser or the magical shift button.
__________________
gabest.org
gabest is offline   Reply With Quote
Old 8th April 2003, 07:30   #58  |  Link
ookzDVD
DVD Rebuilder!
 
ookzDVD's Avatar
 
Join Date: Oct 2001
Posts: 1,147
@gabest,

Any chance for updating the DVobSub.ax as well ?
ookzDVD is offline   Reply With Quote
Old 8th April 2003, 16:01   #59  |  Link
gabest
Registered User
 
gabest's Avatar
 
Join Date: Oct 2001
Posts: 1,459
dvobsub is now: "regsvr32 vsfilter.dll"
__________________
gabest.org
gabest is offline   Reply With Quote
Old 9th April 2003, 05:54   #60  |  Link
ookzDVD
DVD Rebuilder!
 
ookzDVD's Avatar
 
Join Date: Oct 2001
Posts: 1,147
@gabest,

Thank you,
I'm just too stupid
ookzDVD is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:45.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.