Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 ASP

Reply
 
Thread Tools Search this Thread Display Modes
Old 6th December 2006, 21:05   #1  |  Link
SpeakerBR
Registered User
 
Join Date: Nov 2006
Posts: 11
DRF too high? (And another problems)

Hi,

I'm compresing an interlaced video. I want to get the best quality. I compressed the video with two pass with the xvid 1.2 codec and the custom quantization matriz eqm_v3hr.xcm (I use a bitrate of 1900Kb/s) But I obtain a video with a DRF average (Measure using DRF analyzer) too high: 3.557.
DRF 2: 19%
DRF 3: 14%
DRF 4: 56%
DRF 5: 10%

If I compress the same video (I do the two pass again.), with he quantization matriz MPEG, I obtain a video with a DRF average 3'318
DRF 2: 30%
DRF 3: 7%
DRF 4: 63%
DRF 5: 0%

But the XVid status windows show me the next (It is the second pass):



According to these graphic, the Ivop frames has got DRF 2, the Pvop DRF 2 and the Bvop DRF 4. How can to be diferent the values of the DRF Analyser and the Xvid windows status?

How can I obtain the best image quality? Would I can reduce the % of Bvop frames?


Another question, the image shows some ugly spots when its seen in a railings in fast foward. Can it be by the deinterlaces filter (TIVTC+TDeint(EDI) - slow)?



Thanks very much!

Last edited by SpeakerBR; 7th December 2006 at 13:22.
SpeakerBR is offline   Reply With Quote
Old 7th December 2006, 05:38   #2  |  Link
Caspar
Registered User
 
Join Date: May 2003
Posts: 35
It would be very helpful if you can post what settings you used for the codec. I can guess what you used for your min and max DRF settings but that's about it. It looks like you are using 2 bvops... try using 1 instead.

Picture 1 shows interlace artifact. Picture 2 shows edge ringing. I am not sure if the ringing is cause by the codec or your source really looked like that...
Caspar is offline   Reply With Quote
Old 7th December 2006, 10:08   #3  |  Link
DarkZell666
aka XaS
 
DarkZell666's Avatar
 
Join Date: Jun 2005
Location: France
Posts: 1,122
What's this DRF stuff ? You're talking about quantizers right ?

Simply set bvop quantizer offset to 1, quant. ratio to 1.0, and set encoding to "target quantizer mode", with quantizer=2. Since you are targeting quality, it's logical to choose a target quality, not bitrate (I can't make this more obvious, I'm even sounding ridiculous the way I wrote this ). You can even set max bvops to 1 instead of 2, if that's really what you want, but the average quantizer (DRF as you call it) isn't as indicative of the quality when bvops are enabled.

If what you see doesn't suit you, the next step is to try several quantizer matrices until you get the right look
__________________

Q9300 OC @ 3.2ghz / Asus P5E3 / 4GB PC10600 / Geforce 8600 GTS
DarkZell666 is offline   Reply With Quote
Old 7th December 2006, 13:04   #4  |  Link
SpeakerBR
Registered User
 
Join Date: Nov 2006
Posts: 11
Thanks for your reply. My setting are:

For compress I use VirtualDub 1.6.17
Mode "fast recompress"
I use coded Xvid 1.2 (I have got an AMD K8 X2)

Xvid configuration:
Profile@Level: (unrestricted)
Quantization type: MPEG-Custom and matrix EQM V3HR (I use a bitrate of 1900kb/s)

Adaptative Quatization. Marked
Interlaced Enconding. Not Marked
Quarter pixel: Not marked (for best compatibility)
Global Motion Compesantion: Not marked (for best compatibility)

max consecutive BVOPs: 2
Quantizer ratio: 1.50
Quantizer offset: 1.00
Packet bitstream: Not marked (for best compatibility)

Pestaņa de 2nd pasada:
I-frame boost: 10
I-frame closer than 1
are reduced by % 20

Overflow control strength 5
max overflow improvement 5
max overflow degradation 5

High bitrate scenes 0
Low bitrate scenes 0

Motion search precision 6
VHQ mode 4
use VHQ for bframes too: Marked
Use Chroma motion: Marked
Frame drop ratio: 0
Maximum I-frame interval: 300

minimum and maximum Quantizer for I frames: 2-4
minimum and maximum Quantizer for P frames: 2-5
minimum and maximum Quantizer for B frames: 2-5
Trellis quantization: marked

Quote:
Picture 1 shows interlace artifact. Picture 2 shows edge ringing. I am not sure if the ringing is cause by the codec or your source really looked like that...
I will try another deinterlaced filter. What about than the meGUI tell me to use diferent deinterlaced filters?

About the second picture, I am sorry, the source too show small artefacts.

Quote:
Since you are targeting quality, it's logical to choose a target quality, not bitrate
Sorry, but I have to use a limited bitrate.

Quote:
You can even set max bvops to 1 instead of 2, if that's really what you want, but the average quantizer (DRF as you call it) isn't as indicative of the quality when bvops are enabled.
I test to use max bvop to 1. How can I measure the quality? (I suppose I have to look the same frames with diferent settings.)

Sorry for my poor english.

Last edited by SpeakerBR; 7th December 2006 at 19:00.
SpeakerBR is offline   Reply With Quote
Old 7th December 2006, 13:59   #5  |  Link
foxyshadis
ангел смерти
 
foxyshadis's Avatar
 
Join Date: Nov 2004
Location: Lost
Posts: 9,174
The deinterlacer destroyed that image. Not sure why it would, can you post a short extract of that scene? (cut using dgindex or similar, not the xvid encode) That might be where the real quality problems are coming from. Might be able to recomend a filter to denoise the picture slightly too.
__________________
There are four boxes to be used in defense of liberty: soap, ballot, jury, and ammo. Please use in that order. ~ Ed Howdershelt
foxyshadis is offline   Reply With Quote
Old 7th December 2006, 14:43   #6  |  Link
DarkZell666
aka XaS
 
DarkZell666's Avatar
 
Join Date: Jun 2005
Location: France
Posts: 1,122
Quote:
How can I measure the quality?
Choose the same frames and compare with your eyes But the fact of using 1 bvop instead of 2 will either increase the bitrate or degrade the quality at the same bitrate (because you said you have a limited bitrate to respect).

Side note: an average quantizer of 3.557 isn't bad at all, considering that bframes@quant4 look nearly the same as pframes@quant2.
__________________

Q9300 OC @ 3.2ghz / Asus P5E3 / 4GB PC10600 / Geforce 8600 GTS
DarkZell666 is offline   Reply With Quote
Old 7th December 2006, 19:43   #7  |  Link
SpeakerBR
Registered User
 
Join Date: Nov 2006
Posts: 11
I had cutted the railings scene using VideoReDo Plus. I hope you can use it. (I cann't cut it with the video with DGindex.) It is uploaded at (5MB):

http://www.megaupload.com/?d=JOJLMA71

New link:
http://www.sendbigfiles.com/download.php?file=5427393

These video contain the scene of the image:



Can you confirm than the arterfacts are by the source?

I had modified the .avs file and replace the desenterlaced filter lines for use another filter:

Quote:
edeintted = last.SeparateFields().SelectEven().EEDI2(field=-1)
TDeint(full=false,edeint=edeintted)
But It too produce interlace artifact. What can I do?

Quote:
Side note: an average quantizer of 3.557 isn't bad at all, considering that bframes@quant4 look nearly the same as pframes@quant2.
OK, I don't know it.

Last edited by SpeakerBR; 9th December 2006 at 12:37.
SpeakerBR is offline   Reply With Quote
Old 9th December 2006, 02:12   #8  |  Link
henryho_hk
Registered User
 
Join Date: Mar 2004
Posts: 889
I can't download the test clip. Can you upload it elsewhere?

------------------------------------------------------------------

I've just tried the test clip. The fast motion is really harsh. Even mvbob() leaves some artifacts. I am trying to upload it somewhere.

Sample clip: http://dump.ru/files/2/2471515/

Since this is a high motion scene, i encode it at 4000kbps with V3LR.

Last edited by henryho_hk; 10th December 2006 at 02:39.
henryho_hk is offline   Reply With Quote
Old 9th December 2006, 18:59   #9  |  Link
SpeakerBR
Registered User
 
Join Date: Nov 2006
Posts: 11
Thanks.
What can i do?
Is a good idea deactivate the deinterlace filter at those frames? Can I deactivate it during any frames (At the .avs file)?

Always can cut the video at 3 parts, but I prefer to not cut, because It can create "clicks" on the audio.

Last edited by SpeakerBR; 9th December 2006 at 19:01.
SpeakerBR is offline   Reply With Quote
Old 10th December 2006, 09:44   #10  |  Link
henryho_hk
Registered User
 
Join Date: Mar 2004
Posts: 889
There is no need to split the video. If you use 2pass encodes, the difficult scenes will be allocated with more bits.

Interestingly, tomsmocomp() works quite well on this clip after mpeg2source()'s deblock is applied. mvbob() works great too. tdeint() improves a bit too but it still leaves residual combs.

mpeg2source("railing.d2v",cpu=4)
colormatrix(d2v="railing.d2v")
tomsmocomp(1,5,0)
degrainMedian(mode=3)

Sample: http://dump.ru/files/7/749008459/
[Teegedeck's Quality Preset Level 45 at 3000kbps]
-------------------------------------------------
It's strange that I fail to reproduce this result again.

Last edited by henryho_hk; 12th December 2006 at 00:55.
henryho_hk is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 10:25.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.