Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 ASP

Reply
 
Thread Tools Search this Thread Display Modes
Old 31st October 2006, 21:58   #1  |  Link
unskinnyboy
Registered User
 
unskinnyboy's Avatar
 
Join Date: Feb 2004
Location: NTSC R1
Posts: 2,047
XviD 1.1.2 bugfix release

From the devel mailing list..

Code:
-----Original Message-----
From: xvid-devel-bounces@xvid.org [mailto:xvid-devel-bounces@xvid.org] On Behalf Of Michael Militzer
Sent: Tuesday, October 31, 2006 3:52 PM
To: xvid-devel@xvid.org
Subject: [XviD-devel] Xvid 1.1.1 is available!

Hello!

This is Xvid 1.1.1 release.

This release is Xvid 1.1.1 bugfix release. It is API compatible with the previous 1.1.0 stable release.

Changes since 1.1.0:

* xvidcore library
  - Fixed bug when frame-drop (N-VOP) feature is used in combination with packed B-frames
  - Fix for premature EOF in xvid_decraw example
  - Fixed potential crash on Intel EMT64 architecture
  - Several fixes for IA64 platform (patch by Thomas Koeckerbauer)
  - Fix for visual_object_verid vs. video_object_layer_verid problem
  - Ensure intervening bytes are preserved in BitstreamInit()

* VFW frontend
  - Prevent segfault when encoding application calls compress_end with NULL
    codec context (PerfectDark at yandex dot ru)
  - Profile definitions updates

* DShow frontend
  - Add missing debug.c

The files are available in the download section of Xvid.org:
http://www.xvid.org/downloads.html

-- The "Xvid Team"
__________________

Last edited by Koepi; 1st November 2006 at 21:21. Reason: Changing thread title to reflect 1.1.2-release
unskinnyboy is offline   Reply With Quote
Old 1st November 2006, 00:10   #2  |  Link
imcold
pencil artist
 
imcold's Avatar
 
Join Date: Jan 2006
Location: Slovakia
Posts: 197
new version + new website ^_^ many thanks xvid people
imcold is offline   Reply With Quote
Old 1st November 2006, 02:35   #3  |  Link
Inventive Software
Turkey Machine
 
Join Date: Jan 2005
Location: Lowestoft, UK (but visit lots of places with bribes [beer])
Posts: 1,953
That website was a long long time coming... I almost lost faith in the XviD team after they said "The new website should be up next week", in May! But I'm gonna have a compile and a play all the same.
__________________
On Discworld it is clearly recognized that million-to-one chances happen 9 times out of 10. If the hero did not overcome huge odds, what would be the point? Terry Pratchett - The Science Of Discworld
Inventive Software is offline   Reply With Quote
Old 1st November 2006, 03:26   #4  |  Link
celtic_druid
Registered User
 
celtic_druid's Avatar
 
Join Date: Oct 2001
Location: Melbourne, Australia
Posts: 2,173
http://home.wildit.net.au/celticdrui...XviD-1.1.2.exe
http://home.wildit.net.au/celticdrui.../xvid-1.1.2.7z

Last edited by celtic_druid; 4th November 2006 at 12:51.
celtic_druid is offline   Reply With Quote
Old 1st November 2006, 03:31   #5  |  Link
prOnorama
Registered User
 
Join Date: Mar 2005
Posts: 249
Cheers, I'll wait until 1.1.1 is on Koepi's site (the official link from XviD.org still shows 1.1.0)
prOnorama is offline   Reply With Quote
Old 1st November 2006, 04:05   #6  |  Link
IgorC
Registered User
 
Join Date: Apr 2004
Posts: 1,237
Good news.

Koepi's compilation should not differ from Celtic's. Even Koepi's compilations aren't free of bug totally. Like in case with uninstal of all codecs from system.
Celtic's compilations are REALLY well knowed. In big mayority they are stable.
IgorC is offline   Reply With Quote
Old 1st November 2006, 04:53   #7  |  Link
celtic_druid
Registered User
 
celtic_druid's Avatar
 
Join Date: Oct 2001
Location: Melbourne, Australia
Posts: 2,173
Well usually I stick with providing svn/cvs builds so there are usually plenty of bugs, just hopefully not caused by anything that I did.

Koepi has definatly become synonymous with XviD binaries though. Speaking of the installer bug. The 1.1 build on afterdawn from recollection is effected so there could be some major instances as people uninstall their 1.1 builds to install 1.1.1. Very easy mistake to make in inno setup though (setting it to delete an entire key instead of just the one value).
celtic_druid is offline   Reply With Quote
Old 1st November 2006, 12:49   #8  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,655
Have these same fixes been applied to the 1.2 branch as well? If so, any chance of a new 1.2 build?
clsid is offline   Reply With Quote
Old 1st November 2006, 15:08   #9  |  Link
henryho_hk
Registered User
 
Join Date: Mar 2004
Posts: 889
~_~ .... I want multi-thread ~~~~
henryho_hk is offline   Reply With Quote
Old 1st November 2006, 15:34   #10  |  Link
celtic_druid
Registered User
 
celtic_druid's Avatar
 
Join Date: Oct 2001
Location: Melbourne, Australia
Posts: 2,173
You want a 1.2 cvs build then. New one up by the way, but this isn't a thread for discussing 1.2 builds.
celtic_druid is offline   Reply With Quote
Old 1st November 2006, 16:06   #11  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,655
Xvid 1.1.2 released
This release is Xvid 1.1.2 bugfix release. It fixes and replaces previous Xvid 1.1.1 release.

Changes since 1.1.1:

Fixed typo in xvid.c
Updated bitstream.h to fix the previous faulty non-aligned bitstream buffers fix
clsid is offline   Reply With Quote
Old 1st November 2006, 16:31   #12  |  Link
Koepi
Moderator
 
Koepi's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 4,455
...and I finally have binaries available, too

Cheers
Koepi
Koepi is offline   Reply With Quote
Old 1st November 2006, 17:00   #13  |  Link
Inventive Software
Turkey Machine
 
Join Date: Jan 2005
Location: Lowestoft, UK (but visit lots of places with bribes [beer])
Posts: 1,953
2 compiles in 6 hours. GCC's been busy on my system.
__________________
On Discworld it is clearly recognized that million-to-one chances happen 9 times out of 10. If the hero did not overcome huge odds, what would be the point? Terry Pratchett - The Science Of Discworld
Inventive Software is offline   Reply With Quote
Old 1st November 2006, 18:18   #14  |  Link
unskinnyboy
Registered User
 
unskinnyboy's Avatar
 
Join Date: Feb 2004
Location: NTSC R1
Posts: 2,047
Quote:
Originally Posted by clsid View Post
Xvid 1.1.2 released
This release is Xvid 1.1.2 bugfix release. It fixes and replaces previous Xvid 1.1.1 release.

Changes since 1.1.1:

Fixed typo in xvid.c
Updated bitstream.h to fix the previous faulty non-aligned bitstream buffers fix
There is one more change to xvidcore which you missed:
  • Added a test_bits bench to xvid_bench.c to test for non-aligned bitstream buffers.
skal added that^^

P.S: Can a MoD change the title of the thread to 'XviD 1.1.2 bugfix release'?
__________________
unskinnyboy is offline   Reply With Quote
Old 1st November 2006, 18:59   #15  |  Link
bob0r
Pain and suffering
 
bob0r's Avatar
 
Join Date: Jul 2002
Posts: 1,337
celtic_druid, Koepi:
Mind sharing your install script(s) with me?
bob0r is offline   Reply With Quote
Old 1st November 2006, 18:59   #16  |  Link
KornX
primus inter pares
 
KornX's Avatar
 
Join Date: Feb 2004
Posts: 70
hi folks, especially koepi,
what about smp support?
went the code from that release in?

(Latest unstable binary
XviD-1.2.-127-25022006.exe (630kb)
Changelog to XviD-1.1:
- {core}: New experimental SMP support.
- {core}: Trellis improvements (according to sysKin).
- On uniprocessor machines set number of threads to 0!)

KornX
__________________
Field Application Engineer
Advanced Micro Devices
KornX is offline   Reply With Quote
Old 1st November 2006, 20:07   #17  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,655
SMP support is not included in 1.1.x, but only in 1.2.x (= current CVS).
clsid is offline   Reply With Quote
Old 2nd November 2006, 02:08   #18  |  Link
EEPROM
Registered User
 
EEPROM's Avatar
 
Join Date: Dec 2005
Posts: 45
Excused the ignorance, but if during encoding the cpu(AMD 3800X2) works to 100%, does not mean that codec included smp support?
Because i've tested the new build and cpu has worked at 100%
http://forum.doom9.org/showpost.php?...postcount=4232
__________________
sorry for my bad english
EEPROM is offline   Reply With Quote
Old 2nd November 2006, 11:47   #19  |  Link
henryho_hk
Registered User
 
Join Date: Mar 2004
Posts: 889
Not if you are using new version of Virtualdub, which seems to be using separate threads for reading (i.e., incl. avisynth processing) and encoding.
henryho_hk is offline   Reply With Quote
Old 2nd November 2006, 12:29   #20  |  Link
EEPROM
Registered User
 
EEPROM's Avatar
 
Join Date: Dec 2005
Posts: 45
If I have not understood badly,my CPU work at 100% with AutoGK 2.36b(VirtualDubMod) but with new version of VirtualDub or another program, my cpu Work at 50%?
__________________
sorry for my bad english
EEPROM is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 19:22.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.