Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Development

Reply
 
Thread Tools Search this Thread Display Modes
Old 20th July 2005, 20:22   #61  |  Link
mp3boy
Registered User
 
Join Date: Mar 2002
Location: Tehran/Iran
Posts: 71
the file doesn't have sound but virtualdub 32bit also cannot play the file, when I tried to open in device manager it says: "Cannot load the VFAPI 1.05 Driver. the driver may be missing. Try installing the driver agian, or contact your system administrator".

I tried to reinstall the coded for many times.

I also like to add that I have xvid 32bit installed but VirtualDub doesn't detct it and Device Manager (video codec) open its properties with no error.


thanks
mp3boy is offline   Reply With Quote
Old 21st July 2005, 02:12   #62  |  Link
squid_80
Registered User
 
Join Date: Dec 2004
Location: Melbourne, AU
Posts: 1,963
How is the VFAPI driver installed? With an exe or an inf file?
squid_80 is offline   Reply With Quote
Old 21st July 2005, 05:47   #63  |  Link
mp3boy
Registered User
 
Join Date: Mar 2002
Location: Tehran/Iran
Posts: 71
it installed with a batch file containing this:

rundll32.exe advpack.dll,LaunchINFSection vifp.inf,DefaultInstall

and this inf file content which is installing fine:

Code:
[Version]
Signature="$CHICAGO$"

[DefaultInstall]
CopyFiles  = CodecCopyFiles
UpdateInis = vifp.UpdateIni

[DefaultInstall.NT]
CopyFiles = CodecCopyFiles
AddReg    = RegCodecNT

[DestinationDirs]
CodecCopyFiles=11

[vifp.UpdateIni]
system.ini, drivers32,,"VIDC.VIFP=VFCodec.dll"

[RegCodecNT]
HKLM, "Software\Microsoft\Windows NT\CurrentVersion\Drivers32","vidc.vifp", ,"VFCodec.dll"
HKLM, "Software\Microsoft\Windows NT\CurrentVersion\Drivers.desc", "VFCodec.dll",, "VFAPI 1.05"

[SourceDisksNames]
1="VFAPI Reader Codec v1.05 install","",1

[CodecCopyFiles]
VFCodec.dll

[SourceDisksFiles]
VFCodec.dll=1
and this is the other inf file which has problem to load:
Code:
[Installable.Drivers]
VIFP = VFCodec.dll, "VIDC.VIFP", "VFAPI Reader Codec 1.05" , , ,
mp3boy is offline   Reply With Quote
Old 21st July 2005, 07:19   #64  |  Link
squid_80
Registered User
 
Join Date: Dec 2004
Location: Melbourne, AU
Posts: 1,963
That's the problem. Win64 thinks it is a 64-bit driver and is trying to install it as such. Try changing the line in the batch file to:
c:\windows\syswow64\rundll32.exe advpack.dll,LaunchINFSection vifp.inf,DefaultInstall

You might need to change the c:\windows part, depending on where your windows installation is. Let me know if it helps.
squid_80 is offline   Reply With Quote
Old 21st July 2005, 07:49   #65  |  Link
mp3boy
Registered User
 
Join Date: Mar 2002
Location: Tehran/Iran
Posts: 71
thanks mate, its working now, I dont know why it was not working before. however the video codec in device manager for vfapi still gives error which doesn't matter anyway.

actually I thought that I need every single codec to be converted to 32bit in order to be able to use, but virtualdub32 still doesn't detect Divx3,4,5 and xvid even though i have installed the codec
mp3boy is offline   Reply With Quote
Old 18th August 2005, 07:16   #66  |  Link
squid_80
Registered User
 
Join Date: Dec 2004
Location: Melbourne, AU
Posts: 1,963
New x64 plugins

Decomb (source)
UnDot (source)
squid_80 is offline   Reply With Quote
Old 16th October 2005, 02:49   #67  |  Link
Calculon
Registered User
 
Join Date: Jan 2003
Posts: 30
Are these files no longer available? I keep getting a 404 error and I would like to try this version.

Last edited by Calculon; 17th October 2005 at 07:52.
Calculon is offline   Reply With Quote
Old 16th October 2005, 03:05   #68  |  Link
squid_80
Registered User
 
Join Date: Dec 2004
Location: Melbourne, AU
Posts: 1,963
Give me a few days, had to change ISP. I'll post new links soon.
squid_80 is offline   Reply With Quote
Old 16th October 2005, 05:36   #69  |  Link
squid_80
Registered User
 
Join Date: Dec 2004
Location: Melbourne, AU
Posts: 1,963
I've quickly setup a FTP server: ftp://squid80.no-ip.com

Should be available most of the time, might be down now and then between reboots.
squid_80 is offline   Reply With Quote
Old 17th October 2005, 06:46   #70  |  Link
Calculon
Registered User
 
Join Date: Jan 2003
Posts: 30
Thank you.
Calculon is offline   Reply With Quote
Old 4th November 2005, 02:49   #71  |  Link
wiak
Registered User
 
Join Date: Jul 2003
Location: somewhere north
Posts: 260
Squid can you compile lanczos4 for x64?
lanczos4 is faster to
wiak is offline   Reply With Quote
Old 4th November 2005, 06:04   #72  |  Link
squid_80
Registered User
 
Join Date: Dec 2004
Location: Melbourne, AU
Posts: 1,963
Lanczos4 should already be working, did you try it?
squid_80 is offline   Reply With Quote
Old 12th July 2006, 11:57   #73  |  Link
Bluedan
Registered User
 
Bluedan's Avatar
 
Join Date: Oct 2001
Location: were people always get wet feet
Posts: 328
Hm. Squid, have you given up on this project? Your ftp server is unavailable and the temporary avisynth64 compile also.

Unfortunately, I am unable to code by myself.
__________________
I'm probably misconfused...
Bluedan is offline   Reply With Quote
Old 12th July 2006, 12:07   #74  |  Link
squid_80
Registered User
 
Join Date: Dec 2004
Location: Melbourne, AU
Posts: 1,963
Just started getting back to it, I've just finished doing levels and overlay.

See http://okejl.dk/dunstan/ for latest builds. (Note that filters.txt in the zip file is probably not up to date, if you want to know if something works just try it and see what happens.)
squid_80 is offline   Reply With Quote
Old 12th July 2006, 12:24   #75  |  Link
Bluedan
Registered User
 
Bluedan's Avatar
 
Join Date: Oct 2001
Location: were people always get wet feet
Posts: 328
Quote:
Originally Posted by squid_80
Just started getting back to it...
Glad to hear.

Quote:
See http://okejl.dk/dunstan/ for latest builds. (Note that filters.txt in the zip file is probably not up to date, if you want to know if something works just try it and see what happens.)
Will do that. Thanks for your efforts! Really appreciated!
__________________
I'm probably misconfused...
Bluedan is offline   Reply With Quote
Old 29th July 2006, 23:47   #76  |  Link
BoNz1
Registered User
 
BoNz1's Avatar
 
Join Date: Dec 2002
Location: Great White North
Posts: 522
Hi, I just got myself a new AMD64 x2. So, I'm running Windows XP Pro x64 on it. I put avisynth.dll in the windows/system32 dir and ran the reg patcher. My avisynth script looks like this:

loadplugin("E:\Video\DGDecode.dll")
mpeg2source("E:\A_NEW_HOPE\VIDEO_TS\A New Hope.d2v")

When I load this avisynth script into Virtualdub 1.6.15 AMD64 I get this error:

"This application failed to start because libmmd.dll was not found."

I also have squid_80's latest xvid64 release installed. I have placed the libmmd.dll in my virtualdub folder with the dgdecode plugin in the same directory. This gives the same error. When I place it in the system32 dir I also get this error. Can anyone help me out? Cheers.
BoNz1 is offline   Reply With Quote
Old 30th July 2006, 05:53   #77  |  Link
squid_80
Registered User
 
Join Date: Dec 2004
Location: Melbourne, AU
Posts: 1,963
Where did you get that copy of libmmd.dll? It would need to be a 64-bit version of Intel's math library, which I can't seem to find out on the net. I have it here on my machine of course, but I can't find anything that says I'm allowed to redistribute it.
-------
OK, apparently I am allowed. Unfortunately it's a great big whopping thing of 1.36mb, so in the future I'll make sure to stick to multi-threaded builds instead of multi-threaded dynamic.
http://okejl.dk/dunstan/libmmd.zip
Clear out all the other copies, stick this in \windows\sytem32 and everything should work.
squid_80 is offline   Reply With Quote
Old 30th July 2006, 16:46   #78  |  Link
BoNz1
Registered User
 
BoNz1's Avatar
 
Join Date: Dec 2002
Location: Great White North
Posts: 522
Hi,

That fixed it, thanks .
BoNz1 is offline   Reply With Quote
Old 24th September 2006, 06:59   #79  |  Link
nibbles
Registered User
 
nibbles's Avatar
 
Join Date: Aug 2006
Posts: 50
Nice work on the 64bit port. Any chance we'll see a TcpDeliver.dll for it?
I have a huge file I'd like to serve over the network.
TDeint running on 1, DeGrainMedian64 on the other.
Ok, thanks.
nibbles is offline   Reply With Quote
Old 2nd October 2006, 05:23   #80  |  Link
squid_80
Registered User
 
Join Date: Dec 2004
Location: Melbourne, AU
Posts: 1,963
Quote:
Originally Posted by nibbles View Post
Any chance we'll see a TcpDeliver.dll for it?
It's harder than it sounds because of the compression libraries used. But as soon as I get some decent time I'll try again.
squid_80 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 05:23.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.