Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 13th May 2005, 11:51   #1  |  Link
Hobojobo
don't blame me!
 
Hobojobo's Avatar
 
Join Date: Mar 2002
Location: Germany
Posts: 276
Probably not the right place:
I muxed xvid video with a vbr-mp3 audio and subtitle stream into a mp4-container with your great tool.

The playblack is sort of choppy.
How can I make the subtitles show up?

I use:
Media Player Classic
Haali Medi Splitter
ffdshow-20050303
Hobojobo is offline   Reply With Quote
Old 13th May 2005, 12:14   #2  |  Link
planet1
... space nerd ...
 
planet1's Avatar
 
Join Date: Feb 2004
Location: Terra
Posts: 151
Quote:
Originally posted by Hobojobo
The playblack is sort of choppy.
Try different mpeg4 asp decoder filters.


Quote:
Originally posted by Hobojobo

How can I make the subtitles show up?

I use:
Media Player Classic
Haali Medi Splitter
ffdshow-20050303
Media Player Classic should be in "VMR9 renderless" mode.
You need to activate the subs by right-clicking on the splitter icon.
planet1 is offline   Reply With Quote
Old 13th May 2005, 12:55   #3  |  Link
Hobojobo
don't blame me!
 
Hobojobo's Avatar
 
Join Date: Mar 2002
Location: Germany
Posts: 276
Quote:
Originally posted by planet1
You need to activate the subs by right-clicking on the splitter icon.
Question:
Which icon do you mean. And where can I find it?
Hobojobo is offline   Reply With Quote
Old 13th May 2005, 14:00   #4  |  Link
planet1
... space nerd ...
 
planet1's Avatar
 
Join Date: Feb 2004
Location: Terra
Posts: 151
Quote:
Originally posted by Hobojobo
Question:
Which icon do you mean. And where can I find it?
systemtray



its the small version of the matroska logo:


Its always there when the splitter is active ...

Last edited by bond; 16th May 2005 at 12:58.
planet1 is offline   Reply With Quote
Old 13th May 2005, 17:19   #5  |  Link
bond
Registered User
 
Join Date: Nov 2001
Posts: 9,779
Quote:
Originally posted by Hobojobo
I muxed xvid video with a vbr-mp3 audio and subtitle stream into a mp4-container with your great tool.

The playblack is sort of choppy.
try if its choppy with the nero parser filter too

and/or upload the .mp4 files somewhere plz so i can have a look
__________________
Between the weak and the strong one it is the freedom which oppresses and the law that liberates (Jean Jacques Rousseau)
I know, that I know nothing (Socrates)

MPEG-4 ASP FAQ | AVC/H.264 FAQ | AAC FAQ | MP4 FAQ | MP4Menu stores DVD Menus in MP4 (guide)
Ogg Theora | Ogg Vorbis
use WM9 today and get Micro$oft controlling the A/V market tomorrow for free

Last edited by bond; 16th May 2005 at 12:58.
bond is offline   Reply With Quote
Old 16th May 2005, 13:19   #6  |  Link
bond
Registered User
 
Join Date: Nov 2001
Posts: 9,779
splitted to an own thread

so, Hobojobo, any news on this?
__________________
Between the weak and the strong one it is the freedom which oppresses and the law that liberates (Jean Jacques Rousseau)
I know, that I know nothing (Socrates)

MPEG-4 ASP FAQ | AVC/H.264 FAQ | AAC FAQ | MP4 FAQ | MP4Menu stores DVD Menus in MP4 (guide)
Ogg Theora | Ogg Vorbis
use WM9 today and get Micro$oft controlling the A/V market tomorrow for free
bond is offline   Reply With Quote
Old 16th May 2005, 23:13   #7  |  Link
Hobojobo
don't blame me!
 
Hobojobo's Avatar
 
Join Date: Mar 2002
Location: Germany
Posts: 276
It works.

I uninstalled ffdshow, version 20050328 and installed 20050303, I think that has caused the trouble.

Now I have my xvid clips with subs in a mp4 container. Great.


One question:
I can choose srt or ttxt files as format to mux in mp4.
Which way is smarter, in order to produce a 100% conform playable mp4 (for a stand alone device with mp4 support)?
Hobojobo is offline   Reply With Quote
Old 16th May 2005, 23:17   #8  |  Link
bond
Registered User
 
Join Date: Nov 2001
Posts: 9,779
the latest ffdshow version is from 6.4, which you can get here

Quote:
Originally posted by Hobojobo
I can choose srt or ttxt files as format to mux in mp4.
Which way is smarter, in order to produce a 100% conform playable mp4
it doesnt matter, as mp4box converts srt to ttxt while importing "on the fly"

Quote:
(for a stand alone device with mp4 support)?
none of the existing standalones supports ttxt, only vobsub subs as placed in .mp4 with nero recode
__________________
Between the weak and the strong one it is the freedom which oppresses and the law that liberates (Jean Jacques Rousseau)
I know, that I know nothing (Socrates)

MPEG-4 ASP FAQ | AVC/H.264 FAQ | AAC FAQ | MP4 FAQ | MP4Menu stores DVD Menus in MP4 (guide)
Ogg Theora | Ogg Vorbis
use WM9 today and get Micro$oft controlling the A/V market tomorrow for free
bond is offline   Reply With Quote
Old 16th May 2005, 23:35   #9  |  Link
Hobojobo
don't blame me!
 
Hobojobo's Avatar
 
Join Date: Mar 2002
Location: Germany
Posts: 276
Thanks for the quick answer.

I tried another clip.

After muxing the video into mp4 MPC tells me "MP4: sample_descriptor_index in stsc !=1" and refuse to playback the clip.

gSpot is saying something about "DivX Style "packed bitstream" AVI.

Is there something I can do ?
Hobojobo is offline   Reply With Quote
Old 16th May 2005, 23:35   #10  |  Link
bond
Registered User
 
Join Date: Nov 2001
Posts: 9,779
which mp4 muxer did you use?
__________________
Between the weak and the strong one it is the freedom which oppresses and the law that liberates (Jean Jacques Rousseau)
I know, that I know nothing (Socrates)

MPEG-4 ASP FAQ | AVC/H.264 FAQ | AAC FAQ | MP4 FAQ | MP4Menu stores DVD Menus in MP4 (guide)
Ogg Theora | Ogg Vorbis
use WM9 today and get Micro$oft controlling the A/V market tomorrow for free
bond is offline   Reply With Quote
Old 16th May 2005, 23:38   #11  |  Link
Hobojobo
don't blame me!
 
Hobojobo's Avatar
 
Join Date: Mar 2002
Location: Germany
Posts: 276
Yamb 1.2.1 comes along with MP4BOX. That's what I used.
Hobojobo is offline   Reply With Quote
Old 16th May 2005, 23:43   #12  |  Link
bond
Registered User
 
Join Date: Nov 2001
Posts: 9,779
make sure you use the latest version of mp4box and haali here
http://haali.cs.msu.ru/mkv/ and
http://www.aziendeassociate.it/cd.asp?dir=/gpac/dev
__________________
Between the weak and the strong one it is the freedom which oppresses and the law that liberates (Jean Jacques Rousseau)
I know, that I know nothing (Socrates)

MPEG-4 ASP FAQ | AVC/H.264 FAQ | AAC FAQ | MP4 FAQ | MP4Menu stores DVD Menus in MP4 (guide)
Ogg Theora | Ogg Vorbis
use WM9 today and get Micro$oft controlling the A/V market tomorrow for free
bond is offline   Reply With Quote
Old 17th May 2005, 00:13   #13  |  Link
Hobojobo
don't blame me!
 
Hobojobo's Avatar
 
Join Date: Mar 2002
Location: Germany
Posts: 276
I updated MP4Box.

I did some tests.
The subtitle file in causing the trouble.
When I untick the subtitles in Yamb, then the mp4 clip is playing fine.

I have tried to mux the subs in srt format directly, then I tried the converted subs, did not make a difference.
I checked the subtitle file in Subtitle Workshop. No errors.

So, somehow the Haali splitter is tripping over the subtitle file.
Interesting.

Hobojobo is offline   Reply With Quote
Old 17th May 2005, 00:24   #14  |  Link
bond
Registered User
 
Join Date: Nov 2001
Posts: 9,779
did you upate the haali splitter to the last version?
__________________
Between the weak and the strong one it is the freedom which oppresses and the law that liberates (Jean Jacques Rousseau)
I know, that I know nothing (Socrates)

MPEG-4 ASP FAQ | AVC/H.264 FAQ | AAC FAQ | MP4 FAQ | MP4Menu stores DVD Menus in MP4 (guide)
Ogg Theora | Ogg Vorbis
use WM9 today and get Micro$oft controlling the A/V market tomorrow for free
bond is offline   Reply With Quote
Old 17th May 2005, 09:24   #15  |  Link
Hobojobo
don't blame me!
 
Hobojobo's Avatar
 
Join Date: Mar 2002
Location: Germany
Posts: 276
Yep.

Running on my system:

Haali Medi Splitter 2005/05/03
ffdshow 2005/03/03
MP4Box 2005/05/16

I report back after running some more tests.

And thanks for your help.
Hobojobo is offline   Reply With Quote
Old 17th May 2005, 10:05   #16  |  Link
Hobojobo
don't blame me!
 
Hobojobo's Avatar
 
Join Date: Mar 2002
Location: Germany
Posts: 276
I figured out the problem.

The splitter does not like italic subtitles.

When I switch the subtitle to plain style, without any tags, the resulting clip with embedded subs is playing fine.

Is it a known limitation?

Great.
I do not really need italic subtitles.
So, I am fine with the workaround.
Hobojobo is offline   Reply With Quote
Old 19th May 2005, 21:07   #17  |  Link
Hobojobo
don't blame me!
 
Hobojobo's Avatar
 
Join Date: Mar 2002
Location: Germany
Posts: 276
I am confused.
The subtitle problem came back.

I cleaned up my system, new w2k install.
I installed:

ffdshow 20050303
Haali's MediaSplitter 20050503
MPC 6.4.8.4 (directshow video VMR9 renderless)

mp4 clips are playing fine, but the subs are gone.
The icon of the Haali's splitter does not show up in the task bar. show tray icon: yes.
Under filter (in MPC) there is only GPAC Audio and Video Handler.

Does the order in which I install the filters has got to do with it?
Any suggestions?
Hobojobo is offline   Reply With Quote
Old 19th May 2005, 21:49   #18  |  Link
bond
Registered User
 
Join Date: Nov 2001
Posts: 9,779
i assume the haali splitter isnt used, but another mp4 splitter, like nero
__________________
Between the weak and the strong one it is the freedom which oppresses and the law that liberates (Jean Jacques Rousseau)
I know, that I know nothing (Socrates)

MPEG-4 ASP FAQ | AVC/H.264 FAQ | AAC FAQ | MP4 FAQ | MP4Menu stores DVD Menus in MP4 (guide)
Ogg Theora | Ogg Vorbis
use WM9 today and get Micro$oft controlling the A/V market tomorrow for free
bond is offline   Reply With Quote
Old 19th May 2005, 22:46   #19  |  Link
Hobojobo
don't blame me!
 
Hobojobo's Avatar
 
Join Date: Mar 2002
Location: Germany
Posts: 276
Strike.

I installed Nero Burning Rom Demo.
After deinstallation Haali's Splitter took the con.

Is there a way to force the use of Haali's splitter ?
Hobojobo is offline   Reply With Quote
Old 19th May 2005, 23:00   #20  |  Link
bond
Registered User
 
Join Date: Nov 2001
Posts: 9,779
give haali a higher merit as the nero parser with the radlight filter manager:
http://forum.doom9.org/showthread.php?s=&threadid=67687
__________________
Between the weak and the strong one it is the freedom which oppresses and the law that liberates (Jean Jacques Rousseau)
I know, that I know nothing (Socrates)

MPEG-4 ASP FAQ | AVC/H.264 FAQ | AAC FAQ | MP4 FAQ | MP4Menu stores DVD Menus in MP4 (guide)
Ogg Theora | Ogg Vorbis
use WM9 today and get Micro$oft controlling the A/V market tomorrow for free
bond is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 19:22.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.