Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 27th June 2004, 15:32   #1  |  Link
ViRuZ
Registered User
 
Join Date: Oct 2001
Location: @home
Posts: 19
How to rearange audio tracks inside an ogm file?

Hi,

I got a problem with .ogm files which I can't solve on my own.
I allready did a search on the topic but couldn't find anything about it in the forums.

I got some .ogm files with two auido tracks (both ogg vorbis) and one subtitle track (.srt) muxed into one .ogm file (of course).

The files are anime episodes with english audio and japanese audio and english subtitles.

Well my problem here is that the english track, which is the default track that is played, sucks balls.

It's very annoying to enable the japanese track and subtitles manually for each episode.

So I want to remove the english audio track or rearrange the tracks so that the japanese track and the subtitle track playback as default tracks.

Is this possible and what tools do I need to alter the files the way I want them?

ViRuZ
ViRuZ is offline   Reply With Quote
Old 27th June 2004, 15:43   #2  |  Link
ViRuZ
Registered User
 
Join Date: Oct 2001
Location: @home
Posts: 19
Ok,

after experimenting some more with VDubMod I found out how to remove the english audio.

Now I got the promlem that I can't get the subtitles to show by default. Japanes Audio only is annoying too

The streams in the .ogm file are shown like this (in VDubMod Streamlist):

1 Source : Ogg Media File
Desc. : OGM audio stream 1 (vorbis), 2ch, 48000Hz, 96.0kbps
Length : 00:26:15.403

2 Source : Ogg Media File
Desc. : Ogg Media File Text Stream 1
Length : 00:24:12.205

Any suggestions?

ViRuZ
ViRuZ is offline   Reply With Quote
Old 27th June 2004, 16:22   #3  |  Link
Koepi
Moderator
 
Koepi's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 4,455
The subtitles are activated by default - depending on your subtitle filter they#re shown or not.

So it's a filter setup issue (try enabling "all streams" in the OggDS filters).

Koepi
Koepi is offline   Reply With Quote
Old 27th June 2004, 16:35   #4  |  Link
ViRuZ
Registered User
 
Join Date: Oct 2001
Location: @home
Posts: 19
Ok,

works for my Zoomplayer now. Thanks for the reply.

Only thing left to do is to request a "play all streams" feature for xbmc (xbox media center)

Thx for your help.

ViRuZ

// Edit

Fixed some spelling mistakes

ViRuZ


Last edited by ViRuZ; 27th June 2004 at 16:40.
ViRuZ is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 11:02.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.