Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Audio encoding

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 24th May 2004, 15:21   #81  |  Link
neo75903
The One, as in unique :)
 
neo75903's Avatar
 
Join Date: Feb 2004
Posts: 504
@Valex

idd, all seems to work fine except from sending a AC3 signal to my amp.
The result is a cracky noisy sound which i presume the ac3 encoding part is not right yet.
I have a Sony STR DB1070 amp, which is an excellent AC3 decoder, and that Multi Chan led is so kewl when it is lid on

btw nice peace of software!

Regards Neo75903
__________________
Mr. Anderson, welcome back. We...missed you.
-= Agent Smith, The Matrix Revolutions =-
neo75903 is offline  
Old 24th May 2004, 15:24   #82  |  Link
neo75903
The One, as in unique :)
 
neo75903's Avatar
 
Join Date: Feb 2004
Posts: 504
AC3 signal

i mean AC3 signal encoded from my 5.1aac source.
AC3 source works perfect.
Is it true that AC3 filter is going to support 5.1aac?

pls say yes

PS testing DVD playback soon.
__________________
Mr. Anderson, welcome back. We...missed you.
-= Agent Smith, The Matrix Revolutions =-
neo75903 is offline  
Old 24th May 2004, 15:31   #83  |  Link
Valex
Registered User
 
Join Date: Sep 2002
Posts: 144
@neo75903
>Is it true that AC3 filter is going to support 5.1aac?

Yes, but later. Noew I want to make at least first release of new version...

>PS testing DVD playback soon.
If you have mixed formats DVDs please try what yevaman wrote about... (switch between formats in SPDIF output mode)
Valex is offline  
Old 24th May 2004, 18:16   #84  |  Link
yevaman
Registered User
 
Join Date: Feb 2004
Posts: 14
What about my problems Valex ? did u find something ?

If u need real time test we can meet on irc if u want..
yevaman is offline  
Old 24th May 2004, 19:30   #85  |  Link
HarryM
Registered User
 
Join Date: May 2002
Location: Czech rep.
Posts: 390
Valex:

Milan works intensively on a audio part of "ffdshow", which is similar to your second-generation AC3filter project (multiformat audio decoder).

Can you colaborate on this?
__________________
Czech DivX/XviD discussion club
HarryM is offline  
Old 24th May 2004, 19:44   #86  |  Link
Blight
Software Developer
 
Blight's Avatar
 
Join Date: Oct 2001
Location: Israel
Posts: 993
Valex:
There seems to be some sort of timing issue with DTS decoding, here are the details:

1. DTS VOB file from http://www.cinenow.com/us/vobtrailer.php3/id,19/
2. Open Source MPEG Splitter http://inmatrix.osnn.net/osmpegsplitter29032004_nt.exe
3. Open Source MPEG2 Video Decoder http://www.inmatrix.com/download/osm...9032004_nt.exe

Graph is:

File Source Async -> Splitter -> Video Decoder -> Overlay Mixer -> Video Renderer
________________________ -> AC3 Filter -> Default DirectShow Device

I've experimented with this in GraphEdit with the AC3 Filter at it's default setting (Audio decoded to 2.0 stereo, no S/PDIF).

What happens is that the VOB is played in slow-motion. When trying to use the OpenSource Audio Decoder, it plays the clip smoothly.
__________________
Yaron Gur
Zoom Player . Lead Developer
Blight is offline  
Old 24th May 2004, 20:11   #87  |  Link
Frisco
Registered User
 
Join Date: Nov 2001
Posts: 32
SPDIF passthrough

Thanx Valex for the great codec

My Setup is :

Main\Output
- Dolby ProLogic II
- PCM 16 bit
- "True" in SPDIF

System\Use AC3Filter for..
- "True" in AC3

System\SPDIF
- "True" in AC3

This, SPDIF passthrougt, work in RC2, but not in RC4.

(Input sound is AC3 - 48000Hz)

Hi Frisco
Frisco is offline  
Old 24th May 2004, 21:38   #88  |  Link
hippoth
playboi
 
hippoth's Avatar
 
Join Date: Dec 2001
Location: Dschörmänie
Posts: 100
I have also some problems...

Problems with RC4:

I don´t get S/PDIF passthrough (5.1 AC3 48 KHz), when I disable "SPDIF (disable)" in the main-register despite it is enabled in the system-register (I have all options enabled there)...I mean I don´t have any AC3 5.1 sound with this options but I can hear 2.0 AC3 (your maria.ac3 test file) and stereo sound files

...and in the contrary I can´t play normal stereo and 2.0 AC3 (your maria.ac3 test file) files when I enable "SPDIF (disable)" in the main-register but get S/PDIF passthrough for 5.1

for understanding:

what do I have to set in the main-register, in the output?
what quantisation I have to choose for the PCM...16, 24, 32 or float?

and a last understanding question: when I enable the "SPDIF (disable)"-switch in the main-register your filter tries to encode the stereo to an AC3 singnal or?


I hope it´s not to confusing
hippoth is offline  
Old 24th May 2004, 22:14   #89  |  Link
neo75903
The One, as in unique :)
 
neo75903's Avatar
 
Join Date: Feb 2004
Posts: 504
@Valex,

DVD playback trials.
- DVD playback with SPDIF did not work. Tried it with several DVDs.
Movie hangs at the very first second, Analogue playback is ok.

- Locally saved saved VOBS (no menu, main movie only) do play correctly through SPDIF with a few ticks or interruption here and while which does not occur when i passthrough the signal. Analogue is also ok.

Guess AC3 encoding need some more work.

MPC 6.4.8.2, all filters switched off.

Well so far my evening, good nite lads
__________________
Mr. Anderson, welcome back. We...missed you.
-= Agent Smith, The Matrix Revolutions =-
neo75903 is offline  
Old 24th May 2004, 22:47   #90  |  Link
Rash
Registered User
 
Rash's Avatar
 
Join Date: Aug 2002
Posts: 403
Just a question. The Bass Redirection is the one that mixes the LFE channel on the other outputs, for those 4.0 with filtered sub-woofer like me?

Thanks a lot Valex, once again.
Rash is offline  
Old 24th May 2004, 23:32   #91  |  Link
yevaman
Registered User
 
Join Date: Feb 2004
Posts: 14
"DVD playback trials.
- DVD playback with SPDIF did not work. Tried it with several DVDs.
Movie hangs at the very first second, Analogue playback is ok."

Same problems there , analog is ok but as soon as it switch to 5.1 or dts --> freeze

Divx+ ac3 ok anyway
Dts sample too

Divx + 2 way stereo -> crappy sound


All with SPDIF output
yevaman is offline  
Old 25th May 2004, 00:17   #92  |  Link
basje
Registered User
 
Join Date: Jan 2004
Posts: 9
Quote:
Originally posted by yevaman
"DVD playback trials.
- DVD playback with SPDIF did not work. Tried it with several DVDs.
Movie hangs at the very first second, Analogue playback is ok."

Same problems there , analog is ok but as soon as it switch to 5.1 or dts --> freeze

Divx+ ac3 ok anyway
Dts sample too

Divx + 2 way stereo -> crappy sound


All with SPDIF output
I have the exact same problem with DVD playback. I get 100% CPU use. Analog is fine.

Groeten,

Bas
basje is offline  
Old 25th May 2004, 01:05   #93  |  Link
Mitchjs
Registered User
 
Join Date: Dec 2002
Posts: 63
Valex,

RC4 is definitly broken on DTS

when it sees my .dts file i see the stream input section going crazy
it never passes, and i get silence

going back to RC2 works

keep up the good work... anything to help

if ya can squeeze in me the disable all AC3 encode, then
i can use this filter for mpg and pcm (i want the NForce HW to do the encode)

mitch
Mitchjs is offline  
Old 25th May 2004, 04:52   #94  |  Link
Firewave
Registered User
 
Join Date: Feb 2004
Posts: 10
I got a problem with the "Output". I set it to "2/0+SW 2.1 stereo" in the OFFLINE configuration. When I start a movie and got into the configuration of the AC3Filter it shows "3/0 - 3 front". And when I go into the OFFLINE configuration after that it's also set to "3/0 - 3 front".
Using the 1.01a RC4.
Firewave is offline  
Old 25th May 2004, 10:21   #95  |  Link
dimzon
BeHappy/MeGUI developer
 
dimzon's Avatar
 
Join Date: Oct 2003
Location: Moscow, Russia
Posts: 1,727
Quote:
Originally posted by HarryM
Valex:

Milan works intensively on a audio part of "ffdshow", which is similar to your second-generation AC3filter project (multiformat audio decoder).

Can you colaborate on this?
Yeah, I think it's good idea!
dimzon is offline  
Old 25th May 2004, 11:08   #96  |  Link
Gibalou
Registered User
 
Join Date: Feb 2004
Posts: 6
I've been looking for the source code of this pre-release version and couldn't find it.

Anybody knows where it is available ?
Gibalou is offline  
Old 25th May 2004, 14:13   #97  |  Link
oddball
Registered User
 
Join Date: Jan 2002
Posts: 1,261
Just to confirm that AC3 passthru does not work over SPDIF in RC4 (It just sends PCM not matter what).
oddball is offline  
Old 25th May 2004, 15:36   #98  |  Link
Valex
Registered User
 
Join Date: Sep 2002
Posts: 144
@Blight

Everything is too sad...

First. The OpenSource MPEG2 Splitter has a bug. It detects 22050Hz DTS where it is 48000Hz... I follow timestamps come from upstream (otherwise desync is possible in some cases) what leads to slow audio playback...

Second. Standard MPEG2 Splitter (and MPEG2 Demultiplexer) does not understand .vob with only one dts track.

Third. Media Player Classics has the same problem with sample rate detection when switching from ac3 to dts track. In case of only one dts track player decodes it by itself regardless of the fact that decoder is turned off in options.

Valex is offline  
Old 25th May 2004, 15:44   #99  |  Link
Valex
Registered User
 
Join Date: Sep 2002
Posts: 144
@All
http://ac3filter.sourceforge.net/dow..._1_01a_rc5.exe
SPDIF passthrough is back...
Valex is offline  
Old 25th May 2004, 15:47   #100  |  Link
Valex
Registered User
 
Join Date: Sep 2002
Posts: 144
@Rash
>Just a question. The Bass Redirection is the one that mixes the LFE channel on the other outputs, for those 4.0 with filtered sub-woofer like me?

No. Bass redirection routes basses from all channes to subwoofer (if exists at output). So it is not required for you (it just does not work in your case).
Valex is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 16:55.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.