Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > (Auto) Gordian Knot

Reply
 
Thread Tools Search this Thread Display Modes
Old 2nd March 2004, 17:08   #1  |  Link
sebfernando
Registered User
 
Join Date: Jul 2003
Posts: 8
Virtualdub Mod Error

I always get this virtuldub mod error, after the first pass, i took a screenshot of the problem and can been seen below. Here is the log:

---------------------------
02/03/2004 07:45:41: Job " 2" started.

o Xvid - First Pass: F:\FAMILY_GUY_DISC1\VIDEO_TS\bob.avs
o Xvid - Second Pass: F:\FAMILY_GUY_DISC1\VIDEO_TS\bob.avs
o Mux Audio.
End of Job 1 ( 2).
_______________________________________________________________________________________________________________________

Gordian Knot -
Encoding Job Data:

Type: EncXvid_All
Number: 1
Name: 2
Platform: WinXP (5.1.2600).2

Files:
VirtualDubModExe: C:\PROGRA~1\GORDIA~1\VirtualDubMod\VirtualDubMod.exe
NandubExe: C:\PROGRA~1\GORDIA~1\nandub\Nandub.exe
AviFinal: F:\FAMILY_GUY_DISC1\VIDEO_TS\bob.avi
AviMovie: F:\FAMILY_GUY_DISC1\VIDEO_TS\bob_Movie.avi
AviCredits: F:\FAMILY_GUY_DISC1\VIDEO_TS\bob_Credits.avi
MovieFS: F:\FAMILY_GUY_DISC1\VIDEO_TS\bob.avs
CreditsFS:
Log : F:\FAMILY_GUY_DISC1\VIDEO_TS\bob.log
Stats: F:\FAMILY_GUY_DISC1\VIDEO_TS\bob.stats
Ecf : F:\FAMILY_GUY_DISC1\VIDEO_TS\bob.ecf

Options:
Quality/DRF: 0
CreditsStart: 0
UseEcf: 1
CreditsIVTC: 0
CreditsAppend: 0
DeleteInterm.: 0
EnforceBitrate: 0
AntiShit: 0

Calculator:
VideoSize: 1214973 kbyte.
Audio1Size: 212831 kbyte.
Audio2Size: 0 kbyte.
Overhead: 8867 kbyte.
AviSize: 1436672 kbyte (1403 mbyte).
FilesSize: 0 kbyte.
TotalSize: 1436672 kbyte (1403 mbyte).
Interleaving: vbrmp3
Bitrate: 1096 k(=1000)Bits/s
Frames: 227011
FPS: 25.000
Duration: 231:20
Quality: 0.201 bits/(pixel*frame).
CompCheck3: 0.000 bits/(pixel*frame).
CompCheck5: 0.000 bits/(pixel*frame).
Resolution: 544 x 400

Audio 1:
Mode: Just Mux Source File.
SourceFile: F:\FAMILY_GUY_DISC1\VIDEO_TS\bob AC3 T01 2_0ch 192Kbps DELAY 0ms.ac3
WavFile: F:\FAMILY_GUY_DISC1\VIDEO_TS\bob AC3 T01 2_0ch 192Kbps DELAY 0ms.wav
Mp3File: F:\FAMILY_GUY_DISC1\VIDEO_TS\bob AC3 T01 2_0ch 192Kbps DELAY 0ms.mp3
Azid:
Lame:
Delay: 0
Interval: 1
Preload: 500
Mux: 1
Recalc: 1
DeleteWav: 1

Audio 2:
none.

07:45:41: Audio 1, determined: 212831 kb
07:45:41: Audio 1, calc: 212831 kb
07:45:41: New Bitrate for Movie = 1096 k(=1000)Bits/s

Adding this script to C:\PROGRA~1\GORDIA~1\VirtualDubMod\LastJob.vcf :

// $job "Xvid - First Pass"
// $input "F:\FAMILY_GUY_DISC1\VIDEO_TS\bob.avs"
// $output "F:\FAMILY_GUY_DISC1\VIDEO_TS\bob_Movie.avi"
// $state 0
// $start_time 0 0
// $end_time 0 0
// $script

VirtualDub.Open("F:\\FAMILY_GUY_DISC1\\VIDEO_TS\\bob.avs",0,0);
VirtualDub.video.SetDepth(24,24);
VirtualDub.video.SetMode(1);
VirtualDub.video.SetFrameRate(0,1);
VirtualDub.video.SetIVTC(0,0,-1,0);
VirtualDub.video.SetRange(0,0);
VirtualDub.video.SetCompression(0x64697678,0,10000,0);
VirtualDub.video.SetCompData(1192,"AAAAAKDHCwDgIgIARjpcRkFNSUxZX0dVWV9ESVNDMVxWSURFT19UU1xib2Iuc3RhdHMAAFYASQBEAEUATwBfAFQAUwBcAGIAbwBiAC4AcwB0AGEAdABzAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAABkAAAABQAAABAAAABkAAAAZAAAAAYAAAAAAAAAAAAAACwBAAABAAAAAAAAAAAAAAAAAAAAAAAAAAEAAAAAAAAAAgAAAJYAAABkAAAAAAAAAAEAAAAAAAAAAAAAAAIAAAAfAAAAAgAAAB8AAAAIERITFRcZGxESExUXGRscFBUWFxgaHB4VFhcYGhweIBYXGBocHiAjFxgaHB4gIyYZGhweICMmKRscHiAjJiktEBESExQVFhcREhMUFRYXGBITFBUWFxgZExQVFhcYGhsUFRYXGRobHBUWFxgaGxweFhcYGhscHh8XGBkbHB4fIQAAAAAKAAAAHgAAAAEAAAAAAAAAGQAAAAoAAAABAAAAAQAAAB4AAAABAAAAZAAAAAEAAAD0AQAAWgAAAGQAAACAlpgAPAAAADwAAAD6AAAAAAAAAAAAAABcaGludGZpbGUubXZoAGwAZQAuAG0AdgBoAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAFx2aWRlb2drLnN0YXRzAAAuAHMAdABhAHQAcwAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAUAAAAFAAAABQAAAAQJwAAECcAAAAAAAAAAAAAAAAAAM8AAAAAAAAAAAAAAA==");
VirtualDub.video.filters.Clear();
VirtualDub.subset.Delete();
VirtualDub.SaveAVI("F:\\FAMILY_GUY_DISC1\\VIDEO_TS\\bob_Movie.avi");
VirtualDub.Close();

// $endjob
//
//--------------------------------------------------
// $done

07:45:41: Started Xvid - First Pass: F:\FAMILY_GUY_DISC1\VIDEO_TS\bob.avs
11:58:49: Finished Xvid - First Pass: Duration: 4 hours, 13 minutes, 8 seconds.
11:58:49: Trying to open Log-file.
11:58:50: Success: Log-file open.
11:58:50: Encoded: 227011 Frames.
11:58:50: Speed: 14.947 Frames per Second.
11:58:50: New target size = 1214973 Kb

Adding this script to C:\PROGRA~1\GORDIA~1\VirtualDubMod\LastJob.vcf :

// $job "Xvid - Second Pass"
// $input "F:\FAMILY_GUY_DISC1\VIDEO_TS\bob.avs"
// $output "F:\FAMILY_GUY_DISC1\VIDEO_TS\bob_Movie.avi"
// $state 0
// $start_time 0 0
// $end_time 0 0
// $script

VirtualDub.Open("F:\\FAMILY_GUY_DISC1\\VIDEO_TS\\bob.avs",0,0);
VirtualDub.video.SetDepth(24,24);
VirtualDub.video.SetMode(1);
VirtualDub.video.SetFrameRate(0,1);
VirtualDub.video.SetIVTC(0,0,-1,0);
VirtualDub.video.SetRange(0,0);
VirtualDub.video.SetCompression(0x64697678,0,10000,0);
VirtualDub.video.SetCompData(1192,"BQAAAKDHCwD9iRIARjpcRkFNSUxZX0dVWV9ESVNDMVxWSURFT19UU1xib2Iuc3RhdHMAAFYASQBEAEUATwBfAFQAUwBcAGIAbwBiAC4AcwB0AGEAdABzAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAABkAAAABQAAABAAAABkAAAAZAAAAAYAAAAAAAAAAAAAACwBAAABAAAAAAAAAAAAAAAAAAAAAAAAAAEAAAAAAAAAAgAAAJYAAABkAAAAAAAAAAEAAAAAAAAAAAAAAAIAAAAfAAAAAgAAAB8AAAAIERITFRcZGxESExUXGRscFBUWFxgaHB4VFhcYGhweIBYXGBocHiAjFxgaHB4gIyYZGhweICMmKRscHiAjJiktEBESExQVFhcREhMUFRYXGBITFBUWFxgZExQVFhcYGhsUFRYXGRobHBUWFxgaGxweFhcYGhscHh8XGBkbHB4fIQAAAAAKAAAAHgAAAAEAAAAAAAAAGQAAAAoAAAABAAAAAQAAAB4AAAABAAAAZAAAAAEAAAD0AQAAWgAAAGQAAACAlpgAPAAAADwAAAD6AAAAAAAAAAAAAABcaGludGZpbGUubXZoAGwAZQAuAG0AdgBoAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAFx2aWRlb2drLnN0YXRzAAAuAHMAdABhAHQAcwAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAUAAAAFAAAABQAAAAQJwAAECcAAAAAAAAAAAAAAAAAAM8AAAAAAAAAAAAAAA==");
VirtualDub.video.filters.Clear();
VirtualDub.subset.Delete();
VirtualDub.SaveAVI("F:\\FAMILY_GUY_DISC1\\VIDEO_TS\\bob_Movie.avi");
VirtualDub.Close();

// $endjob
//
//--------------------------------------------------
// $done

11:58:50: Started Xvid - Second Pass: F:\FAMILY_GUY_DISC1\VIDEO_TS\bob.avs
15:23:18: Finished Xvid - Second Pass: Duration: 3 hours, 24 minutes, 27 seconds.
15:23:18: Speed: 18.504 Frames per Second.

Adding this script to C:\PROGRA~1\GORDIA~1\VirtualDubMod\LastJob.vcf :

// $job "DivX5 Append"
// $input "F:\FAMILY_GUY_DISC1\VIDEO_TS\bob_Movie.avi"
// $output "F:\FAMILY_GUY_DISC1\VIDEO_TS\bob.avi"
// $state 0
// $start_time 0 0
// $end_time 0 0
// $script

VirtualDub.Open("F:\\FAMILY_GUY_DISC1\\VIDEO_TS\\bob_Movie.avi",0,0);
VirtualDub.RemoveInputStreams();
VirtualDub.stream[0].SetSource("F:\\FAMILY_GUY_DISC1\\VIDEO_TS\\bob AC3 T01 2_0ch 192Kbps DELAY 0ms.ac3",0x00000203,0);
VirtualDub.stream[0].SetMode(0);
VirtualDub.stream[0].SetInterleave(1,500,1,0,0);
VirtualDub.stream[0].SetClipMode(1,1);
VirtualDub.stream[0].SetConversion(0,0,0,0,0);
VirtualDub.stream[0].SetVolume();
VirtualDub.stream[0].SetCompression();
VirtualDub.video.SetDepth(24,24);
VirtualDub.video.SetMode(0);
VirtualDub.video.SetFrameRate(0,1);
VirtualDub.video.SetIVTC(0,0,-1,0);
VirtualDub.video.SetRange(0,0);
VirtualDub.video.SetCompression();
VirtualDub.video.filters.Clear();
VirtualDub.subset.Delete();
VirtualDub.SaveAVI("F:\\FAMILY_GUY_DISC1\\VIDEO_TS\\bob.avi");
VirtualDub.Close();

// $endjob
//
//--------------------------------------------------
// $done

15:23:18: Started Muxing Audio.: F:\FAMILY_GUY_DISC1\VIDEO_TS\bob_Movie.avi
15:23:24: Finished Muxing Audio.: Duration: 6 seconds.

15:23:24: Done.
15:23:24: Movie = F:\FAMILY_GUY_DISC1\VIDEO_TS\bob.avi
Total Encoding Time: 7 hours, 37 minutes, 43 seconds.
02/03/2004 15:23:24: Job " 2" finished.
_______________________________________________________________________________________________________________________
----


This is the error i got:


__________

Please can somone help

Thanks
sebfernando is offline   Reply With Quote
Old 4th March 2004, 08:10   #2  |  Link
jggimi
Moderator Emeritus
 
jggimi's Avatar
 
Join Date: Dec 2001
Location: The NW corner of Lake Erie
Posts: 5,555
It appears to me that the error occurs during the muxing of your audio track, 6 seconds after starting the muxing task.

Can you play the silent video, "bob_Movie.avi" in an avi player? Does it play properly?

You could try muxing the audio manually, and see if you get further.
jggimi is offline   Reply With Quote
Old 4th March 2004, 08:29   #3  |  Link
sebfernando
Registered User
 
Join Date: Jul 2003
Posts: 8
i couldn't play "bob_Movie.avi" in any avi player. But i will try muxing the audio separately.
Thanks for your help!
seb
sebfernando is offline   Reply With Quote
Old 4th March 2004, 08:50   #4  |  Link
jggimi
Moderator Emeritus
 
jggimi's Avatar
 
Join Date: Dec 2001
Location: The NW corner of Lake Erie
Posts: 5,555
If you couldn't play the resultant .avi in an avi player, I doubt you will be able to mux manually. There's obviously something wrong, though it is not yet clear what it is.

You might try opening the file in GSpot, to see what it says, and to see if the video can be rendered ... and if not, what the failure is.

What version of Gknot are you using? VirtualDubMod? XviD?
jggimi is offline   Reply With Quote
Old 5th March 2004, 00:17   #5  |  Link
piscator
Registered User
 
Join Date: Dec 2002
Location: Netherlands
Posts: 182
Perhaps the source is bad (the dialog box suggests corrupt data). You could try to play a bit of each Vob file in Media Player Classic. If one of the Vob files doesn't play, it definately is a corrupt source.

greetz,
Piscator
piscator is offline   Reply With Quote
Old 6th March 2004, 11:57   #6  |  Link
sebfernando
Registered User
 
Join Date: Jul 2003
Posts: 8
That error always comes after the first pass of encodin, when i goto the folder where the movie was encoded, the movie itself is 10kb!! and gspot says it is not a valid avi.
I tried playin the vobs with widnows media player and all my other dvd players, and they work fine!!!
sebfernando is offline   Reply With Quote
Old 6th March 2004, 18:12   #7  |  Link
marioman
Registered User
 
Join Date: Aug 2002
Location: VA USA
Posts: 23
Ok so it seems Im not the onlyone havin probs with multipass, Ivebeen tryin to encode The Order for the past week. I'm using codecpack 1.6 and GK 28.7. Here's what happens, I start encoing, 1st credits, then first pass, once it gets to second pass i hen get this error:

"Cannot Start Video Compression: The source image format is not acceptable (error code -2)."

What I cant figure out is why is it not acceptable? It's no different than any other movie, plus it goes through the credits and the 1st pass fine.
Now that i think about it i didnt have this problem until after i updated the codec pack and GK.

Should i go back to 28.6.2 for now?

EDIT: oh yeah forgot to mention, this seems to be similar to the XVid problem, but just so u know im using DivX 5.1.1
marioman is offline   Reply With Quote
Old 6th March 2004, 18:18   #8  |  Link
sebfernando
Registered User
 
Join Date: Jul 2003
Posts: 8
Hi, thanks from all the input people have given.

Ok ive tried encoding a dolby digital vob trailer i downloaded of the net. Ive done the same settings, same codec. And it encodes fine for the first pass, and then boom, that crappy error pops up. I think there might be a bug in the virtualdub mod.

Ne help.

seb
sebfernando is offline   Reply With Quote
Old 6th March 2004, 20:56   #9  |  Link
marioman
Registered User
 
Join Date: Aug 2002
Location: VA USA
Posts: 23
Now this is where the problem differs, i only get the error if im using GK, i can take and cut out a part of the movie and do miltipass encoding fine...your guess is as good as mine, im goin to go see if theres a newer version of VDubMod and try that
marioman is offline   Reply With Quote
Old 8th March 2004, 00:17   #10  |  Link
piscator
Registered User
 
Join Date: Dec 2002
Location: Netherlands
Posts: 182
Quote:
Originally posted by sebfernando
Ok ive tried encoding a dolby digital vob trailer i downloaded of the net. Ive done the same settings, same codec. And it encodes fine for the first pass, and then boom, that crappy error pops up. I think there might be a bug in the virtualdub mod.
VirtualDub Mod with the newest GKnot and newest Codec Pack should work fine (keyword: should ). Anyway, perhaps something is messed up in your codec installation. Try to deinstall all (old) codecs and reinstall the GKnot Codec Pack. And make sure that the paths in 'Program Paths' are set correctly.
piscator is offline   Reply With Quote
Old 8th March 2004, 17:42   #11  |  Link
sebfernando
Registered User
 
Join Date: Jul 2003
Posts: 8
AGHHHH!!!! soz, ive tried everything reinstalled everything including the rip pack.
I've tried just doing the video and not the audio, and that f**** error still comes up, ive basically tried everything. I think this mite be a bug in virtualdubmod.
sebfernando is offline   Reply With Quote
Old 8th March 2004, 19:53   #12  |  Link
piscator
Registered User
 
Join Date: Dec 2002
Location: Netherlands
Posts: 182
In your first log, I see you use a 2-pass XViD encode. And since the 2nd pass goes wrong, I've a strong feeling that your encoder settings might be wrong.

Check out the 'Options' tab and make sure that the "XViD default codec settings" are correct:
+ For first pass, encoding type should be: "Twopass - 1st pass".
+ For second pass, encoding type should be: "Twopass - 2nd pass".
(in my default config encoding type was empty; it should not be).

Also check out the guides on XViD, so you know what you're doing.

You might also consider to use DivX. I find it more reliable than XViD (i.e. XviD is still under heavy development and 'sometimes' a bit buggy). Certainly, if you haven't so much experience with video encoding, I would try DivX first.

greetz,
Piscator
piscator is offline   Reply With Quote
Old 9th March 2004, 08:27   #13  |  Link
sebfernando
Registered User
 
Join Date: Jul 2003
Posts: 8
IT WORKED!!!! WOHOOOOO!!!
It was my first pass settings which was the problem, it was on
1 pass CBR and not not on twopass - 1st pass.
Thanks to all of u (espically piscator) for your help!!!
Thanks again

seb
sebfernando is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 08:34.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.