Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Development

Reply
 
Thread Tools Search this Thread Display Modes
Old 26th July 2003, 16:29   #261  |  Link
Nic
Moderator
 
Join Date: Oct 2001
Location: England
Posts: 3,285
@Symon: I honestly don't think 3dnow would help that much. However, ive just put in Skal's iDCT properly (sparse one). Thats definitely faster

-Nic
Nic is offline   Reply With Quote
Old 26th July 2003, 16:51   #262  |  Link
symonjfox
IUUULEEEENZ
 
symonjfox's Avatar
 
Join Date: Mar 2002
Location: Italy
Posts: 452
OK, thanks you very much
__________________
PC1:AMD Athlon II x4, 4GB DDR2, Ati Radeon 4830, 4 hard disks
symonjfox is offline   Reply With Quote
Old 26th July 2003, 17:01   #263  |  Link
Nic
Moderator
 
Join Date: Oct 2001
Location: England
Posts: 3,285
mpeg2dec3 v1.09

Ok version 1.09 is up on my site ( http://nic.dnsalias.com ). Only minor changes for this version. When Luminance_Filter is set in the .d2v file it is now used (like it is on all other MPEG2Decs, before Marc took it out).

Its actually the C code one from the new DVD2AVI 1.77.3 rather than the old mmx one from previous versions of DVD2AVI. It could probably do with being made into MMX code, I used the new one because the old (1.76) MMX Luminance_Filter had problems when "darkening" an image.
(It won't get used unless the filter's values are different that the default)

And skal's "sparse" iDCT is used for idct=6, and now should pretty much definitely be the fastest (well, it is on my machine, but I said that last time )

-Nic
Nic is offline   Reply With Quote
Old 26th July 2003, 19:31   #264  |  Link
trbarry
Registered User
 
trbarry's Avatar
 
Join Date: Oct 2001
Location: Gainesville FL USA
Posts: 2,092
Nic -

I'm a bit afraid to ask a stupid question on a program I've made that many changes on, but what does the luminance filter really do anyway?

I've never seen it documented and have just ignored it.

- Tom
__________________
My video filters (still) at www.trbarry.com.
trbarry is offline   Reply With Quote
Old 27th July 2003, 00:22   #265  |  Link
Th3-S4int
Registered User
 
Join Date: Mar 2003
Location: Germany
Posts: 18
I have 2 short question, too:
Is that right that is not recommed to use idct=6 with a Athlon (thunderbird), because the CPU has no SSE unit, or is it not so important and mpeg2dec3 use only MMX with that idct?
And what is with accurate? i think a idct which is more accurate is better, or is idct=6 accurate "enough"?
P.S. I hope everybody understood me, but english is not easy for me

Last edited by Th3-S4int; 27th July 2003 at 00:25.
Th3-S4int is offline   Reply With Quote
Old 27th July 2003, 00:29   #266  |  Link
Nic
Moderator
 
Join Date: Oct 2001
Location: England
Posts: 3,285
@Th3-S4int: idct=6 is probably considered accurate enough...it passes IEEE -256,256 tests, etc. Off the top of my head I don't know if it will work on Duron/non-XP athlons...ill check. It should do though Try it and see is the best bet (ive still got a duron 800 I can try it on)

@Tom: I don't know what its real true use is But I use it for a quick easy way to brighten up a movie....you know how sometimes when you preview in dvd2avi and it looks real dark. Going to the luminance control in DVD2AVI you can brighten it up just a fraction. I do it with almost every encode (went to do it today, and realised it hadn't been working)

-Nic
Nic is offline   Reply With Quote
Old 27th July 2003, 07:29   #267  |  Link
Dreassica
Registered User
 
Join Date: May 2002
Posts: 386
hmm, idct=6 doesnt work for me on an Athlon XP 2100+, it crashes avs with Unrecognised exception error
Dreassica is offline   Reply With Quote
Old 27th July 2003, 08:56   #268  |  Link
JohnMK
Registered User
 
Join Date: Sep 2002
Location: Seattle
Posts: 551
XviD has had issues lately with different dct's, idct's and such. Would it be advised just to stick with idct=2 for now(and 5 which is safe for P4's, since it's just 2)? For example Walken vs. Simple, now all old XviD made with simple will look like shi'ite, etc. I'm just asking this since it appears to me it's best to stick with as standard a DCT/iDCT as possible.
JohnMK is offline   Reply With Quote
Old 27th July 2003, 08:58   #269  |  Link
JohnMK
Registered User
 
Join Date: Sep 2002
Location: Seattle
Posts: 551
Quote:
Originally posted by Nic


. . . I use it for a quick easy way to brighten up a movie....you know how sometimes when you preview in dvd2avi and it looks real dark. Going to the luminance control in DVD2AVI you can brighten it up just a fraction.
Doesn't this reduce compressibility? It's probably better to do this in post-processing.
JohnMK is offline   Reply With Quote
Old 27th July 2003, 09:55   #270  |  Link
Nic
Moderator
 
Join Date: Oct 2001
Location: England
Posts: 3,285
@johnMK: It doesn't matter about what idct you use for decoding, it won't effect the encoding process. But it may very slightly effect the compressibility (as tests in this thread have shown, it looks like idct=7 (SimpleiDCT) might help compressibility)

You're right about the brightness, it could be a bad habbit I got into from day one of encoding that I still carry with me. But for RealVideo encoding (like I was doing yesterday), there is no easy way in MPC to turn up the brightness. So its a useful feature to have and I couldn't believe Marc had taken it out (as it doesn't get run unless you actually change the params in dvd2avi)

-Nic
Nic is offline   Reply With Quote
Old 27th July 2003, 12:23   #271  |  Link
geoffman
Registered User
 
Join Date: Mar 2003
Location: Ozzstralia
Posts: 92
Re: mpeg2dec3 v1.09

Quote:
Originally posted by Nic
Ok version 1.09 is up on my site ( http://nic.dnsalias.com ).
Nic, just visited your site at http://nic.dnsalias.com/mpeg2dec3.html and it still seems to be only listing V1.08?

EDIT: Oops! I see you have updated the link in the first post in the thread. Never mind me!

Last edited by geoffman; 27th July 2003 at 12:25.
geoffman is offline   Reply With Quote
Old 27th July 2003, 12:55   #272  |  Link
Nic
Moderator
 
Join Date: Oct 2001
Location: England
Posts: 3,285
Im sure i'd uploaded that page already, oh well, uploaded it again now it states 1.09 correctly. Thanks for the heads up

@Dressica: Weird, could you give me anymore info? What type of MPEG it was, did it crash straight away, etc. Worked fine for me here, but ill test it with more MPEGs

-Nic
Nic is offline   Reply With Quote
Old 27th July 2003, 13:12   #273  |  Link
Dreassica
Registered User
 
Join Date: May 2002
Posts: 386
DVD mpeg2 files is what i tried it on, never works for me, it crashes straightaway with the message i described a few posts ago. Tried on various dvd sources.
Dreassica is offline   Reply With Quote
Old 27th July 2003, 14:42   #274  |  Link
Nic
Moderator
 
Join Date: Oct 2001
Location: England
Posts: 3,285
@Dreassica: Really strange, The computer I use for all my coding and testing is my Athlon 1800 XP, which should be quite a similar machine to yours, and it works fine with all the DVD samples ive got on my disk so far...ill keep on testing though.

-Nic
Nic is offline   Reply With Quote
Old 27th July 2003, 15:14   #275  |  Link
Dreassica
Registered User
 
Join Date: May 2002
Posts: 386
I think i may have narrowed it down to a plugin in the plugins dir that causes it, because i tried with the plugins dir renamed and then mpeg2dec manually loaded and now it does work. Ill continue looking for the culprit.

[EDIT] Seems i found it already, there was another mpeg2dec3 version hiding within the pluginsfolder that causes it, namely:MPEG2Dec3_Nic.dll.
Deleted it and now idct=7 works fine.

Last edited by Dreassica; 27th July 2003 at 15:19.
Dreassica is offline   Reply With Quote
Old 28th July 2003, 01:43   #276  |  Link
AlphaDivxMovies
Registered User
 
Join Date: Sep 2002
Posts: 34
Weird Brightness increase

I seem to be getting weird brightness increase ever since i installed
the latest version. I did not change a thing on the script namely to compare the previous build with this one. Since the only variable was Mpeg2dec3 i assume this new build is briken somehow.
Has anyone seen this? I am pretty sure it is the variable fault.

This is the test script:
SetMemoryMax(40)

PluginPath ="C:\MAINUS~1\MULTIM~1\Video\GKnot\"
LoadPlugin("C:\MAINUS~1\MULTIM~1\Video\GKnot\MPEG2Dec3.dll")
LoadPlugin("C:\MAINUS~1\MULTIM~1\Video\GKnot\FluxSmooth.dll")
LoadPlugin("C:\MAINUS~1\MULTIM~1\Video\GKnot\Undot.dll")
LoadPlugin("C:\MAINUS~1\MULTIM~1\Video\GKnot\Unfilter.dll")
MPEG2Source("D:\Final_Destination\VIDEO_TS\Final_Destination_a.d2v",cpu=4,moderate_h=40,moderate_v=40,iDCT=2)
crop(4,18,714,544)
Undot()
FluxSmooth(5,7)
Unfilter(-2,-2)
LanczosResize(640,336)
#tweak(bright=3)
Limiter()

Ps - Keep the good work, we all love you guys!
AlphaDivxMovies is offline   Reply With Quote
Old 28th July 2003, 10:19   #277  |  Link
Nic
Moderator
 
Join Date: Oct 2001
Location: England
Posts: 3,285
Damn, Sorry if there is. Ill fix it right away. Could you tell me what version of DVD2AVI is creating your D2V files? and then load up your DVD2AVI and look at the luminance setting (under the video menu) and tell me what numbers are there. Could you also tell me what, what the Luminace_Filter= in your D2V file states.

Its alot to ask for, but if you could give me all that it would be a big help

Cheers,
-Nic
Nic is offline   Reply With Quote
Old 28th July 2003, 10:34   #278  |  Link
Nic
Moderator
 
Join Date: Oct 2001
Location: England
Posts: 3,285
Ok, No Need. I've fixed the problem. New build (1.10) at my site ( http://nic.dnsalias.com )

It only occured with 1.77.3 style D2V files. Sorry about that My mistake.

-Nic
Nic is offline   Reply With Quote
Old 28th July 2003, 11:57   #279  |  Link
AlphaDivxMovies
Registered User
 
Join Date: Sep 2002
Posts: 34
Weird Brightness increase

You were right Nic, it was because of 1.77.3 style D2V files.
Seems to be fine now. Thanks Nic, i really appreciate your effort.
Don`t think you people go unnoticed.

Regards
AlphaDivxMovies
AlphaDivxMovies is offline   Reply With Quote
Old 30th July 2003, 15:15   #280  |  Link
trbarry
Registered User
 
trbarry's Avatar
 
Join Date: Oct 2001
Location: Gainesville FL USA
Posts: 2,092
Nic -

If I go to your main page none of the links in the left column seem to do anything. I had to go to the full deep link. Are they busted or is just my Norton Security too tight or something?

- Tom
__________________
My video filters (still) at www.trbarry.com.
trbarry is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 19:09.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.