Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Audio encoding

Reply
 
Thread Tools Search this Thread Display Modes
Old 27th December 2002, 20:54   #1  |  Link
Dark-Cracker
Registered User
 
Dark-Cracker's Avatar
 
Join Date: Feb 2002
Posts: 1,195
Besweet Bug with --ABR under 77kbts.

Hi,

i think there is a little problem with the --abr mode,
i have make some tests with ac3/mpa and with different version of lame_enc.dll (mitioki/rarewares) i have tested with besweet v1.4 & 1.5b11.

and here were my results :
--------------------------

with the lame_enc (mitioki version) using the lame v3.93.1 & 3.94 alpha there is a problem if u use an ABR bitrate under 77kbts . and it the same with the rarewares version (3.93a)

here my log file :

lame_enc.dll 3.93 @ 77Kbts, all work fine :

BeSweet v1.5b11 by DSPguru.
--------------------------
Using azid.dll v1.8 (b825) by Midas (midas@egon.gyaloglo.hu).
Using lame_enc.dll v1.32 (3/12/2002), Engine 3.93 <http://www.mp3dev.org/>.

Logging start : 12/27/02 , 18:12:52.

C:\WINDOWS\BUREAU\BESWEE~1.4\BESWEET.EXE -core( -input H:\TestVob\out.ac3 -output H:\raspoutine\toto.mp3 -logfile BeSweet.log ) -lame( --abr 77 )

[00:00:00:000] +------- BeSweet -----
[00:00:00:000] | Input : H:\TestVob\out.ac3
[00:00:00:000] | Output: H:\raspoutine\toto.mp3
[00:00:00:000] | Floating-Point Process: Yes
[00:00:00:000] +-------- AZID -------
[00:00:00:000] | Input Channels Mode: 2/0, Bitrate: 192kbps
[00:00:00:000] | Output Stereo mode: Dolby surround compatible
[00:00:00:000] | Total Gain: 0.000dB, Compression: None
[00:00:00:000] | LFE levels: To LR -INF, To LFE 0.0dB
[00:00:00:000] | Center mix level: BSI
[00:00:00:000] | Surround mix level: BSI
[00:00:00:000] | Dialog normalization: No
[00:00:00:000] | Rear channels filtering: No
[00:00:00:000] | Source Sample-Rate: 48.0KHz
[00:00:00:000] +-------- LAME -------
[00:00:00:000] | Bitrate method : ABR
[00:00:00:000] | Avarege Bitrate : 77
[00:00:00:000] | MP3 Min bitrate : 32
[00:00:00:000] | MP3 Max bitrate : 320
[00:00:00:000] | Channels Mode : Joint Stereo
[00:00:00:000] | Error Protection: No
[00:00:00:000] +---------------------
[00:01:00:032] Conversion Completed !
[00:01:00:032] Actual Avg. Bitrate : 71kbps
[00:00:40:000] <-- Transcoding Duration
Logging ends : 12/27/02 , 18:13:32.

as u can see @ 77kbts all work but unhappily @ 76 kbts the encoding process stop , here the bad logfile :

BeSweet v1.5b11 by DSPguru.
--------------------------
Using azid.dll v1.8 (b825) by Midas (midas@egon.gyaloglo.hu).
Using lame_enc.dll v1.32 (3/12/2002), Engine 3.93 <http://www.mp3dev.org/>.

Logging start : 12/27/02 , 18:14:29.

C:\WINDOWS\BUREAU\BESWEE~1.4\BESWEET.EXE -core( -input H:\TestVob\out.ac3 -output H:\raspoutine\toto.mp3 -logfile BeSweet.log ) -lame( --abr 76 )

[00:00:00:000] +------- BeSweet -----
[00:00:00:000] | Input : H:\TestVob\out.ac3
[00:00:00:000] | Output: H:\raspoutine\toto.mp3
[00:00:00:000] | Floating-Point Process: Yes
Error 47: Error with LAME dll!
Quiting...
[00:00:00:000] Conversion Completed !
Logging ends : 12/27/02 , 18:14:29.

------------------
i suppose it a perhaps a lame_enc.dll bug , and not a besweet bug.
can someone could check in the lame_enc source (on rarewares) ?

Thank u ,
Bye.
__________________

AutoDub v1.8 : Divx3/4/5 & Xvid Video codec and .OGG/.MP3/.AC3/.WMA audio codec.
AutoRV10 v1.0 : Use RealVideo 10 Codec and support 2 Audio Streams and Subtitles.

Dark-Cracker is offline   Reply With Quote
Old 28th December 2002, 01:13   #2  |  Link
pacohaas
Audio Moderator
 
Join Date: Oct 2001
Posts: 697
have you tried this with the 3.92/3.90.2 varieties?

Also, have you tried --alt-preset <bitrate> (not sure if this is supported by BeSweet yet, but it's the correct way to do ABR at any bitrate according to everone over at hydrogenaudio)

Also, as of 3.93 --preset = --alt-preset (though this fact may not be true when using BeSweet yet)
__________________
{-n24-}
The Old Fair Use Homepage
pacohaas is offline   Reply With Quote
Old 28th December 2002, 03:17   #3  |  Link
Dark-Cracker
Registered User
 
Dark-Cracker's Avatar
 
Join Date: Feb 2002
Posts: 1,195
i don't have tested with the v3.92 (i don't have found the file) but i have tested with the 3.90.2 (hydrogenaudio version) and with this version the encoding doesn't crash but the output was not an ABR 76 kbts but a CBR 128 output file.
here the logfile :

BeSweet v1.5b11 by DSPguru.
--------------------------
Using azid.dll v1.8 (b825) by Midas (midas@egon.gyaloglo.hu).
Using lame_enc.dll v1.26 (23/12/2001), Engine 3.90 <http://www.mp3dev.org/>.

Logging start : 12/28/02 , 03:13:43.

C:\WINDOWS\BUREAU\BESWEE~1.4\BESWEET.EXE -core( -input H:\TestVob\out.ac3 -output H:\raspoutine\toto.mp3 -logfile BeSweet.log ) -lame( --abr 76 )

[00:00:00:000] +------- BeSweet -----
[00:00:00:000] | Input : H:\TestVob\out.ac3
[00:00:00:000] | Output: H:\raspoutine\toto.mp3
[00:00:00:000] | Floating-Point Process: Yes
[00:00:00:000] +-------- AZID -------
[00:00:00:000] | Input Channels Mode: 2/0, Bitrate: 192kbps
[00:00:00:000] | Output Stereo mode: Dolby surround compatible
[00:00:00:000] | Total Gain: 0.000dB, Compression: None
[00:00:00:000] | LFE levels: To LR -INF, To LFE 0.0dB
[00:00:00:000] | Center mix level: BSI
[00:00:00:000] | Surround mix level: BSI
[00:00:00:000] | Dialog normalization: No
[00:00:00:000] | Rear channels filtering: No
[00:00:00:000] | Source Sample-Rate: 48.0KHz
[00:00:00:000] +-------- LAME -------
[00:00:00:000] | Bitrate method : ABR
[00:00:00:000] | Avarege Bitrate : 76
[00:00:00:000] | MP3 Min bitrate : 32
[00:00:00:000] | MP3 Max bitrate : 320
[00:00:00:000] | Channels Mode : Joint Stereo
[00:00:00:000] | Error Protection: No
[00:00:00:000] +---------------------
[00:01:00:032] Conversion Completed !
[00:01:00:032] Actual Avg. Bitrate : 128kbps
[00:00:16:000] <-- Transcoding Duration
Logging ends : 12/28/02 , 03:13:59.

>Also, have you tried --alt-preset <bitrate>

--alt preset for the abr doesn't work ! if u use a bitrate under 77 kbps.

here the logfile :

BeSweet v1.5b11 by DSPguru.
--------------------------
Using azid.dll v1.8 (b825) by Midas (midas@egon.gyaloglo.hu).
Using lame_enc.dll v1.28 (18/4/2002), Engine 3.93 <http://www.mp3dev.org/>.

Logging start : 12/28/02 , 05:39:33.

C:\WINDOWS\BUREAU\BESWEE~1.5B1\BESWEET.EXE -core( -input H:\testvob\out.ac3 -output H:\raspoutine\toto.mp3 -logfile besweet.log ) -lame( --alt-preset 76 )

[00:00:00:000] +------- BeSweet -----
[00:00:00:000] | Input : H:\testvob\out.ac3
[00:00:00:000] | Output: H:\raspoutine\toto.mp3
[00:00:00:000] | Floating-Point Process: Yes
Error 47: Error with LAME dll!
Quiting...
[00:00:00:000] Conversion Completed !
Logging ends : 12/28/02 , 05:39:33.


EDIT :
tested with lame_enc 3.92 & --abr switch ==> crashed too, here the logfile

BeSweet v1.5b11 by DSPguru.
--------------------------
Using azid.dll v1.8 (b825) by Midas (midas@egon.gyaloglo.hu).
Using lame_enc.dll v1.28 (16/4/2002), Engine 3.92 <http://www.mp3dev.org/>.

Logging start : 12/28/02 , 03:26:46.

C:\WINDOWS\BUREAU\BESWEE~1.4\BESWEET.EXE -core( -input H:\TestVob\out.ac3 -output H:\raspoutine\toto.mp3 -logfile BeSweet.log ) -lame( --abr 76 )

[00:00:00:000] +------- BeSweet -----
[00:00:00:000] | Input : H:\TestVob\out.ac3
[00:00:00:000] | Output: H:\raspoutine\toto.mp3
[00:00:00:000] | Floating-Point Process: Yes
Error 47: Error with LAME dll!
Quiting...
[00:00:00:000] Conversion Completed !
Logging ends : 12/28/02 , 03:26:46.

---------- END EDIT ---------

Bye.
__________________

AutoDub v1.8 : Divx3/4/5 & Xvid Video codec and .OGG/.MP3/.AC3/.WMA audio codec.
AutoRV10 v1.0 : Use RealVideo 10 Codec and support 2 Audio Streams and Subtitles.


Last edited by Dark-Cracker; 28th December 2002 at 05:37.
Dark-Cracker is offline   Reply With Quote
Old 28th December 2002, 05:42   #4  |  Link
Dark-Cracker
Registered User
 
Dark-Cracker's Avatar
 
Join Date: Feb 2002
Posts: 1,195
Hi,

it seems the --alt-preset 76 kbts crash with the lame_enc v3.93 but not with the version v3.92,

the 2 log files :
-----------------
lame 3.93 :

BeSweet v1.5b11 by DSPguru.
--------------------------
Using azid.dll v1.8 (b825) by Midas (midas@egon.gyaloglo.hu).
Using lame_enc.dll v1.28 (18/4/2002), Engine 3.93 <http://www.mp3dev.org/>.

Logging start : 12/28/02 , 05:39:33.

C:\WINDOWS\BUREAU\BESWEE~1.5B1\BESWEET.EXE -core( -input H:\testvob\out.ac3 -output H:\raspoutine\toto.mp3 -logfile besweet.log ) -lame( --alt-preset 76 )

[00:00:00:000] +------- BeSweet -----
[00:00:00:000] | Input : H:\testvob\out.ac3
[00:00:00:000] | Output: H:\raspoutine\toto.mp3
[00:00:00:000] | Floating-Point Process: Yes
Error 47: Error with LAME dll!
Quiting...
[00:00:00:000] Conversion Completed !
Logging ends : 12/28/02 , 05:39:33.

and the working logfile with the lame_enc.dll v3.92 :

BeSweet v1.5b11 by DSPguru.
--------------------------
Using azid.dll v1.8 (b825) by Midas (midas@egon.gyaloglo.hu).
Using lame_enc.dll v1.28 (4/6/2002), Engine 3.92 <http://www.mp3dev.org/>.

Logging start : 12/28/02 , 05:43:56.

C:\WINDOWS\BUREAU\BESWEE~1.4\BESWEET.EXE -core( -input H:\testvob\out.ac3 -output H:\raspoutine\toto.mp3 -logfile besweet.log ) -lame( --alt-preset 76 )

[00:00:00:000] +------- BeSweet -----
[00:00:00:000] | Input : H:\testvob\out.ac3
[00:00:00:000] | Output: H:\raspoutine\toto.mp3
[00:00:00:000] | Floating-Point Process: Yes
[00:00:00:000] +-------- AZID -------
[00:00:00:000] | Input Channels Mode: 2/0, Bitrate: 192kbps
[00:00:00:000] | Output Stereo mode: Dolby surround compatible
[00:00:00:000] | Total Gain: 0.000dB, Compression: None
[00:00:00:000] | LFE levels: To LR -INF, To LFE 0.0dB
[00:00:00:000] | Center mix level: BSI
[00:00:00:000] | Surround mix level: BSI
[00:00:00:000] | Dialog normalization: No
[00:00:00:000] | Rear channels filtering: No
[00:00:00:000] | Source Sample-Rate: 48.0KHz
[00:00:00:000] +-------- LAME -------
[00:00:00:000] | 'abr 76' preset is used
[00:00:00:000] +---------------------
[00:01:00:032] Conversion Completed !
[00:01:00:032] Actual Avg. Bitrate : 75kbps
[00:00:32:000] <-- Transcoding Duration
Logging ends : 12/28/02 , 05:44:28.
__________________

AutoDub v1.8 : Divx3/4/5 & Xvid Video codec and .OGG/.MP3/.AC3/.WMA audio codec.
AutoRV10 v1.0 : Use RealVideo 10 Codec and support 2 Audio Streams and Subtitles.


Last edited by Dark-Cracker; 28th December 2002 at 05:48.
Dark-Cracker is offline   Reply With Quote
Old 2nd January 2003, 10:58   #5  |  Link
Dark-Cracker
Registered User
 
Dark-Cracker's Avatar
 
Join Date: Feb 2002
Posts: 1,195
@dspguru

do u have try to fix this bug ?
PS: your private message box was full.

Bye.
Dark-Cracker is offline   Reply With Quote
Old 2nd January 2003, 20:08   #6  |  Link
DSPguru
BeSweet Author
 
DSPguru's Avatar
 
Join Date: Oct 2001
Location: On top of a supercompact cardinal
Posts: 3,506
sorry, busy.
DSPguru is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 21:06.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.