Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 10th March 2019, 01:36   #55261  |  Link
vanden
Registered User
 
Join Date: Sep 2007
Posts: 81
Quote:
Originally Posted by el Filou View Post
The recommended resolution isn't even 2048x1536 even though it's the highest listed, it's 1600x1200. LaCie also lists an aperture grille pitch of 0,24mm which for this tube size gives ~1690 lines.

(CRTs don't really have a 'native definition', btw)
You're right, I made an image with a white column and a black column repeated and indeed it is only in 1600 that we can tell the number of columns ... :
https://imagizer.imageshack.com/img923/3055/QIngq0.jpg
Yet for me it's visually more beautiful in 1920 than in 1600 ...
vanden is offline   Reply With Quote
Old 10th March 2019, 06:06   #55262  |  Link
TheProfosist
Registered User
 
TheProfosist's Avatar
 
Join Date: Aug 2009
Posts: 136
Trying to troubleshoot something. On my HTPC (Win10x64-1809v2, i7-4820K, 32GB ram, RTX2060, 4K HDR Sony TV) I cant seem to get pans to be smooth even though im withing the render times on a per frame basis. I can disable more things to lower it further and it doesn't seem to improve it. Yes smooth motion is on in the when needed but should be needed her 23fps content and display changed to 24fps. It doesnt show dropped or duplicated frames for how stuttery it is. Previously had the 1060 in there no real improvement going to the 2060.

Ideas on troubleshooting this would be helpful. I have tried:

using different decoders in lav filters. Anything other than CUVID just seems worse
MPC-HC versions 1.7.13 and 1.8.4
madVR versions 0.92.14 and now 0.92.17
upgraded the GPU
lower settings from NGU to superxbr to jinc
increasing buffer from 8 to 16 (though im not sure if 6GB vram is enough for this)

I have not completely wiped my madVR settings to see if it does it from scratch since I thought I would post here first to see if someone has ideas.
TheProfosist is offline   Reply With Quote
Old 10th March 2019, 07:36   #55263  |  Link
ryrynz
Registered User
 
ryrynz's Avatar
 
Join Date: Mar 2009
Posts: 3,215
Are the pans even meant to be smooth though? Here's a test, copy your content on to a USB flash drive and play it back through the TV's USB port.
Worth taking note of the picture settings and make sure they're applied to your HDMI input you're using for the HTPC.
ryrynz is offline   Reply With Quote
Old 10th March 2019, 14:28   #55264  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 3,683
Quote:
Originally Posted by TheProfosist View Post
Trying to troubleshoot something. On my HTPC (Win10x64-1809v2, i7-4820K, 32GB ram, RTX2060, 4K HDR Sony TV) I cant seem to get pans to be smooth even though im withing the render times on a per frame basis.
Is the Nvidia control panel 3D setting "Power management mode" on Optimal Power? It should not be.

Is the Windows 10 Focus Assist enabled in anyway? Disable it, including the extra options, just the global disable is not enough.

Are you running F.lux?
__________________
madVR options explained
Asmodian is offline   Reply With Quote
Old 10th March 2019, 15:01   #55265  |  Link
austinminton
Registered User
 
Join Date: Jun 2017
Posts: 71
Quote:
Originally Posted by TheProfosist View Post
I cant seem to get pans to be smooth even though im withing the render times on a per frame basis.
Try full screen exclusive. It fixed stuttering issues for me on my 2080ti.
austinminton is offline   Reply With Quote
Old 10th March 2019, 17:33   #55266  |  Link
TheProfosist
Registered User
 
TheProfosist's Avatar
 
Join Date: Aug 2009
Posts: 136
Quote:
Originally Posted by TheProfosist View Post
Trying to troubleshoot something. On my HTPC (Win10x64-1809v2, i7-4820K, 32GB ram, RTX2060, 4K HDR Sony TV) I cant seem to get pans to be smooth even though im withing the render times on a per frame basis. I can disable more things to lower it further and it doesn't seem to improve it. Yes smooth motion is on in the when needed but should be needed her 23fps content and display changed to 24fps. It doesnt show dropped or duplicated frames for how stuttery it is. Previously had the 1060 in there no real improvement going to the 2060.

Ideas on troubleshooting this would be helpful. I have tried:

using different decoders in lav filters. Anything other than CUVID just seems worse
MPC-HC versions 1.7.13 and 1.8.4
madVR versions 0.92.14 and now 0.92.17
upgraded the GPU
lower settings from NGU to superxbr to jinc
increasing buffer from 8 to 16 (though im not sure if 6GB vram is enough for this)

I have not completely wiped my madVR settings to see if it does it from scratch since I thought I would post here first to see if someone has ideas.
would like to add that I have also tried moving the source to an NVMe SSD
I have also tried turning off HDR
neither of these show improvement



Quote:
Originally Posted by tp4tissue View Post
1060 will give you a baseline. Everything below 1060 shouldn't be bought at this point.

Everything more expensive than the 1060 has QUESTIONABLE benefits. But the benefits ARE THERE.
when going to 4K and using NGU I would have to agree. In some cases a 1060 is just enough which is why I went up to the 2060


Quote:
Originally Posted by ryrynz View Post
Are the pans even meant to be smooth though? Here's a test, copy your content on to a USB flash drive and play it back through the TV's USB port.
Worth taking note of the picture settings and make sure they're applied to your HDMI input you're using for the HTPC.


yes these should be smooth. Examples would be in live action Ghost In the Shell when they pan up the buildings to where she is standing.

Another would be in the beginning of blade runner 2049 or really any time they pan across a large area.

These pans happen in anime very often as well found some good ones in Hozuki's Coolheadedness and Mardock Scramble that I have been testing with.

These all are normally buttery smooth but now they have are stutters. Not like the normal judder you'd see displaying 24fps on 60fps screen but more hitching than anything like some frames kind of catch and hang more than others.



Quote:
Originally Posted by Asmodian View Post
Is the Nvidia control panel 3D setting "Power management mode" on Optimal Power? It should not be.

Is the Windows 10 Focus Assist enabled in anyway? Disable it, including the extra options, just the global disable is not enough.

Are you running F.lux?
its on Prefer maximum performance

Focus assist is completely turned off

no I'm not running that and I have not yet calibrated the TV as I haven't had the time to look into that yet, especially for HDR



Quote:
Originally Posted by austinminton View Post
Try full screen exclusive. It fixed stuttering issues for me on my 2080ti.
I always run full screen exclusive on this system since it only has one display and watching is all I will be doing on it.
TheProfosist is offline   Reply With Quote
Old 10th March 2019, 19:58   #55267  |  Link
madjock
Registered User
 
Join Date: May 2018
Posts: 223
Quote:
Originally Posted by TheProfosist View Post
These all are normally buttery smooth but now they have are stutters. Not like the normal judder you'd see displaying 24fps on 60fps screen but more hitching than anything like some frames kind of catch and hang more than others.
I read somewhere about a Windows 10 update that was affecting games and maybe video, did you just update ? change drivers etc...

The way you explain it is as if something has changed recently ?

https://www.bleepingcomputer.com/new...ring-in-games/
__________________
Windows 10-1903 | i5-3570k | GTX 1070 Windforce OC Rev2 8GB : 430.64 | Yamaha RX-V377 | Philips 65PUS6703 - 65"

Last edited by madjock; 10th March 2019 at 20:05.
madjock is offline   Reply With Quote
Old 10th March 2019, 20:58   #55268  |  Link
brazen1
Registered User
 
Join Date: Oct 2017
Posts: 227
Use D3D11 auto/native in LAV Filter.
Turn off SM in madVR.
Match refresh rates using madVR for all resolutions in 2160p only.
Add 2 blank folders to madVR install directory named ShowHdrMode and ShowRenderSteps.
Link a screen shot of your OSD.

Slow pans should be butter smooth with absolutely no hitches in the giddy up at all. No judder, no blur, no dropped/repeated frames. Nothing but bliss no matter the resolution. Opening scene of Cowboys and Aliens or opening credits of The Wrestler are my go to test subjects.
__________________
HOW TO-Kodi 2D-3D-UHD (4k) HDR Guide Internal & External Players
W10 1903 9604GB RGB 4:4:4 @Matched Refresh Rates 8,10,12bit
KODI MPC-HC/BE PDVD19 DVDFab 3 & 5
65JS8500 UHD HDR 3D
brazen1 is offline   Reply With Quote
Old 10th March 2019, 21:30   #55269  |  Link
ryrynz
Registered User
 
ryrynz's Avatar
 
Join Date: Mar 2009
Posts: 3,215
Sounds like an OS/Driver issue. You should revert to your last good backup/System Restore point.
ryrynz is offline   Reply With Quote
Old 10th March 2019, 22:04   #55270  |  Link
tp4tissue
Registered User
 
tp4tissue's Avatar
 
Join Date: May 2013
Posts: 406
Quote:
Originally Posted by brazen1 View Post
Use D3D11 auto/native in LAV Filter.
Turn off SM in madVR.
Match refresh rates using madVR for all resolutions in 2160p only.
Add 2 blank folders to madVR install directory named ShowHdrMode and ShowRenderSteps.
Link a screen shot of your OSD.

Slow pans should be butter smooth with absolutely no hitches in the giddy up at all. No judder, no blur, no dropped/repeated frames. Nothing but bliss no matter the resolution. Opening scene of Cowboys and Aliens or opening credits of The Wrestler are my go to test subjects.
What does this mean, -match refresh rates using madvr for all resolutions- ?
__________________
Ghetto | 2500k 5Ghz
tp4tissue is offline   Reply With Quote
Old 10th March 2019, 22:40   #55271  |  Link
border.community
Registered User
 
Join Date: Dec 2018
Posts: 10
Anybody have thoughts on why mpc-hc is freezing during 4k HDR 24p playback? Some movies i can get through no problems but others it can crash every 20 minutes or so. I thought 1050ti was good enough so trying to rule out the card as the problem---otherwise was thinking need to go 1060 or higher.

-1050ti 4gb
-HDR passthrough
-NGU AA med
-D3D11 FSE
-all trade quality for performance unchecked
-smooth motion off
-gpu/cpu queue size 12
-presenting 8 frames in advance
-nothing under "processing" folder turned on
-win10
-390.77
-ryzen 5
border.community is offline   Reply With Quote
Old 10th March 2019, 22:54   #55272  |  Link
brazen1
Registered User
 
Join Date: Oct 2017
Posts: 227
It means sometimes alternate advice works too. Instead of using a player like MPC and entering refresh rates in its settings, use madVR exclusively and turn it off elsewhere for madVR player(s) used.

I have a native 2160p display I use for everything including 1080p 3D. Far too many times I see users suggesting to use players to control resolution switching instead of madVR. This is usually to work around other problems and in turn create even more problems except the one at hand. Furthermore, less experienced users don't match refresh rates at all and then we read complaints about judder. How many times have you seen an OSD screenshot playing 23.976 video and rendering at 60Hz with a 120Hz or higher display? Still others suggest to enter all the refresh rates a display handles instead of just the native highest which creates even more problems. For example, entering a bunch of 1080 resolutions when you are scaling everything to 2160 in the first place.

Thus my statement you clipped a bit "Match refresh rates using madVR for all resolutions in 2160p only".
This because the OP has a native 2160p display and I suggested to let madVR do all the scaling since it's been foolproof for me for years using a lot of diverse sources.
In that case I use these and only these and only entered in madVR for its comparable players aka "Match refresh rates using madVR". I have never run into a problem and again with lots of diverse titles.
2160p23, 2160p24, 2160p25, 2160p30, 2160p50, 2160p59, 2160p60 aka "all resolutions in 2160p only".

Now if your display is not native 2160p unlike mine and the OP's which are, I suppose you would use a completely different set of resolution values and begin working around your true problem. Same goes if you have 3D problems that require 1080p values or HDMI 2.0 vs 1.4 junk capability devices and so on. Fwiw, I also suggest 'whitelisting' these and only these values in Kodi for the times you use its internal VideoPlayer instead of a madVR player since madVR will NOT be controlling the internal player since it is not a madVR related player. If I'm not mistaken, only Kodi v.18 offers these values allowing casual use converting HDR to SDR be possible without side affects such as postage stamping.
__________________
HOW TO-Kodi 2D-3D-UHD (4k) HDR Guide Internal & External Players
W10 1903 9604GB RGB 4:4:4 @Matched Refresh Rates 8,10,12bit
KODI MPC-HC/BE PDVD19 DVDFab 3 & 5
65JS8500 UHD HDR 3D

Last edited by brazen1; 10th March 2019 at 23:13.
brazen1 is offline   Reply With Quote
Old 10th March 2019, 23:04   #55273  |  Link
ryrynz
Registered User
 
ryrynz's Avatar
 
Join Date: Mar 2009
Posts: 3,215
Quote:
Originally Posted by border.community View Post
Anybody have thoughts on why mpc-hc is freezing during 4k HDR 24p playback? Some movies i can get through no problems but others it can crash every 20 minutes or so.
Ain't anything to do with madVR or mpc-hc or even the content itself.. You have a system issue. Test all hardware and revert to your last known good backup.
ryrynz is offline   Reply With Quote
Old 10th March 2019, 23:05   #55274  |  Link
brazen1
Registered User
 
Join Date: Oct 2017
Posts: 227
Border.community, you're learning that what may be 'good enough' for one title doesn't exactly translate for another. Find the hardest title you have to play and lower your settings until it works. I use the Sony camp video at 60fps. 2nd hardest for me is The Hunger Games at 23.976. I can play this one perfectly for about 5 minutes and then it starts dropping frames the queue can't keep with. So, I lowered my aggressive settings that work fine with other titles 100% of the time and now this one is accommodated too. Granted I could tailor settings for every movie but who wants to that? If anything the easy to play titles are now even more relaxed and when a hard to decode and render is selected, it's possible.

On a side note, Green Book will be released in a couple days. I think you will find it the best upscaled 4k movie to date for its video properties. Right there, if not exceeding, Planet Earth II. Probably the cameras. And with madVR chroma...
__________________
HOW TO-Kodi 2D-3D-UHD (4k) HDR Guide Internal & External Players
W10 1903 9604GB RGB 4:4:4 @Matched Refresh Rates 8,10,12bit
KODI MPC-HC/BE PDVD19 DVDFab 3 & 5
65JS8500 UHD HDR 3D

Last edited by brazen1; 10th March 2019 at 23:23.
brazen1 is offline   Reply With Quote
Old 11th March 2019, 00:30   #55275  |  Link
border.community
Registered User
 
Join Date: Dec 2018
Posts: 10
Quote:
Originally Posted by ryrynz View Post
Ain't anything to do with madVR or mpc-hc or even the content itself.. You have a system issue. Test all hardware and revert to your last known good backup.

You mean something with Windows or nvidia drivers? That wouldn't surprise me, yet brazen1 thinks the settings are too high which gets me second guessing whether 1050ti is good enough. And for reference, Blade Runner 2049 didn't have a hiccup, but Planet Earth II usually crashed a few times.

Think my best bet is a clean install and see how it does.

Last edited by border.community; 11th March 2019 at 00:33.
border.community is offline   Reply With Quote
Old 11th March 2019, 00:41   #55276  |  Link
tp4tissue
Registered User
 
tp4tissue's Avatar
 
Join Date: May 2013
Posts: 406
Quote:
Originally Posted by border.community View Post
You mean something with Windows or nvidia drivers? That wouldn't surprise me, yet brazen1 thinks the settings are too high which gets me second guessing whether 1050ti is good enough. And for reference, Blade Runner 2049 didn't have a hiccup, but Planet Earth II usually crashed a few times.

Think my best bet is a clean install and see how it does.
Are you using CPU decode or GPU dxva copyback.

Do you have CPU or Gpu overclock enabled.
__________________
Ghetto | 2500k 5Ghz
tp4tissue is offline   Reply With Quote
Old 11th March 2019, 00:54   #55277  |  Link
border.community
Registered User
 
Join Date: Dec 2018
Posts: 10
Quote:
Originally Posted by tp4tissue View Post
Are you using CPU decode or GPU dxva copyback.

Do you have CPU or Gpu overclock enabled.

Using D3D11 hardware decoder if that's what you mean.

Overclocking the 1050ti, yes---it's the SC version.

Ryzen OC'd to 3.7 GHz.

Last edited by border.community; 11th March 2019 at 00:58.
border.community is offline   Reply With Quote
Old 11th March 2019, 02:23   #55278  |  Link
ryrynz
Registered User
 
ryrynz's Avatar
 
Join Date: Mar 2009
Posts: 3,215
Set clocks back to defaults before reinstalling. Highly recommend a system restore before blitzing an entire OS.
ryrynz is offline   Reply With Quote
Old 11th March 2019, 02:28   #55279  |  Link
border.community
Registered User
 
Join Date: Dec 2018
Posts: 10
Quote:
Originally Posted by ryrynz View Post
Set clocks back to defaults before reinstalling. Highly recommend a system restore before blitzing an entire OS.

I will unclock and report back.


As far as system restore, Planet Earth II was the second thing I ran on madvr and the freezes happened immediately, so not like I have a steady state to revert back to.
border.community is offline   Reply With Quote
Old 11th March 2019, 04:15   #55280  |  Link
tp4tissue
Registered User
 
tp4tissue's Avatar
 
Join Date: May 2013
Posts: 406
Quote:
Originally Posted by border.community View Post
I will unclock and report back.


As far as system restore, Planet Earth II was the second thing I ran on madvr and the freezes happened immediately, so not like I have a steady state to revert back to.
If it still crashes at Stock clocks, (assuming it's not software related), then that means the motherboard default detected settings are unstable.

USUALLY, it's the memory subtimings which are detected wrong, this is common to ryzen boards, since they're still fairly new.

Try lowering the memory clock to the next step below labeled speed + 0.1v to default and test again.

If everything is still crashing when cpu+gpu are at stock, and mem is at _reduced clock_.

THEN it's likely software.

You don't need to reformat, just plug in another disk (hdd or ssd), install a whole new windows 10.. just install madvr and the video drivers, if it crashes, then we're back to hardwrae.

Don't format your current disk, because if it's not the software, then you can save time and just plug it back in.
__________________
Ghetto | 2500k 5Ghz

Last edited by tp4tissue; 11th March 2019 at 04:17.
tp4tissue is offline   Reply With Quote
Reply

Tags
direct compute, dithering, error diffusion, madvr, ngu, nnedi3, quality, renderer, scaling, uhd upscaling, upsampling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 12:14.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.