Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 19th September 2016, 21:51   #21041  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,667
Well, FFplay shows errors. You can test for yourself if you want.

https://ffmpeg.zeranoe.com/builds/
clsid is offline   Reply With Quote
Old 19th September 2016, 22:22   #21042  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 4,132
you should really disable SD hardware acceleration in this case (in my eye in general but what ever).

an SD stream doesn't really need any significant CPU power. software decoding has really good error handling and errors are common in broadcast.
huhn is offline   Reply With Quote
Old 20th September 2016, 08:34   #21043  |  Link
fxv300
Registered User
 
Join Date: Jul 2016
Posts: 2
RX480 and DXVA

Quote:
Originally Posted by nevcairiel View Post
If history with AMD tells us anything, its their drivers. But I do not plan to buy such a card.
Hi, a lot of the issues of the problems with the drivers have already been fixed. Blog here

Re DXVA HW acceleration issues, I can now play SD HD and UHD with HW acceleration turned on. This may not be an RX480 problem after all so don't jump to any conclusions as yet.

DXVAVideo
__________________
AMD PhenomII 6core T1100 3.3Ghz W10_64_16G Ram Sapphire RX 480 8G SoundsOKOK QAcoustic 2020i, ROKU4
AzureWave AD-SP400 DVB-S2 BlackGold BGT3620 DVB-T2 Monitor LG 27MU67 SONY STR-DN8600
fxv300 is offline   Reply With Quote
Old 20th September 2016, 08:37   #21044  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 8,915
Quote:
Originally Posted by fxv300 View Post
Re DXVA HW acceleration issues, I can now play SD HD and UHD with HW acceleration turned on. This may not be an RX480 problem after all so don't jump to any conclusions as yet
If newer drivers fixed it, and it works now, then my conclusion would appear to have been correct and it was a driver problem?
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 20th September 2016, 09:01   #21045  |  Link
CruNcher
Registered User
 
CruNcher's Avatar
 
Join Date: Apr 2002
Location: Germany
Posts: 4,950
Quote:
Originally Posted by fxv300 View Post
Hi, a lot of the issues of the problems with the drivers have already been fixed. Blog here

Re DXVA HW acceleration issues, I can now play SD HD and UHD with HW acceleration turned on. This may not be an RX480 problem after all so don't jump to any conclusions as yet.

DXVAVideo
You should find another recording method the actual achieved framerate distracts a lot from the main problem you want to show especially in the case of DXVA.
Also the way you trying to show it is wrong you need to get to the running Lav Video Process in the Directshow Chain to show what is really happening.
That Dialog is not displaying the running Process Thread in the Chain but opening another Process that will always show as if no Decoder is active at all, because for that new running instance that's the truth it has no active connection to anything.

To achieve the lowest latency with Hardware acceleration try to record over the VCE on the DWM Surface in your Windiows 10 Case.

Broadcast Streams are more complex as huhn said and neither ATI was very good at resilience Decoding back then when they most of all targeted clean Blu-Ray Bitstreams.

UVD inside HD2400 RV610/RV630 UVD 1.0 was a total mess (Driver as well as the Firmware itself) in those regards no chance vs Nvidias VPX core stability in those times

It was the time i got really frustrated with ATI and my change to Nvidia where they happily interacted with Consumers and Developers pretty open with for that time astonishingly low NDA barriers to even further improve the VPX core and it's spread everywhere and their initiation of VDPAU(CUVID), this also happened a lot over DOOM9 Feedback ATI was absolutely not interested a mayor management decision failure back then that surely bites AMD now in the ass improving everything backward.
__________________
all my compares are riddles so please try to decipher them yourselves :)

It is about Time

Join the Revolution NOW before it is to Late !

http://forum.doom9.org/showthread.php?t=168004

Last edited by CruNcher; 20th September 2016 at 10:31.
CruNcher is offline   Reply With Quote
Old 20th September 2016, 15:16   #21046  |  Link
IanD
Registered User
 
Join Date: Jun 2003
Location: Australia
Posts: 184
Which is the last release to support XP SP2?
IanD is offline   Reply With Quote
Old 20th September 2016, 18:17   #21047  |  Link
manolito
Registered User
 
manolito's Avatar
 
Join Date: Sep 2003
Posts: 2,023
Nevcairiel does not "officially" support WinXP any more, but I can assure you that the current stable version 0.68.1 works nicely under WinXP SP2. (AFAIK this is not true for SP1)

Cheers
manolito
manolito is offline   Reply With Quote
Old 20th September 2016, 20:30   #21048  |  Link
Gleb Egorych
Registered User
 
Join Date: Aug 2008
Posts: 231
Hi, nevcairiel,
I would like to return to the problem reported here: http://forum.doom9.org/showthread.ph...14#post1752214
Shortly: LAV CUVID decodes the file with artifacts, while CoreAVC CUDA and LAV software (FFMpeg) do the job without artifacts. Interestingly that wanezhiling and clsid confirmed they had artifacts with LAV CUVID as well.
You wrote that sample played fine for you and it contained stream errors.

Here is a new sample, as the previous one it was recorded from SatTV: https://www.sendspace.com/file/hryhxw
Same problem for me, win7 x64, the newest geforce driver 372.70.

Maybe there is some workaround like you did for deinterlacing with the "Aggressive" option. Success of CoreAVC CUDA gives a chance.
Attached Images
 
Gleb Egorych is offline   Reply With Quote
Old 20th September 2016, 20:52   #21049  |  Link
VictorLS
Registered User
 
Join Date: Mar 2009
Posts: 127
Gleb Egorych, what version of CoreAVC with CUDA are you tried?
PS. I almost always use "Aggressive" deinterlacing in LAV Video Decoder. I hope to try your sample tomorrow.
VictorLS is offline   Reply With Quote
Old 21st September 2016, 06:35   #21050  |  Link
IanD
Registered User
 
Join Date: Jun 2003
Location: Australia
Posts: 184
Quote:
Originally Posted by manolito View Post
Nevcairiel does not "officially" support WinXP any more, but I can assure you that the current stable version 0.68.1 works nicely under WinXP SP2. (AFAIK this is not true for SP1)
I tried installing 0.68.1 but it complains I need XP SP3 and refuses to install.

I have to go back to 0.59.1 (trial & error) before it will install on XP SP2.

Last edited by IanD; 21st September 2016 at 11:29.
IanD is offline   Reply With Quote
Old 21st September 2016, 10:12   #21051  |  Link
andyvt
Registered User
 
Join Date: Jan 2010
Posts: 265
I received a sample file that causes a crash in avutil-lav-55.dll. The same file plays via ffplay.exe. LMK if you need more info.

Thanks

Sample
__________________
babgvant.com
Missing Remote
andyvt is offline   Reply With Quote
Old 21st September 2016, 12:01   #21052  |  Link
filler56789
SuperVirus
 
filler56789's Avatar
 
Join Date: Jun 2012
Location: Antarctic Japan
Posts: 795
Quote:
Originally Posted by IanD View Post
I tried installing 0.68.1 but it complains I need XP SP3 and refuses to install.

I have to go back to 0.59.1 (trial & error) before it will install on XP SP2.
Simply do not use the installer, just extract the 32-bit files from the installer,
and then run regsvr32 on the DirectShow filters (*.AX)

Last edited by filler56789; 21st September 2016 at 12:24. Reason: clarification
filler56789 is offline   Reply With Quote
Old 21st September 2016, 16:06   #21053  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,667
Quote:
Originally Posted by filler56789 View Post
Simply do not use the installer, just extract the 32-bit files from the installer,
and then run regsvr32 on the DirectShow filters (*.AX)
The requirement is there for a reason. It uses Windows API functions only available in SP3. Manual registration will fail.

Quote:
Originally Posted by andyvt View Post
I received a sample file that causes a crash in avutil-lav-55.dll. The same file plays via ffplay.exe. LMK if you need more info.
Sample
Works fine here with 0.68.1.31
clsid is offline   Reply With Quote
Old 21st September 2016, 16:49   #21054  |  Link
filler56789
SuperVirus
 
filler56789's Avatar
 
Join Date: Jun 2012
Location: Antarctic Japan
Posts: 795
Quote:
Originally Posted by clsid View Post
The requirement is there for a reason. It uses Windows API functions only available in SP3. Manual registration will fail.
So I stand corrected, sir. I never used LAV Filters with XP Service Pack 2, so I trusted what manolito said:

Quote:
Originally Posted by manolito
... but I can assure you that the current stable version 0.68.1 works nicely under WinXP SP2. (AFAIK this is not true for SP1)
filler56789 is offline   Reply With Quote
Old 21st September 2016, 16:54   #21055  |  Link
manolito
Registered User
 
manolito's Avatar
 
Join Date: Sep 2003
Posts: 2,023
Sorry I mixed up SP2 and SP3...

The current LAVFilters do need XP SP3, but may I ask why you refuse to install SP3? I never heard of any issues which SP3 introduced.


Cheers
manolito
manolito is offline   Reply With Quote
Old 21st September 2016, 17:22   #21056  |  Link
rancorx2
Registered User
 
Join Date: Aug 2016
Posts: 1
hi, is there any chance of getting an aspect ratio setting added to lav filters?

currently i use ffdshow for everything except hevc which i use lav for but it leaves me with black bars.

i would love to be able to stretch videso to fullsceen like you can do with ffdshow.
rancorx2 is offline   Reply With Quote
Old 21st September 2016, 17:36   #21057  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,667
You can do that with MPC-HC.
menu > view > video frame > stretch to window
clsid is offline   Reply With Quote
Old 21st September 2016, 22:04   #21058  |  Link
VictorLS
Registered User
 
Join Date: Mar 2009
Posts: 127
Gleb Egorych, your 2016-09-20 21-15-33.ts recorded from 1HD is played without artifacts in WinXP with LAV Video Decoder 0.68.1 CUVID (with last XP Cyberlink Video Decoder (PDVD Generic) and MPC Video Decoder and ArcSoft Video Decoder I see square artifacts along all file - DXVA is bad) but hangs up at the end of file in KMP 4.0.0.0 (in MPC-HC 1.7.10.236 all OK).
PS. If CUVID will decode h265 10bit - I have written to nVIDIA about it but have no answer ( - I don't need DXVA at all.

Last edited by VictorLS; 21st September 2016 at 22:11.
VictorLS is offline   Reply With Quote
Old 21st September 2016, 23:28   #21059  |  Link
akim
Registered User
 
Join Date: Jul 2015
Posts: 13
nevcairiel
MPC-HC (LAV Filters) and mad-VR just a fairy tale thanks for that (can integrate them)
Friend implement or use the sane sound normalization in vlc (compressor) or potplayer even if they are incorrect
Another question is why there is no such option in the PAL SpeedDown player except Reclock, it is difficult or even something this amazing option
2-3 have to use one player to another normalization for PAL 25 to 23.976 compensation
One wants to use mpc-hc 64bit reclock but it does not support.
Thank you
akim is offline   Reply With Quote
Old 22nd September 2016, 13:20   #21060  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,667
Windows has an option called "loudness equalization". Google for it. Nevcairiel has already said several times he won't add such functionality to LAV.

The internal audio renderer of MPC-HC might one day get similar functionality as reclock. But not very soon.
clsid is offline   Reply With Quote
Reply

Tags
decoders, directshow, filters, splitter

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 06:38.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.