Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Reply
 
Thread Tools Search this Thread Display Modes
Old 16th August 2012, 14:12   #1  |  Link
gurusinghbrar
Registered User
 
Join Date: Jul 2012
Posts: 39
Encode Audio with x264 (x264_rev2208+677_tMod-Libav) not working

hi,
anybody tell me where is the problem Not working commnad line.

C:\Documents and Settings\Administrator\Desktop>x264.exe --profile main --level 3 --bitrate 300 --b-pyramid none --vbv-bufsize 10000 --vbv-maxrate 10000 --me umh --sar 1:1 --ademuxer auto --acodec fflibfdk_aac --abitrate 48 --acodec-quality 2 --atrack 1 --aextraopt profile:aac_he -o out.mp4 out.avs

show error:

C:\Documents and Settings\Administrator\Desktop>x264.exe --profile main --level
3 --bitrate 300 --b-pyramid none --vbv-bufsize 10000 --vbv-maxrate 10000 --me um
h --sar 1:1 --ademuxer auto --acodec fflibfdk_aac --abitrate 48 --acodec-quality
2 --atrack 1 --aextraopt profile:aac_he -o out.mp4 out.avs
avs [info]: 480x226p 1:1 @ 25/1 fps (cfr)
avs [info]: color matrix: undef
options [error]: Ordered option given after named
lavc [error]: wrong audio options.
mp4 [error]: error opening audio encoder.
mp4 [error]: unable to init audio output.
x264 [error]: could not open output file `out.mp4'


If i use it without --aextraopt it working but i want to use profile can anybody tell me how to use this. help text show like this..


* (ff)libfdk_aac encoder help
--aquality VBR quality
Cannot be used for HE-AAC and possible values are:
1, 2, 3, 4, 5
1 is lowest and 5 is highest.
--abitrate Enables bitrate mode [192]
Bitrate should be one of the discrete preset values depending on
profile, channels count, and samplerate.
Examples for typical configurations
- for 44100Hz to 48000Hz with 1ch
LC: 40, 48, 56, 64, 72, 80, 96, 112, 128, 144, 160, 192, 224, 256
HE: 12, 16, 24, 32, 40
- for 44100Hz to 48000Hz with 2ch
LC: 64, 72, 80, 96, 112, 128, 144, 160, 192, 224, 256, 288, 320, 384, 512
HE: 32, 40, 48, 56, 64, 80, 96, 112, 128
- for 64000Hz to 96000Hz with 2ch
LC: 80, 96, 112, 128, 144, 160, 192, 224, 256, 288, 320, 384, 512, 768, 1024
HE: 32, 40, 48, 56, 64, 80, 96, 112, 128, 160, 192, 256
- for 44100Hz to 48000Hz with 5.1ch
LC: 160, 192, 224, 256, 288, 320, 384, 448, 512, 576, 640, 768, 1024, 1280
HE: 80, 96, 112, 128, 160, 192, 256
- for 64000Hz to 96000Hz with 5.1ch
LC: 256, 288, 320, 384, 448, 512, 576, 640, 768, 1024, 1280, 1600, 1920, 2560
HE: 128, 160, 192, 256, 320, 384, 512, 640
The lower samplerate, the lower min/max values are applied
--aextraopt Profile and bitrate mode
cutoff: set cutoff in Hz
profile : profile for aac codec ["aac_low"]
"aac_low", "aac_he"


thanks

Last edited by gurusinghbrar; 16th August 2012 at 14:18.
gurusinghbrar is offline   Reply With Quote
Old 16th August 2012, 15:46   #2  |  Link
easyfab
Registered User
 
Join Date: Jan 2002
Posts: 311
C:\Documents and Settings\Administrator\Desktop>x264.exe --profile main --level 3 --bitrate 300 --b-pyramid none --vbv-bufsize 10000 --vbv-maxrate 10000 --me umh --sar 1:1 --ademuxer auto --acodec fflibfdk_aac --abitrate 48 --acodec-quality 2 --atrack 1 --aextraopt profile=aac_he -o out.mp4 out.avs
easyfab is offline   Reply With Quote
Old 16th August 2012, 17:08   #3  |  Link
gurusinghbrar
Registered User
 
Join Date: Jul 2012
Posts: 39
thanks @easyfab it working.

can you compile this libfdk-aac with ffmpeg or any source where i can download...
like ffmpeg -h press enter and show in list --enable-libfdk-aac. i read over google but they remove it from ffmpeg but i want it. help me..

thanks
gurusinghbrar is offline   Reply With Quote
Old 17th August 2012, 10:42   #4  |  Link
gurusinghbrar
Registered User
 
Join Date: Jul 2012
Posts: 39
can any one give me any link of ffmpeg build which is --enable-libaacplus. mean it aac+ or aacp enabled. or lifkc-aac anabled.

thanks
gurusinghbrar is offline   Reply With Quote
Old 17th August 2012, 13:05   #5  |  Link
JEEB
もこたんインしたお!
 
JEEB's Avatar
 
Join Date: Jan 2008
Location: Finland / Japan
Posts: 509
Those are unfortunately all under --enable-nonfree in ffmpeg, which means that you cannot distribute binaries with them linked in.

In other words, you most probably will get a binary quicker if you just compile it yourself
__________________
[I'm human, no debug | Unofficial x264 Builds]
JEEB is offline   Reply With Quote
Old 17th August 2012, 13:50   #6  |  Link
gurusinghbrar
Registered User
 
Join Date: Jul 2012
Posts: 39
hey jeeb plz.. can you compile it for me.. i dont know how to complie ffmpeg on window with these lib...
i found it on google ... but i cant understand how it work
http://ffmpeg.gusari.org/viewtopic.php?f=25&t=5
and this
http://tipok.org.ua/node/24
can u help me to compile it with this lib...
gurusinghbrar is offline   Reply With Quote
Old 17th August 2012, 15:24   #7  |  Link
easyfab
Registered User
 
Join Date: Jan 2002
Posts: 311
First step on window: install Mingw/msys

I use xhmikosr's version for example : http://xhmikosr.1f0.de/tools/

After that run msys.bat for Msys . now you can start building ffmpeg.

example you can try :

download and decompress (in Msys/home/your_name directory) http://sourceforge.net/projects/opencore-amr/files/fdk-aac/

and under Msys :
git clone git://source.ffmpeg.org/ffmpeg.git ffmpeg

cd fdk-aac-0.1.0
./configure --enable-shared=no
make -j4
make install
cd ..

cd ffmpeg
./configure --enable-libfdk-aac --enable-gpl --enable-version3 --enable-nonfree --enable-w32threads --enable-memalign-hack
make -j4

you have ffmpeg binaries in ffmpeg directory.
If you want others libs look at http://ffmpeg.zeranoe.com/builds/ for source files and do the same ( ./configure && make && make install )
and try ./configure --help to see the options.
easyfab is offline   Reply With Quote
Old 18th August 2012, 11:12   #8  |  Link
gurusinghbrar
Registered User
 
Join Date: Jul 2012
Posts: 39
hi easyfab i try ur method but not working.. first step of fdk-aac is run successfully but in second step not compile ffmpeg with libfdk-aac not working..
error when compliing.
----------------------------------------
Administrator@ro-sgn-site ~/ffmpeg
$ ./configure --enable-libfdk-aac --enable-gpl --enable-version3 --enable-nonfr
ee --enable-w32threads --enable-memalign-hack
ERROR: libfdk_aac not found

If you think configure made a mistake, make sure you are using the latest
version from Git. If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solving the problem.
-------------------------------------------
is there any already compiled ffmpeg with libaacplus or libfdk-aac libs provided on net. i dont know how to compile it on window pc, or can u help me or compile it for me... or u can send me uploaded complied ffmpeg exe link on my email id gurusinghbrar69[at]gmail[dot]com .. i want it for my personal use only, bcoz i want my songs on lower bitrate, and also video with lower bitrate audio like 48 or 64 kbps. and faac or faad lib quality so poor... plz complie it for me...

i check it out.. "h**p://ffmpeg.org/trac/ffmpeg/wiki/How%20to%20quickly%20compile%20libaacplus" if they are giving tutorial like these, so why they can't complie it into ffmpeg...

thank
gurusinghbrar is offline   Reply With Quote
Old 18th August 2012, 11:42   #9  |  Link
easyfab
Registered User
 
Join Date: Jan 2002
Posts: 311
gurusinghbrar,

Oh yes I forgot Make install -> install all in msys/usr/ or somthing like this and gcc can't find them

So find usr/fdk-aac directory and put all directories (especially lib and include) in MSYS/mingw/i686-w64-mingw32.

I give you the simplest method but I never use this.

I use --prefix= and PKG_CONFIG_PATH= when I compile.
easyfab is offline   Reply With Quote
Old 18th August 2012, 11:54   #10  |  Link
easyfab
Registered User
 
Join Date: Jan 2002
Posts: 311
gurusinghbrar,

Try also to add --prefix=/mingw/i686-pc-mingw32 to ./configure

so for example :

cd fdk-aac-0.1.0
./configure --enable-shared=no --prefix=/mingw/i686-w64-mingw32 ( or another directory )
make -j4
make install
cd ..

cd ffmpeg
PKG_CONFIG_PATH=/mingw/i686-w64-mingw32 /lib/pkgconfig/ ./configure --prefix=/mingw/i686-w64-mingw32 --enable-libfdk-aac --enable-gpl --enable-version3 --enable-nonfree --enable-w32threads --enable-memalign-hack
make -j4
easyfab is offline   Reply With Quote
Old 18th August 2012, 12:50   #11  |  Link
gurusinghbrar
Registered User
 
Join Date: Jul 2012
Posts: 39
thank you very much.... i have compile successfully....

" DOOM 9 site rock" bro.. it help me lot like new bee for compiling area.

now help me more now i want to complie ffmpeg with:

libaacplus + libx264 + libfdk_aac + mp3lame + avisynth + libxvid

tell me the procedure for that....

thank

Last edited by gurusinghbrar; 18th August 2012 at 13:04.
gurusinghbrar is offline   Reply With Quote
Old 18th August 2012, 13:43   #12  |  Link
Chikuzen
typo lover
 
Chikuzen's Avatar
 
Join Date: May 2009
Posts: 597
Quote:
Originally Posted by gurusinghbrar View Post
now help me more now i want to complie ffmpeg with:

libaacplus + libx264 + libfdk_aac + mp3lame + avisynth + libxvid
Why do you also want libaacplus, in order to to have fdk_aac?
__________________
my repositories
Chikuzen is offline   Reply With Quote
Old 18th August 2012, 14:02   #13  |  Link
easyfab
Registered User
 
Join Date: Jan 2002
Posts: 311
As said in a previous thread the simplest for you is to go here : http://ffmpeg.zeranoe.com/builds/
and to download the External Libraries Source Code that you want to add.
After that compile them ( do a ./configure --help to see the options ) and add --enable-libXXX when you compile ffmeg.

I give you an other example with libx264 so that you can encode x264+aac. for others libs try or google.

cd "your x264 directory"
./configure --prefix=/mingw/i686-w64-mingw32 --disable-cli --enable-static --disable-gpac --disable-swscale --enable-win32thread --enable-strip
make -j4
make install


and for ffmpeg

cd ffmpeg
PKG_CONFIG_PATH=/mingw/i686-w64-mingw32 /lib/pkgconfig/ ./configure --prefix=/mingw/i686-w64-mingw32 --enable-libfdk-aac --enable-avisynth --enable-libx264 --enable-gpl --enable-version3 --enable-nonfree --enable-w32threads --enable-memalign-hack
make -j4
easyfab is offline   Reply With Quote
Old 21st August 2012, 09:30   #14  |  Link
gurusinghbrar
Registered User
 
Join Date: Jul 2012
Posts: 39
hey @easyfab by using ur tutorial i successfully compiled ffmpeg with all my need lib but..
when i compile libaacplus it hang in command mode... i use these option..

cd libaacplus-2.0.2
./autogen.sh --enable-shared=no
make -j4
make install

run ./autogen success but when i use make -j4 it run but hang after some process...
and show these type of line.

"[main] sh 5324 sig_send: wait for sig_complete event failed, signal -
2, rc 258, Win32 error 0"


check out this also... same problem.
h@@p://ffmpeg[dot]org/pipermail/ffmpeg-devel/2011-November/116393.html
and attachment jpg.
h@@p://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20111105/17dc5f47/attachment.jpg



tell me how to compile it for ffmpeg....

Last edited by gurusinghbrar; 21st August 2012 at 09:34.
gurusinghbrar is offline   Reply With Quote
Old 1st September 2012, 19:53   #15  |  Link
gurusinghbrar
Registered User
 
Join Date: Jul 2012
Posts: 39
hey can any one provide me compile libpack for libaacplus like this type of "http://sada5.sakura.ne.jp/files/index.php?folder=TGlicGFjay9HQ0M0NzFidWlsZA=="

thankx
gurusinghbrar is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 10:17.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.