Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > (HD) DVD & Blu-ray authoring

Reply
 
Thread Tools Search this Thread Display Modes
Old 18th April 2012, 17:59   #121  |  Link
ttz
Registered User
 
Join Date: Apr 2012
Posts: 3
Hello. It’s my first post but I have been reading doom9’s forums for years. I must say you all helped and teach me a lot about video. I would like to thank crl2007 for this wonderful guide and all those who helped with their knowledge.
Now I have a problem and would like to ask for a little help. I used DVDFab to build a BD 2d from a 3d one. Everything is perfect except the setup menu. When I change audio or subtitles in the menus, main or popup menus, nothing happens. The ssif file disappeared and now I only have an m2ts with the all movie. The menus are IGS but I can’t find where they refer the ssif so I can change to the m2ts. Hope you understand what I’m trying to explain.
Thank you for any help you can give me.
ttz is offline   Reply With Quote
Old 20th April 2012, 04:30   #122  |  Link
no-one
Registered User
 
Join Date: Dec 2011
Posts: 10
Quote:
Originally Posted by tymoxa View Post
What you looking for is in 03001.jar > ca.class + bw.class
But i'm not sure if replacing "Spanish" to "Thai" would help.
Thank you very much

Quote:
Originally Posted by crl2007 View Post
You have to edit this line in bw.class

Thank you very much
no-one is offline   Reply With Quote
Old 3rd May 2012, 11:20   #123  |  Link
Blumaster
Registered User
 
Join Date: Mar 2012
Posts: 6
it possible edits 3D blu rays and keep the 3D version? are made in the same way, only disarming and rebuilding the ISO?

please answer me if you try to edit 3D blu ray.
Blumaster is offline   Reply With Quote
Old 3rd May 2012, 12:51   #124  |  Link
crl2007
Registered User
 
Join Date: Nov 2007
Posts: 650
You can edit the menu. I successfully edited an IGS menu from a 3D disc. But it's useless, because there's no free demuxer/remuxer for the SSIF files and therefore you can't add/remove subtitle/audio tracks. And there's also no free burning software to recreate the ISO.
crl2007 is offline   Reply With Quote
Old 4th May 2012, 21:32   #125  |  Link
Cedvano
Registered User
 
Join Date: Jul 2009
Posts: 227
Hi,

If someone can change the menu video of a BD?

I can shrink 3D video, I convert it in 3D frame packing. That's work for normal video, but sometime I've got error with menus.

Thanks
Cedvano is offline   Reply With Quote
Old 11th June 2012, 15:36   #126  |  Link
no-one
Registered User
 
Join Date: Dec 2011
Posts: 10
Quote:
Originally Posted by tymoxa View Post
What you looking for is in 03001.jar > ca.class + bw.class
But i'm not sure if replacing "Spanish" to "Thai" would help.
Quote:
Originally Posted by crl2007 View Post
You have to edit this line in bw.class

After I change spanish to thai, movie can't play.
How should i do?
no-one is offline   Reply With Quote
Old 11th June 2012, 21:47   #127  |  Link
crl2007
Registered User
 
Join Date: Nov 2007
Posts: 650
Read better. You should read the guide better and understand the operations.
crl2007 is offline   Reply With Quote
Old 13th June 2012, 22:51   #128  |  Link
Phoil
Registered User
 
Phoil's Avatar
 
Join Date: Mar 2012
Location: Denver, Colorado, US
Posts: 21
Hi,

I've created a multi-page .m2ts menu (IGS) from scratch; thank you for BDEdit, it helped *immensely* in putting it all together!

The problem is, while up/down/left/right button navigation works fine in some Blu-ray players (e.g. PowerDVD11), it doesn't work in others (e.g. WinDVD11).

I can't seem to find where the problem is. I'm attaching a small test (av streams removed, just the menu), would someone mind taking a look?

[Full structure is here: https://www.dropbox.com/s/jsr9b4kawafjoom/test.iso, it's under 30Mb.]
Attached Files
File Type: rar test.rar (61.1 KB, 39 views)

Last edited by Phoil; 13th June 2012 at 23:05. Reason: Clarity, and added link to full structure.
Phoil is offline   Reply With Quote
Old 15th June 2012, 23:47   #129  |  Link
Phoil
Registered User
 
Phoil's Avatar
 
Join Date: Mar 2012
Location: Denver, Colorado, US
Posts: 21
...Anyone?
Phoil is offline   Reply With Quote
Old 18th June 2012, 18:01   #130  |  Link
Phoil
Registered User
 
Phoil's Avatar
 
Join Date: Mar 2012
Location: Denver, Colorado, US
Posts: 21
Seriously, can anyone take a look? Is there something I'm missing?
Phoil is offline   Reply With Quote
Old 18th June 2012, 20:01   #131  |  Link
bigotti5
Spielberger
 
bigotti5's Avatar
 
Join Date: Feb 2005
Posts: 837
Some errors I found:

You must not use playlists > 02000 ( you use 10000.mpls)

playitem out_times are > than presentation_end_times
Code:
e.g. 10000.mpls - PlayItem[000] - Out_time = 00:10:03.529
        Presentation_end_time (00001.clpi) = 00:10:01.543
bigotti5 is offline   Reply With Quote
Old 18th June 2012, 20:16   #132  |  Link
Phoil
Registered User
 
Phoil's Avatar
 
Join Date: Mar 2012
Location: Denver, Colorado, US
Posts: 21
Ah, thank you! Those are simple to fix.

Anything that might cause the up/down/left/right button relations not to work correctly?
Phoil is offline   Reply With Quote
Old 19th June 2012, 08:40   #133  |  Link
bigotti5
Spielberger
 
bigotti5's Avatar
 
Join Date: Feb 2005
Posts: 837
IG sub TS start time and end time (00:00:00.000 - 00:00:02.000) differs from PlayItems time range (00:10:00.000 - 00:10:10.000)
bigotti5 is offline   Reply With Quote
Old 19th June 2012, 11:20   #134  |  Link
no-one
Registered User
 
Join Date: Dec 2011
Posts: 10
Quote:
Originally Posted by crl2007 View Post
Read better. You should read the guide better and understand the operations.

OK, I see. I skip step f-g.

Thank You
no-one is offline   Reply With Quote
Old 19th June 2012, 15:51   #135  |  Link
Phoil
Registered User
 
Phoil's Avatar
 
Join Date: Mar 2012
Location: Denver, Colorado, US
Posts: 21
Bigotti5, thanks for catching those two items earlier. They've been fixed, here's an updated test.

Quote:
Originally Posted by bigotti5 View Post
IG sub TS start time and end time (00:00:00.000 - 00:00:02.000) differs from PlayItems time range (00:10:00.000 - 00:10:10.000)
Yes, and that's correct.

The IG SubPath entry (IN 00.000 - 02.000 OUT) fits the timestamps and ClipInfo for that stream (90000.m2ts / 90000.clpi).

The IG stream is completely separate from the playitem streams. There's no reason it needs to match the IN/OUT times for the PlayListItems (which are also correct, by the way).

-------

I think the issue is somewhere in my BOGs. If anyone sees an issue, please let me know.
Phoil is offline   Reply With Quote
Old 19th June 2012, 18:09   #136  |  Link
bigotti5
Spielberger
 
bigotti5's Avatar
 
Join Date: Feb 2005
Posts: 837
Your 800x.m2ts have a framerate of 30...
bigotti5 is offline   Reply With Quote
Old 19th June 2012, 18:19   #137  |  Link
Phoil
Registered User
 
Phoil's Avatar
 
Join Date: Mar 2012
Location: Denver, Colorado, US
Posts: 21
Yes, they do (well, 29.97). They're being encoded through the same muxer that currently encodes my content videos. Is that an issue?
Phoil is offline   Reply With Quote
Old 19th June 2012, 18:26   #138  |  Link
bigotti5
Spielberger
 
bigotti5's Avatar
 
Join Date: Feb 2005
Posts: 837
No not 29,97 but 30, not allowed on BD
bigotti5 is offline   Reply With Quote
Old 19th June 2012, 18:36   #139  |  Link
bigotti5
Spielberger
 
bigotti5's Avatar
 
Join Date: Feb 2005
Posts: 837
Every presentation start time in clpi has to fit in playlist times, even the mux is separate.
bigotti5 is offline   Reply With Quote
Old 19th June 2012, 18:47   #140  |  Link
Phoil
Registered User
 
Phoil's Avatar
 
Join Date: Mar 2012
Location: Denver, Colorado, US
Posts: 21
Whoa, you're right about the 30fps on the menu-background streams. Not sure what's going on there, I'll fix it, thank you!

Quote:
Originally Posted by bigotti5 View Post
Every presentation start time in clpi has to fit in playlist times, even the mux is separate.
The presentation start time does fit in the playlist times! From the updated one I just linked above:

Code:
PlayListItem: file 80000 IN: 00:10:00.000  OUT: 00:10:10.000

ClipInfo 80000.clpi: Presentation start: 00:10:00.000  end: 00:10:10.495
Where's the problem?
Phoil is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 19:58.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.