Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Development

Reply
 
Thread Tools Search this Thread Display Modes
Old 15th March 2012, 23:25   #341  |  Link
SubJunk
Registered User
 
Join Date: Jun 2010
Posts: 441
Thanks a lot for these updates, SET. I find your builds are the best ones!
It seems that env->GetMTMode() is missing, is there a reason for this? I have a plugin that relies on that function
SubJunk is offline   Reply With Quote
Old 18th March 2012, 15:36   #342  |  Link
GMJCZP
Registered User
 
GMJCZP's Avatar
 
Join Date: Apr 2010
Location: I have a statue in Hakodate, Japan
Posts: 430
Quote:
Originally Posted by GMJCZP View Post
Please, I need an answer!
I had to go back to version 2.5.8 MT. I can use there are the VirtualDub fliters.
Any comments or suggestions?
GMJCZP is offline   Reply With Quote
Old 18th March 2012, 22:39   #343  |  Link
pbristow
Registered User
 
pbristow's Avatar
 
Join Date: Jun 2009
Location: UK
Posts: 262
Quote:
Originally Posted by GMJCZP View Post
With this version of Avisynth yesterday I tried to load a plugin for VirtualDub with LoadVirtualDubPlugin the way I've always done and then VirtualDubMod crashes, what is that?

In 2.5.8 MT I could perfectly.
I'll be doing something wrong or need to install anything?
Hi GMJCZP,

To get any answers, you'll need to supply a bit more information, such as what specific plugin you're trying to load and exatcly how (the simplest and best way to do this is to post the exact script you're using), what exact symptoms you get (e.g. any error messages that occur before the crash), what other plugins have you tried and did they behave the same way, etc. Otherwise, the only suggestion anyone can reasonably make is "investigate the problem".

Also, you need to post the question in the Usage forum, not here in the Development forum.

Good luck!
pbristow is offline   Reply With Quote
Old 20th March 2012, 04:04   #344  |  Link
GMJCZP
Registered User
 
GMJCZP's Avatar
 
Join Date: Apr 2010
Location: I have a statue in Hakodate, Japan
Posts: 430
Quote:
Originally Posted by pbristow View Post
Hi GMJCZP,

To get any answers, you'll need to supply a bit more information, such as what specific plugin you're trying to load and exatcly how (the simplest and best way to do this is to post the exact script you're using), what exact symptoms you get (e.g. any error messages that occur before the crash), what other plugins have you tried and did they behave the same way, etc. Otherwise, the only suggestion anyone can reasonably make is "investigate the problem".

Also, you need to post the question in the Usage forum, not here in the Development forum.

Good luck!
Sorry if use this thread.

The problem is straightforward: All plugin Virtualdub I try to carry this latest version of Avisynth, to boot, for example, VirtualDubMod, I get the error message that this program will close.

That's all.
GMJCZP is offline   Reply With Quote
Old 31st March 2012, 20:12   #345  |  Link
SEt
Registered User
 
Join Date: Aug 2007
Posts: 374
Update:

1) Updated to CVS, so everyone can try new interfaces: http://forum.doom9.org/showthread.ph...92#post1567792
2) Some bugfixes/improvements, mostly exceptions-related.
3) VirtualDub plugins now work again.
4) Changed compiler to VS2010 - something could break due to this.


SubJunk, it's not missing - just moved in tables due to 2.6 stuff. Rebuild your plugin with new headers and it should work fine.
SEt is offline   Reply With Quote
Old 31st March 2012, 20:31   #346  |  Link
Boulder
Pig on the wing
 
Boulder's Avatar
 
Join Date: Mar 2002
Location: Hollola, Finland
Posts: 4,322
Thanks, I'll download and start using the new build right away.
__________________
And if the band you're in starts playing different tunes
I'll see you on the dark side of the Moon...
Boulder is offline   Reply With Quote
Old 31st March 2012, 22:09   #347  |  Link
SubJunk
Registered User
 
Join Date: Jun 2010
Posts: 441
Thanks a lot for the new release!
If I rebuild with the new headers is there a risk of 2.5 incompatibility? Do you think 2.6 will eventually require most 2.5.8 plugins to recompile?
SubJunk is offline   Reply With Quote
Old 31st March 2012, 22:38   #348  |  Link
SEt
Registered User
 
Join Date: Aug 2007
Posts: 374
SubJunk, since it uses MT functions it's already incompatible with regular Avisynth, it will be incompatible with 2.5.8 MT due to new placement of MT functions, but there is nothing bad in it - 2.5.8 shouldn't be used anyway. If MT functions are called conditionally - you can still build it and maintain compatibility with 2.5.
2.6 will likely support 2.5 plugins without changes, but I hope they'll be recompiled if just to remove the ancient bad code that is compiled into all plugins and the main reason of "instability" of MT Avisynth mode.
SEt is offline   Reply With Quote
Old 31st March 2012, 23:53   #349  |  Link
SubJunk
Registered User
 
Join Date: Jun 2010
Posts: 441
OK, thanks for the explanation
SubJunk is offline   Reply With Quote
Old 1st April 2012, 04:26   #350  |  Link
GMJCZP
Registered User
 
GMJCZP's Avatar
 
Join Date: Apr 2010
Location: I have a statue in Hakodate, Japan
Posts: 430
Thanks a lot.
GMJCZP is offline   Reply With Quote
Old 2nd April 2012, 13:50   #351  |  Link
ryrynz
Registered User
 
ryrynz's Avatar
 
Join Date: Mar 2009
Posts: 2,509
Yeah, this is very great news. Avisynth development moves at such a slow pace is great to see new revisions.

Everything's working well here with no stability issues. Performance might even be slightly higher judging from the quick test I did. Thanks to you, IanB and everyone else involved.
ryrynz is offline   Reply With Quote
Old 2nd April 2012, 14:25   #352  |  Link
SEt
Registered User
 
Join Date: Aug 2007
Posts: 374
Oh, I forgot one minor thing in change log:

5) This version accepts brackets-less function calls like official Avisynth.
SEt is offline   Reply With Quote
Old 2nd April 2012, 21:13   #353  |  Link
SubJunk
Registered User
 
Join Date: Jun 2010
Posts: 441
Working well for me too so far
SubJunk is offline   Reply With Quote
Old 3rd April 2012, 06:56   #354  |  Link
GMJCZP
Registered User
 
GMJCZP's Avatar
 
Join Date: Apr 2010
Location: I have a statue in Hakodate, Japan
Posts: 430
I tried to load the VirtualDub filter "MSUSmartSharpen", and although not hung up VirtualDubMod, I just could not carry it, gave me error, as if the configuration that before worked now does not work.
GMJCZP is offline   Reply With Quote
Old 3rd April 2012, 10:06   #355  |  Link
tormento
Acid fr0g
 
tormento's Avatar
 
Join Date: May 2002
Location: Italy
Posts: 785
Newer revision works fine and solved some seeking problem too.

Thank you
__________________
@turment on Telegram
tormento is offline   Reply With Quote
Old 3rd April 2012, 11:49   #356  |  Link
hydra3333
Registered User
 
Join Date: Oct 2009
Location: crow-land
Posts: 446
Fresh Win7-64 install, i7-3820 16Gb. Copied 2.6 over the top of tsp's 2.5.7, used VIT functions for QTGMC plus loaded a few other relevant ones for a vanilla QTGMC script with DGindex. Opened script into avs2yuv, and it crashed with no avisynth message. Put 2.5.7 back, backed out to use non-VIT functions in same script and presto, it worked.

In hindsight maybe because I left (only) tsp's "MT" DLLs in the plugins folder and they autoloaded ?
hydra3333 is offline   Reply With Quote
Old 3rd April 2012, 17:46   #357  |  Link
SEt
Registered User
 
Join Date: Aug 2007
Posts: 374
Minor update:

1) Some more VirtualDub plugins compatibility fixes.
2) Issue with Overlay and YV24.


hydra3333, MT dlls are not supported. And as base you should start from 2.6 alpha or 2.5.8, not earlier.

Last edited by SEt; 3rd April 2012 at 17:49.
SEt is offline   Reply With Quote
Old 3rd April 2012, 19:27   #358  |  Link
titlis
Registered User
 
Join Date: Apr 2011
Location: Republic of Korea
Posts: 49
Sorry but the latest mt build keep crashing upon loading avspmod.
Other builds work properly.

titlis is offline   Reply With Quote
Old 3rd April 2012, 19:48   #359  |  Link
SEt
Registered User
 
Join Date: Aug 2007
Posts: 374
Can't reproduce.

Latest as 2012.04.03 or 2012.03.31?
SEt is offline   Reply With Quote
Old 3rd April 2012, 19:56   #360  |  Link
titlis
Registered User
 
Join Date: Apr 2011
Location: Republic of Korea
Posts: 49
Quote:
Originally Posted by SEt View Post
Can't reproduce.

Latest as 2012.04.03 or 2012.03.31?
2012.04.03

I'm using AvsPmod 2.2.1
titlis is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 11:56.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.