Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 13th February 2012, 17:34   #9061  |  Link
fastplayer
Registered User
 
Join Date: Nov 2006
Posts: 799
Typo in decoder/LAVAudio/LAVAudio.rc, line 112:
configura --> configure
fastplayer is offline   Reply With Quote
Old 13th February 2012, 17:35   #9062  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 8,857
Quote:
Originally Posted by fastplayer View Post
Typo in decoder/LAVAudio/LAVAudio.rc, line 112:
configura --> configure
But i like a's.
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 13th February 2012, 17:42   #9063  |  Link
fastplayer
Registered User
 
Join Date: Nov 2006
Posts: 799
Then leave it like that as a treat!
fastplayer is offline   Reply With Quote
Old 13th February 2012, 18:03   #9064  |  Link
dead_screem
Registered User
 
Join Date: Jan 2005
Posts: 105
Quote:
Originally Posted by nevcairiel View Post
The headers were for 4.0 already before, did it still work for you?
In short, not it shouldn't have any impact, unless i start using new functions.
oh, well thats good to know.
dead_screem is offline   Reply With Quote
Old 13th February 2012, 18:07   #9065  |  Link
Razoola
Registered User
 
Join Date: May 2007
Posts: 370
I have upgraded to 046 and since I have had a couple of system hard lockups when hardware decoder is set to none. No locks if its set to a hardware decoder. This has only started with 046, 045 was fine with decoder set to none.

edit, please ignore this.. I think it was a system issue.

Last edited by Razoola; 13th February 2012 at 19:19.
Razoola is offline   Reply With Quote
Old 13th February 2012, 18:44   #9066  |  Link
kolak
Registered User
 
Join Date: Nov 2004
Location: UK
Posts: 2,166
Golden solution for dithering is Floyd-Steinberg+bit of random noise, but ordered+bit of noise will be sufficient in most cases and much faster. Both ordered and random by itself have visible side effects.
kolak is offline   Reply With Quote
Old 13th February 2012, 19:01   #9067  |  Link
DragonQ
Registered User
 
Join Date: Mar 2007
Posts: 901
Quote:
Originally Posted by nevcairiel View Post
You misinterpret the specs.
There is GPU Compute capability, which tops out at 2.1 right now, and specifys which features are supported by the GPU.

The CUDA SDK version is just the software version to match, and support only depends on drivers.
I see, thanks.
DragonQ is offline   Reply With Quote
Old 13th February 2012, 20:49   #9068  |  Link
CoRoNe
Registered User
 
CoRoNe's Avatar
 
Join Date: Nov 2005
Posts: 644
Quote:
Originally Posted by nevcairiel View Post
- Improved Fraps decoding with EVR
For FPS1(yuvj420p) files could you automatically apply TV-levels with VMR-9 Renderless as well as you've done for EVR. The only thing left for both renderers now is BT.709->BT.601 luma conversion and LAV can perfectly decode Fraps files in YV12 mode.
Quote:
Originally Posted by nevcairiel View Post
- Multi-threaded decoding for Lagarith
- LAGS(rgb24): No problem
- LAGS(yuv420p): No problem
- LAGS(YUY2 / YUV 4:2:2 / yuv422p?): Splitter fails. With MPC Avi Source + LAV Decoder the file opens but no image and stays at 0:00. Only MPC Avi Source + LAGS vfw decoder works fine.
Quote:
Originally Posted by nevcairiel View Post
- Support for Snow and FFV1
SoC_[SNOW+Vorbis].mkv: Opens but no image and stays at 0:00. With MPC Matroska Source + LAV Decoder there's no image either, but at least the Vorbis stream is playing.

About FFV1, it all plays fine, but what exactly is "bgr0" for a colorspace? I'm not at all convinced atm FFV1(RGB32) is actually a lossless format. Output is completely different compared to Uncompressed, HFYU, LAGS, MLCY, and MSUD (RGB32).

VP61 issue:
- predator2_vp61.avi (VP61): No problem
- vid.avi (VP61+MP3): Opens but no image and stays at 0:00. With MPC Avi Source + LAV Decoder there's no image either, but at least the MP3 stream is playing.
__________________
My hobby website
CoRoNe is offline   Reply With Quote
Old 13th February 2012, 20:51   #9069  |  Link
cegy
Registered User
 
Join Date: Dec 2009
Posts: 98
since 0.46 i have notice a odd bug with decoding. to make sure it wasn't just that 1 build so i tryed the nightly from http://roy.orz.hm/lavf-w32-nightlies...213-b92b5da.7z which still gives me the same problem, it seems it picky on how the .ts has been saved i have uploaded a sample so you can see what the problem could be. video sample

0.46 slow


0.45 fast (normal it will be over 2x as fast on a bigger sample)
cegy is offline   Reply With Quote
Old 13th February 2012, 22:00   #9070  |  Link
egur
QuickSync Decoder author
 
Join Date: Apr 2011
Location: Atlit, Israel
Posts: 916
New version released 0.27 beta

Version 0.27 beta is out with the following changes:
* Optimized code path to high performance on high bitrate clips.
* FFDShow rev4322

Downloads
* For the latest cutting edge FFDShow builds download my builds Intel QuickSync Decoder SourceForge home page
* FFDShow-tryout site
* LAV Splitter builds
__________________
Eric Gur,
Processor Application Engineer for Overclocking and CPU technologies
Intel QuickSync Decoder author
Intel Corp.
egur is offline   Reply With Quote
Old 13th February 2012, 22:23   #9071  |  Link
CruNcher
Registered User
 
CruNcher's Avatar
 
Join Date: Apr 2002
Location: Germany
Posts: 4,950
Quote:
Originally Posted by CoRoNe View Post
For FPS1(yuvj420p) files could you automatically apply TV-levels with VMR-9 Renderless as well as you've done for EVR. The only thing left for both renderers now is BT.709->BT.601 luma conversion and LAV can perfectly decode Fraps files in YV12 mode.
- LAGS(rgb24): No problem
- LAGS(yuv420p): No problem
- LAGS(YUY2 / YUV 4:2:2 / yuv422p?): Splitter fails. With MPC Avi Source + LAV Decoder the file opens but no image and stays at 0:00. Only MPC Avi Source + LAGS vfw decoder works fine.
SoC_[SNOW+Vorbis].mkv: Opens but no image and stays at 0:00. With MPC Matroska Source + LAV Decoder there's no image either, but at least the Vorbis stream is playing.

About FFV1, it all plays fine, but what exactly is "bgr0" for a colorspace? I'm not at all convinced atm FFV1(RGB32) is actually a lossless format. Output is completely different compared to Uncompressed, HFYU, LAGS, MLCY, and MSUD (RGB32).

VP61 issue:
- predator2_vp61.avi (VP61): No problem
- vid.avi (VP61+MP3): Opens but no image and stays at 0:00. With MPC Avi Source + LAV Decoder there's no image either, but at least the MP3 stream is playing.
VP6 Interlaced is not supported by ffmpeg yet
__________________
all my compares are riddles so please try to decipher them yourselves :)

It is about Time

Join the Revolution NOW before it is to Late !

http://forum.doom9.org/showthread.php?t=168004
CruNcher is offline   Reply With Quote
Old 13th February 2012, 22:43   #9072  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 8,857
Quote:
Originally Posted by CoRoNe View Post
- LAGS(YUY2 / YUV 4:2:2 / yuv422p?): Splitter fails. With MPC Avi Source + LAV Decoder the file opens but no image and stays at 0:00. Only MPC Avi Source + LAGS vfw decoder works fine.
YUY2 Lagarith is currently not supported by the decoder, and i guess also causes failure in the splitter for the same reasons.

Quote:
Originally Posted by CoRoNe View Post
About FFV1, it all plays fine, but what exactly is "bgr0" for a colorspace?
BGR0 is 32-bit RGB without an alpha channel. It matches RGB32, while BGRA matches ARGB32.

Quote:
Originally Posted by cegy View Post
since 0.46 i have notice a odd bug with decoding.
If you're using the Intel QuickSync decoder, then thats a known bug. In any case, you should always mention what decoder you're referring to. (Software, CUVID, QuickSync, DXVA)
__________________
LAV Filters - open source ffmpeg based media splitter and decoders

Last edited by nevcairiel; 13th February 2012 at 23:12.
nevcairiel is offline   Reply With Quote
Old 13th February 2012, 23:06   #9073  |  Link
egur
QuickSync Decoder author
 
Join Date: Apr 2011
Location: Atlit, Israel
Posts: 916
Quote:
Originally Posted by cegy View Post
since 0.46 i have notice a odd bug with decoding. to make sure it wasn't just that 1 build so i tryed the nightly from http://roy.orz.hm/lavf-w32-nightlies...213-b92b5da.7z which still gives me the same problem, it seems it picky on how the .ts has been saved i have uploaded a sample so you can see what the problem could be.
...
In my test clips, 0.46 was faster.
Using the 0.27 QS DLL, I managed to get ~400fps on this clip.

The famous Samsung Oceanic Life clip now runs at 225fps instead of 145. LAV 0.45 ran the same clip at 156fps.
BTW, ffdshow runs the Samsung clip at 270fps.

All benchmarks used LAV splitter as source and were run twice.
__________________
Eric Gur,
Processor Application Engineer for Overclocking and CPU technologies
Intel QuickSync Decoder author
Intel Corp.
egur is offline   Reply With Quote
Old 13th February 2012, 23:25   #9074  |  Link
cegy
Registered User
 
Join Date: Dec 2009
Posts: 98
Quote:
Originally Posted by egur View Post
In my test clips, 0.46 was faster.
Using the 0.27 QS DLL, I managed to get ~400fps on this clip.

The famous Samsung Oceanic Life clip now runs at 225fps instead of 145. LAV 0.45 ran the same clip at 156fps.
BTW, ffdshow runs the Samsung clip at 270fps.

All benchmarks used LAV splitter as source and were run twice.

this was not with quicksync itself and not to sound funny but that .ts has some decoding issue when using the software decoder am not sure what or even why that is but i would like nevcairiel to look into why this is if you need a good sample just ask but that is sample i posted is very slow at decoding and as you can see in the pics that 0.46 is slower
cegy is offline   Reply With Quote
Old 13th February 2012, 23:41   #9075  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 8,857
Quote:
Originally Posted by cegy View Post
this was not with quicksync itself and not to sound funny but that .ts has some decoding issue when using the software decoder am not sure what or even why that is but i would like nevcairiel to look into why this is if you need a good sample just ask but that is sample i posted is very slow at decoding and as you can see in the pics that 0.46 is slower
120 fps is very slow?

Anyway, i found the issue, need to think how to properly solve it.
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 13th February 2012, 23:56   #9076  |  Link
cegy
Registered User
 
Join Date: Dec 2009
Posts: 98
uploaded a sample that is ~3m30s long and as you can see in this pic that yes 120 fps is slow say that i've been getting thing a easy ~600fps untill this decoding bug happened. by the way what was the problem nevcairiel? (i'll been using 0.45 untill this problem as been fixed) good .ts sample


Last edited by cegy; 14th February 2012 at 00:18. Reason: file uploaded
cegy is offline   Reply With Quote
Old 14th February 2012, 00:35   #9077  |  Link
Pat357
Registered User
 
Join Date: Jun 2006
Posts: 400
Seems that cegy is right : there seems something wrong with the decoding (h264) from this file : in my benchmark I got about the same results.
Strange is that the decoding seems to be limited to 1 thread.
I tested with 12 threads and with 1 thread : same result !!
During the benchmark, I had a CPU load between 5-7 % (read from taskmanager), this should to be 50-70% or higher when testing with 12 threads.

Tested on i7-970@3.7/ 6+6 cores.
Pat357 is offline   Reply With Quote
Old 14th February 2012, 01:06   #9078  |  Link
cegy
Registered User
 
Join Date: Dec 2009
Posts: 98
Quote:
Originally Posted by Pat357 View Post
Seems that cegy is right : there seems something wrong with the decoding (h264) from this file : in my benchmark I got about the same results.
Strange is that the decoding seems to be limited to 1 thread.
I tested with 12 threads and with 1 thread : same result !!
During the benchmark, I had a CPU load between 5-7 % (read from taskmanager), this should to be 50-70% or higher when testing with 12 threads.

Tested on i7-970@3.7/ 6+6 cores.
thank you for confirming this if you don't mind could you test the good sample and report back what results you get

Last edited by cegy; 14th February 2012 at 01:08.
cegy is offline   Reply With Quote
Old 14th February 2012, 01:10   #9079  |  Link
Thunderbolt8
Registered User
 
Join Date: Sep 2006
Posts: 2,144
Quote:
Originally Posted by cegy View Post
uploaded a sample that is ~3m30s long and as you can see in this pic that yes 120 fps is slow say that i've been getting thing a easy ~600fps untill this decoding bug happened. by the way what was the problem nevcairiel? (i'll been using 0.45 untill this problem as been fixed) good .ts sample

for this file (H.264), on my system I get

~77fps with LAV copy back
~84fps with LAV without copy back
~150fps with coreavc

for a VC-1 .ts sample, I get

~35 fps with WMV DecoderDMO
~51 fpps with LAV copy back

for some reason, LAV copy back works way better with VC-1 than with H.264 for me (meaning theres actually an improvement) -.-
(maybe thats also because VC-1 CPU decoders are not multithreaded)
__________________
Laptop Acer Aspire V3-772g: i7-4202MQ, 8GB Ram, NVIDIA GTX 760M (+ Intel HD 4600), Windows 8.1 x64, madVR (x64), MPC-HC (x64), LAV Filter (x64), XySubfilter (x64)

Last edited by Thunderbolt8; 14th February 2012 at 01:18.
Thunderbolt8 is offline   Reply With Quote
Old 14th February 2012, 08:07   #9080  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 8,857
Hardware decoding isn't necessarily faster then CPU decoding on todays fast CPUs, but it does reduce the CPU load which can save power.
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Reply

Tags
decoders, directshow, filters, splitter

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 19:46.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.