Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 25th November 2011, 14:45   #7321  |  Link
fastplayer
Registered User
 
Join Date: Nov 2006
Posts: 799
Quote:
Originally Posted by nevcairiel View Post
WebM files are just mkv files with some feature limitations, so yes of course.
Thanks for confirming.
Seeking got better (faster, more responsive) with the new demuxer although the old one was already pretty good.
fastplayer is offline   Reply With Quote
Old 25th November 2011, 15:49   #7322  |  Link
GRENDIZER
Registered User
 
Join Date: Jun 2006
Posts: 7
Sorry if this question has been asked before but I can't figure how to search inside threads.
LAV doesn't have any systray icon, but is there a way to check if the LAV audio decoder is active while playing a video?
Thanks
Gz
GRENDIZER is offline   Reply With Quote
Old 25th November 2011, 18:24   #7323  |  Link
Nevilne
Registered User
 
Join Date: Aug 2010
Posts: 134
I'm not getting default subtitles selected in any mkv with new demuxer.
Nevilne is offline   Reply With Quote
Old 25th November 2011, 18:32   #7324  |  Link
Paladin77
Registered User
 
Join Date: Nov 2011
Posts: 37
Quote:
Originally Posted by GRENDIZER View Post
Sorry if this question has been asked before but I can't figure how to search inside threads.
LAV doesn't have any systray icon, but is there a way to check if the LAV audio decoder is active while playing a video?
Thanks
Gz
If you're using MPC-HC. While the video is playing right click anywhere in the video, choose filters. I think that is the case too in Potplayer (correct me if am wrong anyone).

Here is an example. Credits to Haruhichan weblog:
__________________
Motherboard: GIGABYTE GA-990FXA-D3
Processor: AMD FX 8150 Black Edition 8-core @3.6 Ghz.
RAM: G-Skill Ares 16GB dual channel DDR3.
GPU: 2X Crossfire AMD RADEON HD 6850.
OS: Windows 7 Utlimate x64.
Paladin77 is offline   Reply With Quote
Old 25th November 2011, 20:51   #7325  |  Link
BloodySword
Registered User
 
BloodySword's Avatar
 
Join Date: Jun 2005
Posts: 70
ADTS AAC + LAV 0.40 + ffDSHOW libfaad2 = auto seek to EOF, no playback. :/
works only with isomM4a or with libavcodec as AAC decoder in ffDSHOW.
BloodySword is offline   Reply With Quote
Old 25th November 2011, 21:50   #7326  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 8,852
Quote:
Originally Posted by Nevilne View Post
I'm not getting default subtitles selected in any mkv with new demuxer.
Should be fixed.

Quote:
Originally Posted by BloodySword View Post
ADTS AAC + LAV 0.40 + ffDSHOW libfaad2 = auto seek to EOF, no playback. :/
works only with isomM4a or with libavcodec as AAC decoder in ffDSHOW.
Then, why not just use libavcodec?
Also, it should be fixed - it was however ffdshows fault, it accepts a media type which it doesn't understand, faulty design imho.
__________________
LAV Filters - open source ffmpeg based media splitter and decoders

Last edited by nevcairiel; 25th November 2011 at 21:53.
nevcairiel is online now   Reply With Quote
Old 25th November 2011, 23:55   #7327  |  Link
GRENDIZER
Registered User
 
Join Date: Jun 2006
Posts: 7
Hello Palladin, thanks for your answer. Is there another way to check if LAV Audio is active? Cause I'm using Windows Media Center on Win 7 64.
GRENDIZER is offline   Reply With Quote
Old 26th November 2011, 04:17   #7328  |  Link
STaRGaZeR
4:2:0 hater
 
Join Date: Apr 2008
Posts: 1,307
nev, found a bug in your last "official" build: default flags are ignored. The first audio track and the no subtitle track are always selected, as if the file had no flags.
__________________
Specs, GTX970 - PLS 1440p@96Hz
Quote:
Originally Posted by Manao View Post
That way, you have xxxx[p|i]yyy, where xxxx is the vertical resolution, yyy is the temporal resolution, and 'i' says the image has been irremediably destroyed.
STaRGaZeR is offline   Reply With Quote
Old 26th November 2011, 05:13   #7329  |  Link
mindbomb
Registered User
 
Join Date: Aug 2010
Posts: 578
edit
you know, i think something just went wrong with the muxing, so this isnt a lav splitter issue.

Last edited by mindbomb; 26th November 2011 at 18:21.
mindbomb is offline   Reply With Quote
Old 26th November 2011, 05:17   #7330  |  Link
roytam1
Firefox User
 
Join Date: Sep 2003
Posts: 201
Quote:
Originally Posted by STaRGaZeR View Post
nev, found a bug in your last "official" build: default flags are ignored. The first audio track and the no subtitle track are always selected, as if the file had no flags.
Did you tried the newest revision?

New nightly:
http://roy.orz.hm/lavf-w32-nightlies...ame-65b6e66.7z

diff( " " ):
http://roy.orz.hm/lavf-w32-nightlies...e-65b6e66.diff
roytam1 is offline   Reply With Quote
Old 26th November 2011, 06:11   #7331  |  Link
nx6
Playing with MKV files...
 
nx6's Avatar
 
Join Date: Feb 2007
Posts: 278
Quote:
Originally Posted by nevcairiel View Post
Then, why not just use libavcodec?
I'm using libfaad, too actually.

There was an issue with libavcodec's AAC decoder playing certain types of AAC streams that didn't have issues on the older libfaad decoder. However, if I remember the release notes from the latest CCCP, the new version of ffdshow it ships with should have gotten those issues fixed. I haven't tried it to find out though.
__________________
Intel Core i7 920, 6 GB RAM | GeForce GTX670 | Win8.1 | LAV 0.64 / MadVR 0.87.10 | Zoom Player v10 / MPC-HC 1.7.8
nx6 is offline   Reply With Quote
Old 26th November 2011, 07:55   #7332  |  Link
leewalk
Registered User
 
Join Date: Oct 2011
Posts: 6
LAV Splitter and DTS-HD MA 7.1

Looks like LAV is only seeing 5.1 audio inside a DTS-HD MA 7.1 file like http://www.trailerz.demo-world.eu/hd...t_lossless.rar, even with dtsdecoderdll.dll in use?

Known issue?

Thanks, Lee
leewalk is offline   Reply With Quote
Old 26th November 2011, 07:58   #7333  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 8,852
Quote:
Originally Posted by leewalk View Post
Looks like LAV is only seeing 5.1 audio inside a DTS-HD MA 7.1 file like http://www.trailerz.demo-world.eu/hd...t_lossless.rar, even with dtsdecoderdll.dll in use?

Known issue?

Thanks, Lee
Its just a cosmetic issue, if you decode it, LAV Audio should say 8 channels on its status page - just LAV Splitter doesn't know that.


Quote:
Originally Posted by STaRGaZeR View Post
nev, found a bug in your last "official" build: default flags are ignored. The first audio track and the no subtitle track are always selected, as if the file had no flags.
That was fixed last night.
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is online now   Reply With Quote
Old 26th November 2011, 08:03   #7334  |  Link
leewalk
Registered User
 
Join Date: Oct 2011
Posts: 6
Quote:
Originally Posted by nevcairiel View Post
Its just a cosmetic issue, if you decode it, LAV Audio should say 8 channels on its status page - just LAV Splitter doesn't know that.



That was fixed last night.
LAV Audio says 6 channels. I tried a couple of different demo 7.1 files, but LAV Audio says all of them are 5.1.

Lee
leewalk is offline   Reply With Quote
Old 26th November 2011, 08:20   #7335  |  Link
leewalk
Registered User
 
Join Date: Oct 2011
Posts: 6
For a sanity check, I tried a Dolby HD 7.1 clip http://www.trailerz.demo-world.eu/hd...t_lossless.rar and both LAV Splitter and LAV audio reported 7.1.
leewalk is offline   Reply With Quote
Old 26th November 2011, 10:17   #7336  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 8,852
Quote:
Originally Posted by leewalk View Post
For a sanity check, I tried a Dolby HD 7.1 clip http://www.trailerz.demo-world.eu/hd...t_lossless.rar and both LAV Splitter and LAV audio reported 7.1.
Then you failed at putting the dts dll in the proper directory, or are using a very old version of the dll and forgot to install the required runtime (which would be automatically installed if you installed TMT. )
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is online now   Reply With Quote
Old 26th November 2011, 11:47   #7337  |  Link
fastplayer
Registered User
 
Join Date: Nov 2006
Posts: 799
Interesting commit over at ffmpeg.git:
lavfi: add libass based subtitles renderer
fastplayer is offline   Reply With Quote
Old 26th November 2011, 11:58   #7338  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 8,852
Quote:
Originally Posted by fastplayer View Post
Interesting commit over at ffmpeg.git:
lavfi: add libass based subtitles renderer
TBH, that change isn't all that useful for us.
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is online now   Reply With Quote
Old 26th November 2011, 12:06   #7339  |  Link
fastplayer
Registered User
 
Join Date: Nov 2006
Posts: 799
It was more of an FYI. Quite a few times people have asked for a libass-based sub renderer here on D9. Now it's on ffmpeg which is "usually" a good sign.
fastplayer is offline   Reply With Quote
Old 26th November 2011, 16:38   #7340  |  Link
Paladin77
Registered User
 
Join Date: Nov 2011
Posts: 37
Quote:
Originally Posted by GRENDIZER View Post
Hello Palladin, thanks for your answer. Is there another way to check if LAV Audio is active? Cause I'm using Windows Media Center on Win 7 64.
http://fileforum.betanews.com/detail...r/1262732488/1

You can use this tool to set your preferred DirectShow Decoder in w7. Select LAV audio for audio formats you want MC to decode and MC should use it.
__________________
Motherboard: GIGABYTE GA-990FXA-D3
Processor: AMD FX 8150 Black Edition 8-core @3.6 Ghz.
RAM: G-Skill Ares 16GB dual channel DDR3.
GPU: 2X Crossfire AMD RADEON HD 6850.
OS: Windows 7 Utlimate x64.
Paladin77 is offline   Reply With Quote
Reply

Tags
decoders, directshow, filters, splitter

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 00:12.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.