Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 6th November 2011, 04:13   #10641  |  Link
andybkma
Registered User
 
Join Date: Sep 2006
Posts: 183
Quote:
Originally Posted by TheShadowRunner View Post
Hmm a very strange behavior/bug with 0.78:
Launch the player, start playing a video. Minimize the player in the task bar (so the image isn't displayed) but keep playback going.
Wait like a minute. When you bring the player back up, the video plays super crazy fast to catch up with the audio.
The video itself stops being "refreshed" as soon as it stops being visible (player minimized), it seems.
Yah, same here
andybkma is offline   Reply With Quote
Old 6th November 2011, 05:08   #10642  |  Link
QBhd
QB the Slayer
 
QBhd's Avatar
 
Join Date: Feb 2011
Location: Toronto
Posts: 408
Regarding the failure of exclusive mode when playing from a playlist of multiple files of various frame rates and resolutions:

I have a few more observations to add. First, the failure seems to happen when switching from a 29fps to a 24fps (or vice versa). I thought it might have been when switching from an SD avi to a 720p mkv, but after tracking the problem for weeks I have narrowed it down to a frame rate change. Secondly, I was toying with the idea of using "Disable Desktop Composition (Vista or Higher)" since I did not think having a composition frame rate of 60Hz worked well with a monitor resolution of 24Hz... it just seemed wrong, I might be fooling myself however I thought I would see what would happen when enabling this setting. Guess what, there was not one instance of exclusive mode failure during a very long playlist of varying frame rates. So I may have solved my "exclusive mode failed" issue by accident by testing a setting for another reason.

I just thought I would share my observations.

QB
__________________
QBhd is offline   Reply With Quote
Old 6th November 2011, 06:24   #10643  |  Link
JarrettH
Registered User
 
Join Date: Aug 2004
Posts: 815
To clarify, this technically does not work with DVDs right? madvr works as the renderer in my case, but will not decode

Like 6233638 says, File > Open Disc uses Microsoft DTV-DVD automatically and blocking that uses internal MPC-HC one which is poor. The only problem with the Microsoft one was lack of navigation and subtitles, quality was fine IMO.
In ffdshow I have MPEG2 decoding (libavcodec, 'DVD decoding' ticked), NV12 output, and using the 'set interlaced flag in output media type' option. This combo seems to activate the deinterlacing on my gpu as I don't have it setup anywhere else. Err is that correct?

Last edited by JarrettH; 6th November 2011 at 06:38.
JarrettH is offline   Reply With Quote
Old 6th November 2011, 07:27   #10644  |  Link
jmone
Registered User
 
Join Date: Dec 2007
Posts: 572
Did some more deinterlace testing on my HTPC and it looks pretty good. The issue with the dropped frames is less frequent on this PC and the queue fluctuation seems to rellay only be the SD stuff (worse was the DV-AVI material in 720x576/50i). All the HD material (1920x1080/50&60i in VC-1 and h264 as well as MPEG2 1440x1080/50i) had rock solid queues.
jmone is offline   Reply With Quote
Old 6th November 2011, 07:28   #10645  |  Link
dansrfe
Registered User
 
Join Date: Jan 2009
Posts: 1,212
Quote:
Originally Posted by JarrettH View Post
To clarify, this technically does not work with DVDs right? madvr works as the renderer in my case, but will not decode

Like 6233638 says, File > Open Disc uses Microsoft DTV-DVD automatically and blocking that uses internal MPC-HC one which is poor. The only problem with the Microsoft one was lack of navigation and subtitles, quality was fine IMO.
In ffdshow I have MPEG2 decoding (libavcodec, 'DVD decoding' ticked), NV12 output, and using the 'set interlaced flag in output media type' option. This combo seems to activate the deinterlacing on my gpu as I don't have it setup anywhere else. Err is that correct?
http://forum.doom9.org/showthread.php?t=159492
dansrfe is offline   Reply With Quote
Old 6th November 2011, 10:02   #10646  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 8,917
Quote:
Originally Posted by cyberbeing View Post
WinXP SP3 x86
7800GTX 512

madVR deinterlacing has a tendency to crash at the beginning of MPEG2-TS files.

Crash/Working Logs: http://www.mediafire.com/?fl3x9a973ah3kwx

EDIT: Enabling Managed Upload Texture stops the crashes. Possibly you should automatically enable this when using DXVA2 Deinterlacing on WinXP? I seem to remember that setting hurting smoothness normally though. Maybe I should re-test smoothness with that setting, or is this something you can fix without that setting?
It seems that creating a texture at some point fails in your case. I'm not 100% sure why, but my best guess would be that madVR is simply running out of GPU RAM. Maybe I need to work on that, or maybe allow the render etc queues to be configured smaller. Deinterlacing definitely takes more GPU RAM. Not sure why Managed Textures stop the problem. It's possible Managed Textures resort to PCIe RAM when GPU RAM runs out, but I'm not sure...

Quote:
Originally Posted by dansrfe View Post
Function: Deinterlacing works for me other than when I resize. When I scale up the 10-13/13, 4-7/9, 2-5/9, 2-5/8, 0-3/8 for decoder, upload, deinterlac, render and present queues respectively.
Interesting. Is this exclusive or windowed mode? What happens if you enable Bilinear scaling for chroma and luma up/down? Does it still not work then?

Quote:
Originally Posted by dansrfe View Post
Quality: Deinterlacing certain "uncleanly interlaced" sources causes some artifacts and shimmering to occur. When compared to ffdshow's ffmpeg deinterlacer, ffmpeg does a much cleaner deinterlacement.
Which exact ffmpeg deinterlacer are you using? yadif? It would be *very* helpful if you could cross test this with VMR/EVR. If the same shimmering occurs there, then it's out of my hands.

Quote:
Originally Posted by dansrfe View Post
I have not compared to VMR/EVR deinterlacing yet because I don't know how to activate deinterlacing for VMR/EVR.
You simply use VMR/EVR instead of madVR and make sure to use a decoder which sets the interlaced flags. E.g. LAV Video Decoder does, if you configure it accordingly.

Quote:
Originally Posted by Thunderbolt8 View Post
doesnt even work when activating the trade quality for performance settings and setting scaling algorithms to nearest neighbor (for both, 29.97 fps AVC and VC-1)
Have you tested in windowed or exclusive mode? You don't have your GPU fixed at some lower clock? Does it not even work for interlaced SD content? Please cross check with VMR/EVR.

Quote:
Originally Posted by 6233638 View Post
I'm using LAV Splitter. If you open the video, click at the start of it, and keep going through the frames (ctrl+right) you should be able to select the patterns.

It seems that using madVR to decode doesn't let you go back frame-by-frame though, only forward. (I was still using LAV Video when I tried that) It should be the third pattern.
I can't get them to stay. Tried different decoders and splitters. Anyway, I'll find a way somehow.

Quote:
Originally Posted by 6233638 View Post
Fair enough. With madVR/CUVID deinterlacing, it is considerably better than the results I get with any of the software decoders I've tried, but there's still aliasing on a lot of the image, such as the benches in the background and the mic stand/cables when panning down.

I'm using an Nvidia card though, perhaps AMD handles it better?
Maybe. Is this a native video or movie source, btw (in case you know)? I've put it into my deinterlacing sample collection. Do you have any more such difficult to deinterlace samples?

Quote:
Originally Posted by Plutotype View Post
Can you please tell me, what decoder queue looks like on your setup, when you play a 30Mb bitrate blu-ray movie? What is the decoder queue supposed to behave during movie playback?
The decoder queue is supposed to stay nearly full (at least 8/12) at all times.

Quote:
Originally Posted by Andy o View Post
madshi, one issue with the refresh rate changer. I have an mkv remuxed from DVD (MPEG-2 29i), and when putting a "23p" or "24p" in the file name, refresh rate changes to 50p (without that in the file name, I get correctly 60p but it's telecined content). I have 1080p24, 1080p50 and 1080p60 in the rates field in madVR options.
Will check that.

Quote:
Originally Posted by Andy o View Post
IVTC with decimation seems to be working fine on its own, compared to CUVID where decimation has to be done separately by something like an avisynth script. This is all with the 460 and LAV video in software mode, haven't switched to AMD yet.
Quote:
Originally Posted by Andy o View Post
With AMD IVTC is not working at all with the same remuxed mkv MPEG-2 I mentioned above. Refreshing at 23p, I get very choppy video with many dropped frames per second. With NV and LAV's MPEG-2 decoder it seemed OK. Switching decoders to madVR's mpeg-2 decoder is the same.
Decimation should not be working at all, neither with NVidia nor with AMD. Except for soft-telecined movies. There it's not really decimation, but instead the decoder outputs the soft-telecined frames without splitting them up and DXVA simply leaves these frames untouched. It kinda looks like decimation, but it isn't really. But again, there should be no difference between ATI and NVidia. I'm not 100% sure what CUDA does, but I suspect it should be no different to DXVA in terms of decimation. But I don't really know, nevcairiel might be able to answer that.

Quote:
Originally Posted by TheShadowRunner View Post
Hmm a very strange behavior/bug with 0.78:
Launch the player, start playing a video. Minimize the player in the task bar (so the image isn't displayed) but keep playback going.
Wait like a minute. When you bring the player back up, the video plays super crazy fast to catch up with the audio.
The video itself stops being "refreshed" as soon as it stops being visible (player minimized), it seems.
Is this a new problem with v0.78?

Quote:
Originally Posted by derp View Post
Subs disappear when I pause the video. I'm using v0.78 of course.
This should happen only if you have the madVR debug OSD (Ctrl+J) active. Without the madVR debug OSD the subs should not disappear if you pause the video. Which media player are you using?

Quote:
Originally Posted by SamuriHL View Post
Deinterlacing working beautifully with my quadcore monster HTPC with the AMD 5870. Catalyst 11.10 drivers. I threw one of my toughest interlaced videos at it. Given that machine's power, it doesn't surprise me that it was smoother than my nVidia 450 with CUVID. It's simply a matter of machine power. This is absolutely wonderful.
Good to hear!

Quote:
Originally Posted by Andy o View Post
This seems to be the opposite, I find that Full is the right setting, just like with Media Center and EVR.
What makes you say that? Do you get different black/white levels when switching that option? You should not, when using madVR. You probably will with EVR, but not with madVR. If you do, then please upload two small madVR logs, one with that option off and one with it on. Thx.

Quote:
Originally Posted by Andy o View Post
I can't get the 5770 to deinterlace my video into 50p
How do you know? Does Ctrl+Alt+Shift+D claim deinterlacing is off? And you can't turn it on?

Quote:
Originally Posted by robpdotcom View Post
When deinterlacing 1080i59 (or any "i59" video), is it normal that MPC-HC/Reclock/MadVR all report 29Hz, even though it should be 59Hz after deinterlacing? It looks fine to me (as good as using LAV CUVID, as far as I can tell), so I assume it really is running at 59Hz.
I'm not sure what MPC-HC and Reclock will show, but I guess it's ok that way. Just make sure madVR says that deinterlacing is on.

Quote:
Originally Posted by robpdotcom View Post
I installed my AMD card (5750), and tested with some fast moving content (tennis matches, fwiw, where it's easy for me to see a difference) - it was not nearly as smooth as with the NVIDIA GTS-450. Using EVR (with DXVA decoding) or yadif is clearly smoother than madVR on my AMD card - it really seemed like there was no deinterlacing going on. I tried playing around with some of the AMD video settings, and the "deinterlace in separate thread" option in madVR but no changes made any difference as far as I can see. The OSD shows that deinterlacing is being used, and all queues are full.
Are there dropped frames? Are you using the same decoder for madVR and EVR? Can you see the difference in screenshots? Or is the non-smoothness more looking like frame drops, with no difference visible in screenschots?

Quote:
Originally Posted by QBhd View Post
I was toying with the idea of using "Disable Desktop Composition (Vista or Higher)" since I did not think having a composition frame rate of 60Hz worked well with a monitor resolution of 24Hz... it just seemed wrong, I might be fooling myself however I thought I would see what would happen when enabling this setting. Guess what, there was not one instance of exclusive mode failure during a very long playlist of varying frame rates. So I may have solved my "exclusive mode failed" issue by accident by testing a setting for another reason.
Interesting, thanks for the heads up.

Quote:
Originally Posted by JarrettH View Post
To clarify, this technically does not work with DVDs right? madvr works as the renderer in my case, but will not decode

Like 6233638 says, File > Open Disc uses Microsoft DTV-DVD automatically and blocking that uses internal MPC-HC one which is poor. The only problem with the Microsoft one was lack of navigation and subtitles, quality was fine IMO.
In ffdshow I have MPEG2 decoding (libavcodec, 'DVD decoding' ticked), NV12 output, and using the 'set interlaced flag in output media type' option. This combo seems to activate the deinterlacing on my gpu as I don't have it setup anywhere else. Err is that correct?
Whether you can make madVR work with DVDs or not has nothing to do with deinterlacing. That's still the same problem as in the past. If you do get it to work, then deinterlacing should work just fine. Depending on the decoder deinterlacing might get turned on automatically or not. If it doesn't and you need it, you can turn it on manually by pressing Ctrl+Alt+Shift+D twice.

Quote:
Originally Posted by jmone View Post
Did some more deinterlace testing on my HTPC and it looks pretty good. The issue with the dropped frames is less frequent on this PC and the queue fluctuation seems to rellay only be the SD stuff (worse was the DV-AVI material in 720x576/50i). All the HD material (1920x1080/50&60i in VC-1 and h264 as well as MPEG2 1440x1080/50i) had rock solid queues.
It's pretty weird that you have problems with SD content but not with HD content! The other way round would make more sense...
madshi is offline   Reply With Quote
Old 6th November 2011, 10:12   #10647  |  Link
TheShadowRunner
Registered User
 
TheShadowRunner's Avatar
 
Join Date: Feb 2004
Posts: 396
Quote:
Originally Posted by madshi View Post
Is this a new problem with v0.78?
Hi, yes.
__________________
XP SP3 / Geforce 8500 / Zoom Player
TheShadowRunner is offline   Reply With Quote
Old 6th November 2011, 10:17   #10648  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 8,917
Quote:
Originally Posted by TheShadowRunner View Post
Hi, yes.
Just tried this on my XPSP3 PC. Can't reproduce it. I minimize. Audio continues to play. After 1 minute I restore the window and video continues to play just fine.
madshi is offline   Reply With Quote
Old 6th November 2011, 10:29   #10649  |  Link
TheShadowRunner
Registered User
 
TheShadowRunner's Avatar
 
Join Date: Feb 2004
Posts: 396
When you restore, you don't see the image part of the video playing super crazy fast to catch up with the audio?
That the image hasn't been refreshed since you minimzed 1 minute prior?
__________________
XP SP3 / Geforce 8500 / Zoom Player
TheShadowRunner is offline   Reply With Quote
Old 6th November 2011, 10:46   #10650  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 8,917
That's what I said, it looks perfectly fine here with no catching up or any other visible problems.
madshi is offline   Reply With Quote
Old 6th November 2011, 11:07   #10651  |  Link
TheShadowRunner
Registered User
 
TheShadowRunner's Avatar
 
Join Date: Feb 2004
Posts: 396
Ok, it doesn't happen when madVR's internal decoder is used.. please check with external decoder.
__________________
XP SP3 / Geforce 8500 / Zoom Player
TheShadowRunner is offline   Reply With Quote
Old 6th November 2011, 11:17   #10652  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 8,917
Quote:
Originally Posted by TheShadowRunner View Post
Ok, it doesn't happen when madVR's internal decoder is used.. please check with external decoder.
Tested with CoreAVC, no problems, either.
madshi is offline   Reply With Quote
Old 6th November 2011, 11:55   #10653  |  Link
TheShadowRunner
Registered User
 
TheShadowRunner's Avatar
 
Join Date: Feb 2004
Posts: 396
I'm losing my latin here.. ^^;;
Here is a debug log. I start playing a video, minimize the player for 15 seconds, then bring it back up.
When bringing it back up, I clearly see the video going uber fast to catch up with the audio.
__________________
XP SP3 / Geforce 8500 / Zoom Player
TheShadowRunner is offline   Reply With Quote
Old 6th November 2011, 12:19   #10654  |  Link
Thunderbolt8
Registered User
 
Join Date: Sep 2006
Posts: 2,151
Quote:
Originally Posted by madshi View Post
Have you tested in windowed or exclusive mode? You don't have your GPU fixed at some lower clock? Does it not even work for interlaced SD content? Please cross check with VMR/EVR
what I meant with 'doesnt work' was is 'is too slow'. tested both modes, fullscreen and windowed mode. EVR dxva decoding with MPC internal decoders generally works fine here (with progressive content and no deinterlacing ofc)

got little bit better results 5 mins ago. I could get the 29.97 fps AVC video to play (almost?) smoothly with queue number of at least 3. (coreavc 16.7mbps) same settings as yesterday (nearest neighbor + trade quality setttings). the VC-1 video was so-so (videodecoderdmo). for ~2 seconds the queue numbers are fine, but then they drop again. repeats all the time.

though when I tested the AVC video again just 1 minute later, it wasnt playing smooth any more as before. queues again down to 1, even though I didnt change any setting.

both vids seem to play fine or ok when I deactivate deinterlacing with these settings. (a bit better in fullscreen mode)

in catalyst settings amd overdrive is ticked, but values are set to default. setting the clock values to max or unticking the overdrive option doesnt seem to change anything though.


btw. when using the madvr video decoder, subs (directvobsub) dont seem to get loaded any more, though they do with LAV video for example. (has it always been like that?)

btw²
Quote:
Originally Posted by madshi View Post
The libav VC-1 decoder doesn't support interlaced decoding, unfortunately. Nothing I can do about it.
ffmpeg has "VC-1 interlaced decoding" listed in their changelog for the next version, so hopefully we have interlaced vc-1 decoding soon (and hooooopefully multithreading support)
__________________
Laptop Acer Aspire V3-772g: i7-4202MQ, 8GB Ram, NVIDIA GTX 760M (+ Intel HD 4600), Windows 8.1 x64, madVR (x64), MPC-HC (x64), LAV Filter (x64), XySubfilter (x64)

Last edited by Thunderbolt8; 6th November 2011 at 14:21.
Thunderbolt8 is offline   Reply With Quote
Old 6th November 2011, 14:07   #10655  |  Link
derp
Registered User
 
Join Date: Oct 2011
Posts: 8
Quote:
Originally Posted by madshi View Post
this should happen only if you have the madvr debug osd (ctrl+j) active. Without the madvr debug osd the subs should not disappear if you pause the video. Which media player are you using?
mpc-hc.
derp is offline   Reply With Quote
Old 6th November 2011, 14:17   #10656  |  Link
noee
Registered User
 
Join Date: Jan 2007
Posts: 526
Weird problem with Windowed Mode (MPC-HC and jRiver). Source interlaced SD NTSC Video. I get good numbers for the decoder, upload and interlace queues, but the render and backbuffer queues are 0-1 and it drops about 50 frames/second. When I switch to FSE, everything is golden, queues full and playback is "flawless", zero dropped....

I've created (and emailed to you) a log with playback start in windowed mode, about 5 seconds of playback, then the switch to FSE mode.


EDIT: Argh, I think this might be related to GPU downclocking, it's happening on all my sources now.....

Anyone else with ATI seeing anything like this?

Last edited by noee; 6th November 2011 at 15:07.
noee is offline   Reply With Quote
Old 6th November 2011, 16:23   #10657  |  Link
6233638
Registered User
 
Join Date: Apr 2009
Posts: 1,019
Quote:
Originally Posted by madshi View Post
Maybe. Is this a native video or movie source, btw (in case you know)? I've put it into my deinterlacing sample collection. Do you have any more such difficult to deinterlace samples?
It should be film. (The Sweet Hereafter)

I think I posted a sample from this before, but this should also be film. This was back when I tried getting 29.97 IVTC'ed to 23.976 but couldn't get it working correctly.

http://www.mediafire.com/?p60jl7wc61lxa3b

Quote:
Originally Posted by madshi View Post
Whether you can make madVR work with DVDs or not has nothing to do with deinterlacing. That's still the same problem as in the past. If you do get it to work, then deinterlacing should work just fine. Depending on the decoder deinterlacing might get turned on automatically or not. If it doesn't and you need it, you can turn it on manually by pressing Ctrl+Alt+Shift+D twice.
I had been under the impression that madVR would have to be doing the decoding to perform deinterlacing.

It looks like that is not the case. Previously, I had been recommending disabling the MS DVD decoder for mod-free DVD playback because the MPC-HC one allowed you to force weave deinterlacing, which was fine on "good" titles where that just worked, but disastrous on "tricky" films.

Because that was performing deinterlacing itself, madVR disabled its deinterlacing. (as it should)
It looks like madVR will perform deinterlacing if you use the MS DVD decoder though.

So with an external filter list of:


DVD playback is working and madVR does the deinterlacing.

The ffdshow Audio Processor should not be necessary, I use that to downmix audio for headphone output, otherwise ReClock's WASAPI output complains. (I wish there was a better option)

I have ReClock selected as my audio renderer, and madVR as my video renderer in the Playback > Output section of MPC-HC.

The filter list when playing a DVD ends up as:
ReClock Audio Renderer
madVR Renderer
ffdshow Audio Processor
Microsoft DTV-DVD Video Decoder
LAV Audio Decoder
DVD Navigator
No DLL modifications necessary.


EDIT: And I've just done a quick test in windowed mode, performing deinterlacing in a separate thread seems to improve performance here.

Deinterlace Queue goes from 6–9/9 to 7–9/9
Render Queue goes from 5–8/8 to 6–8/8
Backbuffer Queue goes from 4–7/8 to 5–7/8

Last edited by 6233638; 6th November 2011 at 16:31.
6233638 is offline   Reply With Quote
Old 6th November 2011, 16:36   #10658  |  Link
JarrettH
Registered User
 
Join Date: Aug 2004
Posts: 815
How do you know the MS decoder isn't doing everything?
JarrettH is offline   Reply With Quote
Old 6th November 2011, 16:38   #10659  |  Link
6233638
Registered User
 
Join Date: Apr 2009
Posts: 1,019
Quote:
Originally Posted by JarrettH View Post
How do you know the MS decoder isn't doing everything?
When I disable madVR's deinterlacing, the results are awful with "tricky" titles.
6233638 is offline   Reply With Quote
Old 6th November 2011, 16:52   #10660  |  Link
Andy o
Registered User
 
Join Date: Mar 2009
Posts: 928
Quote:
Originally Posted by madshi View Post
What makes you say that? Do you get different black/white levels when switching that option? You should not, when using madVR. You probably will with EVR, but not with madVR. If you do, then please upload two small madVR logs, one with that option off and one with it on. Thx.
Sorry, 16-235 does get correct levels, but there is a difference between both settings, just like with EVR (if I'm not mistaken that was even implied in your release post?). In any case, logs: http://www.multiupload.com/QJMOEO1E2Q

Quote:
How do you know? Does Ctrl+Alt+Shift+D claim deinterlacing is off? And you can't turn it on?
It's not that deinterlacing is not working (it's turned on), and it's working fine, only that it seems to be deinterlacing into 25p instead of 50p. It's the same difference I saw with LAV Video's CUVID set to 25/30p output vs. it set to 50/60p output.

I'm gonna switch to NV again later today to check these issues more thoroughly and let you know better.
__________________
GA-Z87MX-D3H (Intel Z87), i7-4770, AMD 7790, Win8.1-64
Pioneer VSX-01TXH, Pioneer KRP-500M

Last edited by Andy o; 6th November 2011 at 16:56.
Andy o is offline   Reply With Quote
Reply

Tags
direct compute, dithering, error diffusion, madvr, ngu, nnedi3, quality, renderer, scaling, upsampling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:33.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.