Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 21st May 2011, 11:13   #2781  |  Link
exorcistas
Registered User
 
Join Date: May 2010
Posts: 19
Hi I am having problems after that encode videos with softsub that the caption on one party or another are faster than the audio in MeGUI
exorcistas is offline  
Old 22nd May 2011, 05:32   #2782  |  Link
frozenthorn
Registered User
 
Join Date: Apr 2011
Posts: 3
I updated to the latest stable x86 this month, and for some reason the bitrate I set into megui for xvid encoding is not the bitrate the video ends up with? Sometimes its as much as 50% more, and sometimes its less? I updated to the latest x86 dev in hopes there was a problem somewhere in the latest stable, and the problem seems to exist there too.

The settings I use hasn't changed, previously the bit rate was always spot on +/- a couple bits. So what's changed with MeGUI components recently that would affect the "XviD: 2 pass HQ (no Qpel)" profile?
frozenthorn is offline  
Old 24th May 2011, 16:49   #2783  |  Link
exorcistas
Registered User
 
Join Date: May 2010
Posts: 19
I updated MeGUI and was the 2008 version (svn) and an X appeared on the icon of MeGUI bar work knows how I shot this red x and when I updated the MeGUI I also had to update the neroaac?
exorcistas is offline  
Old 25th May 2011, 21:38   #2784  |  Link
Pulp Catalyst
Registered User
 
Join Date: May 2006
Posts: 260
will you ever implement IFO processing,

like many great converters that currently exist, only very few have IFO processing, it can be real handy for Episode DVD's (most episode disks have combined VOB files)

one can always use DVDShrink to split them up and re-author the disk, but this can be really time consuming, and can become very frustratingly mundane when it can so easily be avoided,

AutoGK, and FUW, TMPGEnc to name a few, not sure if there are more, tried Xvid4PSP but it doesn't support IFO processing either.


the other thing about combined VOB files is audio sync, episode 1 may have -25ms but episode 2 could have -68ms, but DGIndexing would only detect the 1st and that correction would be used for all of the VOB files,

i have found that without IFO processing, then the converter in question is tailored for movie only.


i know DVDShrink is easy enough, but to re-author an entire DVD all because converters don't have the ability to find that information out itself, really a nightmare.

Handbrake is another one that supports IFO processing.
Pulp Catalyst is offline  
Old 25th May 2011, 22:53   #2785  |  Link
Dogway
Registered User
 
Join Date: Nov 2009
Posts: 949
-A few things. What decoder should I use when I want to encode an .avs to mp3? DirectShow?
-Latest update is messed up. I had to run my 3.5 online version and update from there to stable update. Only then my profiles, and changed profile parameters could obey.

-How do I know the order of channels in multichannel audio sources? is it the one mediainfo shows right or is another?
I say because one of my sources mediainfo says is Front: L C R Side: L R LFE
But megui uses c6_stereo which is:
Code:
-[NoImage] function c6_stereo(clip a)
-[NoImage]   {
-[NoImage]      fl = GetChannel(a, 1)
-[NoImage]      fr = GetChannel(a, 2)
-[NoImage]      fc = GetChannel(a, 3)
-[NoImage]      lf = GetChannel(a, 4)
-[NoImage]      sl = GetChannel(a, 5)
-[NoImage]      sr = GetChannel(a, 6)
-[NoImage]      fl_sl = MixAudio(fl, sl, 0.2929, 0.2929)
-[NoImage]      fr_sr = MixAudio(fr, sr, 0.2929, 0.2929)
-[NoImage]      fc_lf = MixAudio(fc, lf, 0.2071, 0.2071)
-[NoImage]      l = MixAudio(fl_sl, fc_lf, 1.0, 1.0)
-[NoImage]      r = MixAudio(fr_sr, fc_lf, 1.0, 1.0)
-[NoImage]      return MergeChannels(l, r)
-[NoImage]   }
Dogway is offline  
Old 26th May 2011, 10:13   #2786  |  Link
tebasuna51
Moderator
 
tebasuna51's Avatar
 
Join Date: Feb 2005
Location: Spain
Posts: 5,155
Quote:
Originally Posted by Dogway View Post
-A few things. What decoder should I use when I want to encode an .avs to mp3? DirectShow?
For audio use NicAudio or BassAudio, DirectShowSource is the last choice.

Quote:
-How do I know the order of channels in multichannel audio sources? is it the one mediainfo shows right or is another?
Forget the MediaInfo channel order, is useless.
The channel order inside AviSynth is always FL,FR,FC,LF,SL,SR if a correct decoder (NicAudio, BassAudio, ffdshow, ...) is used.
__________________
BeHappy, AviSynth audio transcoder, in Doom9 forums. NicAudio, BassAudio, audio decoders.
tebasuna51 is offline  
Old 26th May 2011, 16:44   #2787  |  Link
Dogway
Registered User
 
Join Date: Nov 2009
Posts: 949
I always use NicAudio inside avisynth, so I guess I can use c6_stereo() and forget about anything else. In which case it would be more convenient to just input the .ac3 directly to megui, except when I need some custom editing in avisynth, (delayaudio, TimeStretch, etc)
Dogway is offline  
Old 29th May 2011, 13:44   #2788  |  Link
pancserzso
Registered User
 
Join Date: Oct 2004
Posts: 123
I have some serious problem with MeGUI newer than 1911.

Every time I open an avs file, I get a:
Quote:
Fatal Error:
MeGUI encountered a fatal error and may not be able to proceed.
Reason: Attempted to read or write memory protected memory. This is often an indication that other memory is corrupt.
I have absolutely no problem on 1911 or never had problem before.
pancserzso is offline  
Old 7th September 2011, 17:20   #2789  |  Link
unknownsoldierX
Registered User
 
Join Date: Jun 2005
Posts: 234
I need help with this error:

Code:
Exception message: GetChannel: Attempted to request a channel that didn't exist!
Attached Files
File Type: txt 06x01.megui.log.txt (19.4 KB, 18 views)
unknownsoldierX is offline  
Old 7th September 2011, 21:25   #2790  |  Link
tebasuna51
Moderator
 
tebasuna51's Avatar
 
Join Date: Feb 2005
Location: Spain
Posts: 5,155
Quote:
Originally Posted by unknownsoldierX View Post
I need help with this error:

Code:
Exception message: GetChannel: Attempted to request a channel that didn't exist!
Use NicAudio instead DirectShowSource to decode the ac3 file.
Or configure properly your DirectShow system.
__________________
BeHappy, AviSynth audio transcoder, in Doom9 forums. NicAudio, BassAudio, audio decoders.
tebasuna51 is offline  
Old 7th September 2011, 23:12   #2791  |  Link
unknownsoldierX
Registered User
 
Join Date: Jun 2005
Posts: 234
Switched config to use NicAudio. All is well. Is NicAudio good for decoding MP3 also?

Thanks

Last edited by unknownsoldierX; 8th September 2011 at 03:31.
unknownsoldierX is offline  
Old 8th September 2011, 07:30   #2792  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 4,730
Yes, it contains MPG123, if I remember right.
__________________

German doom9 / Gleitz video board
CQME – change the Matrix!
BeSweet 1.5b31 All In One | HeadAC3he 0.24a13

Rémoulade is spoiled
LigH is offline  
Old 8th September 2011, 10:49   #2793  |  Link
tebasuna51
Moderator
 
tebasuna51's Avatar
 
Join Date: Feb 2005
Location: Spain
Posts: 5,155
Yes, work with AC3, DTS, MP2, MP3, and other uncompressed formats.
__________________
BeHappy, AviSynth audio transcoder, in Doom9 forums. NicAudio, BassAudio, audio decoders.
tebasuna51 is offline  
Old 8th September 2011, 20:06   #2794  |  Link
unknownsoldierX
Registered User
 
Join Date: Jun 2005
Posts: 234
Now I've encountered a different error, while running file indexer on a MKV with AC3.

Standard output stream: Indexing error: Audio format change detected. This is currently unsupported. Channels: 6 -> 2; Sample rate: 48000 -> 48000; Sample format: 16-bit signed integer -> 16-bit signed integer

It creates an .ac3 file, and it seems fine. But it doesn't create a .ffindex file.

EDIT: demuxed with MKVextract. Audio and video are encoding. Wonder why MeGUI couldn't handle it. The MKV isn't any different than other MKVs I've been doing recently.

Last edited by unknownsoldierX; 8th September 2011 at 20:29.
unknownsoldierX is offline  
Old 9th September 2011, 08:32   #2795  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 4,730
This audio stream contains format changes. It was probably taken from a DVB stream which includes some commercial breaks, where the 6 channel audio for the movie switches to stereo audio for the commercials. DVB receivers can handle that easily.

If the video was MPEG2 SD, ProjectX could have cut the transport stream at audio format changes; in any other case I am not sure how to proceed...
__________________

German doom9 / Gleitz video board
CQME – change the Matrix!
BeSweet 1.5b31 All In One | HeadAC3he 0.24a13

Rémoulade is spoiled
LigH is offline  
Old 9th September 2011, 15:23   #2796  |  Link
unknownsoldierX
Registered User
 
Join Date: Jun 2005
Posts: 234
I had four MKV (AVC, AC-3 6ch) files that all had commercial breaks removed. MeGUI only had a problem with the one file, though. It extracted the audio, which it would encode without errors. It's just that it wouldn't create the .ffindex file.

I used AVIdemux to demux the MKV, and MeGUI indexed and encoded the resulting .h264 and .ac3 files just fine.
unknownsoldierX is offline  
Old 10th September 2011, 00:24   #2797  |  Link
blah123
Registered User
 
Join Date: Oct 2010
Posts: 29
I've got problems with 2 TSes (one 1920x1080 interlaced MPEG-4/AVC with mp2 | the second also AVC interlaced, but with AC3 and 720x576) and I try to "import" them to MEgui's AviSynth Script Creator and drag&drop them on "Video Input", i choose DirectShowSource and then I receive win message box with "MeGUI has stopped working" and I need to click "close down".
I have got ffdshow and haali media splitter installed.
(The same problem is with StaxRip.)
blah123 is offline  
Old 12th September 2011, 08:35   #2798  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 4,730
Then don't use DirectShowSource. How many times did we already preach that DSS shall be only the last hope when all other native input plugins fail?

The reason of your DirectShow system failing is hard to discover without analyzing your Windows installation at home, next to you. You probably installed too many concurring filters or "Codec Packs" which mess it up, who knows ...

Multiplex your Transport Streams into MKV (e.g. using gdsmux from the Haali Media Splitter installation), then feed the MKV as source for FFmpegSource.
__________________

German doom9 / Gleitz video board
CQME – change the Matrix!
BeSweet 1.5b31 All In One | HeadAC3he 0.24a13

Rémoulade is spoiled
LigH is offline  
Old 4th October 2011, 05:48   #2799  |  Link
jbeale
Registered User
 
Join Date: May 2003
Posts: 31
Can't create M2TS (Error: No tracks selected)

I'm trying to use MeGUI 2050 to create a M2TS file. I've been using MeGUI for a few years to create .MP4 files, but then my PS3 died and I got a Panasonic Blu-Ray player that won't play MP4 but will play M2TS files. How should this work? I set up the inputs and click "AutoEncode", then select Output Options: Container: M2TS and "Queue". The queue now contains four jobs: encode audio to .m4a, encode video to .264, mux video to mp4, and mux mp4 to m2ts. The first three steps complete OK. The last step fails with the error
SmartLabs tsMuxeR. Standard error stream: No tracks selected.

Can anyone tell me what I'm doing wrong? The full log text file is attached as Create-M2TS-Error.zip in case that's helpful.

EDIT: hmm, maybe it works better if I use AC3 audio instead of AAC...
Attached Files
File Type: zip Create-M2TS-Error.zip (3.9 KB, 11 views)

Last edited by jbeale; 4th October 2011 at 06:14.
jbeale is offline  
Old 4th October 2011, 07:56   #2800  |  Link
QBhd
QB the Slayer
 
QBhd's Avatar
 
Join Date: Feb 2011
Location: Toronto
Posts: 398
is .m4a audio allowed? I don't think so. You should only have 3 jobs in the queue, there should be no mux to mp4.

QB
__________________
QBhd is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 08:57.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.