Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 5th May 2011, 04:59   #7601  |  Link
Mark_A_W
3 eyed CRT supporter
 
Join Date: Jan 2008
Location: Or-strayl-ya
Posts: 563
Yeah, I was thinking of a JVC DLA-X3, which is D-ILA, you are right.

I was also very impressed for the money with a Sony HW-15. Longevity isn't a huge issue, it took me 6 years to do 600 hours on my CRT projector (then I installed another one, due to wear).


I disagree, 3D is coming along nicely, but slowly. Avatar and Tron Legacy are two of my very favourite movies, I want to watch them in 3D.
Mark_A_W is offline   Reply With Quote
Old 5th May 2011, 07:04   #7602  |  Link
6233638
Registered User
 
Join Date: Apr 2009
Posts: 1,019
Quote:
Originally Posted by Mark_A_W View Post
Yeah, I was thinking of a JVC DLA-X3, which is D-ILA, you are right.

I was also very impressed for the money with a Sony HW-15. Longevity isn't a huge issue, it took me 6 years to do 600 hours on my CRT projector (then I installed another one, due to wear).
The Sonys do put out a great image for the money, but if you can afford it, it's really worth stepping up to JVC, especially as a CRT owner.

Quote:
Originally Posted by Mark_A_W View Post
I disagree, 3D is coming along nicely, but slowly. Avatar and Tron Legacy are two of my very favourite movies, I want to watch them in 3D.
The depth you get to the image when it's done right, is absolutely great in 3D. I just don't think the home technology is there yet. Once they eliminate crosstalk completely, and we get passive displays that can maintain 1080p resolution while keeping the same brightness in 3D as 2D (and I do not even keep my displays very bright) I think it will be a lot more compelling.

I'm not anti-3D, I just don't think it's worth buying a new display specifically for 3D while the display technology and content production process still needs to mature.
6233638 is offline   Reply With Quote
Old 5th May 2011, 09:24   #7603  |  Link
someone`
Registered User
 
Join Date: Jan 2010
Posts: 28
Quote:
Originally Posted by Thunderbolt8 View Post
I've got a 226CW, but an ATI graphic card. do you know what I need to do here to achieve the same effect?
no matter what I seem to do, madvr always keeps telling me my display Hz is 59,88 all the time
PowerStrip
someone` is offline   Reply With Quote
Old 5th May 2011, 12:49   #7604  |  Link
Blight
Software Developer
 
Blight's Avatar
 
Join Date: Oct 2001
Location: Israel
Posts: 998
Bug Report (v0.61):
When 'enable automatic fullscreen exclusive mode' is disabled and 'use a separate device for presentation' is enabled, switching to fullscreen causes a lot of weird issues (no video image, exiting fullscreen causes the screen to black out for a few seconds, etc...).
Even with 'use a separate device for presentation' disabled, there's issues of video pauses where you have to click pause/play to get the video going again.
__________________
Yaron Gur
Zoom Player . Lead Developer
Blight is offline   Reply With Quote
Old 5th May 2011, 13:14   #7605  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 9,137
Quote:
Originally Posted by Blight View Post
Bug Report (v0.61):
When 'enable automatic fullscreen exclusive mode' is disabled and 'use a separate device for presentation' is enabled, switching to fullscreen causes a lot of weird issues (no video image, exiting fullscreen causes the screen to black out for a few seconds, etc...).
Even with 'use a separate device for presentation' disabled, there's issues of video pauses where you have to click pause/play to get the video going again.
Is that fullscreen on the same monitor or a different one?
madshi is offline   Reply With Quote
Old 5th May 2011, 15:23   #7606  |  Link
cvrkuth
Registered User
 
Join Date: Apr 2011
Posts: 49
Quote:
Originally Posted by Blight View Post
Bug Report (v0.61):
When 'enable automatic fullscreen exclusive mode' is disabled and 'use a separate device for presentation' is enabled, switching to fullscreen causes a lot of weird issues (no video image, exiting fullscreen causes the screen to black out for a few seconds, etc...).
Even with 'use a separate device for presentation' disabled, there's issues of video pauses where you have to click pause/play to get the video going again.
I notice issues only with D3D11 presentation path
__________________
Intel Core i7-4790 CPU @ 3.60GHz, RAM 32 GB Dual-Channel DDR3 @ 665MHz (9-9-9-24),
Panasonic TX-P42G20E, NVIDIA GeForce GTX 970, Win 10 Pro x64,
PotPlayer 1.7.16291 64-bit, madVR v0.92.17

Last edited by cvrkuth; 5th May 2011 at 19:14.
cvrkuth is offline   Reply With Quote
Old 5th May 2011, 19:42   #7607  |  Link
HTPC-User
Registered User
 
Join Date: Mar 2011
Posts: 16
Hello!
Quote:
Originally Posted by sneaker_ger View Post
This is not a job for the renderer.
LAV Filters have the function you need.
Thank you for that tip!! I`ll try them as soon as possible.
If I`ve understood you correctly, the standard MPC-HC/ffdshow combo isn`t able to display only forced subs. What a pitty! For me this feature is very important as permanently shown subtitles are quite annoying...

Quote:
Originally Posted by madshi View Post
Can anybody else reproduce this? Might be a media player bug, not sure. I don't think madVR actually does anything to the mouse, I think the media player does that, but I'm not 100% sure right now.


You can't *drag* the seekbar, it's not designed for that. But you should be able to click on it to seek. Works for me, at least.


I have not investigated this any further recently and it's not on my near time schedule. Some time later maybe.
Concerning the mouse visibility and the seekbar problems, I have done some tests (all with madvr 0.61 and MPC-HC 1.5.2.3056):

if I:
check 'Always in foreground', check Direct3D Fullscreen (exclusive in MPC-HC) and MPC-HC is allready in fullscreen mode, i.e. maximized without title and menu -> the seekbar is not visible at all, mouse visible all the time *bug*

if I:
check 'Always in foreground', uncheck Direct3D Fullscreen (exclusive) and MPC-HC is allready in fullscreen mode, i.e. maximized without title and menu -> seekbar is ok (i.e. clickable) and mouse ok.

if I:
check 'Always in foreground', uncheck Direct3D Fullscreen (exclusive) and MPC-HC is in window mode, i.e. maximized with title and menu -> the seekbar is not visible at all, mouse visible all the time, movie isn't maximized to cover full screen (although option is checke in MPC-HC)*bug*

if I:
uncheck 'Always in foreground', uncheck Direct3D Fullscreen (exclusive) and MPC-HC is in window mode, i.e. maximized with title and menu -> the seekbar is not visible at all, mouse visible all the time, movie isn't maximized to cover full screen (although option is checke in MPC-HC) *bug*

if I:
uncheck 'Always in foreground', check Direct3D Fullscreen (exclusive) and MPC-HC is in window mode, i.e. maximized with title and menu -> the seekbar is not clickable, mouse ok, movie is fullscreen ok *bug*

if I:
uncheck 'Always in foreground', check Direct3D Fullscreen (exclusive) and MPC-HC is allready in fullscreen mode, i.e. maximized without title and menu -> the seekbar is not clickable, mouse visible all the time, movie is fullscreen ok *bug*

if I:
uncheck 'Always in foreground', uncheck Direct3D Fullscreen (exclusive) and MPC-HC is allready in fullscreen mode, i.e. maximized without title and menu -> the seekbar is ok, mouse ok, movie is fullscreen ok

if I:
check greyed out 'Always in foreground', check Direct3D Fullscreen (exclusive) and MPC-HC is allready in fullscreen mode, i.e. maximized without title and menu -> the seekbar is not clickable, mouse visible all the time *bug*

if I:
check greyed out 'Always in foreground', uncheck Direct3D Fullscreen (exclusive) and MPC-HC is allready in fullscreen mode, i.e. maximized without title and menu -> the seekbar is ok, mouse ok

if I:
check greyed out 'Always in foreground', check Direct3D Fullscreen (exclusive) and MPC-HC is in window mode -> the seekbar is ok, mouse ok, playback has problems: if I click in the seekbar sometimes I can see the video, sometimes I see only the MPC background picture. Seekbar not operational. *bug*

if I:
check greyed out 'Always in foreground', uncheck Direct3D Fullscreen (exclusive) and MPC-HC is in window mode -> the seekbar is not shown at all, mouse is visible all the time, the movie is not shown fullscreen *bug*

EVR-CP seems to be okay.
If you need further tests, no problem.

Concerning the non working DVD menu:
Hopefully you are able to get the DVD menu working at the end (whenever it will be). For me personally this is a must have feature as I watch a lot of original DVDs! Without this the usability of madVR for me is very limited.
So I am desperately in search of a working solution or a workaround at least!

HTPC-User is offline   Reply With Quote
Old 5th May 2011, 20:34   #7608  |  Link
pirlouy
_
 
Join Date: May 2008
Location: France
Posts: 634
Quote:
Originally Posted by 6233638 View Post
No, film should be played back at multiples of 24.000, this requires using Reclock.
No.
You do want to watch your movie at 24fps. Not every users are bothered by watching a film at 23.976 instead of 24.

Quote:
Any frame drops during film playback are obvious and unacceptable.
Wrong again (for me). One dropped frame every 30 minutes is not a problem except if you're a cyborg.

Maybe you don't like the way he gave his advices, but don't bash someone who share his solutions...

ps: you will find another type of cyborg which will tell you Reclock resample audio, thus destruct it. It's impossible to content everybody, but dricks2222's way is an acceptable way.
pirlouy is offline   Reply With Quote
Old 5th May 2011, 21:04   #7609  |  Link
mark0077
Registered User
 
Join Date: Apr 2008
Posts: 1,057
madshi, I notice a little bug you might like to know about. It may be an nvidia problem, I can't be sure.

Using madVR 0.61 (with the fix for the process priorities), when I use fullscreen exclusive mode with "present several frames in advance" ON, there is a fairly significant difference in audio / video desync compared to when the option is OFF

I have all sub options under "present several frames in advance" disabled.

With the option ON: Video / Audio sync seems about 0.2~ of a second off windowed mode
With the option OFF: Video / Audio sync is exactly the same as windowed mode, and the same as other renderers like evr-cp.

As I'm in the middle of trying to tweak audio / video sync I can't be sure which is actually correct.. maybe you and others could test please? Because evr-cp gives the same results as when this option is OFF, I presume this is the value thats behaving correctly.

This is Windows 7 64bit, gtx295. I'm using the 25fps avi file from the following page at 50hz on my HDTV.
http://editorsean.com/blog/49-audiovideosynctest
mark0077 is offline   Reply With Quote
Old 5th May 2011, 22:53   #7610  |  Link
6233638
Registered User
 
Join Date: Apr 2009
Posts: 1,019
Quote:
Originally Posted by pirlouy View Post
No.
You do want to watch your movie at 24fps. Not every users are bothered by watching a film at 23.976 instead of 24.
The point of MadVR is to have the best playback quality possible. Film is shot at 24.0 fps, therefore it should be played back at 24.0 fps.

Quote:
Wrong again (for me). One dropped frame every 30 minutes is not a problem except if you're a cyborg.
You don't notice framedrops!?

Quote:
ps: you will find another type of cyborg which will tell you Reclock resample audio, thus destruct it.
Reclock upsamples to 32/192 before working on the audio. This is essentially lossless, certainly inaudible.

There are also some soundcards that can change their audio clock in the hardware if you want completely lossless.

Quote:
It's impossible to content everybody, but dricks2222's way is an acceptable way.
Not if your goal is the best video playback quality from a PC. That method results in dropped frames, potentially desynced audio and playing films back at the wrong speed.
6233638 is offline   Reply With Quote
Old 5th May 2011, 23:10   #7611  |  Link
e-t172
Registered User
 
Join Date: Jan 2008
Posts: 568
Quote:
Originally Posted by dricks2222 View Post
To obtain a PERFECT fluidity with a LCD monitor and madvr (i have a 226bw), all you have to do is to add a custom resolution with a refresh rate of 47.952 (23.976*2) OR 71.928 (23.976*3)
PS :
Yeah, i still have 1 frame drop every 30 minutes or so at 47.952 and every 45minutes at 71.928 but i think i can live with that
You can get rid of that using Reclock.

However, you seem to think that most LCD monitors support these custom refresh rates ; most don't. I, too, am lucky to have a Hyundai W240D which accepts 48.034Hz (but not below, and not 72Hz either) ; but all my friend's LCD monitors will just stare at you with a black screen if you try to send them anything else than standard 60Hz.

Also, be careful when setting refresh rates higher than 60 Hz ; AFAIK, some LCDs will let you do that, but they will in fact stay at 60 Hz, dropping frames internally (which, as you can imagine, is very, very bad).

Last edited by e-t172; 5th May 2011 at 23:24.
e-t172 is offline   Reply With Quote
Old 5th May 2011, 23:24   #7612  |  Link
ch1n4
Registered User
 
Join Date: Mar 2011
Posts: 11
I have a question for ppl using cards equally weak or weaker than Radeon 5450. I have a Radeon 6450 with a reasonably fast dual core CPU. I have no problems playing most of my video files under Windows7 64 Bit except all 1080p Files (mostly 4 Reference Frames and 23,976 fps). So how did you manage to play without dropped frames, could you tell me the settings which worked for you?
ch1n4 is offline   Reply With Quote
Old 5th May 2011, 23:24   #7613  |  Link
e-t172
Registered User
 
Join Date: Jan 2008
Posts: 568
Quote:
Originally Posted by 6233638 View Post
The point of MadVR is to have the best playback quality possible. Film is shot at 24.0 fps, therefore it should be played back at 24.0 fps.
Actually, do you have a source that clearly says that movies are in fact filmed at 24.00 fps and not 23.97? (Not that I'm saying you're wrong ; I'm just searching for a reliable reference)

Quote:
Originally Posted by 6233638 View Post
Reclock upsamples to 32/192 before working on the audio. This is essentially lossless, certainly inaudible.
Technically, Reclock doesn't use 192 kHz (in fact, it doesn't use any specific sample rate at all), but I agree the quality degradation is probably well below what an human can ear. However, I'm not sure upsampling films audio to 24 fps is The Right Thing To Do. What is the film was slowed down from 24 to 23.97 during mastering using not only downsampling, but also timestretching? How could you tell? In this case, upsampling it to bring it back to 24 fps would alter the audio pitch (very slightly, but still).

Quote:
Originally Posted by 6233638 View Post
There are also some soundcards that can change their audio clock in the hardware if you want completely lossless.
No there aren't. DACs don't work like that. If a soundcard is pretending to accept, say, 48048Hz, it's either lying to you, or it's resampling internally.

Last edited by e-t172; 5th May 2011 at 23:28.
e-t172 is offline   Reply With Quote
Old 5th May 2011, 23:36   #7614  |  Link
Pyroshock
Registered User
 
Pyroshock's Avatar
 
Join Date: Apr 2011
Posts: 4
Quote:
Originally Posted by e-t172 View Post
Actually, do you have a source that clearly says that movies are in fact filmed at 24.00 fps and not 23.97? (Not that I'm saying you're wrong ; I'm just searching for a reliable reference)
Film is at 24 fps, and is slowed down to 24/1.001 fps before telecining for playback on an NTSC display.

See: http://en.wikipedia.org/wiki/Telecine#2:3_pulldown
Pyroshock is offline   Reply With Quote
Old 5th May 2011, 23:42   #7615  |  Link
6233638
Registered User
 
Join Date: Apr 2009
Posts: 1,019
Quote:
Originally Posted by e-t172 View Post
Technically, Reclock doesn't use 192 kHz (in fact, it doesn't use any specific sample rate at all)
The option to upsample to 32-bit (integer or floating point) 192kHz audio has been in Reclock for quite some time now.

Quote:
Originally Posted by e-t172 View Post
What is the film was slowed down from 24 to 23.97 during mastering using not only downsampling, but also timestretching?
It doesn't happen.

Quote:
Originally Posted by e-t172 View Post
No there aren't. DACs don't work like that. If a soundcard is pretending to accept, say, 48048Hz, it's either lying to you, or it's resampling internally.
http://forum.slysoft.com/showthread.php?t=27610
6233638 is offline   Reply With Quote
Old 6th May 2011, 01:20   #7616  |  Link
dricks2222
Registered User
 
Join Date: Apr 2011
Posts: 3
Quote:
Originally Posted by 6233638 View Post
The point of MadVR is to have the best playback quality possible. Film is shot at 24.0 fps, therefore it should be played back at 24.0 fps.

You don't notice framedrops!?

Reclock upsamples to 32/192 before working on the audio. This is essentially lossless, certainly inaudible.

There are also some soundcards that can change their audio clock in the hardware if you want completely lossless.

Not if your goal is the best video playback quality from a PC. That method results in dropped frames, potentially desynced audio and playing films back at the wrong speed.
Sorry, but my ears are as important as my eyes.
And the slight rate adjustment (48 048hz instead of 48khz) introduced by Reclock can be easily spotted. Moreover, it actually introduce audio distortion. So, since i found that i can run at 47.952, reclock stays off

Nevertheless, i can understand that you prefer to get perfect video at the cost of sound quality. Personnally, i prefer to keep native sound, and get 99.99% video quality.

Last edited by dricks2222; 6th May 2011 at 01:23.
dricks2222 is offline   Reply With Quote
Old 6th May 2011, 02:18   #7617  |  Link
6233638
Registered User
 
Join Date: Apr 2009
Posts: 1,019
Quote:
Originally Posted by dricks2222 View Post
Sorry, but my ears are as important as my eyes.
And the slight rate adjustment (48 048hz instead of 48khz) introduced by Reclock can be easily spotted. Moreover, it actually introduce audio distortion. So, since i found that i can run at 47.952, reclock stays off

Nevertheless, i can understand that you prefer to get perfect video at the cost of sound quality. Personnally, i prefer to keep native sound, and get 99.99% video quality.
You need to be upsampling the audio in Reclock.
6233638 is offline   Reply With Quote
Old 6th May 2011, 05:05   #7618  |  Link
Andy o
Registered User
 
Join Date: Mar 2009
Posts: 928
Quote:
Originally Posted by pirlouy View Post
ps: you will find another type of cyborg which will tell you Reclock resample audio, thus destruct it. It's impossible to content everybody
Ain't that the truth, o prophet pirlouy!

War between audiophiles and videophiles, I would pay to see that in 1080/24.000000p and 64-bit 384 kHz audio.
Andy o is offline   Reply With Quote
Old 6th May 2011, 05:28   #7619  |  Link
dansrfe
Registered User
 
Join Date: Jan 2009
Posts: 1,212
Quote:
Originally Posted by Andy o View Post
Ain't that the truth, o prophet pirlouy!

War between audiophiles and videophiles, I would pay to see that in 1080/24.000000p and 64-bit 384 kHz audio.
Funny thing is, digital audio file frequencies beyond 48kHz is pointlessly beyond the frequency range of human ears.

Human ear frequency max = 20kHz (average that people can actually hear is about 16-17kHz)

Digital audio file frequencies with transmission imperfections from decoding to speakers = ~44.1kHz


The only reason why someone might need 192kHz is for editing in the studio where many conversions and clippings will be done on the original stream.
dansrfe is offline   Reply With Quote
Old 6th May 2011, 07:04   #7620  |  Link
6233638
Registered User
 
Join Date: Apr 2009
Posts: 1,019
Quote:
Originally Posted by dansrfe View Post
Funny thing is, digital audio file frequencies beyond 48kHz is pointlessly beyond the frequency range of human ears.

Human ear frequency max = 20kHz (average that people can actually hear is about 16-17kHz)

Digital audio file frequencies with transmission imperfections from decoding to speakers = ~44.1kHz


The only reason why someone might need 192kHz is for editing in the studio where many conversions and clippings will be done on the original stream.
Sample rate is not the same thing as audible frequencies.

It is simply how many samples per second a sound is broken down into when stored digitally.

For example, this graph represents an analogue signal:


And, if the entire X-axis was 1 second in length, this graph would represent the digital representation of that signal at 10Hz.


When making changes to digital audio, you really should be oversampling to avoid a drop in quality.
6233638 is offline   Reply With Quote
Reply

Tags
direct compute, dithering, error diffusion, madvr, ngu, nnedi3, quality, renderer, scaling, uhd upscaling, upsampling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 10:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.