Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 18th June 2010, 17:28   #41  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 3,751
Ok, so, I'll post my bug here. MKV's with DTS-HD MA created by mkvmerge (mkvtoolnix) are not bitstreamed correctly by ffdshow if Haali is used. They work fine if the MPC splitter is used. Mosu, the author of mkvmerge, feels this is a Haali bug. I should be able to provide a sample if necessary, but, any file with a DTS-HD MA audio track that's been run through mkvmerge will repro this problem. More info can be seen in the ffdshow hd audio thread here:

http://forum.doom9.org/showthread.php?t=151151

The info related to this problem is on the last few pages. Let me know if more info is needed and if there's anything I can do. Thanks!
__________________
HTPC1:W8.1 Pro, I7 3770k, GTX 680, Pioneer Elite SC-65
HTPC2:W8.1 Pro, I5 2400s, GTS 450, Pioneer Elite VX21-THX
Laptop: MSI GT70 Dominator
SamuriHL is offline   Reply With Quote
Old 18th June 2010, 23:04   #42  |  Link
rica
Registered User
 
Join Date: Mar 2008
Posts: 2,021
Quote:
Originally Posted by SamuriHL View Post
Ok, so, I'll post my bug here. MKV's with DTS-HD MA created by mkvmerge (mkvtoolnix) are not bitstreamed correctly by ffdshow if Haali is used. They work fine if the MPC splitter is used. Mosu, the author of mkvmerge, feels this is a Haali bug. I should be able to provide a sample if necessary, but, any file with a DTS-HD MA audio track that's been run through mkvmerge will repro this problem. More info can be seen in the ffdshow hd audio thread here:

http://forum.doom9.org/showthread.php?t=151151

The info related to this problem is on the last few pages. Let me know if more info is needed and if there's anything I can do. Thanks!
Hi samuri, mosu is right; nothing to do with Haali for the time being.
mkv files created by MkvMergeGui are never problematic with MPC-Gabest or Solveig Splitters.
And dtshd-ma is horrible with haali.

Quote:
mkv with Gabest:

LPCM:
LPCM works with ReClock directly without an additional decoder.

THD:
It can bitstream over ffdshow.

DTSHD:
It can bitstream over ffdshow.


mkv with Haali:

LPCM:
Haali will be directly linked to ReClock and stream the audio. It doesn't need any additional LPCM decoder.

THD:
Gives blue light and no problem in bitsreaming THD inside mkv.

DTSHD:
Gives blue light but it's problematic: lots of drop-outs in video and audio.

Last edited by rica; 18th June 2010 at 23:07.
rica is offline   Reply With Quote
Old 18th June 2010, 23:58   #43  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 3,751
Thanks, Rica. Hopefully this can get fixed. Then MKV playback for me will be flawless.
__________________
HTPC1:W8.1 Pro, I7 3770k, GTX 680, Pioneer Elite SC-65
HTPC2:W8.1 Pro, I5 2400s, GTS 450, Pioneer Elite VX21-THX
Laptop: MSI GT70 Dominator
SamuriHL is offline   Reply With Quote
Old 30th June 2010, 22:29   #44  |  Link
MeridiusUK
Registered User
 
Join Date: Aug 2003
Posts: 93
hi all i think i have found a bug in the haali splitter

link here

http://forum.doom9.org/showthread.ph...30#post1413130

its seems haali ignores audio flags as if you have a movie with the first 2 audio tracks as DTS and a third track as AC3 it picks the 3rd track the AC3 version even if the flag in the mkv file has set the first audio DTS as the default track.

i post this as my first tracks are dts and 3rd tracks are ac3 but teh third track is french ac3 and the first audio track is english DTS.

if i play the same movie in vlc player the player picks the right default track and plays the english version but haali does not it seems to play the ac3 track over the default 1st track.

is this a bug ?
MeridiusUK is offline   Reply With Quote
Old 3rd July 2010, 19:06   #45  |  Link
MeridiusUK
Registered User
 
Join Date: Aug 2003
Posts: 93
any info on a fix on my last post
MeridiusUK is offline   Reply With Quote
Old 1st August 2010, 11:24   #46  |  Link
Virtual_ManPL
Virtual_ManPL
 
Virtual_ManPL's Avatar
 
Join Date: Sep 2009
Posts: 168
This file isn't properly recognized (no A/V) in Haali splitter (at least in latest version 1.10.175.0)
http://www.mediafire.com/?c5pab9t3pfqk6ch

works fine in Gabest and Windows splitter

Code:
General
Format                           : AVI
Format/Info                      : Audio Video Interleave
File size                        : 1.34 MiB
Duration                         : 1s 919ms
Overall bit rate                 : 5 873 Kbps
Mastered date                    : SUN AUG 01 18:24:06 2010
Writing application              : CanonMVI06

Video
ID                               : 0
Format                           : M-JPEG
Codec ID                         : MJPG
Duration                         : 1s 919ms
Bit rate                         : 5 768 Kbps
Width                            : 320 pixels
Height                           : 240 pixels
Display aspect ratio             : 4:3
Frame rate                       : 59.940 fps
Color space                      : YUV
Chroma subsampling               : 4:2:0
Bit depth                        : 8 bits
Scan type                        : Progressive
Bits/(Pixel*Frame)               : 1.253
Stream size                      : 1.32 MiB (98%)

Audio
ID                               : 1
Format                           : PCM
Format settings, Sign            : Unsigned
Codec ID                         : 1
Codec ID/Hint                    : Microsoft
Duration                         : 1s 917ms
Bit rate mode                    : Constant
Bit rate                         : 88.2 Kbps
Channel(s)                       : 1 channel
Sampling rate                    : 11.024 KHz
Bit depth                        : 8 bits
Stream size                      : 20.6 KiB (1%)
Interleave, duration             : 959 ms (57.50 video frames)
Interleave, preload duration     : 1000 ms
Virtual_ManPL is offline   Reply With Quote
Old 12th August 2010, 20:04   #47  |  Link
mata7
Registered User
 
mata7's Avatar
 
Join Date: Oct 2007
Posts: 36
so how long take haali to fix bugs?
mata7 is offline   Reply With Quote
Old 14th August 2010, 18:28   #48  |  Link
Thunderbolt8
Registered User
 
Join Date: Sep 2006
Posts: 2,138
i'd say if he felt like doing it not long.
Thunderbolt8 is offline   Reply With Quote
Old 16th August 2010, 00:08   #49  |  Link
Jeff Flowerday
Registered User
 
Join Date: Aug 2008
Location: Calgary, AB
Posts: 150
There's a new release of the splitter up on his site.
Jeff Flowerday is offline   Reply With Quote
Old 16th August 2010, 00:15   #50  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 3,751
14/08/2010
Fixed items:
Fixed aspect ratio processing in certain Matroska files, which caused errors on open
__________________
HTPC1:W8.1 Pro, I7 3770k, GTX 680, Pioneer Elite SC-65
HTPC2:W8.1 Pro, I5 2400s, GTS 450, Pioneer Elite VX21-THX
Laptop: MSI GT70 Dominator
SamuriHL is offline   Reply With Quote
Old 16th August 2010, 00:59   #51  |  Link
mata7
Registered User
 
mata7's Avatar
 
Join Date: Oct 2007
Posts: 36
yeah minor bug fix i try one mkv whit DTS-MA that i create wiht mkvmerge and got the same stutter problem, i guest we will have to wait 3 more month for a fix
mata7 is offline   Reply With Quote
Old 31st August 2010, 11:07   #52  |  Link
lmwang
Registered User
 
Join Date: Oct 2006
Posts: 1
bug for ts file

I have got one mpeg ts file, the video can't be displayed by
HaaliSplitter. With graphedit, I can see audio filter only. But the file is
played very well with vlc, coreplayer, mplayer. Please help to check whether
it's bug of haalisplitter. I have upload the file to below link:

http://depositfiles.com/files/vfy0q36hp

For kmplayer, if unregister HaaliSplitter filter in system filter manager, it's ok to play the file.

Last edited by lmwang; 31st August 2010 at 11:18.
lmwang is offline   Reply With Quote
Old 8th November 2010, 12:24   #53  |  Link
xv
Registered User
 
Join Date: Mar 2010
Posts: 98
I found two bugs in Haali Media Splitter:

-Major problems with a lot of MPEG-1-PS files (wrong duration, not seekable, won´t play at all). There is no problem with Microsoft Splitter or MPC-HD internal.

-Does not support IMA ADPCM in Mov. I yust got a Mov-file with SVQ3/IMA ADPCM, with MPC-HD internal everything works fine, with Haali Media Splitter only video is displayed (file can be downloaded here: http://www.mtmfilms.org/mtm6/2_hi.mov).
xv is offline   Reply With Quote
Old 22nd November 2010, 16:08   #54  |  Link
nlnl
Registered User
 
Join Date: Aug 2008
Posts: 175
New version of the splitter.
http://haali.su/mkv/
21/11/2010
* Fixed items:
o Fixed a bug in uninstaller that prevented it from properly unregistering all filters

Has anybody tested DTS HD MA bitstream playback?
nlnl is offline   Reply With Quote
Old 22nd November 2010, 17:28   #55  |  Link
mindbomb
Registered User
 
Join Date: Aug 2010
Posts: 578
DTS-HD MA doesn't work with the arcsoft dts filter with haali, so I'm guessing they still haven't fixed the bitstreaming issue, assuming they both don't work for the same reason.
Though, it appears to have no problem with DTS-HD HRA for some reason.

I don't have the hardware to explicitly test bitstreaming of DTS-HD MA though.

Last edited by mindbomb; 22nd November 2010 at 19:09.
mindbomb is offline   Reply With Quote
Old 22nd November 2010, 18:09   #56  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 3,751
What about bitstreaming a DTS-HD MA track in an MKV made with MkvMerge? That's the issue I have with Haali.
__________________
HTPC1:W8.1 Pro, I7 3770k, GTX 680, Pioneer Elite SC-65
HTPC2:W8.1 Pro, I5 2400s, GTS 450, Pioneer Elite VX21-THX
Laptop: MSI GT70 Dominator
SamuriHL is offline   Reply With Quote
Old 22nd November 2010, 23:01   #57  |  Link
mindbomb
Registered User
 
Join Date: Aug 2010
Posts: 578
are the haali people aware of the bitstreaming issue?
mindbomb is offline   Reply With Quote
Old 22nd November 2010, 23:07   #58  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 3,751
Yes. It's been reported several times.
__________________
HTPC1:W8.1 Pro, I7 3770k, GTX 680, Pioneer Elite SC-65
HTPC2:W8.1 Pro, I5 2400s, GTS 450, Pioneer Elite VX21-THX
Laptop: MSI GT70 Dominator
SamuriHL is offline   Reply With Quote
Old 23rd November 2010, 01:02   #59  |  Link
mata7
Registered User
 
mata7's Avatar
 
Join Date: Oct 2007
Posts: 36
Quote:
Originally Posted by SamuriHL View Post
What about bitstreaming a DTS-HD MA track in an MKV made with MkvMerge? That's the issue I have with Haali.
this update don't fix it, IMO another useless update
mata7 is offline   Reply With Quote
Old 23rd November 2010, 01:26   #60  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 3,751
Quote:
Originally Posted by mata7 View Post
this update don't fix it, IMO another useless update
Thanks for checking. I've personally moved on to other splitters at this point, but, I'd love it if this bug gets fixed. If not, oh well.
__________________
HTPC1:W8.1 Pro, I7 3770k, GTX 680, Pioneer Elite SC-65
HTPC2:W8.1 Pro, I5 2400s, GTS 450, Pioneer Elite VX21-THX
Laptop: MSI GT70 Dominator
SamuriHL is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 06:01.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.