Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > New and alternative video codecs

Reply
 
Thread Tools Search this Thread Display Modes
Old 28th March 2010, 13:30   #11201  |  Link
albain
Media Control author
 
Join Date: Dec 2006
Location: Paris
Posts: 1,014
@Ikarad : I had to reformat my disk and I lost your sample. Can you reupload part2 (the others are still downloadable) ?
albain is offline   Reply With Quote
Old 28th March 2010, 15:24   #11202  |  Link
STaRGaZeR
4:2:0 hater
 
Join Date: Apr 2008
Posts: 1,307
Quote:
Originally Posted by albain View Post
Thanks stargazer

Here is a new build on the audio part

I disabled the jitter correction for TrueHD & MLP codecs

About the build with the new libraries, I don't understand, I really don't reproduce the black screen issues anymore. Although I used the same sample as before (which caused me black screen). The only thing that changed is I had to reformat my drive (so new fresh installation)

Have you tried a clean install ?
Are you sure this is the new build? The filename is the same, the download was instantaneous as if the build was cached in my browser and the log still shows jitter correction when I change to the THD track. The results are the same as before. It looks like ffdshow didn't change to the THD decoder.

About the newlibs beta, yes, all the tests are with clean installs as always. Deband after every filter with problems fixes them.
__________________
Specs, GTX970 - PLS 1440p@96Hz
Quote:
Originally Posted by Manao View Post
That way, you have xxxx[p|i]yyy, where xxxx is the vertical resolution, yyy is the temporal resolution, and 'i' says the image has been irremediably destroyed.
STaRGaZeR is offline   Reply With Quote
Old 28th March 2010, 19:45   #11203  |  Link
ikarad
Registered User
 
Join Date: Apr 2008
Posts: 526
Quote:
Originally Posted by albain View Post
@Ikarad : I had to reformat my disk and I lost your sample. Can you reupload part2 (the others are still downloadable) ?
here the part 2
http://www.zshare.net/info.html?7431...08c17414f5f336

Last edited by ikarad; 29th March 2010 at 12:13.
ikarad is offline   Reply With Quote
Old 28th March 2010, 21:06   #11204  |  Link
hoborg
Registered User
 
Join Date: Nov 2008
Posts: 454
@albain:
Hi.
Tested 3336 build from http://www.xvidvideo.ru/.
How "...subtitle/audio streams switching" supose to work?
Audio switcher and keys & remotes are enabled, MPC-HC mkv source filter is in use, but pressing CTRL+ALT+F4 or nunlock 1 simply does nothing for me, no OSD info.

Tested on this sample in graphstudio.
BTW, FF/RW working fine.
__________________
Working machine: Win10x64 + Intel Skull Canyon
My HTPC.

How to start with Bitcoin
hoborg is offline   Reply With Quote
Old 28th March 2010, 21:40   #11205  |  Link
Sebastiii
Registered User
 
Join Date: Oct 2009
Location: France
Posts: 586
Quote:
Originally Posted by STaRGaZeR View Post
No, it doesn't . In an MKV with AC3 and THD, changing from the AC3 track to the THD track results in silence, ffdshow reports 621 kbps ac3 (liba52). If I change back to the AC3 track I get silence too, with the same message. Info & CPU is empty in both cases.
Hi, Can you provide a sample ?
Thanks,
Seb.
__________________
HTPC : i7 920 4Go Win7(x86) / Nvidia 460GTX / P6T Deluxe / Harman-Kardon AVR-355.
Sebastiii is offline   Reply With Quote
Old 28th March 2010, 22:30   #11206  |  Link
kolak
Registered User
 
Join Date: Nov 2004
Location: UK
Posts: 2,121
Is there a way to force makeavis to create YUY2 file (with YUY2 header) for a software that reads files natively (can't access directshow or VFW filters)?

Thx,
Andrew
kolak is offline   Reply With Quote
Old 29th March 2010, 02:24   #11207  |  Link
Casshern
Registered User
 
Join Date: Apr 2007
Posts: 220
v3336 breaks sp/dif passthrough on some dts cores of dts master audio tracks. Before if you just enabled dts passthrough and disabled dts hd passthrough ffdshow would pass the dts core just fine to the sp/dif output. This sometimes does not work anymore (e.g. GI Joe Bluray main m2ts), ffdshow decodes the dts hd stream and does not extract the core:
Filter : ffdshow Audio Decoder - CLSID : {0F40E1E5-4F79-4988-B1A9-CC98794E6B55}

- Connected to:

CLSID: {1365BE7A-C86A-473C-9A41-C0A6E82C9FA3}
Filter: G:\GIJOE\BDMV\STREAM\01002.m2ts
Pin: Audio

- Connection media type:

Audio: DTS 48000Hz 6ch 1509kbps

AM_MEDIA_TYPE:
majortype: MEDIATYPE_Audio {73647561-0000-0010-8000-00AA00389B71}
subtype: MEDIASUBTYPE_DTS {E06D8033-DB46-11CF-B4D1-00805F6CBBEA}
formattype: FORMAT_WaveFormatEx {05589F81-C356-11CE-BF01-00AA0055595A}
bFixedSizeSamples: 1
bTemporalCompression: 0
lSampleSize: 1
cbFormat: 18

WAVEFORMATEX:
wFormatTag: 0x2001
nChannels: 6
nSamplesPerSec: 48000
nAvgBytesPerSec: 188719
nBlockAlign: 2012
wBitsPerSample: 0
cbSize: 0 (extra bytes)

pbFormat:
0000: 01 20 06 00 80 bb 00 00 2f e1 02 00 dc 07 00 00 . ..€../.....
0010: 00 00

Interestingly other titles with the same info work! Also GI Joe works with older versions of ffdshow.... ..

Last edited by Casshern; 29th March 2010 at 02:37.
Casshern is offline   Reply With Quote
Old 29th March 2010, 04:10   #11208  |  Link
leeperry
Kid for Today
 
Join Date: Aug 2004
Posts: 3,405
I was wondering, sometimes 5.1 AC3 seems to be tagged as stereo...I've got a DVD here, where KMPlayer says it's stereo, but both MediaInfo and ffdshow show it as 6 channels.

too bad my "stereo <> 6 channels" rule in ffdshow audio doesn't work and reverts to stereo...yet it shows as 6 channels input in ffdshow audio, I guess I'm SOL?

I've put a sample here: http://www.mediafire.com/file/mn23gioeoug/Sample.ac3

Last edited by leeperry; 29th March 2010 at 04:14.
leeperry is offline   Reply With Quote
Old 29th March 2010, 07:41   #11209  |  Link
albain
Media Control author
 
Join Date: Dec 2006
Location: Paris
Posts: 1,014
@Casshern : please copy/paste the debugview logs (check "send strings to debugger" in ffdshow)

@hoborg : are you able to see the streams inside the ffdshow video context menu ?
albain is offline   Reply With Quote
Old 29th March 2010, 08:00   #11210  |  Link
hoborg
Registered User
 
Join Date: Nov 2008
Posts: 454
Quote:
Originally Posted by albain View Post

@hoborg : are you able to see the streams inside the ffdshow video context menu ?
Yes, and i can swap them by mouse without any problem

__________________
Working machine: Win10x64 + Intel Skull Canyon
My HTPC.

How to start with Bitcoin
hoborg is offline   Reply With Quote
Old 29th March 2010, 14:34   #11211  |  Link
ikarad
Registered User
 
Join Date: Apr 2008
Posts: 526
Quote:
Originally Posted by albain View Post
@Casshern : please copy/paste the debugview logs (check "send strings to debugger" in ffdshow)

@hoborg : are you able to see the streams inside the ffdshow video context menu ?
Have you succeed to download part2?
ikarad is offline   Reply With Quote
Old 29th March 2010, 17:47   #11212  |  Link
albain
Media Control author
 
Join Date: Dec 2006
Location: Paris
Posts: 1,014
Quote:
Originally Posted by ikarad View Post
Have you succeed to download part2?
I am downloading it right now, works fine, thanks
albain is offline   Reply With Quote
Old 29th March 2010, 18:06   #11213  |  Link
albain
Media Control author
 
Join Date: Dec 2006
Location: Paris
Posts: 1,014
@hoborg : weird, could you post the content of Media Control logfile (first you have to set loglevel to debug from the configuration program)

Thx
albain is offline   Reply With Quote
Old 29th March 2010, 18:17   #11214  |  Link
hoborg
Registered User
 
Join Date: Nov 2008
Posts: 454
Quote:
Originally Posted by albain View Post
@hoborg : weird, could you post the content of Media Control logfile (first you have to set loglevel to debug from the configuration program)

Thx
sorry, i am not using WMC or Media Control...
__________________
Working machine: Win10x64 + Intel Skull Canyon
My HTPC.

How to start with Bitcoin
hoborg is offline   Reply With Quote
Old 29th March 2010, 18:19   #11215  |  Link
rsd78
Registered User
 
Join Date: Jan 2009
Posts: 73
Quote:
Originally Posted by albain View Post
@hoborg : weird, could you post the content of Media Control logfile (first you have to set loglevel to debug from the configuration program)

Thx
Albain, could Hoborg be seeing the same issues I had using the mpc splitter and no enumeration of individual audio/sub streams?

I also could see the streams listed under the ffdshow properties, but not via 6.04 Media Control using mpc splitter and ffdshow dxva. Again, everything works fine if ffdshow regular is being used and not dxva.

EDIT: Let me know if you want logs, since I'm using Media Control and Hoborg is not. But ffdshow dxva + mpc-splitter seem to be in common between our two cases.

Last edited by rsd78; 29th March 2010 at 18:37.
rsd78 is offline   Reply With Quote
Old 29th March 2010, 18:45   #11216  |  Link
albain
Media Control author
 
Join Date: Dec 2006
Location: Paris
Posts: 1,014
Yes I am interested in such logs.

Actually I was referring to this problem but I mixed up the issues.

About Hoborg issue, I should be able to reproduce it on my own
albain is offline   Reply With Quote
Old 29th March 2010, 20:56   #11217  |  Link
rsd78
Registered User
 
Join Date: Jan 2009
Posts: 73
Quote:
Originally Posted by albain View Post
Yes I am interested in such logs.

Actually I was referring to this problem but I mixed up the issues.

About Hoborg issue, I should be able to reproduce it on my own
Ok I will get those to you tonight

EDIT: Attached is a log file. I tested a few things.
1. Used ffdshow dxva + mpc-splitter. Pressed blue button to get to menu but it failed to find individual sub streams.
2. Used ffdshow + mpc-splitter. Pressed blue button to get to menu but it failed to find individual sub streams.
3. Still using ffdshow + mpc-splitter but resumed the same file and this time it found subtitle streams automatically (i.e. the context menu popped up while previously it did not) as well as going through the menu.

All tests done using same mkv with several embedded subtitles.
Attached Files
File Type: rar MediaControl.rar (3.9 KB, 3 views)

Last edited by rsd78; 29th March 2010 at 22:30.
rsd78 is offline   Reply With Quote
Old 29th March 2010, 23:09   #11218  |  Link
baribal
Registered User
 
Join Date: Sep 2005
Posts: 7
Guys, just wanted to know if someone has kmplayer + ffdshow dxva working? I have last version of kmplayer and 3336 x86 version of ffdshow from the xvidvideo.ru site. I have also tried earlier ffdshow versions. The problem is kmplayer always using ffdshow video decoder instead of ffdshow dxva video decoder. I decrease ffdshow video decoder merit and increase ffdshow dxva video decoder merit as high as possible. I also turned on in ffdshow video decoder ffmpeg-mt for H264/AVC. Nothing helped. And of course i turned on H264 and VC1 in hardware acceleration DXVA options in ffdshow DXVA video decoder, EVR renderer in player, win7 x64 OS. MPC HC working like a charm with ffdshow dxva video decoder. Could someone help me to resolve the issue? Thanks in advance.

Last edited by baribal; 29th March 2010 at 23:24.
baribal is offline   Reply With Quote
Old 29th March 2010, 23:24   #11219  |  Link
onomatopellan
Registered User
 
Join Date: Jan 2010
Posts: 47
Quote:
Originally Posted by baribal View Post
Guys, just wanted to know if someone has kmplayer + ffdshow dxva working? I have last version of kmplayer and 3336 x86 version of ffdshow from the xvidvideo.ru site. I have also tried earlier ffdshow versions. The problem is kmplayer always using ffdshow video decoder instead of ffdshow dxva video decoder. I put ffdshow video decoder merit low and ffdshow dxva video decoder merit as high as possible. I also turned on in ffdshow video decoder ffmpeg-mt for H264/AVC. Nothing helped. And of course i turned on H264 and VC1 in hardware acceleration DXVA options in ffdshow DXVA video decoder. MPC HC working like a charm with ffdshow dxva video decoder. Could someone help me to resolve my issue? Thanks in advance.
It doens't work with TheKMPlayer. You can try PotPlayer (from the same author), it works but the player crash when you close it.
__________________
Intel Pentium Dual Core E2200 | Intel(R) G33/G31 Express Chipset Family (256Mb) | 4 GB DDR2 | Windows 8.1 Pro RTM x64
onomatopellan is offline   Reply With Quote
Old 30th March 2010, 00:17   #11220  |  Link
Casshern
Registered User
 
Join Date: Apr 2007
Posts: 220
v3336: DTS core is not passed to sp/dif in all cases

Quote:
Originally Posted by albain View Post
@Casshern : please copy/paste the debugview logs (check "send strings to debugger" in ffdshow)

@hoborg : are you able to see the streams inside the ffdshow video context menu ?
Here is the debug run. The v3336 just does not pass the dts core to sp/dif. It is as if is just does not recognize that there is a dts core. It works with older versions - and with the mpc-hc inbuilt dts decoder. The strange thing is that other titles work!


[1484] Loading modified build of detours library designed for MPC-HC player (http://sourceforge.net/projects/mpc-hc/)
[1484] TffdshowBase::Constructor
[1484] TffdshowDecAudio::Constructor
[1484] Join filter graph
[1484] Removed from filter graph
[1484] Join filter graph
[1484] TffdshowDecAudio::CheckConnect (input)
[1484] TffdshowDecAudio::CheckInputType
[1484] TffdshowDecAudio::getCodecId
[1484] TffdshowDecAudio::getCodecId: codecId=dts (107)
[1484] TinputPin::SetMediaType
[1484] TffdshowDecAudioInputPin::initAudio
[1484] TffdshowDecAudio::getCodecId
[1484] TffdshowDecAudio::getCodecId: codecId=dts (107)
[1484] initPreset
[1484] TffdshowDecAudio::getOutsf PCM 1
[1484] TffdshowBase::Constructor
[1484] TffdshowDecAudio::Constructor
[1484] Join filter graph
[1484] Removed from filter graph
[1484] Join filter graph
[1484] Removed from filter graph
[1484] TffdshowDecAudio::getOutsf PCM 1
[1484] TffdshowDecAudio::CheckConnect (output)
[1484] initPreset
[1484] TffdshowDecAudio::getOutsf PCM 1
[1484] TffdshowDecAudio::CheckTransform From :
[1484] Media Type Structure
[1484] Format type : FORMAT_WaveFormatEx
[1484] Sub type : MEDIASUBTYPE_DTS
[1484]
[1484] WAVEFORMATEX :
[1484] wFormatTag : DTS wave
[1484] Channels : 6
[1484] Bits per sample : 0
[1484] Samples per second : 48000
[1484] nBlockAlign : 2012
[1484] nAvgBytesPerSec : 188719
[1484]
[1484] TffdshowDecAudio::CheckTransform To :
[1484] Media Type Structure
[1484] Format type : FORMAT_WaveFormatEx
[1484] Sub type : MEDIASUBTYPE_PCM
[1484]
[1484] WAVEFORMATEXTENSIBLE :
[1484] subFormat : MEDIASUBTYPE_PCM
[1484]
[1484] wSamplesPerBlock : 16
[1484] Valid bits per sample : 16
[1484] dwChannelMask : 63
[1484]
[1484] WAVEFORMATEX :
[1484] wFormatTag : WAVE_FORMAT_EXTENSIBLE
[1484] Channels : 6
[1484] Bits per sample : 16
[1484] Samples per second : 48000
[1484] nBlockAlign : 12
[1484] nAvgBytesPerSec : 576000
[1484]
[1484] TffdshowDecAudio::CheckInputType
[1484] TffdshowDecAudio::getCodecId
[1484] TffdshowDecAudio::getCodecId: codecId=dts (107)
[1484] TffdshowDecAudio::getOutsf PCM 1
[1484] TffdshowDecAudio::CheckTransform To generated by FFDShow :
[1484] Media Type Structure
[1484] Format type : FORMAT_WaveFormatEx
[1484] Sub type : MEDIASUBTYPE_PCM
[1484]
[1484] WAVEFORMATEXTENSIBLE :
[1484] subFormat : MEDIASUBTYPE_PCM
[1484]
[1484] wSamplesPerBlock : 16
[1484] Valid bits per sample : 16
[1484] dwChannelMask : 63
[1484]
[1484] WAVEFORMATEX :
[1484] wFormatTag : WAVE_FORMAT_EXTENSIBLE
[1484] Channels : 6
[1484] Bits per sample : 16
[1484] Samples per second : 48000
[1484] nBlockAlign : 12
[1484] nAvgBytesPerSec : 576000
[1484]
[1484] TffdshowDecAudio::CheckTransform result 0
[1984] TffdshowBase::Constructor
[1984] TffdshowDecVideo::Constructor
[1984] TffdshowDecVideoOutputPin::Constructor
[1984] TffdshowDecVideoDXVA constructor
[1984] TffdshowDecVideo:estructor
[1984] TffdshowDecVideoOutputPin:estructor
[1984] TffdshowBase::Constructor
[1984] TffdshowDecVideo::Constructor
[1984] TffdshowDecVideoOutputPin::Constructor
[1984] Join filter graph
[1984] TffdshowVideoInputPin::ReceiveConnection
Casshern is offline   Reply With Quote
Reply

Tags
ffdshow, ffdshow tryouts, ffdshow-mt, ffplay, icl

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 18:05.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.